Vraag

IPv6 en Pi-hole...het zoveelste topic

  • 10 juli 2019
  • 23 Reacties
  • 1476x Bekeken

Reputatie 2
Eventjes een nieuw topic gemaakt zodat een ander topic niet nog verder vervuild raakt. Ik zie dat er al meer topics open zijn gemaakt met soortgelijke problemen maar ik kan nergens precies hetzelfde probleem vinden.

Ik heb dus met de Arris Connect Box het probleem dat mijn Pi-hole prima werkt via IPv4 omdat ik daar de DHCP server kan uitzetten, maar niet via IPv6 omdat de Connect Box daar zelf persé adressen wil uitdelen met bijbehorende DNS servers van Ziggo.

Ik wil die DNS servers van Ziggo helemaal niet hebben omdat daarom het hele nut van de Pi-hole teniet gedaan wordt. Ook heb ik een aantal apparaten waar het apart instellen van de DNS server totaal niet praktisch is, bijvoorbeeld mijn Macbook die het globaal opslaat en waardoor ik dus constant moet wisselen tussen de verschillende servers wanneer ik thuis ben en weer weg ga.

Dit alles zou makkelijk opgelost kunnen worden als je gewoon een DNS server in kon stellen in de Connect Box zelf. Ik snap eerlijk gezegd ook niet waarom die functie ontbreekt; elders op het forum las ik dat je de veiligheid van een DNS-server van een derde partij niet kunt vertrouwen maar dit vind ik zelf onzin.

Bij het aanzetten van de IPv6 DHCP in Pi-hole zelf krijg ik inderdaad een Pi-hole DNS in mijn lijstje...naast de DNS servers van Ziggo. Het lijkt er ook op alsof ik dubbele IPv6 adressen krijg op dit moment, waarschijnlijk ééntje van de Connect Box en de andere van Pi-hole.


https://

@DannyW dit is de output van ifconfig op de Pi-hole. Ik heb mijn publieke ipv6 adres even weggestreept.

code:
eth0: flags=4163 mtu 1500
inet 192.168.178.241 netmask 255.255.255.0 broadcast 192.168.178.255
inet6 fe80::808d:db17:7906:c661 prefixlen 64 scopeid 0x20
inet6 2001:xxxx:ded1 prefixlen 64 scopeid 0x0
ether b8:27:eb:20:76:2c txqueuelen 1000 (Ethernet)
RX packets 2837977 bytes 603381440 (575.4 MiB)
RX errors 0 dropped 1601 overruns 0 frame 0
TX packets 1694768 bytes 290593650 (277.1 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

23 Reacties

Reputatie 7
Badge +35
Vraag Ziggo om je modem in IPv4 te zetten als je IPv6 niet ergens voor gebruikt, want daar zit nog een vreemde configuratie achter.@NanoSector
Reputatie 2
@Be rt misschien ben ik daar heel koppig in en is het voor nu de beste oplossing, maar ik vind dat totaal geen oplossing.

Ik ben van mening dat er gewoon een optie moet komen om DNS-servers van een derde partij in te stellen, of dat er anders een héél goede reden publiekelijk gemaakt moet worden waarom dit niet kan. Bij de concurrent KPN kan dit bijvoorbeeld weer wel, maar ik stap liever niet over als het even kan (zeker niet om een enkele missende optie in mijn modem...). Er zijn talloze topics hier en bij Pi-hole zelf opengemaakt door mensen die deze optie missen.
Reputatie 7
Badge +35
Ik ben ook zo koppig, maar als er ergens vreemde configuraties achterhangen of het hele achterliggende systemen draaien nog niet zoals het zou moeten, dan geef ik het ook op en als het dan niet kan zoals het moet, dan moet het maar zoals het kan.
Reputatie 2
@Be rt Helemaal mee eens, daar niet van, maar ik heb het idee dat Ziggo hier helemaal niets mee doet. Vandaar dat ik me er niet zomaar bij wil neerleggen, op korte termijn is het dan wel dé oplossing, maar ik ben bang dat die optie er dan ook nooit gaat komen want "het werkt nu toch voor je?". Vandaar dat ik dit topic eigenlijk nog niet wil sluiten.

Bovendien speelt dit niet alleen bij IPv6 waar dan de "vreemde configuratie" achter hangt, maar ook bij IPv4 waar deze optie nooit heeft bestaan in de Connect Box (en ik mag hopen dat Ziggo IPv4 tenminste wel onder de knie heeft inmiddels...).
Reputatie 7
Badge +14
@NanoSector

Mijn opstelling is niet hetzelfde als bij jou. Ik heb een ander Ziggo-modem-router (Technicolor) met full dual stack en een eigen router daarachter (in cascade) met voor IPv6 gebruik ik Prefix Delegation.
In de Technicolor heb ik geen keuze voor stateless en statefull en in de eigen router heb ik een IPv6 DHCP-server actief. Daarom is er bij mij geen noodzaak om de Pi-Hole als DHCP-server te gebruiken; in mijn eigen router verwijs ik voor zowel IPv4 als IPv6 naar de (interne) IP adressen van de Pi-Hole als DNS-server(s). Die IP-adressen worden dan ook doorgegeven bij een DHCP-opvraag.

Wat in jouw situatie m.i. wel anders zou moeten is, ten eerste de Pi-Hole configuratie opnieuw doorlopen en daar bij IPv4 een statisch IP-adres opgeven buiten de DHCP-range (b.v. 192.168.178.5) en voor IPv6 het Link Local adres fe80::…enz..

Daarna in de Pi-Hole DHCP aanzetten en de Pi-Hole ook de IPv6 adressen laten uitdelen. Mogelijk moet je in de CB dan nog ook nog spelen met stateless en statefull. Voor dat laatste durf ik geen advies te geven wat ik mijn opstelling en Ziggo router is anders dan bij jou en veel meer IPv6 ervaring heb ik eigen lijk ook niet.

Nou ja, ik heb wel eens getest met een PC en de Pi-Hole rechtstreeks op de Technicolor met de DHCP-server van de Pi-Hole actief (+SLAAC). Dat werkte wel, maar een Windows-PC verzint steeds zelf een Link-Local-adress dus de Pi-Hole had hier geen rol in. Ik dacht dat er wel het juiste IPv6 DNS-server-adres van de Pi-Hole gebruikt werd, maar helemaal zeker weet ik dat nu niet meer.
Reputatie 2
@DennyW (ah, in de eerste post de verkeerde aangehaald, oeps) Dankjewel voor je feedback, ik ben nu even Pi-hole opnieuw aan het instellen.

Ik krijg bij het instellen geen keuze voor het IPv6 adres:


Ik ga hem wel op 192.168.178.7 zetten maar ik verwacht niet dat dit iets gaat oplossen.

Ik ga eens spelen met Stateful vs Stateless, maar van wat ik kan lezen zorgen beide opties ervoor dat de Connect Box alsnog gegevens gaat verspreiden in het netwerk en niet Pi-hole zoals de bedoeling is. Maar niet geschoten is altijd mis.
Reputatie 7
Badge +14
@NanoSector

Ja, het klopt helaas dat je tegenwoordig, bij her-configuratie, IPv6 niet meer kan wijzigen: de makers hebben aan de module geknutseld. (Er zijn dingen uit gesloopt!)

Het IPv4 adres wordt bij Raspbian wegeschreven in:
/etc/dhcpcd.conf
De IPv4 gegevens van interface eth0 staan onderaan in het file.

Het IPv6 adres dat de PI-Hole gebruikt staat in:
/etc/pihole/setupVars.conf

(Bestanden zijn te wijzigen met sudo nano)

Ik heb laatst (voor de lol en als "back-up") nog een extra SD-kaartje beschreven met een nieuw installatie. Omdat ik een IPv6 DHCP-server heb in mijn eigen router moest ik setupVars.conf aan passen om dat adres erin te zetten.
Ik heb mijn aantekeningen er even bij gepakt en zie dat de Pi-Hole bij een schone installatie niet het fe80:: -adres gebruikte, maar het fc00:: -adres! (=ULA ). Mijn aanwijzing om het fe80:: adres te gebruiken is dan onjuist geweest.

N.B.:
Bij mij krijgt eth0 standaard drie IPv6 adressen:
fe80::…..
fc00::….
2001::.....
en het eigen IPv6 DHCP-adres fc::00xxx/7 is hier bij gekomen als vierde.


**EDIT***
Aanvulling:
De aangepaste configuratie-module van de Pi-Hole -in combinatie met nieuwe functionaliteit van de Pi-Hole (t.w.: het kunnen invoeren van DNSSEC DNS-servers)- veroorzaakt nog een ander probleem, waardoor de installatie met fouten verloopt.
Vul daarom bij een schone installatie als te gebruiken DNS-server het IP-adres van jouw router in (t.w. 192.168.178.1) en muteer dat na installatie in de Pi-Hole zelf naar de DNS-server van jouw keuze.
Zo niet dan loopt de installatie steeds vast want halverwege wordt de ingevoerde DNS gebruikt om de FTL module te installeren en dat gaat anders steeds fout.
Reputatie 7
Badge +14
De makers van Pi-Hole hebben de configuratie-tool behoorlijk verpest (stand /versie per begin en medio 2019 in ieder geval). De tool laat je geloven dat je kan kiezen tussen het gebruik van een (dynamisch) DHCP-adres en een statisch IP-adres. Dit werk niet meer; in het onderliggende Linux-OS wordt er, voor IPv4) zondermeer een statisch IP-adres vastgelegd. (onderin /etc/dhcpcd.conf) .

Het statische IPv6 IP-adres komt in: /etc/pihole/setupVars.conf

Zou je willen her-configureren, dan zou je die info kunnen wissen of de regels met # kunnen uitschakelen.

Gebruik als IPv6 IP-adres niet het externe (2001: ) maar het fc00: -adres van de Pi-Hole in de tool. Immers de PI-Hole is juist bedoeld om door de hosts / clients van binnenuit het LAN aangeroepen te worden zodat deze een DNS-request in gang kan zetten.
(N.B.: Voor IPv4 gebruik je immers toch ook het interne IP-adres?)

Ook het vastleggen van de gewenste DNS-server middels deze tool kan behoorlijk de boel frustreren. Kies je namelijk een DNS-server waarbij extra functionaliteit nodig is (die op dat moment nog niet in de Pi-Hole is geïnstalleerd), dan loop je kans dat de installatie vastloopt bij het downloaden van verdere onderdelen. Kies daarom maar, (voorlopig) tijdens de installatie van de Pi-Hole, voor het IP-adres van de router, als DNS-server-adres.

Zelf gebruik een Raspbian-versie zonder grafische desktop en raadpleeg en muteer de bestandjes via de command line tool “nano”. Om te mogen wijzigen dien je wel de rechten verhogen met “sudo”.

Inzien / opvragen van de verbindingsgegevens (IP-adressen) kan je dan doen met het commando “ifconfig”.

Helaas is de configuratie-tool van de Pi-Hole nu wat minder gebruikers vriendelijk. Hopelijk kan iemand met deze info zich wat kopzorgen en tijd besparen.
Reputatie 2
@DennyW dankjewel voor je uitleg. Ik heb pihole werkend op ipv4 en een statisch adres is niet zo spannend om in te stellen, maar ook al zou ik het op die manier instellen dan zit ik nog vast aan de DNS servers van ziggo.

Wat er straks waarschijnlijk gebeurd is dat een laptop vraagt “Wie is google.com?” waarop pihole dus geen antwoord geeft en hij vraagt het dan aan de volgende, de Ziggo DNS, die het antwoord wél weet. Dat maakt heel de pihole dus compleet nutteloos ook al zou die werken.
Reputatie 7
Badge +14
@DennyW dankjewel voor je uitleg. Ik heb pihole werkend op ipv4 en een statisch adres is niet zo spannend om in te stellen, maar ook al zou ik het op die manier instellen dan zit ik nog vast aan de DNS servers van ziggo.

Wat er straks waarschijnlijk gebeurd is dat een laptop vraagt “Wie is google.com?” waarop pihole dus geen antwoord geeft en hij vraagt het dan aan de volgende, de Ziggo DNS, die het antwoord wél weet. Dat maakt heel de pihole dus compleet nutteloos ook al zou die werken.


Een eigen router biedt in de regel meer instel-mogelijkheden dan die van Ziggo.

Maar pas op: als je het Ziggo-modem in bridge (laat) zet(ten) dan heb je geen IPv6 meer. Het terugzetten naar dual stack blijkt een probleem te zijn en als je oorspronkelijk full dual stack had, dan ligt terugval op DS Lite op de loer.
Reputatie 2

@DennyW dankjewel voor je uitleg. Ik heb pihole werkend op ipv4 en een statisch adres is niet zo spannend om in te stellen, maar ook al zou ik het op die manier instellen dan zit ik nog vast aan de DNS servers van ziggo.

Wat er straks waarschijnlijk gebeurd is dat een laptop vraagt “Wie is google.com?” waarop pihole dus geen antwoord geeft en hij vraagt het dan aan de volgende, de Ziggo DNS, die het antwoord wél weet. Dat maakt heel de pihole dus compleet nutteloos ook al zou die werken.
Een eigen router biedt in de regel meer instel-mogelijkheden dan die van Ziggo.

Maar pas op: als je het Ziggo-modem in bridge (laat) zet(ten) dan heb je geen IPv6 meer. Het terugzetten naar dual stack blijkt een probleem te zijn en als je oorspronkelijk full dual stack had, dan ligt terugval op DS Lite op de loer.


Ik denk dat "meer" instelmogelijkheden de understatement van het jaar is in dit geval :)

Eerlijk gezegd ben ik redelijk gefrustreerd dat wij zo'n 80 euro(!) in de maand neertellen en dan met zulke 'brakke' apparatuur opgezadeld worden, waarvan bekend is dat ze onder andere bugs hebben in de Puma chipset en véél te weinig opties bieden voor de 'power user' zullen we maar zeggen.

Dat, terwijl de concurrent KPN 10 euro goedkoper is in de maand en een modem/router levert met al deze instellingen en meer netjes geïntegreerd. Dit maakt het wel heel erg verleidelijk om over te stappen.

Sterker nog, ga naar de dichtstbijzijnde elektronica winkel en koop de meest goedkope router die je daar kan vinden: Die heeft al deze instellingen ook!

Bovendien vind ik dat hele IPv6-uit-in-bridge-modus gebeuren gewoon scheef en vreemd. Het lijkt net alsof Ziggo je niet vertrouwt om dat zelf te regelen, maar mijn ASUS RT-N66U van veel jaren terug kan dit allemaal netjes regelen...als Ziggo dit toeliet.

En dan kan Ziggo zeggen dat ik een uitzondering ben op de regel en dan hebben ze helemaal gelijk. Maar dat neemt niet weg dat ieder ander apparaat wat ik me zo kan bedenken deze opties wél heeft (en zelfs oudere Ziggo modems!!) en dat het dus naar mijn inzien schandalig is dat Ziggo met een "vernieuwend" modem komt dat dit er allemaal uit sloopt en vervolgens niet luistert naar alle klachten op het forum die geplaatst worden door gebruikers als ik, want zoals de titel van dit topic al laat merken, ik ben niet de eerste.

En nu voel ik me een jonge oude zeikerd maar dit moest ik even kwijt, tijd voor koffie.
Bovendien vind ik dat hele IPv6-uit-in-bridge-modus gebeuren gewoon scheef en vreemd. Het lijkt net alsof Ziggo je niet vertrouwt om dat zelf te regelen, maar mijn ASUS RT-N66U van veel jaren terug kan dit allemaal netjes regelen...als Ziggo dit toeliet.

En dan kan Ziggo zeggen dat ik een uitzondering ben op de regel en dan hebben ze helemaal gelijk. Maar dat neemt niet weg dat ieder ander apparaat wat ik me zo kan bedenken deze opties wél heeft (en zelfs oudere Ziggo modems!!) en dat het dus naar mijn inzien schandalig is dat Ziggo met een "vernieuwend" modem komt dat dit er allemaal uit sloopt en vervolgens niet luistert naar alle klachten op het forum die geplaatst worden door gebruikers als ik, want zoals de titel van dit topic al laat merken, ik ben niet de eerste.


IPv6 is denk ik "moeilijk voor klanten". Blijkbaar heeft men er voor gekozen de instellingen zeer bepekt te maken in het modem. De beste oplossing voor power users is normaliter bridge-modus, en dat ondersteunt Ziggo dan ook. Helaas verlies je dan IPv6 tot voor kort vond ik dat ook nogal merkwaardig, maar ik ik weet inmiddels enigszins waarom dit (nog) niet wordt ondersteund, maar dat valt onder een NDA.
Reputatie 5
Badge +5
Eventjes een nieuw topic gemaakt zodat een ander topic niet nog verder vervuild raakt. Ik zie dat er al meer topics open zijn gemaakt met soortgelijke problemen maar ik kan nergens precies hetzelfde probleem vinden.

Ik heb dus met de Arris Connect Box het probleem dat mijn Pi-hole prima werkt via IPv4 omdat ik daar de DHCP server kan uitzetten, maar niet via IPv6 omdat de Connect Box daar zelf persé adressen wil uitdelen met bijbehorende DNS servers van Ziggo.

Ik wil die DNS servers van Ziggo helemaal niet hebben omdat daarom het hele nut van de Pi-hole teniet gedaan wordt. Ook heb ik een aantal apparaten waar het apart instellen van de DNS server totaal niet praktisch is, bijvoorbeeld mijn Macbook die het globaal opslaat en waardoor ik dus constant moet wisselen tussen de verschillende servers wanneer ik thuis ben en weer weg ga.

Dit alles zou makkelijk opgelost kunnen worden als je gewoon een DNS server in kon stellen in de Connect Box zelf. Ik snap eerlijk gezegd ook niet waarom die functie ontbreekt; elders op het forum las ik dat je de veiligheid van een DNS-server van een derde partij niet kunt vertrouwen maar dit vind ik zelf onzin.

Bij het aanzetten van de IPv6 DHCP in Pi-hole zelf krijg ik inderdaad een Pi-hole DNS in mijn lijstje...naast de DNS servers van Ziggo. Het lijkt er ook op alsof ik dubbele IPv6 adressen krijg op dit moment, waarschijnlijk ééntje van de Connect Box en de andere van Pi-hole.
.............



Ik heb exact hetzelfde probleem. Mijn Connect Box ( Compal CH7465LG ) lekt ook IPv6 DNS adressen ( terwijl de DHCP functie op de CB geheel uit staat ).

Ook ik heb een paar maand geleden een Pi-hole geïnstalleerd om van alle reclames e.d. af te zijn. Ook ik heb Ziggo gevraagd of mijn verbinding naar IPv4 only teruggezet kon worden i.v.m. de IPv6 lek in de CB. Dit is ook zonder problemen uitgevoerd, echter toen bleek mijn vpn met torrents dramatisch traag te zijn geworden, namelijk max. 1Mb/s. Niet werkbaar dus.

Daarop heb ik Ziggo gevraagd om mijn verbinding terug te zetten zoals die oorspronkelijk was ( IPv6 lite ). Dit bleek uiteindelijk een probleem te zijn, want dat wil Ziggo in principe niet. Omdat mij niet was verteld, dat terug naar IPv6 niet mogelijk was ( dan had ik me misschien nog bedacht ), heeft Ziggo uiteindelijk toch de verbinding weer teruggezet naar IPv6 lite ( opnieuw mijn dank daarvoor, want anders was mijn 3 jarig vpn abonnement waardeloos geworden ).

Ik heb veel instellingen geprobeerd ( maar geen bridge-mode ) en ben uiteindelijk gestopt met de voor mij best werkende opstelling: op de Raspberry Pi is IPv4 en IPv6 enabled en daarop draait DHCP en Pi-Hole. De DHCP op de CB staat dan natuurlijk uit. De extra TP-Link C1200 op zolder, staat in AP-mode.

Omdat de CB toch IPv6 DNS adressen blijft lekken, heb ik alle desktop/laptops op IPv4 only gezet en daar zijn ( bijna ) alle reclame meldingen ( en andere privacy 'gevaarlijk' zaken ) verdwenen.

Op mijn smartphones ben ik de Brave browser gaan gebruiken, want deze heeft o.a. een anti reclame filter standaard ingebouwd.
Maar ook de smartphones gebruiken de Pi-hole soms, want in de statistieken ( van de Pi-hole ) staan genoeg smartphone entries.

Ondanks alle 'moeilijkheden' ben ik tevreden met de werking van de Pi-hole. Alle internet reclame is verdwenen, heel veel onnodige privacy 'gevaarlijke' sites worden geblocked en het browsen algemeen ( b.v. het openen van Nu.nl ) is sneller geworden..

Zie ook: Vpn traag met ipv4 en terug van ipv4 naar ipv6 niet mogelijk

Ik hoop dat Ziggo uiteindelijk deze bug in de CB oplost, zodat deze geen IPv6 adressen uitgeeft/lekt als dat niet gewenst is. Hoe ze dat doen ( waar en via welke optie in het menu ), maakt me eigenlijk niet uit.
Reputatie 2
@efok Dat je niks kan zeggen over IPv6 vanwege je NDA snap ik, maar vertel mij eens waarom Ziggo die andere basale instellingen weg laat? Nu ben je min of meer genoodzaakt om een eigen router achter het modem te hangen (of met workaround te gaan werken zoals het uitzetten van DHCP) omdat het zulke basisfuncties niet ondersteunt.

@Pasi IPv6 uitschakelen op de client devices is één optie. Maar dan kan je naar mijn inziens beter je modem terug laten schakelen naar IPv4 only, toch? Dan kun je bij iemand anders die wel IPv6 heeft gewoon gebruik maken daarvan maar dan heb je alleen IPv4 in je thuisnetwerk. Zoals ik eerder heb beargumenteerd vind ik dit alleen geen oplossing.

(Bovendien ben ik niet zo'n fan van Brave's business practices omdat heel veel van het opgehaalde geld helemaal niet doorgesluisd wordt naar de websites, maar dat terzijde; als dit werkt voor je, prima! Als alternatief kan ik je AdGuard aanraden op iOS en Android; op Android heb je zelfs een VPN-optie die een beetje hetzelfde te werk gaat als Pi-hole)
@efok Dat je niks kan zeggen over IPv6 vanwege je NDA snap ik, maar vertel mij eens waarom Ziggo die andere basale instellingen weg laat? Nu ben je min of meer genoodzaakt om een eigen router achter het modem te hangen (of met workaround te gaan werken zoals het uitzetten van DHCP) omdat het zulke basisfuncties niet ondersteunt.

Ik snap je frustratie, dat weet ik echt niet. Ik heb al langer geleden de keuze voor een eigen router gemaakt en mijn modem gebridged. Ik vind de bridge optie niet zo gek hoor. Voor "de meute" doet een ziggo modem in router mode wat het moet doen. Heb je meer nodig dan zet je hem in bridge, en investeer je in een eigen router, die doet wat jij wil. Ik voel dat niet zo als genoodzaakt worden, maar een eigen keuze waarbij ik ben juist blij ben dat bridge-modus wordt onderteund, dat geeft me alle vrijheid. Bij KPN VDSL kun je naar bridge-modus fluiten en heb je weer NAT achter NAT. Ook niet alles.
Ik koop ook mijn eigen Access-points. Eigenlijk verwacht ik van een provider niet meer dan een dom modem, waar ik mijn eigen gear wel aanhang.
Een edgerouter van ubiquiti is niet heel duur en kan heel veel 😀
Reputatie 2

@efok Dat je niks kan zeggen over IPv6 vanwege je NDA snap ik, maar vertel mij eens waarom Ziggo die andere basale instellingen weg laat? Nu ben je min of meer genoodzaakt om een eigen router achter het modem te hangen (of met workaround te gaan werken zoals het uitzetten van DHCP) omdat het zulke basisfuncties niet ondersteunt.Ik snap je frustratie, dat weet ik echt niet. Ik heb al langer geleden de keuze voor een eigen router gemaakt en mijn modem gebridged. Ik vind de bridge optie niet zo gek hoor. Voor "de meute" doet een ziggo modem in router mode wat het moet doen. Heb je meer nodig dan zet je hem in bridge, en investeer je in een eigen router, die doet wat jij wil. Ik voel dat niet zo als genoodzaakt worden, maar een eigen keuze waarbij ik ben juist blij ben dat bridge-modus wordt onderteund, dat geeft me alle vrijheid. Bij KPN VDSL kun je naar bridge-modus fluiten en heb je weer NAT achter NAT. Ook niet alles.
Ik koop ook mijn eigen Access-points. Eigenlijk verwacht ik van een provider niet meer dan een dom modem, waar ik mijn eigen gear wel aanhang.

Ik vind het juist niks raar dat Ziggo bridge modus aanbiedt want ze moeten in principe de klant een eigen modem laten gebruiken volgens de wet (KPN ook). Dit is echter een discussie voor een ander topic, dat al bestaat.

Ik snap ook heel goed dat je het argument geeft van "koop iets wat je zelf fijn vindt". Maar ik heb op zich geen problemen met de Connect Box naast wat ik hier heb aangegeven, als switch of als extra AP bijvoorbeeld functioneert het ding prima. Dan zou ik voor een paar kleine instellingen een geheel eigen router moeten aanschaffen en dingen als IPv6 moeten inleveren (tijdelijk tenminste). Het is ook niet alsof Ziggo een geheel nieuwe functie moet implementeren op het modem; het kan al via DHCP een DNS server meegeven, waarom dat dan niet configureerbaar maken?

Hoe dan ook vind ik niet dat ík hier de oplossing moet gaan verzinnen en moet gaan inleveren op functionaliteit, ik vind dat Ziggo hier een oplossing moet bieden. Als je een modemrouter levert, lever dan ook eentje waar je iets op kunt instellen. Ik heb al een behoorlijk duur abonnement en ik vind niet dat ik dan ook nog een router van 100+ euro (voor een redelijk fatsoenlijke router) erbij moet kopen voor deze basisdingen.

Een edgerouter van ubiquiti is niet heel duur en kan heel veel 😀

Dat hoor ik van meer mensen, maar dan komt er ook een AP bij, oh en boven ook eentje, en in het tuinhuis moet eigenlijk nog een switch komen met AP... Daar gaat weer 500 euro :)
Ik zeg niet dat het dat niet waard is maar ik heb nu apparatuur staan die al tijden goed werkt en ook gewoon geschikt blijkt. Misschien stap ik ooit nog wel over en denk ik bij mezelf "wat heb ik al die tijd gemist" maar die tijd is niet nu 🙂
Reputatie 7
Badge +14
@NanoSector

Ik heb als experiment de Raspberry Pi (met de Pi-Hole installatie op mijn reserve /back-up SD-kaartje) eens rechtstreek aangesloten op mijn Ziggo-modem-router (Technicolor TC7210). In het bestand /etc/dhcpcd.conf heb ik het statische IPv4 IP-adres omgezet naar 192.168.178.200 en laten herstarten. De RP kreeg geen (ULA) IPv6 adres zoals fc00:: of fd00:: (Wel een 2001: en fe80:: adres).

Het gevolg was dat de Pi-Hole configuratie tool voor IPv6 het 2001: adres uit koos. Dit was inderdaad niet tijdens de configuratie te wijzigen.

Nadat ik in de TC7210 de DHCP gedeactiveerd hand en de Pi-Hole als DHCP-server had ingesteld, werden de Ziggo DNS-server ook meegegeven aan de clients /hosts (samen met die van de Pi-Hole).

Het mee krijgen van de Ziggo DNS-servers werd opgelost door de Ziggo-modem-router te herstarten. Verder heb ik in het bestand dhcpcd.conf een statisch fc00:: adres ingevoerd. Ik heb hier maar het adres ingevoerd dat de RP normaal verkrijgt van mijn eigen router. Het zo iets geworden als dit:

interface eth0

static ip_address=192.168.178.200/24
static ip6_address=fc00::d99:???c:???8:f??7/64
static routers=192.168.178.1
static domain_name_servers=127.0.0.1

Bij het opnieuw draaien van sudo pihole –r , koos de tool nu voor het fc00:: adres.

Vervolgens op de PC met ipconfig nieuwe verbindingsgegevens op laten van vragen bij de ”nieuwe” DHCP-server:

ipconfig /release
ipconfig /release6
ipconfig /renew
ipconfig /renew6

Met ipconfig / all zie ik dan twee vermelding voor DNS: het fc00:: en het 2001: adres van de Pi-Hole.

N.B.:
-Er is in dit forum wel vaker voorbij gekomen dat sommige wijzigingen in een Ziggo-modem-router pas willen werken na een herstart. Ik heb hier niet meer aan gedacht; ik ben veel te verwend door mijn eigen router.
-Voor zover ik weet mag je zo’n (hexadecimaal) fc00:: …/64 of fd00:: …./64 adres gewoon zelf verzinnen (doet Windows immer ook).
Reputatie 2
@DennyW top, fijn dat je zo meedenkt!

Was het bij jou mogelijk om de hele DHCP/adrestoewijzing uit te zetten op het modem? Bij de connect box mis ik namelijk die optie denk ik. Ik heb stateless en stateful allebei geprobeerd en bij beide krijg ik de ziggo DNS er gratis bij.

Helaas is het voor mij wel een overstap naar kpn geworden, niet alleen heb ik daar meer opties maar het scheelt ons ook 300 euro in het jaar voor nagenoeg hetzelfde pakket, plus voor mijn Nextcloud kan ik de symmetrische snelheden en dus de flink betere upload goed gebruiken.

De overstap is pas 14 augustus dus tot die tijd wil ik nog wel meehelpen om een oplossing te zoeken voor eventuele mensen na mij.
Reputatie 7
Badge +14
@DennyW top, fijn dat je zo meedenkt!

Was het bij jou mogelijk om de hele DHCP/adrestoewijzing uit te zetten op het modem? Bij de connect box mis ik namelijk die optie denk ik. Ik heb stateless en stateful allebei geprobeerd en bij beide krijg ik de ziggo DNS er gratis bij.


@NanoSector
In de TC7210 valt er niet te kiezen tussen tussen stateless en stateful. Het enige wat ik kon doen in de TC7210 was de DHCP-server uitzetten. Als de Pi-Hole DHCP actief heeft, dan "weet" deze dat hij ook DNS-proxy is.
Reputatie 7
Was het bij jou mogelijk om de hele DHCP/adrestoewijzing uit te zetten op het modem? Bij de connect box mis ik namelijk die optie denk ik. Ik heb stateless en stateful allebei geprobeerd en bij beide krijg ik de ziggo DNS er gratis bij.
DHCP is bij Stateless (SLAAC) überhaupt niet van toepassing, en DHCPv6 zonder DHCP kan niet (what's in a name). Ik vermoed echter dat in beide configuraties de DNS adressen al bij de RA meegestuurd worden, maar ik heb hier niet de tools om dat te kunnen bevestigen. Deze vraag staat nog open bij onze specialisten.
Reputatie 2
Helaas is het voor mij wel een overstap naar kpn geworden, niet alleen heb ik daar meer opties maar het scheelt ons ook 300 euro in het jaar voor nagenoeg hetzelfde pakket, plus voor mijn Nextcloud kan ik de symmetrische snelheden en dus de flink betere upload goed gebruiken.

De overstap is pas 14 augustus dus tot die tijd wil ik nog wel meehelpen om een oplossing te zoeken voor eventuele mensen na mij.


De overstap gaat hem niet worden aangezien we op de een of andere manier toch een nieuw jaarcontract hebben gekregen terwijl de website maandelijks opzegbaar zegt (nergens mee akkoord gegaan, maargoed, ik heb geen zin in een hoop onzin). Dan marcheren we maar verder naar een oplossing hiervoor :)


DHCP is bij Stateless (SLAAC) überhaupt niet van toepassing, en DHCPv6 zonder DHCP kan niet (what's in a name). Ik vermoed echter dat in beide configuraties de DNS adressen al bij de RA meegestuurd worden, maar ik heb hier niet de tools om dat te kunnen bevestigen. Deze vraag staat nog open bij onze specialisten.

Maar bij beide technieken krijg je zover ik kan lezen (en zover ik het snap) een set servers door vanuit Ziggo. Bij SLAAC direct van Ziggo en bij DHCPv6 vanaf het modem lijkt me. Maar op beide manieren zie ik geen mogelijkheid dat de Pi-hole zijn adres naar de clients kan brengen (je kan de DHCP server dan wel aanzetten maar dan krijg je een dubbel IPv6 adres + de Pi-hole bovenop de Ziggo DNS).

Ik wil dit ook best testen met bijv. Wireshark als ik weet hoe.
Reputatie 7
Badge +14

Verder heb ik in het bestand dhcpcd.conf een statisch fc00:: adres ingevoerd. Ik heb hier maar het adres ingevoerd dat de RP normaal verkrijgt van mijn eigen router. Het zo iets geworden als dit:

interface eth0

static ip_address=192.168.178.200/24static ip6_address=fc00::d99:???c:???8:f??7/64static routers=192.168.178.1
static domain_name_servers=127.0.0.1


knip
...

N.B.:
-Voor zover ik weet mag je zo’n (hexadecimaal) fc00:: …/64 of fd00:: …./64 adres gewoon zelf verzinnen (doet Windows immers ook).


Ter aanvulling of als alternatief
Je kan i.p.v. het zelf zo 'n een statisch IPv6 IP-adres intikken / verzinnen, met een andere aanpassing in het bestandjre dhcpcd.conf zorgen dat er automatsch (na een reboot) een adres wordt aangemaakt / gebruikt. Een adres op basis van het MAC-adres (waarbij er iets in het midden wordt tussen gevoegd en het 7e bitje omgeflipt wordt).

Zet hiertoe in het bestand dhcpcd.conf een # voor de regel waar staat: slaac private
Ik loop ook tegen hetzelfde probleem aan, ik kan DHCPv6 niet disablen in de Compal waardoor deze blijft adverteren in mijn netwerk en daarmee concurreert met mijn Pi-Hole.
Ik heb zojuist gebeld met de Ziggo klantenservice om IPv6 uit te zetten en terug te gaan naar IPv4.
De klantenservice gaf aan dat IPv6 al uit stond voor mij, maar dat mijn huidige Compal dit niet lokaal wordt overgenomen. Ze hebben mij daarom een Arris ter vervanging opgestuurd waarbij dit wel goed zou werken, met de Arris zou ook mijn lokale stack naar IPv4 only worden teruggezet.
Ik laat mijn ervaringen met de Arris nog weten zodra hij is geïnstalleerd...

Reageer