How to: router achter modem

  • 30 april 2017
  • 77 reacties
  • 96233 keer bekeken

Reputatie 3
Badge +3
● HOW TO:


router achter modem/router. door WAN poort te gebruiken als LAN poort.


1: Sluit router aan op pc of laptop. niet op de WAN poort maar op een LAN poort.

2: Ga nu naar het menu van je router 192:168:***.***

3: Ga naar het menu waar je het IP-adres van de wan poort in kan stellen. Meestal heet deze network.

4: Geef bij het IP adres een adres in dat valt binnen de IP bereik van het modem/router, maar buiten het bereik van de DHCP. Dus DHCP begint bijvoorbeeld bij 192.168.178.10 dan moet het vaste ip adres dus een getal zijn tussen de 1 en 10 bijvoorbeeld 2. zorg dat het een vast/static IP word. Voorbeeld IP-adres van de modem router is 192.168.178.1 geef dan de WAN poort 192.168.178.2

5: Bij subnetmask vul je het adres in van de subnetmask van de modem/router meestal 255:255:255:0 of 255:255:254:0 Deze kun je ook vinden door in te loggen op je modem/router.

6: Bij default gateway vul je het IP-adres in wat je gebruikt om in te loggen op je modem/router.

7: Bij primaire en secundaire DNS vul je de DNS server adressen in die je kunt vinden in je modem/router of google op je ISP.

8: Stel bij LAN ook een vast IP adres in op je router wat buiten het IP bereik van de modem/router valt bijvoorbeeld het modem/router heeft 192.168.178.1 geef dan de router het vast ip 192.168.0.1

9: Schakel nu de DHCP server uit op je modem/router, schakel de DHCP server in op je router.

10: Koppel nu je router los van de pc of laptop. doe een kabel in de lan van de modem/router en in de WAN van de router.

11: Zet nu beide uit en start dan als eerste modem/router weer op en daarna de router.


Zo heb je een stabiele verbinding waarbij je eigen router al de IP adressen uitdeelt. Doordat je de WAN poort van je router nu gebruikt om aan te sluiten op je
modem/router, heb je alle LAN poorten vrij. Ook de storingen die kunnen ontstaan door dubbele DHCP zijn hiermee verholpen.


Modem hoeft niet in bridge, dus je kan gewoon gebruik blijven maken van je wifi spots

77 Reacties

@Marten1980 goeie uitleg, ik vraag me alleen af, zet je dit in, om gebruik te maken van de WiFi van de Ziggo modem?  Zelf kies ik er voor om de modem in bridged mode te zetten, en het publiek ip af te vangen op mijn router. [mikrotik] Dit werkt prima als je zelf je eigen wifi router gebruikt. Wel een kleine disclaimer: je bent daarmee ook zelf verantwoordelijk voor je eigen firewall en zo.

Hallo,

Het spijt me maar ik spreek niet goed nederland.

I was able to read (and I think understand) but would not be able to explain my porblem in Dutch...Sorry for that.

 

Allow me to revive this quite old but very interesting topic. I have a very similar setup than Martin (I highlighted the difference in bold):

IP adres van connectbox: 192.168.178.1

Internet instellingen in router:
WAN IP-adres: 192.168.178.2 (this is out of the DHCP range and permantely assigned to the MAC address of my router thanks to the Connect Box )
Subnet Mask: 255.255.255.0
Default gateway: 192.168.178.1

The reasons why I didn’t put my Connect box in bridge mode are the following :

  • I don't want to be dependent of customer care to change my set-up (or revert the change)
  • I still want to be able to administrate the Connect Box
  • I want to use the Connect Box ethernet ports

 

This set-up works fine BUT has several limitiations :

  • The Connect Box and the Router are 2 separated networks and they don't communicate. So when I plug a device on one of the Connect Box ethernet port, the other devices connectd to the router can't see/access it
  • Surprisignly, when I deactivate DHCP on the Connect box, nothing works anymore, it looks like the rules to assign a fix IP based on MAC address are not working anymore

I have 2 questions :

  1. I understand that I can't have the WAN IP and the Router IP on the same subnet so what can I do to get devices plugged on hte Connect Box ethernet port visible to devices connected to the Router subnet?
  2. How can I assign a fixed IP adress on a device connect to the Connect box ethernet ports when DHCP is deactivated? Can such adress belong to the subnet of my router?

 

Thank you all for your precious help.

 

GR

 

D.

I think you are complicating your network by using this router after router setup. You explained why you don’t want bridge mode. It is possible to login to the modem in bridge mode, and you only need the helpdesk once. However if you want to keep your Ziggo modem in router mode, please explain why you need a second router? In most cases, a switch and extra access point is sufficient to expand your network. A second router complicates the matter, since it’s a router. It segments your network. Maybe you can put your second router in access point mode?

First of all (it is actually very simple :wink: ).

just connect your second router to your modem and see which ip address the modem assigns to the second router.

Edit the modem and reserve that ip address to that router, but do this in the modem.

(i will assume in this case for the story it is 192.168.178.10

 

a small explanation about static ip addresses (or preserved or permanent as each router names this differently) and the dhcp server.

normally we assign a static ip address outside the DHCP spool (this is the range of ip addresses which are reserved for the dhcp server . so if the lan network is 192.168.178.1/24 and the dhcp spool starts at 192.168.178.10 and has 50 addresses then the spool is from 192.168.178.10 to 192.168.178.59 which are 50 addresses.).

however if we let a router (in this case the ziggo modem) assign a static address to a local device (in this case the second router) it does not matter if that address is inside or outside the dhcp spool as long as it is inside the 192.168.178.1/24 network. (192.168.178.1/24 means a subnetmask of 255.255.255.0 with 255 addresses including it`s own. as 192.168.xxx.xxx is a class C network it standard has a subnetmask of 255 addresses fyi).

why does this not matter? because it knows that that specific address is assigned  and will not hand it out to another device (mac-address).

 

But if we set up a device to be static in a network outside the router.

So as it is explained in the first post in this topic.

Then off course it needs to be outside the DHCP spool of the router to which it is connected

but within it`s LAN ip range (in this case the LAN range of the modem which is 192.168.178.1/24) in order to make sure that the dhcp server of that router does not hand out that same ip address to an other device. 

 

Back to the begin.

the second router is now connected to the ziggo-modem and has a IP address from the dhcp server off the ziggo-modem which you made static in the ziggo-modem.

 

Now you connect your devices to the second router and make sure no device has it`s ip settings static in their device. So all devices are set to receive their ip address from the dhcp server (in this case from the second router).

In windows type in the "run” button the command ncpa.cpl

this will open your network devices off the computer.

find the one which you connect with to the router and click on it with the right mouse button.

then in that roll down menu click with the left mouse button on the word "status”

then in the window that opens click again on "details” this should list the received ip address of that windows pc but also it`s ipv4 standard gateway (this is the routers LAN ip address).

let`s assume this is 192.168.0.1 (it can literally be any other address).

 

now in your browser on your pc enter in the address field that ip address 192.168.0.1

and if all is well we will now see the login page of the router.

in here you should be able to find the Pi-server in the dhcp client-list (or under connected devices which ever it is called).

assign a static ip address to that PI device as you did earlier but now you do this in this router for the Pi device. 

 

after you have done this go to port forwarding and add a rule.

set at the ip address the ip address of the Pi device,

set as local start port, port 80 (if that is the port you need to enter the pi device but i assume it is)

if asked set as local end port also the same port which is in this case port 80.

 

set as external start port any port you want but not port 80 or 443 or any other tcp and udp port that is preserved.  for a Overview of common TCP and UDP Default Ports click on this link.

let`s assume you choose port 1212.

then fill in at external start port 1212 and do the same with external end port if prompted.

then choose protocol (choose both if you are in doubt )

 

lastly activate or enable the rule (mostly you need to vink that option)

and apply.

 

now open a second tab in your browser and in the address field type 192.168.178.1

and login to your ziggo modem.

in here go to port forwarding and add a rule.

fill in that rule ip address 192.168.178.10 (which is the Wan-ip address off your second router)

at the local start port you fill in 1212 and do the same at the local end point if asked.

at the external start port again any port (except the ones listed in the earlier link) is okay,

let`s take 1111 fill this in also at the external end port when prompted.

 

vink on activate or enabled and apply the rule.

before everything works you need to restart the router if you gave the 

Pi device an other static ip address then it also was given by the routers dhcp server.

in order to make sure the pi device has the ip address you assigned to it.

however if that was the same it received from the router already then no restart is necessary.

 

no open a new tab in your browser and go to www.whatismyip.com and see what your Ipv4 is that the provider assigned to your ziggo modem.

copy that address and fill it in on the browsers address field but add a double point and the port 1111. for instance your ipv4 is 85.86.52.86 then in the address field fill in 85.86.52.86:1111

 

now you should be able to enter you Pi server from outside your local area network.

 

hope it helps if you still haven`t found a solution.

Greets :wink:

Hallo,

Het spijt me maar ik spreek niet goed nederland.

I was able to read (and I think understand) but would not be able to explain my porblem in Dutch...Sorry for that.

 

Allow me to revive this quite old but very interesting topic. I have a very similar setup than Martin (I highlighted the difference in bold):

IP adres van connectbox: 192.168.178.1

Internet instellingen in router:
WAN IP-adres: 192.168.178.2 (this is out of the DHCP range and permantely assigned to the MAC address of my router thanks to the Connect Box )
Subnet Mask: 255.255.255.0
Default gateway: 192.168.178.1

The reasons why I didn’t put my Connect box in bridge mode are the following :

  • I don't want to be dependent of customer care to change my set-up (or revert the change)
  • I still want to be able to administrate the Connect Box
  • I want to use the Connect Box ethernet ports

 

This set-up works fine BUT has several limitiations :

  • The Connect Box and the Router are 2 separated networks and they don't communicate. So when I plug a device on one of the Connect Box ethernet port, the other devices connectd to the router can't see/access it
  • Surprisignly, when I deactivate DHCP on the Connect box, nothing works anymore, it looks like the rules to assign a fix IP based on MAC address are not working anymore

I have 2 questions :

  1. I understand that I can't have the WAN IP and the Router IP on the same subnet so what can I do to get devices plugged on hte Connect Box ethernet port visible to devices connected to the Router subnet?
  2. How can I assign a fixed IP adress on a device connect to the Connect box ethernet ports when DHCP is deactivated? Can such adress belong to the subnet of my router?

 

Thank you all for your precious help.

 

GR

 

D.

Ok. Duidelijk. Dit Topic gaat over Router op Router. Vandaar de vragen.
Je hebt een ander probleem. Start een ander Topic hierover.
Wat gaat er nu precies mis met die Pi?
Hoe komt ie aan z'n Ip? Wat is dat Ip?
Over welke service gaat het op de Pi, die je extern wilt bereiken?
Werkt die service wel binnen je LAN?
Combineer je DMZ-host met handmatige Port Forwards en/of door UPnP in de list gezette Port Mappings?
Wat heb je voor Firmware op de ConnectBox. Is het IPv4 of IPv6 Dual Stack?
Port Forwarding op de ConnectBox kan alleen met deze twee Firmware varianten.
Check via http://www.test-ipv6.com/ op een PC of je een Public IPv6 address hebt.
Dan weten we dat ook weer.

Gr Han
Dr komt hier niet eens een router aan te pas dan die op modem en de wan daarvan bepaalt ziggo dynamisch, en een webservice houd dat weer voor me bij en redirect je daarnaartoe vanuit een site, mijn pi zit op het modem, de dmz staat op het ip van de pi. Simple as that, hoef geen nummers te noemen.
@Brampage
Tsja, dit is te globaal om iets te weten te komen over je probleem.
Wil je nog proberen in te zoomen?
Gewoon enkele lullige vraagjes.
Wat is het WAN Ip van je eigen Router en hoe stelde je dit IP in?
Wat is het subNet van je eigen Router?
Toch niet 192.168.178.0/24 Of stelde je dat van de ConnectBox anders is dan de standaard?
Gr Han
Dus wat ik hieruit haal is dat er geen oplossing is en dit is de enige echte legit ongoing discussion over dit probleem wat betreft ziggo om dit op te lossen? Want dit werkt nog steeds voor geen meter en ik baal hier echt hard van, na de verhuizing moest ik over naar ziggo en bij kpn draaide het modem met zijn dmz functie fantastisch, simplistisch, en toch geavanceerd als het nodig was (en dat dan zonder te bellen om vanalles te unlocken)
.... Flauwekul.....

schreef je.
Het is geen flauwekul, wat ik je op jouw verzoek
Al eens geprobeerd?

liet weten, maar feit.
Die moeite had ik me dus kunnen besparen.

Neem je niet kwalijk dat je dit in twijfel trekt.
Diskussie wat mij betreft gesloten.
@liefde
Als je het over Ziggo kastjes hebt?
Ja. Op een UBEE (typenr weet ik niet meer) en op mijn huidige Techniclor 7210.

Ook met Router op Router. De tweede Router was de TP-Link Archer C7, die
ik nu als Access Point gebruik.
IP adressen buiten de DHCP Range ging ook prima op die Archer.

Een Router realiseert een subNet. Alle adressen in dat subNet kunnen.
Je kunt desnoods de DHCP Server uitzetten en aan een andere DHCP Server overlaten.
Of zelfs helemaal geen DHCP en alles met het handje een vast IP geven.
DHCP staat los van wat een Router doet. Een Router werkt zonder wetenschap van DHCP.

Misschien ben je in het verleden eens een probleem tegengekomen dat lijkt op wat je beweert. Dat was dan iets anders.

GR Han


Flauwekul. Ik heb aan diverse router/modem firmware meegeschreven over de jaren. De reden dat het in veel modems niet werkt is simpel; Firewall en NAT traversal is gekoppeld aan de DHCP range. Je kunt proberen wat je wilt, maar je krijgt geen NAT over een LAN IP dat buiten de DHCP range zit (zodra je de DHCP enabled hebt), met als gevolg dat je geen verkeer naar binnen/buiten zult zien. Daar zijn open-source modules voor, in code, en die worden bijna overal ingezet (ze staan op github). In ieder geval op Hitron CGNV modems en veel Cisco/LinkSys en D-Link modems.
Als je het over Ziggo kastjes hebt?
Ja. Op een UBEE (typenr weet ik niet meer) en op mijn huidige Techniclor 7210.

Ook met Router op Router. De tweede Router was de TP-Link Archer C7, die
ik nu als Access Point gebruik.
IP adressen buiten de DHCP Range ging ook prima op die Archer.

Een Router realiseert een subNet. Alle adressen in dat subNet kunnen.
Je kunt desnoods de DHCP Server uitzetten en aan een andere DHCP Server overlaten.
Of zelfs helemaal geen DHCP en alles met het handje een vast IP geven.
DHCP staat los van wat een Router doet. Een Router werkt zonder wetenschap van DHCP.

Misschien ben je in het verleden eens een probleem tegengekomen dat lijkt op wat je beweert. Dat was dan iets anders.

GR Han

Er zijn echter een heleboel typen modems en routers die geen verkeer accepteren op adressen buiten de DHCP range, zoals de modems van Hitron.
@liefde
Dit is flauwekul.
Gr Han

Eeh, nee. Al eens geprobeerd?
Er zijn echter een heleboel typen modems en routers die geen verkeer accepteren op adressen buiten de DHCP range, zoals de modems van Hitron.

@liefde
Dit is flauwekul.
Gr Han
Als je een IP adres gebruikt buiten de DHCP server, kan de DHCP server hetzelfde IP adres niet per ongeluk uitreiken aan een ander apparaat, als hij de router even niet zou zien, waardoor je wel eens DHCP IP conflicten krijgt in je netwerk.
Je zit uiteraard wel in dezelfde IP range dus volledig bereikbaar.

Ik zet ook alle apparaten waar ik een eigen IP adres in kan zetten buiten de DHCP range zoals netwerk printers op 192.168.178.4 en 192.168.178.5, Wifiboosters via stopcontact op 192.168.178.2 en 192.168.178.3.
Ik hoef nu ook geen IP adressen te reserveren in de router op MAC adres.
Hierdoor hebben deze apparaten altijd hetzelfde IP adres en zijn makkelijk te bereiken als je instellingen wilt veranderen en hebben ze bij een reset van het modem of de router nog steeds hetzelfde IP adres.

Mocht je veel apparaten in gebruik hebben kun je zelfs je DHCP server op b.v. laten starten op 192.168.178.50, dan heb je van 192.168.178.2 tot 192.168.178.49 o apparaten een vast IP adres te geven.

Er zijn echter een heleboel typen modems en routers die geen verkeer accepteren op adressen buiten de DHCP range, zoals de modems van Hitron.
Goed punt @acoster

Je zou dit evt ook 'een beetje dom' kunnen testen door tijdelijk alle Firewalls uit te zetten.
Van de ConnectBox, van je eigen Router en van de Web Server.
Als het dan wel werkt, dan een voor een weer aanzetten etc, etc.
Dan komt de boosdoener te voorschijn.
Werkt het ook niet met alle Firewalls uit, dan zijn we terug op square one.

Gr Han
Reputatie 6
Badge +9
Heb je ook gekeken naar de routering terug, vanaf je webserver?
Als je hem via het lokale netwerk benaderd, gaat het goed, dus de weg terug binnen je eigen netwerk kan de server prima vinden. Weet hij ook de weg naar buiten te vinden? Kan je vanaf je webserver eens kijken of je de buitenwereld kan bereiken?
Reputatie 7
Badge +14
@Martin Wingelaar ,

Als de eigen router ook Dual Stack heeft, dan zou je eens moeten kijken of je daarin DHCP Prefix Delegation kan activeren (en daarna herstarten).
Hi @Martin Wingelaar, kan ik vanuit hier ook je website benaderen of is dat puur een privé server die je op hebt gezet? Dan kan ik ook wat pingtestjes doen e.d.

Jouw Connectbox heeft Dual-stack firmware, dus je hebt zowel een publiek uniek IPv4- als IPv6-adres.
Nu heb ik hier persoonlijk geen ervaring mee (router-achter-router setup op deze manier), maar ik kan me voorstellen dat een IPv4 DMZ instelling alleen werkt voor IPv4 verkeer en niet voor inkomend IPv6 verkeer, wellicht dat dat roet in het eten gooit?


Mark,

met het oude modem/router van ziggo was de website gewoon van buitenaf benaderbaar.
Nu krijg ik het met geen mogelijkheid aan de praat. Via het WAN ip-adres van mijn eigen router lukt het nog. Maar ik kom niet door het nieuwe ziggo modem heen.

Martin
@Mark Ziggo
maar ik kan me voorstellen dat een IPv4 DMZ instelling alleen werkt voor IPv4 verkeer en niet voor inkomend IPv6 verkeer, wellicht dat dat roet in het eten gooit?


Op zich is dit wel een punt om over na te denken.

Maar.
Het uitgangspunt mag zijn dat de Web Server via port 80 van buiten via het externe IPv4 address van de ConnectBox wordt benaderd. De eigen Router als IPv4 DMZ-host van de ConnectBox krijgt dat binnen en geeft een Forward naar het Ip van de Web Server in het subNet van de eigen Router. Die Forward is Ok getest in het LAN!
Dat is de theorie. Het is echt heel vreemd dat dit in de praktijk niet blijkt te werken.
Ook niet als je DMZ-host niet gebruikt en een dubbele Port Forward probeert als alternatief. (extern port 80 in ConnectBox forwarden naar 80 van het Wan Ip van de eigen router).

Van buiten benaderen via het globale IPv6 adres van de Web Server kan in principe, maar is andere koek, die los staat van bereikbaarheid over IPv4. Het is tenslotte Dual Stack, toch?
1e randvoorwaarde is dat er IPv6 beschikbaar is in het network waar je zit, anders gaat het feest sowieso niet door.
Op bv een Phone via 4G is dat (meestal?) niet zo. En er zijn nog zat andere omstandigheden, waarbij er geen IPv6 beschikbaar is (PC op het werk, etc).
Stel je hebt IPv6.
Dan moet er thuis ook nog wat gebeuren om bij de web server te kunnen komen via IPv6.
In de IPv6 Firewall van de ConnectBox moet poort 80 worden geopend voor het IPv6 address van de Web Server.
En dan: heeft die web server op de eigen Router wel een IPv6 address?
Dat heeft weer te maken met of de eigen Router voor IPv6 goed samenwerkt met de ConnectBox. Dat hoeft niet zo te zijn (geen IPv6 support eigen Router, foute instelling of probleem met IPv6 standaards tussen CB en eigen Router). Dan is er alleen een IPv4 address, wat verder geen echt probleem is, behalve dan dat benadering via IPv6 niet mogelijk is.
Een optie kan in zo'n geval nog zijn de Web Server aan de ConnectBox te hangen, als je hem per se van een IPv6 address wilt voorzien.

Gr Han
Reputatie 7
Hi @Martin Wingelaar, kan ik vanuit hier ook je website benaderen of is dat puur een privé server die je op hebt gezet? Dan kan ik ook wat pingtestjes doen e.d.

Jouw Connectbox heeft Dual-stack firmware, dus je hebt zowel een publiek uniek IPv4- als IPv6-adres.
Nu heb ik hier persoonlijk geen ervaring mee (router-achter-router setup op deze manier), maar ik kan me voorstellen dat een IPv4 DMZ instelling alleen werkt voor IPv4 verkeer en niet voor inkomend IPv6 verkeer, wellicht dat dat roet in het eten gooit?
Right. Vreemde zaak. Ziet er prima uit.
Zou DMZ-host niet werken?

Probeer dan dit op de ConnectBox.
Geen DMZ-host.
extern port 80 Forwarden naar intern port 80 van 192.168.178.10

Verder ook dit.
Het zou bizar zijn, maar stel dat het ligt aan het uitzetten van DHCP op de ConnectBox. Kun je ook ff testen.
Na wijziging van iets op ConnectBox voor de zekerheid altijd maar een Reboot/Restart doen + Check of je wijziging er nog is. Ook al zou dat officieel niet nodig moeten zijn.

Gr Han

Han,

Ook met DHCP aan werkt het niet. Port 80 geforward in de connectbox en nog steeds werkt het niet.
Als ik in mijn browser het WAN-adres van mijn router ingeef (192.168.178.10) dan kom ik wel op mijn website. Dus port-forwarding in mijn router is ok.
Ik kom gewoon niet door de connectbox heen, wat ik ook probeer.
Raar allemaal.

Martin
Reputatie 6
Badge +9
Yep..dat is waar, dat is enkel als hij als AP en/of switch wordt gebruikt.

En verbinding van binnen naar buiten werkt wel goed, als je een laptop bekabeld op de TP-link aan sluit??
@acoster
LAN0 van de TP-Link?
Welnee. Dit is Router op Router. De kabel vanaf de ConnectBox moet in de WAN/Ethernet port van de TP-Link.
Dat gaat ook prima. Er is slechts een akkefietje met DMZ-host ivm remote access via het externe Ip van de ConnectBox.

Aansluiten op een LAN poort van de TP-Link doe je als hem configureert als Access Point, dwz niet als Router gebruikt. Bij veel moderne Routers hoeft dat niet eens meer. Als je die als Acces Point configureert met een simpele daarvoor bedoelde instel-optie, dan wordt de WAN poort automatisch de vijfde LAN-poort.

Gr Han
Reputatie 6
Badge +9
Als ik het goed begrijp, heeft je connectbox gewoon nog de verbinding met buiten, met het WAN... De connectbox staat niet in bridgemode toch?

Je moet waarschijnlijk de TP-link aansluiten op LAN0, niet op de WAN-port.
Reputatie 3
Badge +3
Tp link ip moet op 2 tot 10 staan blijft op die.manier buiten.de dhcp van de connectbox mocht je die als router blijven gebruiken

Reageer