Beantwoord

Eigen IPv6 router achter Connectbox

  • 18 januari 2019
  • 10 reacties
  • 1806 keer bekeken

Hallo iedereen,

Sinds vandaag heb ik een nieuwe modem gekregen van Ziggo. Dit is een Aris Connectbox. Ik had begrepen dat met dit type modem IPv6 in full dual-stack mogelijk is in het fZiggo gebied. Daarom wilde ik IPv6 doorzetten naar mijn eigen netwerk.

Ik heb inderdaad full dual-stack IPv6. Achter de Connectbox heb ik mijn eigen router die via Prefix Delegation een prefix opvraagt. Ik krijg een /60 terug die ik kan gebruiken achter mijn eigen router.

Tot zover positief, maar dan... Als ik vanaf mijn netwerk een ping doe naar buiten krijg ik geen reactie. De route naar buiten is goed, icmp in de firewall staat ook op allow en in de Connectbox firewall heb ik ook al het verkeer naar mijn eigen router toegestaan. Als ik een traceroute vanaf een andere plek uitvoer naar een IP-adres in mijn netwerk, dan krijg ik reactie tot de Connectbox. Ook als ik bij een ping naar buiten een packetsniffer aanzet op de lijn tussen de Connectbox en mijn router zie ik wel ICMP uitgaan, maar niet terugkomen.

Het lijkt alsof de Connectbox geen route heeft voor mijn toegewezen prefix. Helaas is dat niet te zien.

Ben ik iets vergeten in te stellen? Of is een eigen IPv6 router toch niet mogelijk? Ik hoop dat iemand met mij mee kan denken of mij kan vertellen of het wel of niet mogelijk is.

Alvast bedankt.

Groet,
Christiaan
icon

Best beantwoord door KoffieKopje 20 januari 2019, 01:25

Het probleem is opgelost! Misschien een beetje beschamend.... De firewall in de Connectbox stond nog aan. Ik dacht dat ik die al had uitgezet.
Bekijk origineel

Dit topic is gesloten. Staat je antwoord hier niet bij, stel dan je vraag in een nieuw topic.

10 Reacties

Reputatie 7
Badge +14
@KoffieKopje

Hi Christiaan,


Helpt het misschien als je:
Router Advertisement enabled? Bij mij staat dit onder DHCP.
En /of
RIPng . Bij mij staat dit bij Advanced Routing / Dynamic Routing.

Groet,
DennyW
Hoi DennyW,

Bedankt voor je antwoord. Ik heb bovenstaande zojuist aangezet op mijn router, maar helaas krijg ik nog geen reply.
Het probleem is opgelost! Misschien een beetje beschamend.... De firewall in de Connectbox stond nog aan. Ik dacht dat ik die al had uitgezet.
Hallo,

Ik veronderstel dat je de IPv6 Firewall op de ConnectBox hebt uitgezet.
Dat kan als er tenminste een goede IPv6 Firewall op je eigen Router is &
je verder geen hosts aansluit op de ConnectBox.
Wat je niet moet willen is dat al je globale IPv6 adressen van buitenaf zomaar bereikbaar zijn.
Ik experimenteerde eens met IPv6 op een TP-Link Archer C7. Die heeft wat IPv6 support maar een IPv6 Firewall ontbreekt. Vandaar. (Heb geen ConnectBox maar een Technicolor 7210 met Dual Stack).
Uit interesse: wat voor eigen Router heb je?
Gr Han
Hallo,

Ik veronderstel dat je de IPv6 Firewall op de ConnectBox hebt uitgezet.
Dat kan als er tenminste een goede IPv6 Firewall op je eigen Router is &
je verder geen hosts aansluit op de ConnectBox.
Wat je niet moet willen is dat al je globale IPv6 adressen van buitenaf zomaar bereikbaar zijn.
Ik experimenteerde eens met IPv6 op een TP-Link Archer C7. Die heeft wat IPv6 support maar een IPv6 Firewall ontbreekt. Vandaar. (Heb geen ConnectBox maar een Technicolor 7210 met Dual Stack).
Uit interesse: wat voor eigen Router heb je?
Gr Han


Hoi Han,

Dat klopt, ik heb de ipv6 firewall in de Connectbox uitgeschakeld. Ik heb daar mijn eigen router achter en sluit verder niks aan op de Connectbox. Voorheen had ik altijd mijn modem in de bridge, maar daar wordt IPv6 nog niet ondersteund.

De router die ik gebruik is een Mikrotik RB962 (hAP AC). Deze heeft wel een ingebouwde IPv6 firewall die gebasseerd is op iptables. Standaard is mijn forward chain vanuit buiten op drop. Dus interne apparaten zijn niet zomaar vanuit buitenaf bereikbaar.

Ik vind het wel bijzonder dat een TP-link router geen firewall heeft ingebakken voor IPv6. Dat zou je toch juist wel verwachten van zo'n type router?
Die te oude TP-Link van mij had dat niet. Prefix Delegation werkte wel.
De Firewall van mijn Dual Stack Technicolor kon dus niet uit.
Moderne TP-Links zullen nu ongetwijfeld wel een nette IPv6 Firewall hebben.
En met die Mikrotik van jou zit dat zeker wel goed!
Gr Han
@hanh schreef: "De Firewall van mijn Dual Stack Technicolor kon dus niet uit."

Zojuist gekeken en ik kan de IPv6 firewall in de TC7210 nu wel uitzetten.
Of ging de firewall bij jou niet echt uit?
@Be rt Ik kan de IPv6 Firewall op de Technicolor ook uitzetten, maar dat kon/mocht ik niet doen toen er een Router achter hing die geen IPv6 Firewall aan boord heeft.
Die contructie gebruik ik niet meer- die Router is nu een een Access Point.
Gr Han
@hanh Ah, natuurlijk, ik dacht even niet ver genoeg door.🤔
Nou dat 'kon' was op twee manieren uit te leggen. Ik bedoelde 'mocht'. Het blijft lastig iets zo duidelijk op te schrijven dat er geen misverstand mogelijk is!. Eigenlijk is dit soms vrijwel niet snel te doen.