1
Vraag
2
Reacties
henk99999

Gedreven Raadgever
  • 33Posts
  • 2Oplossingen
  • 4Likes

wat doet ziggo bij mij met portforwarding

Hoi,

 

Ik ben vast niet de enige.

Sinds een aantal dagen werkt portforwarding niet meer.

 

Er was eergisteren storing. Die was na een uurtje opgelost.

Echter inkomend verkeer werkte niet meer.

 

De helpdesk helpt niet. Je kan hoog of laag springen met je dure zakelijke abbo.

poortforwarding wordt niet ondersteund.

Je kan het lekker zelf uitzoeken. Wat een service.

Ik heb mijn ziggo modem connnectbox opnieuw ingericht. met een eenvoudig servertje op poort 80.

geforward.

Dat leek heel even te werken, maar als ik nu een testje doe krijg ik

> User-Agent: curl/7.74.0

> Accept: */*

> 

* Mark bundle as not supporting multiuse

< HTTP/1.1 301 Moved Permanently

< Location: https://xxx.xxx.xxx.xxx/

< Content-Length: 0

< Date: Wed, 21 Sep 2022 17:41:54 GMT

< Server: lighttpd

< 

Dus geen nginx?

Als ik een poort forward op 443 of 8443 krijg ik connection refused.

Het lijkt dus of het bewust wordt ondervangen en tegengehouden.

 

Hoe nu verder met mijn eigen wireguard server die tijden prima werkte.

Laat staan de rest van mijn selfhosted hobby project. Die achter zijn eigen router hangt.

Lokaal draait alles als een zonnetje.

 

Groet,

Henk

 

NB moet ik overstappen naar een provider die dit nog wel support?

Oplossing

Geaccepteerde oplossingen
henk99999
topicstarter
Gedreven Raadgever
  • 33Posts
  • 2Oplossingen
  • 4Likes

Ik heb mijn router via de ziggo site in bridge mode gezet en ben dus nu mijn DMZ en spare WIFI netwerk kwijt. 😪

Na het opnieuw instellen van mijn eigen router heb ik weer gewoon inkomend verkeer op de geforwarde poorten. Heb wel een nieuw WAN ipadres. Misschien dat ik om te testen het nog eens terugzet, maar voorlopig kan ik mijn wireguard VPN server weer bereiken. Heb ik in ieder geval die security laag weer op al mijn clients.

Het blijft natuurlijk een vreemd filmpje dat na een volledige reset (meerdere malen) portforwarding op de ziggo router (na een storing) niet meer werkt. Misschien doet ziggo dit wel bewust om van het gezeik af te zijn. Ze zijn natuurlijk aan de beurt geweest om vrije modem keuze te ondersteunen.

Ik zal dit ook als oplossing markeren. 

Bekijk in context

16 Reacties 16
tobiastheebe
Super Expert
Super Expert
  • 13827Posts
  • 849Oplossingen
  • 5540Likes

Is je IPv4-adres aan WAN-zijde misschien veranderd?

 

Port forwarding op router achter router vereist DMZ (1:1 NAT) op de modemrouter of dubbele forwarding-regels, maar dat wist je waarschijnlijk al.

henk99999
topicstarter
Gedreven Raadgever
  • 33Posts
  • 2Oplossingen
  • 4Likes

Dat kan wel zijn, maar dan is dat nieuw. Tot eergisteren werkte alles perfect.

Bovendien staat mijn test webserver nu direct aan de ziggo box met een vast ipadres op 192.168.178.x netwerk.

Ik heb het bij een onderbreking wel eens vaker aan de hand gehad en er werd geadviseerd in bridge mode te werken. Maar daarom heb ik juist mijn eigen router. Eigenlijk is het ziggo netwerk mijn DMZ. En voor als ik mijn eigen netwerk down gooi voor onderhoud.

Ze zeiden wel  eens dat men dan iets moest aanpassen, om het te laten werken, maar er werd nooit uitgelegd wat.

Security by obscurity 😉

Ipadres is niet aangepast en daar hebben we dyndns voor...

En ja ik heb dubbele portforwarding op mijn eigen router en de connectbox.

tobiastheebe
Super Expert
Super Expert
  • 13827Posts
  • 849Oplossingen
  • 5540Likes

Het kan geen kwaad om even te controleren of je WAN IP-adres nog hetzelfde gebleven is.

 

In een ander topic bleek dat port forwarding alleen werkte voor DHCP-leases. Ik weet niet meer om wat voor type modem het ging, het was wel een SmartWifi modem/Connectbox. Wat ook kan helpen, is de firewall-instellingen zo aanpassen dat alleen 'Firewall beveiliging' is ingeschakeld en het uitschakelen van UPnP.

 

Bij gebruik van een eigen router is inderdaad bridge mode aanbevolen. Dit is stabieler dan dubbele router/NAT en minder gevoelig voor configuratieproblemen.

henk99999
topicstarter
Gedreven Raadgever
  • 33Posts
  • 2Oplossingen
  • 4Likes

Nee het WAN ip adres is ongewijzigd. Ik zal alle what is my ip adres  sites nog eens checken, maar ook modem info in de connectbox geeft hetzelfde WAN ipadres.

Ook met nmap kan ik zien dat het goed is, als ik mijn server uitzet geeft nmap filtered op poort 80 als ik de server aanzet zegt nmap open poort 80. Ik controleer het via een servertje bij digital ocean.

Ik heb al jarenlang deze omgeving draaien en nooit echte problemen gehad.

Bridge modus vind ik meer een soort verkooppraatje.

De laatste keer dat er een (gratis) monteur kwam om mijn mediabox te vervangen heb ik hem uitgebreid mijn selfhosted netwerk laten zien. Hij was onder de indruk :-).

 

Bedankt voor je pogingen te helpen in ieder geval.

Al meer dan de helpdesk mij kon/mocht bieden. Een beleid van likmevessie zeggen ze dan in Amsterdam.

 

Groet,

Henk

 

NB Ik zag ook je opmerking over DHCP leases. Ik neem aan dat je het ziggo modem bedoelt. Daar heb ik 1 DHCP lease op het macadres van mijn router in staan. en nu ook voor dat testservertje. Maar het testresultaat zegt mij dat bij binnenkomst al en 301 op poort 80 wordt geforceerd., omdat dat niet bij mij draait Dat zegt mij dus eigenlijk dat ze poort 80 niet doorlaten. Wat ik me goed kan voorstellen. Ik zet het altijd alleen even aan en uit om mijn letsencrypt certificaat te vernieuwen helaas nog steeds nodig.

 

tobiastheebe
Super Expert
Super Expert
  • 13827Posts
  • 849Oplossingen
  • 5540Likes

Ik heb hier ook een eigen thuisnetwerk met Ubiquiti-apparatuur. Echter gebruik ik bridge mode op mijn UBC1318ZG. De eRouters van modems zijn erg basic en vertonen nog wel eens bugs en andere problemen. Door alleen je eigen router als router te gebruiken, heb je alles zelf in de hand en het zorgt voor een eenvoudigere configuratie. Ik zou bridge mode nog eens overwegen.

 

De reactie die je ziet op poort 80 moet haast wel van jouw server komen, ook gezien je aangeeft: "als ik mijn server uitzet geeft nmap filtered op poort 80 als ik de server aanzet zegt nmap open poort 80". Luistert jouw server wel op 443 en 8443?

efok
Expert
Expert
  • 3612Posts
  • 196Oplossingen
  • 1304Likes

Ik begrijp dat je een 301 redirect krijgt op poort 80 van lighttpd, terwijl jezelf nginx draait? Dat is wel merkwaardig. Lighttpd zou zomaar uit het modem kunnen komen. Welk modem is dit?

Bridge modus is geen verkooppraatje, maar kan juist een prima oplossing zijn voor problemen als deze. Ben er zelf erg blij mee.

tobiastheebe
Super Expert
Super Expert
  • 13827Posts
  • 849Oplossingen
  • 5540Likes

In theorie is het mogelijk dat de eRouter van het modem op poort 80 luistert op de WAN-interface en antwoord (van lighttpd) geeft met de 301 redirect naar HTTPS. Dat zou wel heel vreemd zijn en een grote impact hebben op klanten die port forwarding gebruiken met pre-NAT destination port 80.

 

Je kunt de DevTools van de browser eens bekijken wanneer je de webinterface van het modem oproept: is de server in de response header dan lighttpd?

henk99999
topicstarter
Gedreven Raadgever
  • 33Posts
  • 2Oplossingen
  • 4Likes

Het verkooppraatje is dat ze hiermee de slechte kwaliteit van het apparaat maskeren.

je kan bijvoorbeeld niet eens je eigen  (LAN) DNS invullen op die DHCP server.

Nee schakel maar uit. Waar betaal je dan voor?

Ik heb ook al uitgelegd waarom ik voor de andere oplossing kies.

Even een knopje erbij om een ander wanipadres te forceren van hun DHCP server lijkt me toch niet te veel gevraagd. Ieder janboerenfluitjesmodem kan dat.

Zeker als de helpdesk dat niet kan of wil. Nee zelf je modem resetten en zoek het maar uit.

Ik ben al klant sinds tv2000 dus ik heb al menig verkoper van een mercedes voorzien. 😉 dan verwacht ik toch iets meer. Bestaande klanten zijn lucht. Ik zal wel geblocked voor deze vuilspuiterij, maar ik ben dan ook behoorlijk over de zeik. Excuses alvast. Ik ga er maar eens een nachtje over slapen.

Groet, Henk

efok
Expert
Expert
  • 3612Posts
  • 196Oplossingen
  • 1304Likes

Ik snap je frustratie wel over modem en helpdesk. Ik ben daarom juist blij dat de Bridge optie er ook is, dan heb je daar minder gedoe mee. Maar even terug naar de kwestie, ben benieuwd of je de vragen van @tobiastheebe @nog kunt beantwoorden.

henk99999
topicstarter
Gedreven Raadgever
  • 33Posts
  • 2Oplossingen
  • 4Likes

Vandaag kleurt mijn modem weer prachtig rood. Twee keer 5 minuten van de stroom helpt niet Volgens de storingen checker is het al opgelost. Via de chat is de storing nu als het goed is opnieuw aangemeld. Wij wachten in spanning af. 

 

henk99999
topicstarter
Gedreven Raadgever
  • 33Posts
  • 2Oplossingen
  • 4Likes

Ha internet en TV werkt weer. Internet weer op hetzelfde ipadres.

Maar het probleem met inkomend verkeer is nog steeds hetzelfde.

Laatste melding de log van het modem;

No Ranging Response received - T3 time-out;CM-MAC=ac:f8:cc:43:7b:22;CMTS-MAC=00:01:5c:87:a8:64;CM-QOS=1.1;CM-VER=3.1;

Uitzoeken wat dat betekent...

Volgens nmap heeft mijn WAN ipadres MAC Address: AC:F8:CC:6A:C8:9D (Arris Group)

Volgens info op modem in de interface van Ziggo;

 AC:F8:CC:43:7B:24

Ik kom dus op een ander modem terecht dan wat bij mij staat?

 

Wordt vervolgd. (hoop ik)

 

tobiastheebe
Super Expert
Super Expert
  • 13827Posts
  • 849Oplossingen
  • 5540Likes

Een SmartWifi modem heeft ongeveer 6 MAC-adressen (CM, MTA, WAN (eRouter), ethernet (switch), Wi-Fi-radio's 2,4 + 5 GHz). Het MAC-adres wat je ziet met nmap (AC:F8:CC:6A:C8:9D) komt echter niet uit dezelfde reeks als AC:F8:CC:43:7B:22 (CM) en AC:F8:CC:43:7B:24 (WAN), dus dat is vreemd. Ik zou toch nog eens je publieke IP-adres controleren.

 

Een enkele T3 timeout duidt overigens niet op een probleem, dit geeft aan dat een RNG-RSP vanuit het CMTS niet (op tijd) werd ontvangen en is een algemeen voorkomende melding.

henk99999
topicstarter
Gedreven Raadgever
  • 33Posts
  • 2Oplossingen
  • 4Likes

Als ik de helpdesk daarmee confronteer ben ik bang dat ik weer nul op het rekest krijg 😫.

Zijn er andere manieren om de techneuten die met deze storing bezig zijn aan te sturen?

Hij staat nog open ondanks dat de tijd voor de oplossing is verstreken. Het lijkt mij een redelijk duidelijke diagnose.

henk99999
topicstarter
Gedreven Raadgever
  • 33Posts
  • 2Oplossingen
  • 4Likes

Storing is als opgelost afgevinkt. Zit weer in dezelfde cirkel. Daar wordt sinterklaas niet vrolijk van. Krijg een SMS dat er morgen onderhoud is gepland. Ga dat maar eens afwachten. Als dat niet helpt zeg ik mijn abonnement op. En ga naar mijn oude werkgever (KPN), waar ik uit principe (zelfs gratis) nooit naar toe wilde omdat ik tig jaren voor ze gewerkt heb en weet hoe een ander achter de schermen werkt. Dit verandert echter de zaak.

Ik hoop echt dat ik dit eens doorgeleid wordt naar de marketing managers of de manager van de service desk. Maar ik weet dat dat ijdele hoop is. Zoals eerder gezegd bestaande klanten zijn lucht voor dat niveau.

 

Een zwaar teleurgestelde klant.

 

Groet,

HEnk

henk99999
topicstarter
Gedreven Raadgever
  • 33Posts
  • 2Oplossingen
  • 4Likes

Nog een tegenvaller. Ik blijk een zakelijk contract tot oktober 2025 getekend te hebben bij de overstap van particulier (op een ipad aan de deur) naar zakelijk. Als ik weg wil moet ik dan drie jaar betalen.

Kleine lettertjes.

Dus ik moet roeien met de riemen niet werken. 

henk99999
topicstarter
Gedreven Raadgever
  • 33Posts
  • 2Oplossingen
  • 4Likes

Ik heb mijn router via de ziggo site in bridge mode gezet en ben dus nu mijn DMZ en spare WIFI netwerk kwijt. 😪

Na het opnieuw instellen van mijn eigen router heb ik weer gewoon inkomend verkeer op de geforwarde poorten. Heb wel een nieuw WAN ipadres. Misschien dat ik om te testen het nog eens terugzet, maar voorlopig kan ik mijn wireguard VPN server weer bereiken. Heb ik in ieder geval die security laag weer op al mijn clients.

Het blijft natuurlijk een vreemd filmpje dat na een volledige reset (meerdere malen) portforwarding op de ziggo router (na een storing) niet meer werkt. Misschien doet ziggo dit wel bewust om van het gezeik af te zijn. Ze zijn natuurlijk aan de beurt geweest om vrije modem keuze te ondersteunen.

Ik zal dit ook als oplossing markeren. 

E-mail notificaties
Aan Uit

Ontvang een update bij nieuwe reacties in dit topic.

Uitgelicht topic