1
Vraag
2
Reacties
admin0

Stamgast
  • 3Posts
  • 0Oplossingen
  • 1Likes

bridge-mode ipv6 /56 mikrotik

kan iemand mij helpen met ipv6 dhcp instellingen op mikrotik voor /56

 

Hi All, 

My dutch is not very good, so I used google translate to ask the above question. I apologize if the grammar is not correct. 

 

I have a mikrotik router and ziggo modem is in bridge mode. When I request a /56 prefix, I do not get anything. If I request  ipv6 address, i only get /64 which I cannot use/route. 

 

Looking for help from anyone who has mikrotik and successfully received a /56 range. 

1 Oplossing

Geaccepteerde oplossingen
chrisvanlith

Raadgever
  • 8Posts
  • 1Oplossingen
  • 4Likes

@admin0  Just finished a basic configuration of my mikrotik (routeros 4.49.1) to connect to ziggo ipv6 through a Ubee modem.

At first I was using al sorts of complex scripts from the internet. I got a prefix almost immediately but the rest was difficult.

Now I use the following script to connect all my lan-ports (one network, so I use Bridge) to ether1-WAN (connected to Ubee). Devices in the network get their ipv6 address automatically through SLAAC.

 

 

/ipv6 dhcp-client
 add add-default-route=yes interface=ether1-WAN pool-name=ziggo-ipv6 \
 prefix-hint=::/56 pool-prefix-length=64 request=prefix
/ipv6 nd
 set [ find default=yes ] advertise-dns=no advertise-mac-address=no \
 hop-limit=64 interface=bridge
/ipv6 address
 add address=::1 eui-64=yes advertise=yes from-pool=ziggo-ipv6 \
 interface=bridge

 

 

That is all. For now I rely on the default firewall settings of the mikrotik.

 

Good luck!

Chris

Bekijk in context

7 Reacties 7
Havanna
Expert
Expert
  • 3044Posts
  • 112Oplossingen
  • 166Likes

I am no expert but what I know is with a bridged modem you get a /56 that you can divide into 256 /64s, 1/64 per internal network/vlan.

chrisvanlith

Raadgever
  • 8Posts
  • 1Oplossingen
  • 4Likes

@admin0  Just finished a basic configuration of my mikrotik (routeros 4.49.1) to connect to ziggo ipv6 through a Ubee modem.

At first I was using al sorts of complex scripts from the internet. I got a prefix almost immediately but the rest was difficult.

Now I use the following script to connect all my lan-ports (one network, so I use Bridge) to ether1-WAN (connected to Ubee). Devices in the network get their ipv6 address automatically through SLAAC.

 

 

/ipv6 dhcp-client
 add add-default-route=yes interface=ether1-WAN pool-name=ziggo-ipv6 \
 prefix-hint=::/56 pool-prefix-length=64 request=prefix
/ipv6 nd
 set [ find default=yes ] advertise-dns=no advertise-mac-address=no \
 hop-limit=64 interface=bridge
/ipv6 address
 add address=::1 eui-64=yes advertise=yes from-pool=ziggo-ipv6 \
 interface=bridge

 

 

That is all. For now I rely on the default firewall settings of the mikrotik.

 

Good luck!

Chris

Havanna
Expert
Expert
  • 3044Posts
  • 112Oplossingen
  • 166Likes

Nice one @chrisvanlith !

Erik S
Community Moderator
Community Moderator
  • 2243Posts
  • 337Oplossingen
  • 537Likes

Hi there @admin0! First of all, welcome to the Ziggo Community 🙂 I'm glad you've found us here!

@chrisvanlith was nice enough to share his experiences here with us (thanks Chris!). Did this work for you aswell?

admin0
topicstarter
Stamgast
  • 3Posts
  • 0Oplossingen
  • 1Likes

Hi @chrisvanlith     .. this worked perfectly.   Many thanks. 

admin0
topicstarter
Stamgast
  • 3Posts
  • 0Oplossingen
  • 1Likes

Thank you for allowing me to post in English

Erik S
Community Moderator
Community Moderator
  • 2243Posts
  • 337Oplossingen
  • 537Likes

How nice that this worked out @admin0! Thank you for getting back to us and letting us know. Have a lovely day!

E-mail notificaties
Aan Uit

Ontvang een update bij nieuwe reacties in dit topic.

Uitgelicht topic