1
Vraag
2
Reacties
RAD

Level 2
  • 3Posts
  • 1Oplossingen
  • 2Likes

Ziggo blocks certain DNS queries?

Hi. Sorry, I have just recently moved to NL and don't know Dutch yet, so I am writing here about my problem.

I am a new client, yesterday I set up the router and it works fine, the speed is great and connection is stable. I am a DevOps engineer and as part of my job I need to have access to some not publicly accessible(but resolvable) domain names.

The issue is really strange, when my PC tries to resolve certain AWS public DNS names I am getting I/O timeout errors. I thought initially that it's something related to my PC but it's not, when I am doing the same when connected to my mobile internet on the same PC problem dissapears. Also the issue is reproducible with any DNS server and also when I resolve some regular domain names like example.com, google.com, etc there are no issues whatsoever, so the problem also is not related to DNS servers itself.

So, all in all it looks like there is some kind of firewall blocking my DNS requests.

Also attached the screenshot to show the problem

Oplossingen

Geaccepteerde oplossingen
tobiastheebe

Level 20
T.E.A.M.
  • 32363Posts
  • 2285Oplossingen
  • 16344Likes

The black SmartWifi modem (Sagemcom F3896) employs DNS rebind protection which blocks queries containing one or more private (RFC 1918) address in the reply, such as 10.1.2.196 and 10.1.4.208. You will need to append entries for the FQDN and these IP addresses to your operating system's hosts file to circumvent this. Another option is installing your own router and having the modem configured in bridge mode.

Bekijk in context

RAD
Topicstarter
Level 2
  • 3Posts
  • 1Oplossingen
  • 2Likes

@Welmoed 
@tobiastheebe 
By the way I solved it in my case the other way, so marking it as a solution for future.

I've enabled and configured DNS over TLS on my PC and it solves the problem since modem can't read DNS traffic now.

Bekijk in context

4 Reacties 4
tobiastheebe

Level 20
T.E.A.M.
  • 32363Posts
  • 2285Oplossingen
  • 16344Likes

The black SmartWifi modem (Sagemcom F3896) employs DNS rebind protection which blocks queries containing one or more private (RFC 1918) address in the reply, such as 10.1.2.196 and 10.1.4.208. You will need to append entries for the FQDN and these IP addresses to your operating system's hosts file to circumvent this. Another option is installing your own router and having the modem configured in bridge mode.

Welmoed
Community Moderator
Community Moderator
  • 1790Posts
  • 165Oplossingen
  • 1180Likes

Hi @RAD, no problem you can't write in Dutch 🙂 welcome to NL!

I see @tobiastheebe gave you some advice, were you able to follow up these tips?

RAD
Topicstarter
Level 2
  • 3Posts
  • 1Oplossingen
  • 2Likes

Hi @Welmoed , thanks, yes, looks like @tobiastheebe is right, also I checked other posts with the same problem, it seems that I will have to use hosts file for now to make it work

RAD
Topicstarter
Level 2
  • 3Posts
  • 1Oplossingen
  • 2Likes

@Welmoed 
@tobiastheebe 
By the way I solved it in my case the other way, so marking it as a solution for future.

I've enabled and configured DNS over TLS on my PC and it solves the problem since modem can't read DNS traffic now.

E-mail notificaties
Aan Uit

Ontvang een update bij nieuwe reacties in dit topic.

Uitgelicht topic