1
Vraag
2
Reageer en help mee
KiskuB

Level 2
  • 7Posts
  • 0Oplossingen
  • 1Likes

Vaste prefix ook voor IPv6

Inmiddels heb ik IPv6 geheel functioneel met een /56 prefix. Na reboot van de router veranderd de prefix ook als het Mac adres het zelfde blijft. Bij IPV4 krijg je steeds het zelfde adres terug gelukkig. Hierdoor raakt mijn aangesloten server in de war. Is het mogelijk de prefix voor IPv6 constant te houden?

18 Reacties 18
tobiastheebe

Level 20
Super Expert
  • 16067Posts
  • 1022Oplossingen
  • 7046Likes

De koppeling tussen MAC-adres en IP-adres is specifiek voor DHCPv4. Bij IPv6 verzendt de client (router) een DUID en IAID naar de DHCPv6-server. De DUID identificeert de client zelf en de IAID identificeert de (WAN-)interface. Als de DUID statisch is, dan moet de ontvangen prefix (IA_PD) ook statisch zijn.

 

Welk merk en type router gebruik je? Gebruik je bridge mode op het modem?

KiskuB
Topicstarter
Level 2
  • 7Posts
  • 0Oplossingen
  • 1Likes

Inderdaad de router van Ziggo staat in Bridge mode. IPv6 functioneerd uitstekend op mijn MikroTik RB750GR. Kan ik parameters constant houden?

tobiastheebe

Level 20
Super Expert
  • 16067Posts
  • 1022Oplossingen
  • 7046Likes

Om te beginnen zou je deze informatie moeten vergelijken tussen twee reboots van de router, verandert dan de DUID?

KiskuB
Topicstarter
Level 2
  • 7Posts
  • 0Oplossingen
  • 1Likes

Vanmorgen de router herstart en de prefix blijft het zelfde, joho!

 

Gisteren heb ik een configuratie item in de ipv6 client aangepast en weer terug gezet. het viel me toen op dat er iets tijd overheen ging voor dat een nieuwe verbinding werd gemaakt. Deze veranderingen hebben waarschijnlijk de prefix veranderd.

 

Zo kan ik er wel weer mee leven. Weer wat bijgeleerd, veel dank voor de reactie!

os

Level 6
  • 129Posts
  • 8Oplossingen
  • 58Likes

Ik heb hetzelfde probleem, praktisch elke keer als ik de WAN6 interface opnieuw opstart krijg ik een nieuwe prefix. Net twee keer opnieuw opgestart en de volgende adressen gekregen op de WAN6 interface (nu niet meer in gebruik):

 

IPv6-DHCPv6: 2a02:a204:0:54:890c:b544:e402:ec22/128
IPv6-PD:     2a02:a210:2a00:c500::/57

IPv6-DHCPv6: 2a02:a204:0:54:813c:aca1:80ae:87bf/128
IPv6-PD:     2a02:a210:2a01:1380::/57

 

Ik gebruik OpenWrt. Als het goed is is de DUID statisch. Enig idee wat er aan de hand is of dat dit op te lossen is?

IPv4 blijft wel hetzelfde na een herstart.

os

Level 6
  • 129Posts
  • 8Oplossingen
  • 58Likes

Elke keer als ik nu herstart blijf ik wel dezelfde PD krijgen, maar nu maar kijken voor hoe lang. Het DHCPv6 adres heeft een valid_lft van 4200sec en ook een preferred_lft van 4200sec.

 

Kijken of ik over 1 uur en 10 minuten nog steeds dezelfde PD krijg.

os

Level 6
  • 129Posts
  • 8Oplossingen
  • 58Likes

Halverwege de leasetime nu (2100 seconden), interface herstart en weer een ander DHCPv6 adres + andere prefix..

KiskuB
Topicstarter
Level 2
  • 7Posts
  • 0Oplossingen
  • 1Likes

@os 

Wat bedoel je met WAN6 interface?

os

Level 6
  • 129Posts
  • 8Oplossingen
  • 58Likes

@KiskuB Op OpenWrt is IPv4 en IPv6 gescheiden met een aparte (virtuele) interface. Het gaat wel over dezelfde ethernet poort.

os

Level 6
  • 129Posts
  • 8Oplossingen
  • 58Likes

Plaatje:

wan+wan6.png

os

Level 6
  • 129Posts
  • 8Oplossingen
  • 58Likes

Bij KPN kreeg ik een praktisch vast IPv4 adres en een statische /48 IPv6 prefix.. Heb IPv6 maar uitgezet nu op Ziggo omdat de prefix te vaak verandert voor m'n RA clients, die kunnen er niet mee omgaan.

KiskuB
Topicstarter
Level 2
  • 7Posts
  • 0Oplossingen
  • 1Likes

Bij een Mikrotik router wordt ook een client gebruikt voor de verbinding met een provider apart voor IPv4 en IPv6. In de client wordt alleen de basis nodig voor het onderhouden van de verbinding geconfigureerd. Apart heb je DHCP servers voor ipv4 en ipv6. Voor ipv6 is een DHCP server niet nodig. Er is een lange leercurve om de configuratie Mikrotik apparatuur onder de knie te krijgen. Zelf heb ik er drie maanden voor nodig gehad, maar nu draait het prima met een router en twee access points.

 

Als ik de router reboot dan houd ik dezelfde prefix. Verander ik iets in de client die verbinding maakt met IPv6 dan wordt blijkbaar de prefix opnieuw ingesteld. Ik moet dan op een aantal plaatsen e.e.a. aanpassen. De client verander ik eigenlijk nooit alleen als ik problemen heb met PiHole dan heb je geen DNS server meer en moet je wel het een en ander aanpassen.

 

Wat ook blijkt dat de router voorkeur geeft aan IPv6. Via PiHole kan je dat goed zien.

 

Bij mij werkt het netwerk prima sinds ik Mikrotik apparatuur gebruik. Mikrotik timmert voortdurend aan de weg. Maar er is nog veel te leren dat zeker. Wel nog wat zorg over de veranderende prefix. Ik denk er nu over om mijn contract bij Strato aan te passen zodat ik DynDNS kan draaien.

os

Level 6
  • 129Posts
  • 8Oplossingen
  • 58Likes

Ik gebruik DuckDNS op mijn server met een statisch suffix (ip token set ::1234 dev eth0). Om de firewall open te zetten gebruik ik een negatief subnet (::1234/-64), voor als de prefix verandert. Kost niets.

org

Level 6
  • 100Posts
  • 5Oplossingen
  • 41Likes

Ik had een prefix nu voor zo'n twee weken en heb net mijn router herstart. Momenteel nog steeds hetzelfde prefix als voorheen. Het probleem lijkt nu opgelost te zijn!

@KiskuB kan jij dit bevestigen?

KiskuB
Topicstarter
Level 2
  • 7Posts
  • 0Oplossingen
  • 1Likes

Mijn ervaring is dat mijn Router, van Mikrotik de zelfde prefix krijgt na een reboot. Wanneer je de IPV6 client in de router aanpast krijg je een andere prefix. De prefix is /56. Je moet er op letten dat je dan de subnetten aanmaken van /64. Op die manier kan je 256 subnetten aanmaken.

 

Lastig is dat de 256 subnetten niet geconfigureerd kunnen worden binnen een MikroTik router. Wel komen mijn 2 gebruikte subnetten, zijnde privé en gast steeds op 00 en 03 terecht na reboot. Das dan voor mij voldoende stabiel. Gelukkig.

 

 

org

Level 6
  • 100Posts
  • 5Oplossingen
  • 41Likes

Hoe verander je de client in de router? Welke parameters pas je aan?

 

Ik kreeg voorheen een andere prefix elke 30 minuten, na een reboot, restart van de WAN interface of herpluggen van de kabel. Dit lijkt nu niet meer te gebeuren en hij lijkt zo 'stabiel' als het IPv4 adres.

KiskuB
Topicstarter
Level 2
  • 7Posts
  • 0Oplossingen
  • 1Likes

Welke router gebruik je?

 

org

Level 6
  • 100Posts
  • 5Oplossingen
  • 41Likes

Ik gebruik OpenWrt.

E-mail notificaties
Aan Uit

Ontvang een update bij nieuwe reacties in dit topic.

Polls
Ga je voor een film of een serie?

Uitgelicht topic