1
Vraag
2
Reacties
fmulder

Level 3
  • 26Posts
  • 1Oplossingen
  • 2Likes

Toegang externe MySql-server

Sinds een dag of 10 is mijn Technicolor modem vervangen door een Connectbox.

Voorheen was het mogelijk om vanaf een PC in het huisnetwerk een verbinding te maken met een externe MySql-server. Na installatie van het nieuwe modem lukt dat helaas niet meer.

Via 4g lukt het wel, dus zijn de instellingen van de PC en de externe server goed.

Kan iemand mij helpen om dit op te lossen?

 

Oplossing

Geaccepteerde oplossingen
fmulder
Topicstarter
Level 3
  • 26Posts
  • 1Oplossingen
  • 2Likes

Dan zal ik contact opnemen met de hostingprovider. Hartelijk dank voor de moeite. Ondanks dat er nog geen oplossing is, zal ik dit topic hier wel als Opgelost markeren.

Bekijk in context

33 Reacties 33
tobiastheebe

Level 20
Super Expert
  • 15969Posts
  • 1014Oplossingen
  • 6989Likes

Gaat het om een MySQL-server op internet (dus een uitgaande verbinding, LAN naar WAN)? Benader je de server via een domeinnaam of IPv4/IPv6-adres? Probeer het eens via IPv4, indien dat nu niet het geval is.

 

Je kunt de firewall-instellingen van de modemrouter zo aanpassen, dat alleen 'Firewall beveiliging' is ingeschakeld voor IPv4 en IPv6.

fmulder
Topicstarter
Level 3
  • 26Posts
  • 1Oplossingen
  • 2Likes

Het gaat om een uitgaande verbinding naar een MySql-server op internet. Ook via het IP4-adres lukt het niet.

Ook als de firewall, tijdelijk, uitstaat, lukt het niet.

tobiastheebe

Level 20
Super Expert
  • 15969Posts
  • 1014Oplossingen
  • 6989Likes

Zie je een foutmelding? Zo ja, welke? Lukt het ook niet om de server via ICMP/ping te bereiken?

 

Ik ga er niet van uit dat de router Dual-Stack Lite gebruikt, maar kun je voor de zekerheid de eerste helft van je IPv4-adres vermelden?

fmulder
Topicstarter
Level 3
  • 26Posts
  • 1Oplossingen
  • 2Likes

Met een gewone ping (ICMP is mij onbekend) kan ik de server bereiken. Met telnet xx.xx.xx.xx.xx 21 ook. Met telnet xx.xx.xx.xx 3306 NIET, maar via een 4G-verbinding lukt dat WEL.

Mijn IP-adres begint met 217.103.

Bij IP- en Poortfiltering ingesteld, voor Afzender en Bestemming,  UDP/TCP,  3306 is ingeschakeld. En daarna het modem opnieuw opgestart.

 

tobiastheebe

Level 20
Super Expert
  • 15969Posts
  • 1014Oplossingen
  • 6989Likes

Ping is hetzelfde als ICMP echo, een van de typen ICMP-verkeer.

 

Port filtering zorgt er juist voor dat verkeer wordt geblokkeerd, dus verwijder deze regel.

fmulder
Topicstarter
Level 3
  • 26Posts
  • 1Oplossingen
  • 2Likes

Er staat blokkeren (uitgeschakeld?) of toelaten (ingeschakeld?), is verwarrend.

Maar ook als deze regel is verwijderd lukt het helaas niet. Dat was één van de experimenten om 3306 aan de praat te krijgen.

tobiastheebe

Level 20
Super Expert
  • 15969Posts
  • 1014Oplossingen
  • 6989Likes

Misschien zou je de domeinnaam of het IPv4-adres van de server via een privébericht naar mij kunnen sturen? Dan kijk ik even of ik vanaf hier wel poort 3306 op de server kan bereiken.

fmulder
Topicstarter
Level 3
  • 26Posts
  • 1Oplossingen
  • 2Likes

Bericht inmiddels verzonden. Maar dat lukt vast wel. Via een 4G-verbinding lukt het mij ook.

Het probleem lijkt echt in mijn modem te zitten.

tobiastheebe

Level 20
Super Expert
  • 15969Posts
  • 1014Oplossingen
  • 6989Likes

Dank voor je PB. Ik kan ook niet de server bereiken op TCP 3306:

 

Test-NetConnection -ComputerName [IPv4] -Port 3306
WARNING: TCP connect to ([IPv4] : 3306) failed

ComputerName : [IPv4]
RemoteAddress : [IPv4]
RemotePort : 3306
InterfaceAlias : Ethernet
SourceAddress : 192.168.1.101
PingSucceeded : True
PingReplyDetails (RTT) : 10 ms
TcpTestSucceeded : False

fmulder
Topicstarter
Level 3
  • 26Posts
  • 1Oplossingen
  • 2Likes

Ook zo'n modem? Kun je ook een ander proberen?

tobiastheebe

Level 20
Super Expert
  • 15969Posts
  • 1014Oplossingen
  • 6989Likes

Ik gebruik een zakelijk modem (Ubee UBC1318ZG) in bridge mode met een eigen router (Ubiquiti EdgeRouter 4). Ik heb ook nog even getest op deze site, resultaat: 'port closed'. Vanaf Vodafone 4G ook geen verbinding mogelijk.

fmulder
Topicstarter
Level 3
  • 26Posts
  • 1Oplossingen
  • 2Likes

Die test was, voorzover ik het begrijp, op poort 80 van mijn IP-adres en die staat inderdaad dicht.

Net nog op een andere computer via 4G getest op het domein in het PB en poort 3306. Dan krijg ik keurig een melding, dat het IP-adres geen toegang heeft tot de MySql-server.

tobiastheebe

Level 20
Super Expert
  • 15969Posts
  • 1014Oplossingen
  • 6989Likes

Ik was wat verbaasd omdat je eerder aangaf dat je via 4G wel verbinding kon maken, maar dat lukt dus toch niet (meer)?

 

De oorzaak lijkt aan serverzijde te liggen. Is de MySQL service/daemon nog actief, wordt inkomend verkeer toegelaten op de firewall en luistert MySQL op het IPv4-adres van het domein c.q. niet alleen op localhost? Ik maak nog geen gebruik van IPv6, dus kan alleen via IPv4 testen.

fmulder
Topicstarter
Level 3
  • 26Posts
  • 1Oplossingen
  • 2Likes

Via 4G krijg ik wel verbinding met de MySql-server, nadat ik daar het IP-adres van de 4G-verbinding als toegestane Host heb toegevoegd. Dat had ik alleen op dat moment nog niet gedaan.

Ook als ik via 4G 'telnet xx.xx.xx.xx 3306' uitvoer krijg ik een positieve reactie. Aan de serverzijde lijkt dus alles correct. Daar is bovendien niets veranderd de afgelopen tijd. Het probleem is begonnen na de installatie van het nieuwe modem.

tobiastheebe

Level 20
Super Expert
  • 15969Posts
  • 1014Oplossingen
  • 6989Likes

Het lijkt (nu) dus noodzakelijk om handmatig IP-adressen welke toegang nodig hebben op de whitelist te plaatsen. Je zou dit dan ook voor jouw IPv4-adres van Ziggo (217.103.x.x) moeten doen. Door het vervangen van het modem heeft de router een nieuw IPv4-adres ontvangen.

Marinus

Level 11
Expert
  • 541Posts
  • 23Oplossingen
  • 205Likes

Met het ontvangen en installeren van de nieuwe Connector heb je ook een nieuw eigen IPv4 adres gekregen.

Dit adres al toegevoegd als toegestane Host op de Server? 

fmulder
Topicstarter
Level 3
  • 26Posts
  • 1Oplossingen
  • 2Likes

Volgens mijn provider hebben ze dat gedaan. Het IP-adres via 4G staat ook niet op de whitelist en toch lukt de verbinding.

Karel.

Level 13
Expert
  • 796Posts
  • 82Oplossingen
  • 442Likes

Je Ziggo modem kan waarschijnlijk niet goed overweg met Hairpin NAT of ook wel loopback NAT.

In andere topic gelezen dat het eventueel met UPnP te maken kan hebben. Toggle daarvan eens de instelling en herstart het modem daarna steeds. 

tobiastheebe

Level 20
Super Expert
  • 15969Posts
  • 1014Oplossingen
  • 6989Likes

Het betreft een MySQL-server op internet, dit heeft dus niets met hairpin/loopback NAT te maken.

 

Vanaf mijn 4G-verbinding (Vodafone) kan ik geen verbinding maken op TCP 3306. Heb je zelf via 4G wel specifiek getest naar 3306?

E-mail notificaties
Aan Uit

Ontvang een update bij nieuwe reacties in dit topic.

Polls
Ga je voor een film of een serie?

Uitgelicht topic