HuibertBoon
Ontdekker
  • 2Posts
  • 0Oplossingen
  • 0Likes

Subnetmask aanpassen ivm VPN

Dag allen,

 

Wij moeten vanuit thuiswerksituatie via VPN inloggen op 2 verschillende kantoornetwerken.

Het ene netwerk zit lokaal op 192.168.80.xxx, het andere op 192.168.1.xxx.

Wijzelf zitten op 192.168.200.xxx (ivm een weerbarstige oude netwerkprinter)

Daarom hebben we het subnetmask 255.255.0.0 nodig om via VPN verbinding te kunnen maken met de computers in die 2 lokale netwerken.

De DHCP-server van de Ziggo ConnectBox deelt standaard /24 (=255.255.255.0) uit voor het subnetmask en dat zou dus op /16 (=255.255.0.0) moeten staan.  Daar kan vlgns mij niets aan gedaan worden. Echter: als we de computers die de VPN op moeten, elk handmatig een IP-adres toekennen, bijv: 192.168.200.210, met subnetmask 255.255.0.0 komen deze in de Ziggo ConnectBoxtoch met /24 in de lijst van verbonden computers te staan: 192.168.200.210/24 ipv 192.168.200.210/16.

 

Is dit op te lossen?

 

BVD voor het meedenken.

mvg Huibert Boon

5 Reacties 5
tobiastheebe
Super Expert
Super Expert
  • 4966Posts
  • 268Oplossingen
  • 1651Likes

Het zou niet nodig moeten zijn om het subnet mask aan te passen. Als je vanuit het eigen subnet een verzoek naar een van VPN-subnets, dan moet dit vanzelf via de virtuele netwerkinterface door de tunnel uitgestuurd worden.

 

In de Connect Box is het inderdaad niet mogelijk om een LAN-subnet met andere grootte dan /24 in te stellen.

HuibertBoon
topicstarter
Ontdekker
  • 2Posts
  • 0Oplossingen
  • 0Likes

Helder. Is er iets anders te bedenken in de modem/routerinstellingen die communicatie dwarsboomt? Vanaf MacOS gaat wel de VPNverbinding open (‘verbonden’, teller loopt), maar zie geen aangesloten computers. Vanaf Win10 lukt de VPNverbinding niet (LTP2 IPsec met geheime key). Geeft foutmelding geen verbinding mogelijk. Ping vanaf de ConnectBox geeft geen respons.

Jonathan-458
Super Expert
Super Expert
  • 2418Posts
  • 162Oplossingen
  • 852Likes

@HuibertBoon,

Als LT2P IPSEC zich achter NAT bevindt dan dient er binnen Windows een aanpassing gedaan te worden.

 

Zie:

Configure L2TP/IPsec server behind NAT-T device - Windows Server | Microsoft Docs

 

MVG

tobiastheebe
Super Expert
Super Expert
  • 4966Posts
  • 268Oplossingen
  • 1651Likes

Kun je deze instellingen toepassen op de Connect Box? Mogelijk heeft dit effect.

 

Controleer ook of DS-Lite actief is op de internetverbinding (IPv4-adres in subnet 213.127.0.0/17).

Paul
Community Moderator
Community Moderator
  • 8923Posts
  • 734Oplossingen
  • 2009Likes

Goedemiddag @HuibertBoon en een warm welkom op de Community,

Goed dat je met deze vraag een topic bent gestart op dit forum! Zo te zien zijn er al de nodige adviezen gegeven door de hier aanwezige experts. Heb je ook al gekeken naar de tip van @tobiastheebe? Zet anders ook je postcode en huisnummer in je Community profiel. Ik kan dan gelijk voor je achterhalen of jouw modem een IPV6 DS Lite of IPV4 profiel heeft. 

Uitgelicht topic