1
Vraag
2
Reacties
Heesheij

Raadgever
  • 6Posts
  • 1Oplossingen
  • 2Likes

SMTP werkt opeens niet meer

SMTP werkt niet meer op een computer met Windows 7 met Windows live mail. Mail is ook opnieuw ingesteld. Alle instellingen zijn nagekeken, webmail werkt, internet werkt, op een andere computer werkt het wel, op een iPad ook beide met imap ingesteld. Alleen ontvangen werkt nog. Groet

Oplossing

Geaccepteerde oplossingen
Heesheij
topicstarter
Raadgever
  • 6Posts
  • 1Oplossingen
  • 2Likes

Het werkt :-), ik had ipv regkeys tls 1.1 en 1.2 de keys SSL 1.1 en 1.2 aangemaakt… 

 

heren onwijs veel dank

Bekijk in context

26 Reacties 26
Gerr_it
Expert
Expert
  • 102Posts
  • 15Oplossingen
  • 34Likes

Hi,

Het is waarschijnlijk een probleem met versleuteling die wordt gebruikt, of eigenlijk die niet meer wordt ondersteund. TLS 1.0 en TLS 1.1 werden door Windows 7 vooral gebruikt en zijn niet meer veilig volgens de huidige normen. Ziggo SMTP gebruikt TLS1.2 en TLS 1.3 zover ik kan zien.  Je kunt proberen Windows 7 een upgrade te geven zodat het wel TLS 1.2 ondersteunt. Windows 7 wordt alle lange tijd niet meer ondersteunt.

Als je toch graag Windows 7 wilt blijven gebruiken zou je het volgende kunnen proberen:

https://top.host/support/knowledge-base/how-can-i-enable-tls-v1-2-in-outlook-on-windows-7/#:~:text=T....

 

Groet,

Gerr

gekko

Raadgever
  • 24Posts
  • 1Oplossingen
  • 6Likes

Ik heb sinds vanmiddag precies hetzelfde probleem met Thunderbird. Inkomende mails ok, uitgaande foutmelding "unknown reason" of "connection timed out".  Op ziggo mail werkt het verzenden wel. Mijn pc werkt op win 8.1 en dat is toch nog ok.  Ik wil perse thunderbird blijven gebruiken. Bedankt voor elke hulp.

tobiastheebe
Super Expert
Super Expert
  • 12196Posts
  • 742Oplossingen
  • 4673Likes

@Heesheij @gekko Zorg ervoor dat de SMTP-instellingen overeenkomen met de instellingen op deze pagina. De SMTP-server accepteert geen onbeveiligde verbindingen (op poort 25) meer.

 

@Gerr_it Ik heb circa een maand geleden een test gedaan met OpenSSL, TLS 1.0 en 1.1 worden nog ondersteund door smtp.ziggo.nl.

Heesheij
topicstarter
Raadgever
  • 6Posts
  • 1Oplossingen
  • 2Likes

Dank Gert. Ik vermoede al dat w7 roet in het eten gooit. Zolang mijn buurman w7 kan gebruiken zal hij blij zijn. Ik ga dit zeker even proberen. Ik laat hier nog even weten of dit lukt. 

 

gekko

Raadgever
  • 24Posts
  • 1Oplossingen
  • 6Likes

Uiteraard had ik dat al gecontroleerd en ik heb niks aan mijn instelling gewijzigd en die waren al zoals op "deze paginga" gemeld. Wat kan er aan de hand zijn?

Heesheij
topicstarter
Raadgever
  • 6Posts
  • 1Oplossingen
  • 2Likes

Hi, deze zijn nagelopen, ook account verwijderd en opnieuw gedaan. Op w10 werkt het op deze w7 niet. Zowel Windows live niet als incredimail

Gerr_it
Expert
Expert
  • 102Posts
  • 15Oplossingen
  • 34Likes

Probeer nog maar eens, het is niet meer ondersteund. 

gekko

Raadgever
  • 24Posts
  • 1Oplossingen
  • 6Likes

Als ik ziggo bel hierover krijg ik te horen dat ze over emails geen telefoon meer beantwoorden. Als dit forum het niet weet, kijkt dan wel iemand van ziggo hiernaar op dit forum? Zoniet wat dan in vredesnaam.

Ik ga er vanuit dat de oorzaak bij ziggo ligt en niet bij mij. Immers er is niets veranderd op mijn pc en mijn smtip instellingen zijn zoals ze moeten zijn.

tobiastheebe
Super Expert
Super Expert
  • 12196Posts
  • 742Oplossingen
  • 4673Likes

Ik dacht dat ik ook TLS 1.0 had getest, maar dat blijkt niet zo te zijn, deze versie wordt niet ondersteund door (mijn versie van) OpenSSL. Met TLS 1.1 kan ik echter verbinding maken:

 

Lees meer
openssl s_client -connect smtp.ziggo.nl:587 -starttls smtp -tls1_1
CONNECTED(00000003)
3070074944:error:14094410:SSL routines:ssl3_read_bytes:sslv3 alert handshake failure:../ssl/record/rec_layer_s3.c:1544:SSL alert number 40
---
no peer certificate available
---
No client certificate CA names sent
---
SSL handshake has read 318 bytes and written 159 bytes
Verification: OK
---
New, (NONE), Cipher is (NONE)
Secure Renegotiation IS NOT supported
Compression: NONE
Expansion: NONE
No ALPN negotiated
SSL-Session:
Protocol : TLSv1.1
Cipher : 0000
Session-ID:
Session-ID-ctx:
Master-Key:
PSK identity: None
PSK identity hint: None
SRP username: None
Start Time: 1660060762
Timeout : 7200 (sec)
Verify return code: 0 (ok)
Extended master secret: no
---
Gerr_it
Expert
Expert
  • 102Posts
  • 15Oplossingen
  • 34Likes

Hi @tobiastheebe ,

Dat lijkt zo, maar het zal niet werken. Maak er maar eens -tls1_2 van. Dan krijg je wel het verwachte resultaat. Ik had overigens niet goed gekeken, want TLS1.3 is nog niet ondersteund. Zie hier het resultaat van een ander ssl tooltje:

 

Testing protocols via sockets except NPN+ALPN

SSLv2 not offered (OK)
SSLv3 not offered (OK)
TLS 1 not offered
TLS 1.1 not offered
TLS 1.2 offered (OK)
TLS 1.3 not offered and downgraded to a weaker protocol
NPN/SPDY not offered
ALPN/HTTP2 not offered

 

 

tobiastheebe
Super Expert
Super Expert
  • 12196Posts
  • 742Oplossingen
  • 4673Likes

@Gerr_it Je hebt gelijk. Met TLS 1.1 is geen certificaat beschikbaar en wordt de verbinding verbroken voor het STARTTLS-commando. Ik twijfelde al na het zien van die handshake error bij TLS 1.1. Het lijkt er dus inderdaad op dat TLS 1.2 nu de minimum vereiste versie is. Daarnaast wordt een nieuwe cipher suite gebruikt (ECDH) waar oudere besturingssystemen en clients (mailapplicaties) ook niet mee overweg kunnen, ik weet niet of er ook oudere ciphers worden ondersteund.

 

Lees meer

openssl s_client -connect smtp.ziggo.nl:587 -starttls smtp -tls1_2
CONNECTED(00000003)
depth=2 C = BM, O = QuoVadis Limited, CN = QuoVadis Root CA 2 G3
verify return:1
depth=1 C = BM, O = QuoVadis Limited, CN = QuoVadis Global SSL ICA G3
verify return:1
depth=0 C = NL, ST = Utrecht, L = Utrecht, O = Ziggo Services B.V., CN = email.ziggo.nl
verify return:1
---
Certificate chain
0 s:C = NL, ST = Utrecht, L = Utrecht, O = Ziggo Services B.V., CN = email.ziggo.nl
i:C = BM, O = QuoVadis Limited, CN = QuoVadis Global SSL ICA G3
1 s:C = BM, O = QuoVadis Limited, CN = QuoVadis Global SSL ICA G3
i:C = BM, O = QuoVadis Limited, CN = QuoVadis Root CA 2 G3
2 s:C = BM, O = QuoVadis Limited, CN = QuoVadis Root CA 2 G3
i:C = BM, O = QuoVadis Limited, CN = QuoVadis Root CA 2 G3
---
Server certificate
-----BEGIN CERTIFICATE-----
(knip)
-----END CERTIFICATE-----
subject=C = NL, ST = Utrecht, L = Utrecht, O = Ziggo Services B.V., CN = email.ziggo.nl

issuer=C = BM, O = QuoVadis Limited, CN = QuoVadis Global SSL ICA G3

---
No client certificate CA names sent
Peer signing digest: SHA256
Peer signature type: RSA
Server Temp Key: ECDH, P-256, 256 bits
---
SSL handshake has read 6232 bytes and written 369 bytes
Verification: OK
---
New, TLSv1.2, Cipher is ECDHE-RSA-AES256-GCM-SHA384
Server public key is 2048 bit
Secure Renegotiation IS supported
Compression: NONE
Expansion: NONE
No ALPN negotiated
SSL-Session:
Protocol : TLSv1.2
Cipher : ECDHE-RSA-AES256-GCM-SHA384
Session-ID: FDCC97494C55EA96A8E2E665FD4DD324865E2D07A6F17F14219C682ECFF8DFA8
Session-ID-ctx:
Master-Key: F94402238826CEB3F366B46A66274FD81365CD33FDECC67E25B39A003D41BA72754AEBF2AF30777639DB684BE0BEEBD8
PSK identity: None
PSK identity hint: None
SRP username: None
Start Time: 1660068858
Timeout : 7200 (sec)
Verify return code: 0 (ok)
Extended master secret: no
---
250 STARTTLS
quit
221 2.0.0 smtp2.tb.mail.iss.as9143.net smtp2.tb.mail.iss.as9143.net closing connection
read:errno=0 

Gerr_it
Expert
Expert
  • 102Posts
  • 15Oplossingen
  • 34Likes

Dit zijn de cypher suites die gebruikt kunnen worden voor smtp.ziggo.nl. Volgens mij is dat OK.


ECDHE-RSA-AES256-GCM-SHA384      
ECDHE-RSA-AES256-SHA384          
ECDHE-RSA-AES256-SHA              
DHE-RSA-AES256-SHA256            
DHE-RSA-AES256-SHA                
AES256-SHA                        
EDH-RSA-DES-CBC3-SHA              
DES-CBC3-SHA                      
ECDHE-RSA-AES128-GCM-SHA256      
ECDHE-RSA-AES128-SHA256          
ECDHE-RSA-AES128-SHA              
DHE-RSA-AES128-SHA256            
DHE-RSA-AES128-SHA              
AES128-SHA                        
DHE-RSA-AES128-GCM-SHA256
tobiastheebe
Super Expert
Super Expert
  • 12196Posts
  • 742Oplossingen
  • 4673Likes

Dat lijkt mij inderdaad voldoende ondersteuning voor legacy besturingssystemen en applicaties.

BasF91

Stamgast
  • 2Posts
  • 0Oplossingen
  • 2Likes

Goedenavond, ik heb exact hetzelfde probleem op Windows 7. De computer wordt door 80+ers gebruikt, enkel voor mail. Dat is na jaren oefenen eindelijk goed erin gesleten. Bestaat er een oplossing zonder naar Windows 10 te upgraden? Kan ik ergens handmatig aangeven dat ik TLS 1.2 wil gebruiken? alvast bedankt

Gerr_it
Expert
Expert
  • 102Posts
  • 15Oplossingen
  • 34Likes

Hi Bas, 

Ik heb even voor je gezocht: https://manage.accuwebhosting.com/knowledgebase/3008/How-do-you-enable-TLS-1-2-on-Windows-7.html

 

Misschien helpt dit.

Groeten,

Gerr

Gerr_it
Expert
Expert
  • 102Posts
  • 15Oplossingen
  • 34Likes

Hi @gekko ,

Ik heb even op m'n oude Windows 8.1 machine ingelogd en Thunderbird geïnstalleerd. Ik kan email versturen via smtp.ziggo.nl.

 

User-Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:102.0) Gecko/20100101 Thunderbird/102.1.2

Ik heb het met zowel poort 465+SSL/TLS als 587+StartTLS kunnen doen. 

 

Ik zou het volgende proberen:

 

- Zorg ervoor dat Windows up-to-date is. 

- Zorg dat je de laatste versie van Thunderbird gebruikt.

- Installeer Thunderbird evt opnieuw en configureer opnieuw, Thunderbird vindt de instellingen automatisch.

- Check of je via een ander netwerk wel kan emailen (dus andere wifi of via een hotspot op je telefoon) dan weet je zeker dat het niet aan je netwerk ligt.

- Je kan natuurlijk geblokkeerd zijn door een andere reden. Je zou je wachtwoord kunnen wijzigen.

 

Zo zien mijn instellingen eruit in Thunderbird. Gebruik je het hele emailadres als gebruikersnaam? Misschien hebben ze dat gewijzigd? 

 

Gerr_it_0-1660073456990.png

 

Zomaar wat ideeën...

Fijne avond.

 

BasF91

Stamgast
  • 2Posts
  • 0Oplossingen
  • 2Likes

@Gerr_it  hartelijk bedankt voor de supersnelle reactie. Ik heb de stappen gevolgd en het werkt op Windows 7! Fantastisch

gekko

Raadgever
  • 24Posts
  • 1Oplossingen
  • 6Likes

@Gerr_it 

Bedankt voor de uitvoerige reactie en het vele werk.  Hierbij mijn reactie:

1) Om met het laatste te beginnen. Ja bij mij ziet het hetzelfde uit muv Beschrijving is bij mij anders en achter poort 587 staat bij mij Standaard 25. M.i. is beschrijving niet relevant en standaard 25 kan ik niet veranderen.

2) Bij mijn 8.1 werken zowel 587+STARTTLS als 465+SSL/TLS niet. Verder ziet mijn register hetzelfde uit als beschreven in de link voor win7 TLS1.2 aanpassing. Toch zegt google dat win 8(.1) wel TLS1.2 enabled moet hebben. Als ik via configscherm naar internetopties/advanced ga zie ik SSL 2.0 en 3.0 zonder check en TLS 1.0, TLS1.1 en TLS1.2 met check. Bij mijn proeven heb ik SSL 2.0 en SSL 3.0 ook wel een check gegeven en TLS 1.0 en TLS 1.1 ook ge-unchecked. Moet ik dan soms toch die gekke reg. key voor TLS1.2 maken????? Vindt die key ook zo gek trouwens omdat hij eindigt met het woord "disabled by default" maar dat zal aan mij liggen dat ik dat niet snap.

3) Mijn win 8.1 is volledig uptodate

4) Ik kan vanaf de ziggo website en mijn.mail wel emails versturen dus zou ik denken dat ik niet geblocked ben. Ook werkt mijn internet (browsen) etc nog gewoon dus het netwerk en de wifi zijn ook OK. Ik ontvang trouwens ook wel mails.

5) Mijn wachtwoord wijzigen wil ik nog proberen al vind ik het absurd als dat de remedie zou zijn.

6) Last but not least mijn thunderbird is vz 10 (zegge tien, uit 2012 geloof ik). Ik heb versie 101 (2021/2023) geloof ik geinstalleerd maar ik was al mijn mails kwijt. Ik had wel een backup gemaakt van de profiel folder met de gekke naam nhq6 etc.default (3,5 G!!) maar die heb ik niet hoeven te gebruiken want via systeem herstel naar eergisteren was ik 101 weer kwijt en met 10 weer gelukkig terug bij af. 101 zag er zo anders uit en ik zag niet hoe ik mijn mails weer terug zou kunnen krijgen, mede omdat de betreffende profiel folder er nog gewoon was. Extra complicatie is dat in de mail map van die profiel folder nog sporen (lees mappen) zijn van eerdere providers tiscali, planet etc. Verder blijft mijn vraag waarom zou van gisteren naar vandaag TB 10 niet meer goed zijn. Daar moet ziggo meer van weten zou ik denken.

Gerr_it
Expert
Expert
  • 102Posts
  • 15Oplossingen
  • 34Likes

Ah kijk! Het ligt denk ik aan de oude TB versie. Als je e-mail wilt bewaren zou je een tweede ziggo account toe kunnen voegen (met IMAP). Vervolgens sleep je alle mails naar een map (of mappen) in het nieuwe e-mail account. Je kan controleren in webmail of al je mails er in staan. Kan even duren natuurlijk. Vervolgens maak je een backup van je computer en verwijder je Thunderbird en installeer je het opnieuw. Daarna voeg je beide e-mail accounts toe en heb je je mail weer. Overigens zou een upgrade ook kunnen werken, maar wees voorzichtig als je niet alles op de mailserver hebt staan. Een backup van je waardevolle informatie is altijd belangrijk natuurlijk. Succes! Vr groet

E-mail notificaties
Aan Uit

Ontvang een update bij nieuwe reacties in dit topic.