1
Vraag
2
Reageer en help mee
Dad

Gedreven Ontdekker
  • 6Posts
  • 0Oplossingen
  • 0Likes

Router + Connect box (no bridge mode)

Hi all,

 

I'm trying to get an “external” router managing my home network (Ethernet + Wifi) but still be able to use the Connect box (for basic administration and to connect devices via ethernet)

My desired set-up is the following :

- Connect Box :

  1. Wifi deactivated
  2. DHCP/NAT deactivated
  3. No bridge mode (I still want to administrate the box and use its ethernet ports)

- External Router :

  1. Manages DHCP/NAT/DNS (or use default Ziggo DNS)
  2. Manages Wifi
  3. I want the router to "see/reach" the devices connected to the Connect box via Ethernet 

So basically I'm trying to get 1 single network (all IPs in the same subnet whether devcies are connected to the Connect box or the external router) with DHCP/NAT managed by the external router.

 

So far, the only working set up I could achieve is to get 2 different subnets but the problem is that devices connected on the Connect box (via Ethernet) are not visible/reachable on the subnet of the external router.

 

Any idea  how to achieve this?

 

Thank you for your help and expertise

 

BR,

 

D.

14 Reacties 14
tipo

Stamgast
  • 62Posts
  • 0Oplossingen
  • 29Likes

I guess read the how to: Router achter modem. If you need translation in English, we can help. I don’t know enough about your setup, but also guessing, you need to configure some port forwarding. I wonder what IP-adresses the devices connected on the Connect box (via Ethernet) are getting.

Dad
topicstarter
Gedreven Ontdekker
  • 6Posts
  • 0Oplossingen
  • 0Likes

Thanks for your feedback.

I've been through the discussion you are referring to (actually I posted a question at the end of it) 

 

My current set up is the following :
1 - The Connect Box manages the 192.168.178.xxx subLAN (incl. DHCP/NAT/DNS management) and I have de-activated Wifi.
I have assigned IP 192.178.168.2 to my personal Router
2 - The Router manages the 192.168.50.xxx subLAN (incl. DHCP/NAT/DNS management) and the Wifi network.
Note that when I look at the WAN IP on the Router, I can indeed see that it is 192.168.178.2 (as configured on the Connect Box)

The problem of this set up is obviously that the 2 network are "isolated" and if I plug a device on the ethernet port of the Connect Box, it is not reachable on the Router subLAN.

 

To answer your question, when I plug a device on the Connect Box, it gets an IP in the 192.168.178.xxx range and that is actually the origin of the problem. So I guess I must find a way to route this IP range from the Connect Box box to my Router. I'm not sure this is port forwarding because it is about routing an IP range and not only some ports…

 

tipo

Stamgast
  • 62Posts
  • 0Oplossingen
  • 29Likes

Dad wrote:

To answer your question, when I plug a device on the Connect Box, it gets an IP in the 192.168.178.xxx range and that is actually the origin of the problem. So I guess I must find a way to route this IP range from the Connect Box box to my Router. I'm not sure this is port forwarding because it is about routing an IP range and not only some ports…

You are right, the networks are isolated. I don’t (yet) have personal experiance with this, but it depends on the possibilities of your personal router. Most consumer routers only have port forwarding (or Port-trigger) possibilities. Sometimes you can configure the firewall and routing. I don’t know how the firewall works on the connect box (only for external/Internet or also internal). So sorry, i can’t help you here. I’m busy setting up separated (isolated) networks in my house, but it’s complicated (and my daughter kills me if there is no wifi internet). I purchased some cheap Miktotik routers, switches and wifi AP’s and still finding out how to configure. But those devices have al the possibiities you need (VRF, Route leaking, firewall configuration). OpenWRT also has these possibilities (you can flash in on your router if it is supported) but it’s something i won’t recommend if you don’t know how to.

A simple solution may be disabling the DHCP on the connect box, so connected devices get their IP from the personal router and are in the same network. but again i don’t have experience with the connect box and if it can function as a “switch” in this case. Other simple solution connect the ethernet devices to your personal router and if jou don’t have enough ports buy a cheap network switch (20 euro),

efok
Expert
Expert
  • 3426Posts
  • 187Oplossingen
  • 1186Likes

@Dad what is the brand and model of your external router? What are you trying to achieve? You don’t want to use the Ziggo DHCP, is it not sufficiënt for your needs? You are adding an extra NAT in your network, which cause your troubles. Not all consumer routers allow traffic to private subnets on their WAN.

(Maybe you are beter off with a switch and an access point iinstead. Another option might be to put your modem in bridge modem, and let your router handle your complete network.)

Dad
topicstarter
Gedreven Ontdekker
  • 6Posts
  • 0Oplossingen
  • 0Likes

Hi and thanks all for your feedback.

 

I'm trying to avoid bridge mode because I still want to be able to administrate the Connect box and also because en(dias)abling bridge mode requires customer care support. Also I'd like to make use of the free Ethernet plugs available on the Connect box.

 

I made several attemps in disablig DHCP but that didn't end well. I was unbable anymore to connect to the Connect Box, my laptop connected to the Connect Box via ethernet was getting an IPv6 address and I was not even able to even ping 192.178.168.1 (not sure why) so in the end I had to reset the Connect Box.

What I tried as well was to enable DHCP from 192.168.178.50 and assign a reserved IP for the devices plugged on the Ethernet ports out of the DHCP range (based on their MAC address) but it looks like those “reserved” IPs rules are not used anymore when DHCP is deactivated so it didn't work in the end…

My router is an Asus AX 11000 and it has quite some flexibility in terms of port forwarding, NAT configuration and Routing, but isn't it the Connext Box that needs to be configured in that case? Because I would imagine that what I need is to have the devices connected to the Connect box to “broadcast” their IP/Route to the other subnetwork so they can be visible….

But again I'm not sure…

 

Thanks again for your help 

 

 

Jan F.
Super Expert
Super Expert
  • 16786Posts
  • 1317Oplossingen
  • 3035Likes

Hi @Dad If you want to use the ethernetports of the Connectbox there has to be an internal IP-adres assigned to it. That is done by the DHCP. So it seems to me that disabling the DHCP is not  a good idea. If you need more ethernet ports, you can use a switch, connected to your router.

If the connectbox is in bridgemode, you can access it through 192.168.100.1 

Dad
topicstarter
Gedreven Ontdekker
  • 6Posts
  • 0Oplossingen
  • 0Likes

@Jan F. 

I'm curious, when the Connect Box is in bridge mode then there is no DHCP so how does your laptop get an IP when you want to log to 192.168.100.1?

Is this via IPv6 or do you manually configure a fixed IP in the 192.168.100.xxx range on your Laptop?

Jan F.
Super Expert
Super Expert
  • 16786Posts
  • 1317Oplossingen
  • 3035Likes

192.168.100.1 is the default access dor the connectbox in bridge mode. IP-adressen in your network are assigned by your router.

Dad
topicstarter
Gedreven Ontdekker
  • 6Posts
  • 0Oplossingen
  • 0Likes

I get that but are you saying that even if my router provides IPs in a different subrange (like 192.168.50.xxx) my Laptop would be able to reach 192.168.100.1? Or would I need to configure my router to work in the 192.168.100.xxx range?

Jan F.
Super Expert
Super Expert
  • 16786Posts
  • 1317Oplossingen
  • 3035Likes

Dad wrote:

I get that but are you saying that even if my router provides IPs in a different subrange (like 192.168.50.xxx) my Laptop would be able to reach 192.168.100.1? Or would I need to configure my router to work in the 192.168.100.xxx range?

Yes, you will be able to log in to your connectbox. 

Marije
Community Moderator
Community Moderator
  • 2822Posts
  • 375Oplossingen
  • 585Likes

Hiya @Dad , welcome here to the Community!

 

Reading and scrolling through the topic I can tell that you've landed in the very capable hands of @tipo , @efok and @Jan F. ! Did you get answers to all the questions you had and find all of the information you needed? 

If you have any additional questions or would like more information, don't hesitate to find everyone here! 

I do hope you have a lovely weekend. 

zlimvos

Stamgast
  • 4Posts
  • 0Oplossingen
  • 1Likes

Very interesting discussion, I've been going through the same things. I want to mention, @Dad has listed the reasons why I would also prefer to use his desired setup. An extra reason is that we cannot set our own DNS server in DHCP scope, so we can't utilize services such as pihole on home smart devices. I know bridge mode is a solution but I trust the hardware capabilities of the new Gigabox, I just wish there where some more 'advanced' settings available.

Update: i see the new gigabox has DNS settings.

Maud
Community Moderator
Community Moderator
  • 2050Posts
  • 200Oplossingen
  • 375Likes

Hai @zlimvos! Sorry for the very late respons 😞 

Did you already find a good solution? Or did you put your modem in brigde mode? 

zlimvos

Stamgast
  • 4Posts
  • 0Oplossingen
  • 1Likes

Hi, yeap indeed i piggybacked another thread where i had my modem's software updated in a version that supports change of the 3 first octets on the LAN/DHCP. So problem solved and all good!
I am only curious now what is the ipv6 capabilities of the router/service, can dual stack now supported? But I guess that is topic for different thread.

E-mail notificaties
Aan Uit

Ontvang een update bij nieuwe reacties in dit topic.

Uitgelicht topic