1
Vraag
2
Reacties
Pghatak

Level 1
  • 7Posts
  • 0Oplossingen
  • 0Likes

Request - enable IpV6

I need ipv6 on my Sagemcom routers. Anyone knows how to enable this. Ziggo support can’t help as they have no clue. 

Oplossing

Geaccepteerde oplossingen
tobiastheebe

Level 20
T.E.A.M.
  • 32335Posts
  • 2283Oplossingen
  • 16315Likes

When using your own router, you should have the modem configured in bridge mode. Prefix delegation through cascaded routers is not supported by Ziggo modems. Enabling IPv6 on your router and the LAN behind it requires configuring the appropriate WAN + LAN IPv6 settings.

Bekijk in context

14 Reacties 14
Bert

Level 21
T.E.A.M.
  • 76357Posts
  • 5203Oplossingen
  • 22506Likes

Do you see an IPv4 and an IPv6 address here? What Is My IP? Best Way To Check Your Public IP Address

tobiastheebe

Level 20
T.E.A.M.
  • 32335Posts
  • 2283Oplossingen
  • 16315Likes

You may verify whether IPv6 is enabled on the modem's eRouter by logging in to the web interface at 192.168.178.1 and determining whether the Admin, Info displays IPv6 addresses.

Pghatak
Topicstarter
Level 1
  • 7Posts
  • 0Oplossingen
  • 0Likes

Hi there. It does. However why is then a report on https://test-ipv6.com/ and also https://ipv6-test.com/ shows ipv6 does not exist and communication fails?

tobiastheebe

Level 20
T.E.A.M.
  • 32335Posts
  • 2283Oplossingen
  • 16315Likes

This indicates IPv6 is already enabled on the modem's eRouter. Does the 'Connected devices' page display IPv6 addresses? Is IPv6 enabled on your PC's network adapter?

MR_CHIP

Level 19
  • 12126Posts
  • 136Oplossingen
  • 4135Likes

furthermore what does the dhcp tab ipv6 section give you

MR_CHIP_0-1689102249085.png

 

is there info like my there or is it blank ?

 

Pghatak
Topicstarter
Level 1
  • 7Posts
  • 0Oplossingen
  • 0Likes

There is info but it’s all grayed out. Should this be stateful or stateless? 

Pghatak
Topicstarter
Level 1
  • 7Posts
  • 0Oplossingen
  • 0Likes

The connected device in this case is my LinkSys mesh modem with address 192.168.178.51/24. But no ipv6 there. But ipv6 is enabled on the computer net work. I have the same issue on windows or Mac or iOS or iPadOS

Bert

Level 21
T.E.A.M.
  • 76357Posts
  • 5203Oplossingen
  • 22506Likes

If a device don't get a IPv6 adres, try Stateful.

LinkSys mesh modem ??? Do you main a router?

Which router exactly?

tobiastheebe

Level 20
T.E.A.M.
  • 32335Posts
  • 2283Oplossingen
  • 16315Likes

When using your own router, you should have the modem configured in bridge mode. Prefix delegation through cascaded routers is not supported by Ziggo modems. Enabling IPv6 on your router and the LAN behind it requires configuring the appropriate WAN + LAN IPv6 settings.

Pghatak
Topicstarter
Level 1
  • 7Posts
  • 0Oplossingen
  • 0Likes

Hello Bert and readers.

I am getting the ipv6 now, only when I put my modem IPv6 to stateful. However, I also had to change my router to have a "passthrough" since the "automatic" version does not let me choose the prefix address:

 

 

Pghatak
Topicstarter
Level 1
  • 7Posts
  • 0Oplossingen
  • 0Likes

Thank you. I do not have the option on my router to have a "Delegated" prefix of ipv6 addres space, and only works with "Passthrough". Then I get the ipV6. But this also means, it won't work, the moment I change my router to bridge mode. Is. this correct?

tobiastheebe

Level 20
T.E.A.M.
  • 32335Posts
  • 2283Oplossingen
  • 16315Likes

I recommend having the modem configured in bridge mode using this form and setting your router's IPv6 connection type to automatic, in order to have it obtain a delegated prefix (either /56 or /57) from Ziggo's DHCPv6 server. Currently, the 'automatic' setting will not work properly, because of the cascaded router setup. Setting IPv6 prefixes manually is not necessary nor recommended, except for the LAN prefix ID potentially.

Pghatak
Topicstarter
Level 1
  • 7Posts
  • 0Oplossingen
  • 0Likes

Hello  tobias

Thank you. That does make sense. But please explain if this will work, since just in your previous post, you mentioned Ziggo modem will not do the /56 delegation ? In fact I do not even see that option. The only options are there are IP's stated in disabled text, and whether I want it stateless or stateful . I habve them currently as stateful.

tobiastheebe

Level 20
T.E.A.M.
  • 32335Posts
  • 2283Oplossingen
  • 16315Likes

In your case, the modem's eRouter receives the /56 or /57 delegated prefix and constructs a /64 LAN prefix from the delegated prefix. These processes are fully automatic. Some routers support prefix delegation to downstream routers (which would receive /60 prefixes, for example), however this is not supported by Ziggo modem routers, which is why you should use bridge mode on the modem. Using SLAAC + stateless DHCPv6 is recommended. Android does not support stateful DHCPv6 and will fall back to IPv4.

E-mail notificaties
Aan Uit

Ontvang een update bij nieuwe reacties in dit topic.

Uitgelicht topic