Thijs Z
Oud Community Moderator
Oud Community Moderator
  • 3070Posts
  • 318Oplossingen
  • 230Likes

Problemen met je verbinding op Android met IPv6? Foutcode 303? Bekijk de mogelijke workaround!

Een verborgen probleem?
We hebben binnen onze Community wat lastig te onderzoeken problemen opgemerkt. Het gaat dan om Android apparaten die veel issues ervaren met het laden van websites en andere diensten. Soms helpt het dan om de pagina te verversen. Dit lijken in eerste instantie problemen met de draadloze verbinding. Logischerwijs wordt er dan gekeken naar het bereik, de kanalen, enzovoorts. Dit helpt vervolgens niet en dankzij meerdere Community leden is het duidelijk geworden dat dit issue komt doordat veel Android apparaten moeite hebben met een Stateless autoconfiguratie van IPv6. De achtergrond hiervan wordt onderaan nog verder toegelicht. Het probleem valt dan simpel op te lossen door in de modem te kiezen voor een Stateful autoconfiguratie. Hoe je dat doet staat hieronder per modem beschreven.

De workaround

Connect Box
1. Log in op de modem
2. Ga naar 'Geavanceerde instellingen'
3. Klik op 'DHCP'
4. Vink bij automatische instellingen onder 'DHCPv6 Server' Stateful aan
5. Klik eronder op 'Wijzigingen toepassen'




Ubee EVW321

1. Log in op de modem
2. Klik rechtsboven op 'Geavanceerde Instellingen'
3. Klik links op DHCPv6
4. Vink het hokje aan bij 'Disable Stateless Dhcpv6'
5. Klik onderaan op 'Apply'
Dit is met de huidige firmware helaas niet mogelijk. Er volgt een update wanneer dit verandert.

Kom je er niet uit met het wijzigen van de instellingen, laat dan hier een reactie achter. Als je geen IPv6 op je modem hebt dan zul je deze opties ook niet in je modem zien staan.
Twijfel je of je IPv6 hebt? Ga dan naar http://test-ipv6.com.

De achtergrond
Als eerste een eervolle vermelding naar stokstick die dit probleem al enige tijd geleden heeft aangekaart in dit topic. De reden waarom het wijzigen van deze instelling helpt, is omdat vele Android toestellen moeite hebben om goed om te gaan met een Stateless autoconfiguratie. Voor een mooie uitleg over de verschillende configuraties hiervan zie dit topic van caesar (kopje 'Hoe worden adressen uitgegeven'). Dit probleem is bekend bij Google er loopt ook een onderzoek naar. Jonathan-458 heeft ons gewezen op het juiste item op de issuetracker van Google in dit topic.

Tot slot
Het is van belang om goed onderscheid te maken tussen deze problemen en 'gewone' problemen met je draadloze verbinding. Dit onderscheid is natuurlijk lastig te maken en daarom is dit probleem ook zo lastig te troubleshooten. Heb je geen IPv6 maar toch problemen met je draadloze verbinding kijk dan eens op deze pagina. Heb je issues met je draadloze verbinding die hier niet mee in verband staan, dan is het beter om dit in een apart topic aan te kaarten.

Aanvulling
Community user CND koppelt in dit topic de 303 foutmelding op Ziggo GO ook aan het hier beschreven verschijnsel met de Stateless autoconfiguratie op Android apparaten. Voor de kleine groep gebruikers die dat probleem ervaren zijn de bovenstaande stappen ook een mogelijke oplossing.

Gerelateerde onderwerpen:
Laatste kans series Ziggo On Demand. Geen tijd te verliezen!
Help ons de TV Gids te verbeteren op al onze diensten
Valt je wifi weg? Lees dit topic!
62 Reacties 62
Digitaldude

Level 2
  • 5Posts
  • 0Oplossingen
  • 1Likes
Geweldig!
Sinds vorige week Ziggo klant en ik heb alles succesvol aan kunnen sluiten en werkend gekregen.

Enige puntje bleek dat Android devices geen goede Wifi verbinding hadden. Dat is met deze instelling helemaal opgelost.

Waarom wordt dit niet als default instelling in het modem ingesteld?
Gooijerke

Level 1
  • 5Posts
  • 0Oplossingen
  • 0Likes
Thijs Ziggo wrote:
Een verborgen probleem?
We hebben binnen onze Community wat lastig te onderzoeken problemen opgemerkt. Het gaat dan om Android apparaten die veel issues ervaren met het laden van websites en andere diensten. Soms helpt het dan om de pagina te verversen. Dit lijken in eerste instantie problemen met de draadloze verbinding. Logischerwijs wordt er dan gekeken naar het bereik, de kanalen, enzovoorts. Dit helpt vervolgens niet en dankzij meerdere Community leden is het duidelijk geworden dat dit issue komt doordat veel Android apparaten moeite hebben met een Stateless autoconfiguratie van IPv6. De achtergrond hiervan wordt onderaan nog verder toegelicht. Het probleem valt dan simpel op te lossen door in de modem te kiezen voor een Stateful autoconfiguratie. Hoe je dat doet staat hieronder per modem beschreven.

De workaround

Connect Box
1. Log in op de modem
2. Ga naar 'Geavanceerde instellingen'
3. Klik op 'DHCP'
4. Vink bij automatische instellingen onder 'DHCPv6 Server'
Stateful aan
5. Klik eronder op 'Wijzigingen toepassen'





Ubee EVW321
1. Log in op de modem
2. Klik rechtsboven op 'Geavanceerde Instellingen'
3. Klik links op DHCPv6
4. Vink het hokje aan bij 'Disable Stateless Dhcpv6'
5. Klik onderaan op 'Apply'

Dit is met de huidige firmware helaas niet mogelijk. Er volgt een update wanneer dit verandert.


Kom je er niet uit met het wijzigen van de instellingen, laat dan hier een reactie achter. Als je geen IPv6 op je modem hebt dan zul je deze opties ook niet in je modem zien staan.
Twijfel je of je IPv6 hebt? Ga dan naar http://test-ipv6.com.

De achtergrond
Als eerste een eervolle vermelding naar stokstick die dit probleem al enige tijd geleden heeft aangekaart in dit topic. De reden waarom het wijzigen van deze instelling helpt, is omdat vele Android toestellen moeite hebben om goed om te gaan met een Stateless autoconfiguratie. Voor een mooie uitleg over de verschillende configuraties hiervan zie dit topic van caesar (kopje 'Hoe worden adressen uitgegeven'). Dit probleem is bekend bij Google er loopt ook een onderzoek naar. Jonathan-458 heeft ons gewezen op het juiste item op de issuetracker van Google in dit topic.

Tot slot
Het is van belang om goed onderscheid te maken tussen deze problemen en 'gewone' problemen met je draadloze verbinding. Dit onderscheid is natuurlijk lastig te maken en daarom is dit probleem ook zo lastig te troubleshooten. Heb je geen IPv6 maar toch problemen met je draadloze verbinding kijk dan eens op deze pagina. Heb je issues met je draadloze verbinding die hier niet mee in verband staan, dan is het beter om dit in een apart topic aan te kaarten.

Aanvulling
Community user CND koppelt in dit topic de 303 foutmelding op Ziggo GO ook aan het hier beschreven verschijnsel met de Stateless autoconfiguratie op Android apparaten. Voor de kleine groep gebruikers die dat probleem ervaren zijn de bovenstaande stappen ook een mogelijke oplossing.

Gerelateerde onderwerpen:
Laatste kans series Ziggo On Demand. Geen tijd te verliezen!Help ons de TV Gids te verbeteren op al onze dienstenValt je wifi weg? Lees dit topic!
Gooijerke

Level 1
  • 5Posts
  • 0Oplossingen
  • 0Likes
Bedankt voor je reactie. ik ben een leek op dit gebied misschien een gekke vraag maar hoe log ik in op mijn modem ??
Steefb

Level 20
  • 15663Posts
  • 2966Oplossingen
  • 7107Likes
Dat hangt van je modem af, staat als het goed is in je handleiding, wachtwoord staat vaak op het modem.

https://www.ziggo.nl/klantenservice/wifi/modem-inloggen/
jdeij

Level 3
  • 30Posts
  • 1Oplossingen
  • 4Likes
Net over naar alles in 1.
Had eerst alleen de Mediabox XL.
Alles werkte goed.
Alleen wilde ik een apart modem hebben, omdat dat handiger is etc.
Conncetbox ontvangen.
Werkte eerst ook allemaal niet lekker, maar later wel.
Nu werkt alles, alleen op 2 oude Android telefoons niet meer.
Hij geeft aan dat je gewoon wifi hebt, maar werkt niet.
Kwam uit bij dit topic.
De oplossing werkt niet bij/voor ons.
Als ik de test op de site http://test-ipv6.com dan krijg ik overal timeout.
Op de nieuwere telefoons etc. werkt het wel, maar niet op de Samsung S4 mini met android versie 4.xxx
jdeij

Level 3
  • 30Posts
  • 1Oplossingen
  • 4Likes
Heeft contact met Ziggo en die heeft ons op ipv4 gezet en nu werkt het wel.
Bert

Level 21
T.E.A.M.
  • 74488Posts
  • 5099Oplossingen
  • 21644Likes
jdeij Top, dank voor je update, veel internetplezier gewenst.:relaxed:
rkellynl

Level 4
  • 59Posts
  • 1Oplossingen
  • 7Likes
Het lijkt erop dat ik eenzelfde probleem had op meerdere Windows 10 laptops die via WIFI verbinding maken. IPv6 adressen werden wel op de laptop gezet, maar bleken onbruikbaar te zijn. Toen ik in mijn Compal Connectbox de IPv6 DHCP overschakelde van stateless naar statefull waren die problemen ineens als sneeuw voor de zon verdwenen.

Firmware op de Connectbox: CH7465LG-NCIP-4.50.18.23-4m2-GA-NOSH
Ergun

Level 1
  • 4Posts
  • 0Oplossingen
  • 1Likes
Bij mij is IPv6 ook uitgeschakeld. Laatste tijd heb ik nog steeds problemen met 'trage' verbinding. Ik heb ook een Wifi booster gehuurd van Ziggo maar dit was ook geen oplossing. Ik heb nu een oude Router geinstalleerd en hierop DNS servers van Google op geconfigureerd. OP dit moment ervaren wij dus geen problemen als wij daar deze router connecteren.
Volgens mij heeft Ziggo al paar jaar problemen met de DNS servers als ik zoek in diverse Fora. Blijkbaar is het niet simpel om dit probleem op te lossen.
Christurbo

Level 1
  • 15Posts
  • 0Oplossingen
  • 2Likes
Ik heb een connectbox maar ik heb nergens een optie om de IPV6 instellingen te veranderen? Op de testwebsite geeft hij ook aan dat ik geen IPV6 heb. Hoe komt dit?
Bert

Level 21
T.E.A.M.
  • 74488Posts
  • 5099Oplossingen
  • 21644Likes
Christurbo Welk modem heb je in gebruik?
Waar zou je IPv6 voor willen gebruiken?
Rendolk

Level 2
  • 5Posts
  • 0Oplossingen
  • 2Likes
Naar aanleiding van e-mail Ziggo om de Mediabox XL om te ruilen voor de mediabox Next hiervan gebruik gemaakt, Kreeg kort daarna de mediabox next en ook een nieuw modem ConnectBox. Modem zelf aangesloten. Wifi verbinding duidelijk beter bij testen. Ik maakte reeds gebruik van een wifibooster van Ziggo voor beter signaal 1e etage. Bij handmatig switchen van wifiverbindingen kreeg ik de melding wel verbonden, maar mogelijk geen internet. Na circa 40 sec tot 1 minuut was er wel internet. Verschillende apps bleken heel traag op te starten, waaronder Ziggo Go. Uiteindelijk bij starten programma foutmelding 303. Ik maak gebruik van Samsung tablet S2 en S3 en samsung mobiel S8. Klacht de maandag gemeld bij klantenservice/helpdesk. De medewerkster kon zien, dat bepaalde instellingen in het modem nog niet goed doorlopen waren. Afspraak gemaakt voor monteur ook tbv installatie mediabox next, de volgende dag al. Monteur voortvarend aan de slag, diverse connectors etc vervangen en mediabox geinstalleerd. Wifi in hele woning getest en overal naar behoren. So far, so good. Later bleek de app Ziggo go via de wifi op de verschillende apparaten nog steeds dezelfde foutmelding te geven, 303. Via 3/4g geen problemen met de app. Via zoekvragen uitgekomen in deze community en de aanpassing in de connectbox toegepast::
Connect Box
Verbergen
1. Log in op de modem
2. Ga naar 'Geavanceerde instellingen'
3. Klik op 'DHCP'
4. Vink bij automatische instellingen onder 'DHCPv6 Server'
Stateful aan
5. Klik eronder op 'Wijzigingen toepassen'
Dit bleek in mijn geval ook de oplossing te zijn. Zowel het switchen van toegangspunten, meteen verbonden en geen melding meer van mogelijk geen internet, als functioneren apps zoals Ziggo Go, NPO Start e.d.
blueline

Level 1
  • 35Posts
  • 1Oplossingen
  • 5Likes

Nadat ik deze post heb gemaakt: https://community.ziggo.nl/internetverbinding-102/rare-problemen-na-verhuizing-47239#post493009

heb ik nu ip6 op stateful gezet. Ik ga dit nu testen. Alvast bedankt.

raymondsober

Level 4
  • 28Posts
  • 0Oplossingen
  • 3Likes

Sinds ongeveer twee weken last van de genoemde problemen. 

 

De apparaten die niet juist werken;

 

PlayStation 4 (met kabel of wifi) 

Samsung Galaxy note 10 +

Philips 65pled803 (met kabel of wifi)

 

Alle mogelijke stappen doorlopen, maar geen goed werkende oplossing gevonden. 

 

De Apple spullen hier in huis werken naar behoren. 

 

Hopende dat er een oplossing komt…

 

Fijne week

Anne H
Community Developer
Community Developer
  • 3865Posts
  • 224Oplossingen
  • 1572Likes

Hallo @raymondsober je TV, Smartphone en playstation geven dus IPv6 foutmeldingen. Dat zijn nou niet echt apparaten waar je zonder kan!

Ik zie dat je ook contact met de helpdesk hebt gehad over een ander probleem met je verbinding. Dat is samen opgelost. Is alles nu weer werkend? Zo niet dan horen we graag iets specifieker waarom het op de betreffende apparaten niet lukt om alleen IPv4 in te schakelen 🙂

raymondsober

Level 4
  • 28Posts
  • 0Oplossingen
  • 3Likes
Anne H Ziggo wrote:

Hallo@raymondsober je TV, Smartphone en playstation geven dus IPv6 foutmeldingen. Dat zijn nou niet echt apparaten waar je zonder kan!

Ik zie dat je ook contact met de helpdesk hebt gehad over een ander probleem met je verbinding. Dat is samen opgelost. Is alles nu weer werkend? Zo niet dan horen we graag iets specifieker waarom het op de betreffende apparaten niet lukt om alleen IPv4 in te schakelen 🙂

Hoi @Anne H Ziggo ,

 

Helaas heeft de aangeboden mogelijkheid tot de oplossing vanuit de klantenservice geen oplossing gebracht. Het probleem zoals omschreven blijft. Sterker nog, mijn MacBook lijkt nu ook moeite te krijgen met het juist laden van pagina's en verbinden met diensten. 

 

Zou jij voor mij kunnen nazien of uitzoeken wat er gaande is? Nooit eerder heb ik langdurige problemen gehad.. 

 

Dank alvast. 

 

Ps. De ks gaf bij mij aan wel meer dan 17 vaste verbindingen te zien, mogelijk is dat een aanwijzing? Weet dat ik geen switch of iets gebruik. Slechts 4 poorten zijn bezet en aangesloten op apparaten.. 

Rikst
Community Moderator
Community Moderator
  • 5101Posts
  • 476Oplossingen
  • 1603Likes

Hi @raymondsober 

Jammer dat deze problemen nog niet verholpen zijn! En het breidt zich ook uit begrijp ik : -( Om je verder te helpen hoor ik graag van je waarom het voor deze apparaten niet lukt om slechts IPv4 in te schakelen. Laat je het hier weten? 

bast1aan

Level 1
  • 1Posts
  • 0Oplossingen
  • 4Likes

Veel vergelijkbare problemen gehad hier in huis. Wifi op Android viel steeds weg, met als gevolg dat smartphones geen berichten (Whatsapp) en notificaties meer ontvangen en de internetverbinding dood bleek als je je telefoon pakte om iets op te zoeken. Zeer hinderlijk. Hier ook IPv6. Laptops hebben daarentegen geen enkele connectiviteitsproblemen.

Na een paar week uitzoeken en rondvragen hebben de volgende instellingen in mijn wifi AP en mijn router voor flinke verbetering gezorgd:
Wifi AP: dit is een eigen apparaat waar OpenWRT op staat waardoor ik hier alle instellingen makkelijk van kan wijzgen. Wijziging: DTIM periode op 3, beacon interval op 500ms.  Deze tip kreeg ik van een kennis die veel van wifi hardware weet vanuit zijn werk als network engineer. Vooral de DTIM periode op 3 is belangrijk voor Android smartphones en tablet. Deze stond bij mij op 2.

Verder heb ik ook een aantal instellingen in de RADVD van mijn (eveneens custom) router aangepast. RADVD is een softwareonderdeel van de router dat zorgt voor de uitgifte van de IPv6 SLAAC in het netwerk zodat je apparatuur de juiste IPv6 verbinding krijgen. De volgende parameters zijn aangepast:
AdvReachableTime 2700000;  # 45 minuten
AdvPreferredLifetime 1200;  # 20 minuten
AdvValidLifetime 1800;  # 30 minuten

Hebben Ziggogebruikers hier direct wat aan? Nee, ik denk het niet, ik denk dat iemand anders er in moet duiken hoe deze instellingen momenteel in de Ziggo routers staan en of het misschien zin heeft om deze aan te passen. Enige wat ik kan zeggen na 2 week proberen is dat de DTIM/Beacon intervalwijziging gelijk voor veel verbetering zorgde en de RADVD parameter wijzigingen ook nog voor kleine verbetering hebben gezorgd. Verder moet getest worden of dit geen nadelig effect heeft op bv Apple apperatuur, want dat heb ik hier niet. Enkel Windows, Ubuntu en Android.

De eerder voorgestelde wijziging van SLAAC naar DHCPv6 heeft bij mij twijfels, omdat zover ik weet Android totaal niet werkt met DHPCv6. Dus de kans is groot dat het enkel voor verbetering zorgt omdat Android apparaten nu helemaal geen IPv6 verbinding meer krijgen en terugvallen op IPv4.

CobusR

Level 9
  • 244Posts
  • 4Oplossingen
  • 94Likes

Dit probleem is nog steeds aanwezig merk ik terwijl bv KPN wel goed werkt waarom kan Ziggo dat niet?

Thuis heb ik Ziggo waarmee ik geen ipv6 adres op de android telefoon krijg als ik overschakel naar mobiel internet wel op het werk heb ik KPN als provider en werkt het wel gewoon. Hoe zit dat en wat is de status ?

Danitsja
Community Moderator
Community Moderator
  • 1292Posts
  • 137Oplossingen
  • 769Likes

Hey @CobusR, wat frustrerend dat je tegen deze problemen aanloopt. Zo te lezen ervaar jij nog problemen met een iPv6 verbinding via een Android telefoon. Wat zijn de exacte storingsklachten die je ervaart? En ervaar je dit ook op andere Android apparaten of alleen de telefoon? 😊

E-mail notificaties
Aan Uit

Ontvang een update bij nieuwe reacties in dit topic.

Uitgelicht topic