Thijs Z
Oud Community Moderator
Oud Community Moderator
  • 3070Posts
  • 318Oplossingen
  • 230Likes

Problemen met je verbinding op Android met IPv6? Foutcode 303? Bekijk de mogelijke workaround!

Een verborgen probleem?
We hebben binnen onze Community wat lastig te onderzoeken problemen opgemerkt. Het gaat dan om Android apparaten die veel issues ervaren met het laden van websites en andere diensten. Soms helpt het dan om de pagina te verversen. Dit lijken in eerste instantie problemen met de draadloze verbinding. Logischerwijs wordt er dan gekeken naar het bereik, de kanalen, enzovoorts. Dit helpt vervolgens niet en dankzij meerdere Community leden is het duidelijk geworden dat dit issue komt doordat veel Android apparaten moeite hebben met een Stateless autoconfiguratie van IPv6. De achtergrond hiervan wordt onderaan nog verder toegelicht. Het probleem valt dan simpel op te lossen door in de modem te kiezen voor een Stateful autoconfiguratie. Hoe je dat doet staat hieronder per modem beschreven.

De workaround

Connect Box
1. Log in op de modem
2. Ga naar 'Geavanceerde instellingen'
3. Klik op 'DHCP'
4. Vink bij automatische instellingen onder 'DHCPv6 Server' Stateful aan
5. Klik eronder op 'Wijzigingen toepassen'




Ubee EVW321

1. Log in op de modem
2. Klik rechtsboven op 'Geavanceerde Instellingen'
3. Klik links op DHCPv6
4. Vink het hokje aan bij 'Disable Stateless Dhcpv6'
5. Klik onderaan op 'Apply'
Dit is met de huidige firmware helaas niet mogelijk. Er volgt een update wanneer dit verandert.

Kom je er niet uit met het wijzigen van de instellingen, laat dan hier een reactie achter. Als je geen IPv6 op je modem hebt dan zul je deze opties ook niet in je modem zien staan.
Twijfel je of je IPv6 hebt? Ga dan naar http://test-ipv6.com.

De achtergrond
Als eerste een eervolle vermelding naar stokstick die dit probleem al enige tijd geleden heeft aangekaart in dit topic. De reden waarom het wijzigen van deze instelling helpt, is omdat vele Android toestellen moeite hebben om goed om te gaan met een Stateless autoconfiguratie. Voor een mooie uitleg over de verschillende configuraties hiervan zie dit topic van caesar (kopje 'Hoe worden adressen uitgegeven'). Dit probleem is bekend bij Google er loopt ook een onderzoek naar. Jonathan-458 heeft ons gewezen op het juiste item op de issuetracker van Google in dit topic.

Tot slot
Het is van belang om goed onderscheid te maken tussen deze problemen en 'gewone' problemen met je draadloze verbinding. Dit onderscheid is natuurlijk lastig te maken en daarom is dit probleem ook zo lastig te troubleshooten. Heb je geen IPv6 maar toch problemen met je draadloze verbinding kijk dan eens op deze pagina. Heb je issues met je draadloze verbinding die hier niet mee in verband staan, dan is het beter om dit in een apart topic aan te kaarten.

Aanvulling
Community user CND koppelt in dit topic de 303 foutmelding op Ziggo GO ook aan het hier beschreven verschijnsel met de Stateless autoconfiguratie op Android apparaten. Voor de kleine groep gebruikers die dat probleem ervaren zijn de bovenstaande stappen ook een mogelijke oplossing.

Gerelateerde onderwerpen:
Laatste kans series Ziggo On Demand. Geen tijd te verliezen!
Help ons de TV Gids te verbeteren op al onze diensten
Valt je wifi weg? Lees dit topic!
62 Reacties 62
pvt

Level 5
  • 53Posts
  • 1Oplossingen
  • 10Likes
Thijs Ziggo , caesar

Na enige test sessies, weet ik het volgende:

1) Problemen die ik heb met de internetverbinding, heb ik ALLEEN met Android 5.01, NIET met 6.01 noch met Android 7.0. Met Windows 10 noch met Linux heb ik enig probleem

2) Probleem is de verbinding met websites (surfen). Die verbindingen vallen spontaan uit, of ik kan geen verbinding krijgen (kunnen ook spontaan terugkomen, of wel instabiele verbinding). Verbindingssnelheid via Ookla, is wel snel, alhoewel verbinding krijgen met Ookla servers niet altijd vlot verloopt.

3) Mijn modem is een Ubee 321B. Dit is belangrijk: De problemen doen zich niet voor als ik de verbinding maakt met het wifi signaal van de Ubee modem. Het probleem is beperkt tot de WifI boosters!!

4) Ik heb (nog :wink: ) onvoldoende kennis van de technische details van Ipv6 van Ziggo om te beoordelen of de problemen specifiek Ipv6 zijn dan wel een generiek probleem van Android 5.01 met WifI boosters (via stopcontact), dus onafhankelijk van ipv4 of ipv6. De verbinding met Android 5.01 en Wifi boosters is instabiel. Het werkt de ene keer wel, de andere keer niet.
caesar

Level 17
  • 4135Posts
  • 70Oplossingen
  • 1325Likes
Zo te lezen is het een probleem tussen de WiFi software van de Android 5.01 apparaten en de WiFi boosters, en staat het helemaal los van IPv6.

Immers, de Ubee is jouw centrale verbinding met Ziggo, en daarmee heb je geen enkel probleem.
robbo

Level 20
T.E.A.M.
  • 17385Posts
  • 727Oplossingen
  • 4120Likes
Even wellicht overbodig, hier op android 6.01 en ios 9.3.5 (oudere ipad) ipv6 werkt naar behoren.
op de site " test your ipv6"http://test-ipv6.com scoort beide apparaten 10/10

even de melding omdat enkele reactie ook de 6.01 benoemd is ( wel enkele maanden geleden:))

Ik heb ipv6 dualstack voor de info. Gr Rob
pvt

Level 5
  • 53Posts
  • 1Oplossingen
  • 10Likes
Thijs Ziggo
Is een update van de firmware van Ubee 321B te verwachten (nu 9.12.7009) waarin de problemen met stateless autoconfiguration te verhelpen zijn?

m.vr.groet
Peter
caesar

Level 17
  • 4135Posts
  • 70Oplossingen
  • 1325Likes
Het is blijkbaar geen probleem van de Ubee, maar van oude versies Android.
Thijs Z
Oud Community Moderator Topicstarter
Oud Community Moderator
  • 3070Posts
  • 318Oplossingen
  • 230Likes
@pvt Ik heb een kanttekening geplaatst dat dit met de huidige firmware helaas niet valt aan te passen. Het is in dit geval dan ook geen IPv6 issue omdat je aangeeft dat het alleen via de wifiboosters speelt. Je kan daarover het beste een apart topic openen voor het overzicht.
pvt

Level 5
  • 53Posts
  • 1Oplossingen
  • 10Likes
Thijs Ziggo
Ik heb een al een apart item geopend onder thuisnetwerk, daar het probleem specifiek optreedt voor WifiBoosters (maar wel achter een Ubee 321B).

https://community.ziggo.nl/thuisnetwerk-101/android-5-01-en-wifi-booster-via-stopcontact-21976

Ik begrijp nu van je dat de 321B niet aan te passen valt, maar ik ben iemand die alle opties graag uitsluit.
Strikt genomen weet ik niet of de combinatie van WifiBooster met 321B niet tot problemen zou kunnen leiden voor android 5.01.

Als zou blijken dat android 5.01 met WifiBooster een probleem is onafhankelijk van de modem (wel zeer waarschijnlijk) weten we meer. Is android 5.01 getest bij de het uitrollen van WifiBoosters?

Overigens ter informatie, ik heb een oude telefoon op android 4.x eruit gegooid, daar die combinatie met een Ubee 321B niet werkte.
Thijs Z
Oud Community Moderator Topicstarter
Oud Community Moderator
  • 3070Posts
  • 318Oplossingen
  • 230Likes
Je kan het nog 100% uitsluiten door op je telefoons IPv4 in plaats van IPv6 af te dwingen. Zie deze discussie waarin Frenzke de app DNS changer gebruikt om handmatig een DNS op Android in te stellen. Bijgevolg was dat de telefoon op IPv4 ging werken. Er zijn geen issues bekend met Android 5 en de boosters.
pvt

Level 5
  • 53Posts
  • 1Oplossingen
  • 10Likes
Thijs Ziggo
caesar

Thijs, Je suggestie om Ipv6 volledig uit te schakelen via de DNS app werkt in de voorlopige tests!
(Voorlopig, daar ik alleen vanmorgen heb getest)

1) Indien de DNS app ipv4 afdwingt (geverifieerd via test-ipv6.com ), dan werken de tablets (Asus Zenpad 7c, Android 5.01) normaal direct zowel op de modem, en ook via de WifiBoosters.

2) Zonder de DNS app is de verbinding op de modem tot nu toe stabiel, en kan ik ook ipv6 testen (!!!???)

Hieruit moet ik nu concluderen dat de combinatie van WifiBoosters en Ubee 321B niet goed werkt voor Android 5.01. Instabiel, werkt soms wel (en dan ook snel, en met ipv6 ), dan weer niet.

Ik hou een slag om de arm, daar ik niet 100% zeker ben dat de directe verbinding met de modem altijd werkt zonder de DNS app, terwijl ik ook niet 100 % zeker ben dat de DNS app altijd afdoende is voor de WifiBooster.

Het lijkt me dat ipv6 voor de Ubee 321B niet goed werkt voor android 5.01. Waarom dat echt pas zichtbaar wordt via Wifiboosters lijkt me "voer voor netwerkspecialisten". (Het is geen glitch van een enkel apparaat. Ik heb het met twee Zenpads en twee Boosters uitwisselbaar)

Ik ben wel zeer geholpen met je suggestie::grinning:

bedankt
Peter
JaapFK

Level 1
  • 5Posts
  • 0Oplossingen
  • 0Likes
Ik heb dit probleem ook, op alle android apparaten. En dat zijn er hier een stuk of 8. Dus de beste optie zou zijn om ipv6 uit te laten schakelen? Ik heb een Cisco 3928 modem trouwens.
caesar

Level 17
  • 4135Posts
  • 70Oplossingen
  • 1325Likes
Ik heb wat commentaar gelezen over de IPv6 stacks van de Technicolor en de Compal Connectbox. Er zaten in beide stacks knollen van fouten. De Cisco was eerst ook afgekeurd voor IPv6, hoe die stack nou is, geen idee. Hoe het met de andere routers is, geen idee. Maar ik ben niet hoopvol.
pvt

Level 5
  • 53Posts
  • 1Oplossingen
  • 10Likes
JaapFK
Ik heb het probleem met android 5.01 en oudere versies van android.
Android 6.01 en jonger (7 en 😎 gaat goed met een Ubee 321B. Indien je de problemen met de Cisco 3928 ook met Android 6/7/8 optreden, dan zou ik toch maar eens contact opnemen met Ziggo ivm met de ouderdom van je modem. Als Ziggo ipv6 zegt te ondersteunen dan moet het ook ondersteund worden. Uitschakelen kun je tolereren voor oudere tablet's, maar niet voor de moderne telefoons en tablet's.
JaapFK

Level 1
  • 5Posts
  • 0Oplossingen
  • 0Likes
Ik had er nog een DNS nr van Open DNS instaan, in die Cisco router. Uit de tijd dat de ziggo DNS servers niet goed werkten. Dat heb ik nu weggehaald en hij lijkt het nu wel goed te doen. Sinds twee dagen, dus ik hou nog een slagje om de arm.
sojab0on

Level 9
  • 291Posts
  • 9Oplossingen
  • 63Likes
Merk het ook op bij iphone 6 en ipad air die er moeite mee hebben connectie verlies of niet eens google kunnen laden
Dns errors bad config dit los ikndan op door ze op het gasr netwerk te zetten doe ik ook met oudere android versies.

Hoewel ik mijn pixel c en nokia 8 ook wel is connectie problemen zie traag zien van internet langzaam laden van paginas zelfs de connectbox zelf is traag met de login pagina door geven. Deze 2 hangen aan de 5ghz wifi van de connectbox. Maar hebben er op de 2.4 ook last van.
Tegenlicht

Level 1
  • 6Posts
  • 0Oplossingen
  • 0Likes
Mijn internet (wi-fi) is na twee maanden van huis geweest te zijn, opeens kaput. Mijn android 7.0 maakte slecht contact met de modem afgelopen maandag toen ik thuiskwam. En nu na een factory reset helemaal geen contact meer. "authentication problem". Ik snap er niks van.Kan IPV6 hiermee te maken hebben?

Mijn modem is een: TG2492LG-ZG

En hoe reset to defaults je die domme router eigenlijk. Ik houd dat knopje ingedrukt 15 seconde en oanger. Maar er gebeurt niks behalve dat dat lampje uitgaat. Maar geen geknipper geen reset niks. Als ik de knop loslaat gaat dat witte lampje doodleuk weer aan.
Evert

Level 18
T.E.A.M.
  • 6902Posts
  • 788Oplossingen
  • 1995Likes
Tegenlicht Je hebt je eigen topic al gemaakt over dit probleem. Het is niet handig om dan ook op andere plekken je probleem neer te leggen, helemaal niet in topics die niet met jouw probleem overeen komen, omdat dan het overzicht gauw zoek is. Ik zie dat iemand ondertussen al in jouw topic gereageerd heeft, dus vergeet die reactie zeker niet 🙂
sojab0on

Level 9
  • 291Posts
  • 9Oplossingen
  • 63Likes
caesar wrote:
Ik heb wat commentaar gelezen over de IPv6 stacks van de Technicolor en de Compal Connectbox. Er zaten in beide stacks knollen van fouten. De Cisco was eerst ook afgekeurd voor IPv6, hoe die stack nou is, geen idee. Hoe het met de andere routers is, geen idee. Maar ik ben niet hoopvol.


Je hebt gelijk dat je niet hoopvol bent ik heb de arris connectbox staan met in Fziggo gebied full stack ipv6 maar wat een kriem zeg.
bekabeld is het ineens een stuk wnakeler wifi devices worden er ook een stuk moeilijker mee.

plus ik zag in een eigen topic ook al anderen die een ds-lite profiel hebben met ipv6 ben je ineens ook heel veel van je lijn snelheid kwijt en er zitten nog steeds een hoop dns problemen in de ds-lite en full stacks

En een groot nadeel van de arris en compal connectboxen is dat ze gewnn geforceerd worden op de ziggo dns servers, je kan niet in je modem al een overrule maken naar opendns, google dns of cloudflare dns

en het in je divces forceren werkt ook niet dan heb je gewoon geen dns dus geen internet.

dinsdag komt er een monteur naar wat anders kijken, ik ga denk ik ook toch het profiel terug laten zetten.
naar ipv4 only.
Henno

Level 17
  • 2620Posts
  • 79Oplossingen
  • 730Likes
Ik heb de EVW312b hier maar weer eens op stateless gezet. Bepaalde Android apparaten blijven DNS problemen houden, daar lijkt het op.
Omzetten naar 4G doet het meestal direct oplossen.
De apps die er hier last van hebben:
Facebook; commentaar bij postings komt niet te voorzijn als je er op drukt
Google; suggesties komen niet te voorschijn.

Oh ja, sinds een week of twee gebruik DNS van Cloudflare. Het probleem is niet anders als op Ziggo DNS op OpenDNS.

Ervaringen?

gr, Henno
Zwavelstok

Level 1
  • 178Posts
  • 7Oplossingen
  • 22Likes
Kunnen dit soort artikelen "sticky" gemaakt worden. Veel te belangrijk om vergeten te worden.
Anne H
Community Developer
Community Developer
  • 3865Posts
  • 224Oplossingen
  • 1572Likes
Zwavelstok wrote:
Kunnen dit soort artikelen "sticky" gemaakt worden. Veel te belangrijk om vergeten te worden.

Dat kunnen we zeker eens proberen! Sticky is geen archief overigens, het gaat om het verbeteren van de vindbaarheid. Ik ga bijhouden hoeveel mensen dit topic vanaf nu gaan bezoeken, als dat niet toeneemt haal ik later dit jaar de Sticky er weer af 🙂
E-mail notificaties
Aan Uit

Ontvang een update bij nieuwe reacties in dit topic.

Uitgelicht topic