J123456
Gedreven Meedenker
  • 36Posts
  • 1Oplossingen
  • 5Likes

Probleem FTP. Kan NAS niet bereiken

Ik ben bezig om mijn NAS te bereiken via de Technicolor TC7210 via FTP.

Op de NAS heb ik de poort (21 in dit geval) aangegeven, alsmede de poortrange voor bestandsoverdracht.  Ook heb ik daar aangevinkt, dat enkel beveiligde verbindingen toe te staan

Op de Technicolor heb ik de NAS een vast IP adres gegeven (werkt ook). En port forwarding ingesteld met als met interne IP het vaste IP adres en als poort 21, als externe poort een specifiek nummer gekozen en ext IP niet ingevuld (0.0.0.0  dus)

Ik kan de NAS echter niet bereiken… waar zou dat aan kunnen liggen?

 

1 Geaccepteerde oplossing

Geaccepteerde oplossingen
DennyW
Expert
Expert
  • 2772Posts
  • 232Oplossingen
  • 691Likes
J123456 wrote:

Hallo DennyW, aan de NAS zijde heb ik poort range 1234 t/m 5678 (voorbeeld) opgegeven voor de data communicatie. De 2de portforward regel, hoe ziet die er dan uit? Local Start/End port = 1234/5678 en hetzelfde bij Extern Start/End port?

 

Ja.

Bekijk in context

11 Reacties 11
DennyW
Expert
Expert
  • 2772Posts
  • 232Oplossingen
  • 691Likes

@J123456 

Van binnenuit het LAN kan je het externe IP-adres sowieso niet bereiken. De TC7210 heeft geen ondersteuning voor NAT-loopback (het z.g. hairpinning). Heb je de bereikbaarheid al getest via b.v. de data-bundel van een smart-phone?

J123456
topicstarter
Gedreven Meedenker
  • 36Posts
  • 1Oplossingen
  • 5Likes

Ja, met FTPmanager app op telefoon. Deze werkt helaas ook niet, terwijl dit met vorige router wel werkte. 
Deze app heeft wel meerdere instellingen. Ik heb nu gekozen coor FTP (terwihl ik eerst FTPS had). 
ik zal ook nog eens proberen met Cyberduck of WinSCP… met notebook verbonden via telefoon en extern netwerk v Vodafoon. 
en als er bog tips zijn, hoor ik dat graag

DennyW
Expert
Expert
  • 2772Posts
  • 232Oplossingen
  • 691Likes

Je hebt het over de vorige router. Heb je onlangs een TC7210 gekregen? Dat zou dan merkwaardig zijn omdat dit een wat ouder type is. Tegenwoordig verstrekt men veelal een Connecbox.

J123456
topicstarter
Gedreven Meedenker
  • 36Posts
  • 1Oplossingen
  • 5Likes

Nee ik had een Netgear R7000 achter de Technicolor in bridge, maar na de firmwareupgrade was de Netgear niet maar aan de praat te krijgen.

 

DennyW
Expert
Expert
  • 2772Posts
  • 232Oplossingen
  • 691Likes

Standaard staat Firewall Protection van de TC7210 op Low. Poort 21 wordt dan doorgelaten. Met de instellingen “Medium” en / of “High” wordt die poort niet genoemd bij de Allowed Services; dus geblokt.  Na wijzing op “Apply” klikken en modem-router herstarten. (Zet desnoods de TC7210 even terug naar fabrieksinstellingen, door reset ca 20 a30 sec. ingedrukt te houden / of via de web-interface. Default gebruiksersnaam wordt dan “ziggo” en wachtwoord “draadloos”.)

Als de TPF-server intern wel op diens interne IP-adres aan te roepen is, dan zou je verwachten dat het met een port forward ook zou moeten lukken op het externe IP-adres. Heeft de server geen log waar terug kan lezen wanneer en wie geprobeerd heeft in te loggen?

 

J123456
topicstarter
Gedreven Meedenker
  • 36Posts
  • 1Oplossingen
  • 5Likes

Met WinSCP kan ik wel de NAS bereiken, maar enkel als ik deze benader via een onversleutelde verbinding (dit moet ik dan ook toestaan aan de NAS zijde). Zodra ik dit probeer met een versleutelde verbinding (met TLS en FTP expliciet) gaat het niet. Ik krijg dan foutmelding in logbestand:

. Server sent passive reply with unroutable address <int IP; static>, using host address instead.
. MLSD
. Bezig met verbinding maken met <ext IP:poort voor data exchange, zoals in NAS aangegeven>
. Time-out opgetreden. (Dataverbinding)
. Kan mappenlijst niet opvragen
. (EFatal) **Verbinding verbroken.**

 

Iemand enig idee wat er hier gebeurd en hoe op te lossen? Ik weet niet hoe een goed FTP(S) logbestand er uit ziet…

Ik vond nog dit:

The firewall and NAT on the FTP server side have to be configured not only to allow/route the incoming connections on FTP port 21, but also a range of ports for the incoming data connections. Typically, the FTP server software has a configuration option to setup a range of the ports, the server will use. And the same range has to be opened/routed on the firewall/NAT.  

Ik heb inderdaad op de NAS deze “range of ports” gespecificeerd, maar ik heb dit niet gedaan op de Technicolor? Waar/hoe doe ik dit?

 

 

DennyW
Expert
Expert
  • 2772Posts
  • 232Oplossingen
  • 691Likes

Je zou dus kunnen proberen om de server op passieve FTP in te stellen en een tweede port forward regel hiervoor te maken in de router.
Bij de client moet je dan ook instellen dat passieve FTP gebruikt moet worden met bij behoren welke poortreeks.

 

FTP werkt net zoals andere server-diensten: een client benadert de server op een specifieke poort (hier dus poort 21) waarop de server “luistert”. Er vind een z.g. hand shake plaats waarin o.a. gecommuniceerd wordt over welke poorten het eigenlijke (uit te wisselen) data-verkeer zal verlopen.

FTP-server kan je instellen op actieve of op passieve-FTP. Bij actieve FTP worden tamelijk willekeurige poorten gebruikt voor het dataverkeer en bij de passieve variant is er in de server vastgelegd welke poorten gebruikt kunnen worden.

Bij de hand shake / data-pakketjes wordt ook het IP-adres van de server vermeld. Als de server zich met het interne IP-adres bekend maakt i.p.v. het externe IP-adres, dan kan het ook fout gaan. (Vaak kan je dit instellen bij de server.)

Voor wat meer uitleg even deze Engelstalige link, maar met een beetje zoeken kan je dit soort teksten vast wel ook in het Nederlands op het internet vinden.

 

In principe zal de firewall van een Ziggo-modem-router er geen problemen mee hebben over welke poorten de data-stream zal verlopen als je de standaard poort 21 gebruikt. Anders wordt het als je hiervan afwijkt of als je meerdere routers achterelkaar hebt (dus eigen ook meerdere firewalls) of als er meerder firewalls achtereen gebruikt worden.

Zelf gebruikte ik passieve FTP en twee router achter elkaar (Daisy chaining / in cascade). Daarom moest ik bij mijn Ziggo-modem-router (TC7210) een tweede portforward-regel maken voor de reeksje passieve data-poorten.

Zie b.v. dit linkje naar een oud topic.

J123456
topicstarter
Gedreven Meedenker
  • 36Posts
  • 1Oplossingen
  • 5Likes

Hallo DennyW, aan de NAS zijde heb ik poort range 1234 t/m 5678 (voorbeeld) opgegeven voor de data communicatie. De 2de portforward regel, hoe ziet die er dan uit? Local Start/End port = 1234/5678 en hetzelfde bij Extern Start/End port?

 

DennyW
Expert
Expert
  • 2772Posts
  • 232Oplossingen
  • 691Likes
J123456 wrote:

Hallo DennyW, aan de NAS zijde heb ik poort range 1234 t/m 5678 (voorbeeld) opgegeven voor de data communicatie. De 2de portforward regel, hoe ziet die er dan uit? Local Start/End port = 1234/5678 en hetzelfde bij Extern Start/End port?

 

Ja.

Bekijk in context

J123456
topicstarter
Gedreven Meedenker
  • 36Posts
  • 1Oplossingen
  • 5Likes

Hi DennyW, FTP(S) via beveiligde verbinding werkt nu! Weer iets meer geleerd hoe FTP werkt. Dankjewel

DennyW
Expert
Expert
  • 2772Posts
  • 232Oplossingen
  • 691Likes


@J123456 

Dank voor de positieve terugkoppeling. Het lijkt erop dat jouw Netgear router “iets” slimmer was dan de TC7210 is.

Uitgelicht topic