1
Vraag
2
Reacties
BasicBas

Level 3
  • 16Posts
  • 1Oplossingen
  • 1Likes

Port forwarding werkt niet op Compal CH7465LG

Goedenavond,

 

Sinds pakweg een week lijken de door mij geforwarde porten op de Compal modem vanaf het internet niet meer zichtbaar te zijn. De modem staat niet in bridge modus. Ik heb deze modem pakweg ruim een jaar en tot voor kort werkte alles naar behoren. Gegevens van de modem:

 

Standard specification compliant : DOCSIS 3.0
Hardware version : 4.01
Software version : CH7465LG-NCIP-6.15.32p3-NOSH

 

De poorten gebruik ik om op een windows computer (Windows 10 Pro 20H2, OS build 19042.1081, Windows Feature Experience Pack 120.2212.3530.0) wat programma's te draaien. Ik heb zelf niets veranderd (zeker niet aan de modem), wel zijn er wat windows updates geweest. 

 

Ziggo heeft voor mij de modem al compleet gereset, teruggezet naar fabrieksinstellingen,  daarna heb ik nog uPNP afgewisseld met NAT, maar niets lijkt te werken; als ik vanaf het internet mijn externe IP (zowel IP4 als ook IP6) scan, lijkt de router in complete stealth modus te staan. Niet alleen mijn persoonlijke poorten, maar géén enkele poort lijkt bereikbaar. Zie bijlage. 

 

Vreemdgenoeg  heb ik wel verbinding met het internet, ik kan gewoon browsen en deze post aanmaken, maar daar blijft het bij. Programma's die een open of getriggerde port nodig hebben werken niet. 

 

Ziggo biedt geen telefonisch hulp als je het woord 'portforwarding' slechts al noemt, ookal lijkt het probleem hier de router te zijn? Wie kan mij helpen dit puzzeltje op te lossen?

 

bij voorbaat dank

 

Oplossing

Geaccepteerde oplossingen
BasicBas
Topicstarter
Level 3
  • 16Posts
  • 1Oplossingen
  • 1Likes

We waren al een flink eind gekomen gister en ik heb een boel geleerd. Ik bleef zitten met de vraag: wat loopt nou de boel op mijn pc te blokkeren?

-Firewall uitgezet, virusscanner uitgezet; geen resultaat

 

Toen kwam ik toevallig in een tempdir de installer tegen van een prog dat ik een paar maanden terug uitprobeerde: Portmaster (https://safing.io). Dit om meer grip en overzicht te krijgen op het netwerkverkeer. 

Het is een mooi programma, maar indertijd heb ik het gestopt omdat ik op geen enkele manier er poorten in geforward kreeg (story of my life...). Nou reboot ik niet zo vaak en kennelijk werd na herstart weer netjes de bijpassende service gestart. Dit was niet zichtbaar door een systray icoontje oid. Na deïnstallatie van het prog gaven meteen alle net-connection tests een positief resultaat. 

 

Ik wil @tobiastheebe hartelijk danken dat hij mij aan de hand heeft genomen en in de goede richting geduwd. Wordt zeer gewaardeerd. 

 

De netwerkprogs waar ik het gister over had werken nu naar behoren. In de router heb ik nu een config met NAT/PNP zonder UPnP. Ook de scope heb ik aangepast voor de netheid, al was dat niet de oorzaak (zou ook raar zijn want dit werkte voorheen altijd). 

 

Merkwaardig blijft nog wel dat mijn ftp-server nog niet bereikbaar is vanaf de WAN kant. Het gaat om de FileZilla server. Ik heb ports geforward voor de control connection, TLS, en een pasv port range, maar 'no dice'. Net-connection test werkt voor beide porten (control en TLS) maar jouw port forward tester geeft aan dat de ports niet open staan. Alhoewel ik weet dat FTP gecompliceerder is voor een modem dan één simpele port voor torrents, heb ik er vertrouwen in dat het uiteindelijk wel lukt: eerder heeft het immers ook gewerkt. 

 

Tips zijn uiteraard welkom

Bekijk in context

22 Reacties 22
tobiastheebe

Level 20
Super Expert
  • 15969Posts
  • 1014Oplossingen
  • 6989Likes

Kun je een screenshot plaatsen van de port forwarding-regels? Kun je de firewall-instellingen zo aanpassen dat alleen 'Firewall beveiliging' is ingeschakeld voor zowel IPv4 als IPv6? Port forwarding heeft overigens alleen betrekking op IPv4. Is het IP-adres van de PC nog hetzelfde?

 

Bij handmatig aangemaakte regels dient UPnP uitgeschakeld te worden, deze werken niet goed samen.

 

Controleer of het netwerkprofiel van Windows nog is ingesteld op Privé/Private.

 

Een aantal poorten die je hebt ingevoerd als custom ports, zijn poorten die worden geblokkeerd op de firewalls binnen de infrastructuur van Ziggo en kun je in ieder geval niet gebruiken voor port forwarding. Dit zijn 25, 135, 139 en 445.

BasicBas
Topicstarter
Level 3
  • 16Posts
  • 1Oplossingen
  • 1Likes

Hoi,

 

Superbedankt voor het megasnelle antwoord. 

 

-Zie bijlages voor instellingen NAT en Firewall;

-uPNP had ik al uitgeschakeld als test, staat nu nog steeds uitgeschakeld

-Netwerkprofiel staat idd ingesteld op 'privé'. Ik ga die op 'publiek' zetten en kijken wattie doet, 

-De geforwarde porten zijn niet de poorten die standaard worden gebruikt voor standaard mail/ftp/telnet you name it. De bijlage was bedoeld om te tonen dat er echt niets open stond. 

 

 

tobiastheebe

Level 20
Super Expert
  • 15969Posts
  • 1014Oplossingen
  • 6989Likes

Voor het profiel is 'Privé' de juiste optie, 'Openbaar' zorgt ervoor dat alle inkomende verbindingen worden geblokkeerd, deze optie dus niet kiezen.

 

Heb je al gecontroleerd of de PC nog steeds IP-adres 192.168.178.18 heeft?

 

Wat geven onderstaande PowerShell-commando's als resultaat?

 

  • Test-NetConnection -ComputerName 192.168.178.18 -Port 4189
  • Test-NetConnection -ComputerName 192.168.178.18 -Port 50501
BasicBas
Topicstarter
Level 3
  • 16Posts
  • 1Oplossingen
  • 1Likes

Wederom dank;

 

Met ipconfig /all kan ik zien dat mijn pc nog op 192.168.178.18 staat. Dit adres heb ik vastgezet (custom settings) in de properties van het IP4 protocol van de netwerkadapter.

 

Profiel 'prive' is actief, met 'network discovery' met suboptie 'automatische setup van verbonden netwerkapparaten' ook aangevinkt. 

 

Powershell commando's geven foutmelding; 'Test-NetConnection' is not recognized as an internal or external command, operable program or batch file.' Ik zal het verkeerd ingevoerd hebben?

 

bvd,

tobiastheebe

Level 20
Super Expert
  • 15969Posts
  • 1014Oplossingen
  • 6989Likes

De commando's moet je in PowerShell uitvoeren, niet in de Opdrachtprompt.

BasicBas
Topicstarter
Level 3
  • 16Posts
  • 1Oplossingen
  • 1Likes

Oh, my bad.. PowerShell is iets anders dan commandprompt.. 😕

Het commando werd in PS netjes uitgevoerd waarbij de pc wel werd gevonden, zo lijkt het, maar de port wordt niet open gemeld. Zie bijlage.

tobiastheebe

Level 20
Super Expert
  • 15969Posts
  • 1014Oplossingen
  • 6989Likes

Dat betekent dat het probleem bij de PC ligt. De applicatie/service luistert niet op de poort.

BasicBas
Topicstarter
Level 3
  • 16Posts
  • 1Oplossingen
  • 1Likes

Dank,

 

De applicatie lijkt wel te luisteren. Met NAT ging het niet (de applicatie gaf aan de ingestelde porten niet te kunnen mappen in de modem), maar wel met UPnP. In de modem heb ik alle NAT-entries weggehaald en vervolgens UPnP aan gezet. De porten werden vervolgens netjes geregistreerd in de modem. Zie bijlage. 

Het powershell commando gaf overigens nog steeds aan de poort niet te kunnen openen.

Nog ideeën? 

 

 

tobiastheebe

Level 20
Super Expert
  • 15969Posts
  • 1014Oplossingen
  • 6989Likes

Er lijkt toch iets mis te gaan met de applicatie. Geeft poort 10552 in hetzelfde commando ook geen resultaat?

BasicBas
Topicstarter
Level 3
  • 16Posts
  • 1Oplossingen
  • 1Likes

Ja, port 10552 geeft helaas ook niet thuis met het commando, op dezelfde manier als 4189; ping 'true' en tcptestsucceed: 'false'. 

Wat geeft je het idee dat het aan de applicatie ligt?

Er draaide nog een ander programma dat ook met UPnP werkt, netjes de port doorgaf (en die ook netjes in de modem gelist werd) die vervolgens niet open bleek. 

tobiastheebe

Level 20
Super Expert
  • 15969Posts
  • 1014Oplossingen
  • 6989Likes

Lokaal zou de poort altijd open moeten staan voor inkomende verbindingen, ook al zou port forwarding niet werken, zodat je de poort wel vanaf een andere client binnen het LAN bereiken. Gebaseerd op de output van Test-NetConnection zou dat nu ook niet werken.

 

Om wat voor applicatie(s) gaat het?

BasicBas
Topicstarter
Level 3
  • 16Posts
  • 1Oplossingen
  • 1Likes

Ok.... 

Jij zegt: het ligt lokaal binnen je pc. Je logica daarin volg ik wel, Test-NetConnection zou 'succeed' aan moeten geven. 

Maar, is het niet apart dat, vanaf het internet gescand op mijn externe ip, alle porten steevast 'closed/timed-out/stealth' geven?

 

Het gaat om een torrent-client.

 

Het wordt al wat later, ik snap heel goed als je er genoeg van hebt voor vandaag, hoe dan ook nogmaals hartelijk dank voor de genomen moeite. Hopelijk kan je me nog een hint geven in welke richting ik het ongeveer moet zoeken.

 

 

 

tobiastheebe

Level 20
Super Expert
  • 15969Posts
  • 1014Oplossingen
  • 6989Likes

Dat is juist niet apart en maar goed ook.

 

In een 'normale situatie' zijn alle verbindingen uit het LAN afkomstig. Hiervoor creëert de router willekeurig gekozen poorten aan WAN-zijde, welke slechts kortstondig bestaan, zolang als nodig. Inkomende verbindingen van WAN naar LAN worden beantwoord met een DROP (timeout), als daarvoor geen overeenkomstige DNAT-regels (bijvoorbeeld port forwarding) bestaan.

 

Heb je toevallig meerdere actieve interfaces/IP-adressen op de PC, waardoor de applicatie mogelijk wel op een ander adres luistert naar inkomende verbindingen?

BasicBas
Topicstarter
Level 3
  • 16Posts
  • 1Oplossingen
  • 1Likes

Nee, geen andere interface/ip. Het ziet er als volgt uit (bijlage)

tobiastheebe

Level 20
Super Expert
  • 15969Posts
  • 1014Oplossingen
  • 6989Likes

Luistert de torrent client wel naar TCP-verkeer?

 

Ik gebruik zelf Tixati, welke statisch op poort 6881 is ingesteld. Luistert uiteraard naar zowel TCP als UDP. Ik maak geen gebruik van UPnP.

 

20221026-03.PNG

20221026-02.PNG

BasicBas
Topicstarter
Level 3
  • 16Posts
  • 1Oplossingen
  • 1Likes

Dat ziet er wel uit als een handig progje, 'port forwarding tester', maar het zal wezenlijk niet veel meer doen dan een website zoals https://dnschecker.org/ ? 

Edit: ik zie het al, Port Forward Tester hierboven is ook een website. 

 

Het gaat om meerdere applicaties (testen deed ik met twee apps), ik schat niet dat die allemaal ineens niet meer 'luisteren?

Binnen windows heb ik al eens een 'netwerk reset' gedaan, dat werkte niet. Misschien wordt het tijd voor een herinstallatie..

Ik ga er eens een nachtje over slapen. 

tobiastheebe

Level 20
Super Expert
  • 15969Posts
  • 1014Oplossingen
  • 6989Likes

Als test zou je de PC weer via DHCP een IP-adres kunnen laten ophalen en nieuwe port forwarding-regels laten aanmaken. Het huidige (statische) IP-adres valt bij standaardconfiguratie van het SmartWifi modem in de DHCP-scope, dat is niet wenselijk en kan conflicten veroorzaken, maar misschien heb je de scope aangepast?

BasicBas
Topicstarter
Level 3
  • 16Posts
  • 1Oplossingen
  • 1Likes

We waren al een flink eind gekomen gister en ik heb een boel geleerd. Ik bleef zitten met de vraag: wat loopt nou de boel op mijn pc te blokkeren?

-Firewall uitgezet, virusscanner uitgezet; geen resultaat

 

Toen kwam ik toevallig in een tempdir de installer tegen van een prog dat ik een paar maanden terug uitprobeerde: Portmaster (https://safing.io). Dit om meer grip en overzicht te krijgen op het netwerkverkeer. 

Het is een mooi programma, maar indertijd heb ik het gestopt omdat ik op geen enkele manier er poorten in geforward kreeg (story of my life...). Nou reboot ik niet zo vaak en kennelijk werd na herstart weer netjes de bijpassende service gestart. Dit was niet zichtbaar door een systray icoontje oid. Na deïnstallatie van het prog gaven meteen alle net-connection tests een positief resultaat. 

 

Ik wil @tobiastheebe hartelijk danken dat hij mij aan de hand heeft genomen en in de goede richting geduwd. Wordt zeer gewaardeerd. 

 

De netwerkprogs waar ik het gister over had werken nu naar behoren. In de router heb ik nu een config met NAT/PNP zonder UPnP. Ook de scope heb ik aangepast voor de netheid, al was dat niet de oorzaak (zou ook raar zijn want dit werkte voorheen altijd). 

 

Merkwaardig blijft nog wel dat mijn ftp-server nog niet bereikbaar is vanaf de WAN kant. Het gaat om de FileZilla server. Ik heb ports geforward voor de control connection, TLS, en een pasv port range, maar 'no dice'. Net-connection test werkt voor beide porten (control en TLS) maar jouw port forward tester geeft aan dat de ports niet open staan. Alhoewel ik weet dat FTP gecompliceerder is voor een modem dan één simpele port voor torrents, heb ik er vertrouwen in dat het uiteindelijk wel lukt: eerder heeft het immers ook gewerkt. 

 

Tips zijn uiteraard welkom

tobiastheebe

Level 20
Super Expert
  • 15969Posts
  • 1014Oplossingen
  • 6989Likes

Fijn om te lezen dat je zelf de oorzaak van het probleem hebt gevonden. Blijkbaar had Portmaster zich flink diep in Windows geworteld. Ik gebruik zelf applicaties van NirSoft als ik meer inzicht wens te hebben in inkomende/uitgaande verbindingen. Applicaties die eigenhandig de firewall van Windows overnemen komen er hier niet in.

 

Ik heb een aantal jaar geleden ook port forwarding ingesteld voor FTPS (vsftpd), maar gebruik tegenwoordig alleen nog SFTP op mijn server. Kun je bij de instellingen van FileZilla Server controleren of WAN IP-adressen mogen verbinden? Zie de pagina IP Filter.

E-mail notificaties
Aan Uit

Ontvang een update bij nieuwe reacties in dit topic.

Polls
Ga je voor een film of een serie?

Uitgelicht topic