jstrnisa

Gedreven Ontdekker
  • 8Posts
  • 0Oplossingen
  • 0Likes

Port Forwarding on ConectBox not working

Hello!

 

I am trying to forward port 80 on my ConnectBox. I have a nginx web server running on my raspberry pi and can access it from within the local network. But when I add a new forwarding rule on my modem (as described here) I still cant access my web server page from outside the local network (get ERR_ADDRESS_UNREACHABLE)

 

What could be wrong?

Thank you for your help.

16 Reacties 16
Bert
Super Expert
Super Expert
  • 51083Posts
  • 3196Oplossingen
  • 11614Likes

Is UPnP still on?

Remove your port forward and turn off UPnP and unplug the modem for 30 seconds.

Then re-enable the port forward.

Meindert
Community Moderator
Community Moderator
  • 524Posts
  • 54Oplossingen
  • 115Likes

Hello @jstrnisa , did you solved your question with the tips of Bert?

If you can still use the help of our community members, or if you have any following up questions, please let us know by responding to this topic.

jstrnisa
topicstarter
Gedreven Ontdekker
  • 8Posts
  • 0Oplossingen
  • 0Likes

Hello!

 

Thank you for your answer. I will check if it works as soon as I can and will get back to you.

 

 

jstrnisa
topicstarter
Gedreven Ontdekker
  • 8Posts
  • 0Oplossingen
  • 0Likes

Hi @Bert! Sorry this did not work either. I followed your steps:

  • Removed the port forwarding
  • disabled UPnP
  • disconnected the ConnectBox for 30s
  • created the port forwarding again (80-80 80-80 Both protocols)

The result is the same as before. The server is not reachable on the http.

 

Any other ideas what could be wrong?

 

Thanks for your help!

Bert
Super Expert
Super Expert
  • 51083Posts
  • 3196Oplossingen
  • 11614Likes

Is there a service running on the server, what can answer the request?

jstrnisa
topicstarter
Gedreven Ontdekker
  • 8Posts
  • 0Oplossingen
  • 0Likes

 

It's a web server running in a docker container. It is a database server with a web interface so when it's running entering the IP in the browser a page opens. That is when accessed from within the local network.  That makes me think that there is nothing wrong with the server configuration but on the router side.

I'm not really an expert so I might be wrong somewhere here but I could test my assumption by opening the SSH port.

Then if I can't ssh into the PI from outside the network it would mean a problem at the router.

 

PS: for testing access from outside the local network I use my phone because it is the only device to use mobile network.

 

Bert
Super Expert
Super Expert
  • 51083Posts
  • 3196Oplossingen
  • 11614Likes

I have to little experience with that, possible @efok can help you with this.

He comes by if / as soon he is online.

efok
Expert
Expert
  • 3283Posts
  • 179Oplossingen
  • 1101Likes

I think portforwarding for port 80 is blocked in the modem, unless it is in bridge.

Off course testing with port 22 is possible.

jstrnisa
topicstarter
Gedreven Ontdekker
  • 8Posts
  • 0Oplossingen
  • 0Likes

@efok could you be a bit more specific? What is bridge and how do I enable it?

 

PS: I opened a SSH port (22) and could not ssh into the raspberry pi from my phone while on mobile network (when I am on wifi, I can)

 

Thank you for your help,

efok
Expert
Expert
  • 3283Posts
  • 179Oplossingen
  • 1101Likes

If your modem is in bridge mode, it functions as a modem only. That means the router function will be diabled, and you will need your own router, which wil get an external IP adress. So, you will be in full control of opening ports.

jstrnisa
topicstarter
Gedreven Ontdekker
  • 8Posts
  • 0Oplossingen
  • 0Likes

 

Ok, that I don't want to do. Buying and installing my own router. Is there a way to unblock port 80 (or port 443)?

 

Thank you for your help

jstrnisa
topicstarter
Gedreven Ontdekker
  • 8Posts
  • 0Oplossingen
  • 0Likes

It seems like no port forwarding rule I create works.  I changed the listening port of the server to 5000 and tried to forward that port but it does not work either. the ports are just not open. Who can I contact so this can be fixed?

 

Lotte
Community Moderator
Community Moderator
  • 1171Posts
  • 115Oplossingen
  • 303Likes

Good afternoon @jstrnisa, I think I found the cause of the problem. You didn't have an ipv4 only ip address yet, port forwarding is only possible with an ipv4 address. You will have this within 24 hours and it should work. Keep us updated! 

jstrnisa
topicstarter
Gedreven Ontdekker
  • 8Posts
  • 0Oplossingen
  • 0Likes

Hi @Lotte

Do I need to do anything (like reset the router) for this change to take effect? How do I check if the change to ipv4 only has been made?

 

Thank you for your help!

Bert
Super Expert
Super Expert
  • 51083Posts
  • 3196Oplossingen
  • 11614Likes

@jstrnisa Then you can set port forward.

 

If that is not possible now, disconnect your modem from the power for 30 seconds. It is possible that the correct settings are then picked up by the modem.

Jamyla
Community Moderator
Community Moderator
  • 2051Posts
  • 234Oplossingen
  • 438Likes

Goodmorning @jstrnisa

 

Have you tried to change the setting to port forwarding recently? Did it worked after the change of my colleague Lotte? Please let us know so we know if you still need any help.

Uitgelicht topic