1
Vraag
2
Reacties
Tobias2

Level 4
  • 34Posts
  • 1Oplossingen
  • 6Likes

Poort 25 gebruiken voor mailserver

goede dag Ik heb even een vraagje ik heb een ziggo modem en een eigen e-mail server maar die moet poort 25 gebruiken heb het al op andere manieren geprobeerd maar zonder succes en hoe kan ik dit oplossen want heb een zakelijke abonnement dus dan zou het toch moeten lukken dacht ik

 

 

Met vriendelijke groet Tobias

98 Reacties 98
Bert

Level 21
T.E.A.M.
  • 74664Posts
  • 5110Oplossingen
  • 21689Likes

Hier een uitgebreidere uitleg van de situatie: https://community.ziggo.nl/t5/Internet/Email-poort-25/m-p/967061/highlight/true#M132360

 


@Erik S  schreef:

Dag allen! Sorry voor de ietwat late reactie vanuit ons allereerst. We hebben één en ander na moeten vragen en daar ging tijd in zitten. Hopelijk kan ik middels dit bericht duidelijkheid scheppen over de verwarring die is ontstaan nu het bij de één (nog) wel werkt, en bij de ander niet (meer).

 

Na interne rondvraag blijkt dat Ziggo bezig is met een project dat op CMTS (wijkcentrale) niveau poort 25 blokkeert. Hierdoor kunnen er verschillen zijn tussen bepaalde regio's en kan het voor persoon A nog wel werken, terwijl het voor persoon B niet meer werkt. Het duurt niet lang meer voor dit project helemaal is afgerond en er zullen dan geen verschillen meer zijn. Het werkt dan op geen enkele CMTS meer.

 

Klanten die de Ziggo SMTP server gebruiken over poort 25 zijn in 2021 geïnformeerd om dit zo spoedig mogelijk aan te passen naar 587 met STARTTLS, TLS of SSL met authenticatie. Klanten die pas later poort 25 zijn gaan gebruiken dan de periode in 2021 waarin geïnformeerd werd hierover hebben deze communicatie mogelijk niet ontvangen. 

 

Al met al ben ik het met jullie eens dat de communicatie rondom dit project gebrekkig is en beter had gekund. Wij als moderators waren hier ook niet van op de hoogte en hebben daarom niet eerder met duidelijke informatie kunnen komen in dit topic. Op deze pagina vind je nog meer informatie over veilig mailen terug.


Mark
Oud Community Moderator
Oud Community Moderator
  • 5774Posts
  • 655Oplossingen
  • 1962Likes

Laat ik het nog specifieker maken.

 

Inkomend verkeer naar jouw modem op poort 25 wordt niet geblokkeerd.

Je kunt deze poort alleen niet forwarden in onze Wifimodems, dat is geblokkeerd in de router GUI (en dat is niet van toepassing in bridge mode). Dit blokkeert dus geen dataverkeer, dat komt gewoon aan op jouw modem en als je die in bridge hebt staan ook op jouw eigen router waar je het pakketje wel kunt forwarden.

 

Uitgaand verkeer vanaf jouw modem op poort 25 wordt alleen geblokkeerd naar de volgende adressen: smtp.ziggo.nl (212.54.42.9), smtp.ziggozakelijk.nl (212.54.42.15) en 'legacy mail' (212.54.42.34).

 

Verder kun je alles doen met poort 25. Werkt het niet? Check je instellingen/configuratie.

MarcAngelo

Level 4
  • 29Posts
  • 0Oplossingen
  • 5Likes

Beste Mark,

 

Uit mijn XS4ALL opstelling is eigenlijk niets gewijzigd. 
De VDSL verbinding is opgezegd. De FritzBox is echter behouden. 
In plaats van dat de internet verbinding via de DSL lijn binnen komt, komt deze nu via de WAN poort binnen vanaf de Ziggo Connectbox Giga, welke in bridged mode staat.

Alle portforwards, welke reeds op de Fritzbox stonden ingesteld, zijn hierdoor dan ook ongewijzigd. 
De port forward voor port TCP/25, heeft op de Fritzbox jaren gewerkt en stond dus reeds ingesteld.

Doordat de Connectbox Giga in bridged mode staat, heeft de Fritzbox het publieke IPv4 adres.
Toch komt inkomend port 25 niet aan. 

De SMTP servers van Ziggo gebruik ik sowieso niet, aangezien ik mijn eigen mailserver gebruik. 

Maar wat ik ook doe...
Poort 25 komt niet binnen... Niet wanneer ik gebruik maak van een DMZ, maar ook niet als de Connectbox Giga in bridged mode (zoals nu het geval is)... Dus hoop dat je nog suggesties hebt?

Mark
Oud Community Moderator
Oud Community Moderator
  • 5774Posts
  • 655Oplossingen
  • 1962Likes

Ik heb een poortscan gedaan op het ip van @MarcAngelo, zie hier het resultaat (volledige resultaat in privebericht):

  7.60 ( https://***.***.nl ) at 2022-05-31 15:03 CEST
 Scan rapport voor ***-***-***-***.dynamic.upc.nl (***.***.***.***)
Host is actief (0.015s latency).

POORT   STATUS SERVICE
25/tcp open  smtp

 Uitgevoerd: 1 IP adres (1 host actief) gescand in 0.52 seconden

 

De poort staat open, het moet ergens in je eigen setup fout gaan.

MarcAngelo

Level 4
  • 29Posts
  • 0Oplossingen
  • 5Likes

Naar aanleiding van de portscan door Mark (Ziggo Moderator), ben ik nogmaals verder gaan kijken.

Ik had vanaf 2 VPS servers, welke op het internet draaien, diverse tests en portscans gedaan. Daar kwam telkens uit dat port 25 niet open stond, zelfs niet terwijl de Connectbox in bridged mode staat.

Wat blijkt nu:
Beide VPS servers welke ik heb gebruikt, beschikken niet alleen over een firewall voor inkomend verkeer, maar ook voor uitgaand verkeer. 

Omdat hier niets voor stond ingesteld, was uitgaand verkeer naar poort 25 niet toegestaan en gaven de portscans onterecht aan dat deze poort was gesloten.

Inmiddels is het aangepast en werkt het inderdaad gewoon.


Excuses voor het misverstand!
Iedereen bedankt voor de hulp en het meedenken!

RichardBoGLue

Level 3
  • 23Posts
  • 1Oplossingen
  • 2Likes

Ik heb het ziggo modem in bridge mode laten zetten maar nog steeds komen er geen emails meer binnen na de vervanging van mn technicolor modem door een nieuwere versie. Terwijl ik wel lees dat dat een oplossing is. Alle port forwards in mn router na de bridge staan goed.

Carlien
Community Moderator
Community Moderator
  • 2391Posts
  • 257Oplossingen
  • 1135Likes

Hoi @RichardBoGLue! Wat vreemd dat er nog niks binnenkomt. Je bent er al druk mee bezig geweest. Misschien dat @Bert nog even met je mee kan kijken! 

RichardBoGLue

Level 3
  • 23Posts
  • 1Oplossingen
  • 2Likes

Dag Calien, Dat zou mooi zijn want mn technicolor is een kachel. Ik heb ondertussen wel deze als router terug (laten) zetten.
Je bevestigd dus dat in bridge mode ik dus wel SMTP verkeer op mijn net werk zou moeten binnen krijgen?

Bert

Level 21
T.E.A.M.
  • 74664Posts
  • 5110Oplossingen
  • 21689Likes

@RichardBoGLue Kun je meer informatie geven wat en hoe en waarmee en welke poorten enz. met het smtp verkeer?

RichardBoGLue

Level 3
  • 23Posts
  • 1Oplossingen
  • 2Likes

Het gaat over poort 25 om van buiten emails te ontvangen. Versturen doe ik via de ziggo relay host. Port 25 is geblokkert bij het nieuwe modem maar in het technicolor modem nog wel open.

Lotte
Oud Community Moderator
Oud Community Moderator
  • 2761Posts
  • 400Oplossingen
  • 976Likes

@RichardBoGLue Super dat je deze informatie gedeeld hebt! Mogelijk dat @Bert nog ideeën heeft over wat je het beste kunt doen. 

Bert

Level 21
T.E.A.M.
  • 74664Posts
  • 5110Oplossingen
  • 21689Likes

@Lotte Geen idee waarom het ene modem het wel doet en het andere modem niet.

Dat kan ik hier niet uitzoeken, daar heb ik de apparatuur niet voor, dat zal Ziggo moeten doen.

In dit geval Ziggo zakelijk.

RichardBoGLue

Level 3
  • 23Posts
  • 1Oplossingen
  • 2Likes

Dag Lotte en Bert, Ik heb ondertussen een tweede poging gedaan om het modem via bridge mode mn email verkaar door te laten. Dit maal succesvol. Via MXtools nu gecontroleerd of het verkeer mn server kon bereiken. Wat is merkte is dat naast de DNS propagatie ook de MX records een bepaalde tijd nodig hebben om het nieuwe IP adres van de verbinding te leren. Via de registar moet ik natuurlijk het IP adress aanpassen om mijn domein te vinden. Mn nieuwe IP adres was binnen minuten bekend maar de MX records duurden veel langer. Ik ben de vorige keer te ongeduldig geweest en het oude modem toen weer in router mode laten terugzetten omdat ik geen emails ontving. Het is dus opgelost en werk nu met het nieuwe modem in bridge mode. Dank voor het meedenken.

AdriaanB

Level 5
  • 41Posts
  • 4Oplossingen
  • 17Likes

@RichardBoGLue  Versturen doe je via de ziggo relay host??

Wij hebben als gezin een eigen mail-server en domein. De mail-server draait op Linux met Postfix mailer en Ziggo relay duurde maar kort. Snel kreeg ik van Ziggo een block omdat we teveel e-mail verstuurden. Kon wel eens spam zijn.....

Dat was het natuurlijk niet, het was wel aardig wat e-mail, tussen de 50 en 100 per dag en dat vindt Ziggo niet okee. Kan wel eens spam zijn. Dat was het niet en dat is het niet. Tweemaal verbinding weer toegestaan en tweemaal weer een block van Ziggo. Is er een andere ziggo relay host die dat wel okee vindt?

We hebben nu helaas dan maar een abonnement bij smtp.com genomen.

 

De Postfix mailserver is optimaal beveiligd: mail-relay is geblokkeerd en password-hacks is beveiligd met Fail2Ban een programma dat misbruik afvangt en ip-nummers blokkeert. SSH is alleen op het interne netwerk mogelijk voor beheer. Port 25 is geforward in het Ziggo Modem. Ook dat kan nog steeds. Ik heb een niet-zakelijke aansluiting, Ziggo compleet ofzoiets.

 

Bert

Level 21
T.E.A.M.
  • 74664Posts
  • 5110Oplossingen
  • 21689Likes

@RichardBoGLue Dank voor je update met de oplossing, daar kunnen anderen met hetzelfde probleem ook weer verder mee 🙂

AdriaanB

Level 5
  • 41Posts
  • 4Oplossingen
  • 17Likes

@Bert  Enige tijd geleden stond er een reactie om port 25 in de ConnectBox toch te forwarden met behulp van de Albertino Port Mapper. Die reactie is verdwenen?  Dit was namelijk een veiliger oplossing dan de DMZ oplossing. Ik kan middels de zoekfunctie met de woorden albertino en/of port en/of mapper deze reactie niet meer vinden. Kan het zijn dat zo'n reactie is verwijderd?

Bert

Level 21
T.E.A.M.
  • 74664Posts
  • 5110Oplossingen
  • 21689Likes

@AdriaanB Het gebeurd wel eens dat software linken en adviezen die mogelijk kunnen leiden tot veiligheidsissues verwijderd worden van dit forum.

AdriaanB

Level 5
  • 41Posts
  • 4Oplossingen
  • 17Likes

@Bert  Dank voor je reactie. Mijn virusbewaker sloeg ook aan op dit tooltje maar maar na downloaden op een een speciale server en viruscheck aan alle kanten niets kunnen vinden. Tooltje aansluitend toch ingezet om port 25 op mijn connectbox te forwarden. Het tooltje doet niet meer dan even de forward in de modem pushen. De werking veroorzaakt geen veiligheidsissue, de gewenste poort, 25 in mijn geval, wordt geforward middels upnp/tcp push en deze werking is legaal, games doen dit onderwater ook en dat is legitiem. Alleen bij een reset van de connectbox verdwijnt de forward, helaas. Ik heb inmiddels beter programmatuur om de forward identiek aan die Albertinio Port Mapper te realiseren. Na elke reset door Ziggo van mijn connectbox moet ik dat weer even instellen. Maar mijn mailserver werkt inmiddels weer zoals voorheen toen ik nog een Ubee modem had, Daar kon ik port 25 gewoon forwarden. Jammer dat Ziggo dat in de nieuwe connectbox GUI geblokkeerd heeft. Nu gaan mensen de mailserver in de DMZ hangen of een extra router in zetten waarbij de connectbox dan in bridged-mode moet. Echt jammer.

RichardBoGLue

Level 3
  • 23Posts
  • 1Oplossingen
  • 2Likes

Inderdaad erg jammer. De uitleg dat het is om SPAM emails tegen te gaan is mij volledig onduidelijk.

RichardBoGLue

Level 3
  • 23Posts
  • 1Oplossingen
  • 2Likes

Ja, die verstuur ik via de ziggo relay host. Maar wij zijn geen groot "gebruikers" in het versturen van emails. Fail2Ban ken ik niet. Ga ik eens naar kijken. Merci.

E-mail notificaties
Aan Uit

Ontvang een update bij nieuwe reacties in dit topic.

Uitgelicht topic