1
Vraag
2
Reacties
EMV1

Level 3
  • 11Posts
  • 0Oplossingen
  • 4Likes

OpenVPN werkt niet meer na installatie nieuwe smartwifi modem

Voor werk maak ik verbinding met een OpenVPN server met de Viscosity client. Met de oude witte Ziggo modem ging dit zonder problemen. Na installatie van de nieuwe SmartWifi modem komt de OpenVPN verbinding nog wel tot stand, maar komt er geen DNS-resolution voor de domeinen die via de VPN moeten lopen.

Als ik, zonder verder instellingen te wijzigen, mijn telefoon gebruik als hotspot (dus geen thuis-WiFi) werkt de OpenVPN verbinding weer naar behoren.

 

Al geprobeerd:

De 4 vinkjes bij “Beveiliging” in de SmartWifi modem-instellingen. Geen effect.

Google DNS servers 8.8.8.8 en 8.8.4.4 instellen op de modem. Geen effect.

Google DNS servers instellen in de netwerkadapterinstellingen van mijn laptop. Geen effect.

Andere OpenVPN client. Geen effect.

Rommelen met de DNS instellingen in de OpenVPN client. Geen effect.

 

Mijn setup:

Smartwifi modem in reguliere modus, met DHCP aan en DNS op de default instelingen.

Wifi staat uit.

Achter de modem hangt een setje TP-link Deco mesh-punten waarbij DHCP uitstaat. Dus de Ziggo modem regelt alle ip-adressen binnen het hele thuisnetwerk.

Windows 10 laptop met Viscosity met een ovpn profiel.

 

Mijn conclusie is dat er een verschil is tussen de oude witte Connect box en de SmartWifi modem, aangezien dat de enige verandering is die ertoe heeft geleid dat het niet meer werkt. Hoe krijg ik OpenVPN weer aan de praat?

Oplossing
Uitgelicht
EMV1
topicstarter
Level 3
  • 11Reacties
  • 0Oplossingen
  • 4Likes

Update: Ubee modem ontvangen nadat ik bij de klantenservice naar de conclusie in dit topic had verwezen. Modem geïnstalleerd zonder problemen, en OpenVPN met DNS-resolution binnen het VPN netwerk werkt weer .

Alles opgelost dus. Dank aan @efok  voor het aandragen van de juiste oplossing, en @tobiastheebe @S4R en @Jiri  voor het meedenken!

 

(voor wie het weten wil: het toevoegen van specifieke entries aan de hosts file heb ik ook nog even geprobeerd met het Sagemcom modem. Dat werkte ook, maar dat is alleen een tijdelijke workaround, geen echte oplossing aangezien de IPs kunnen veranderen)

27 Reacties 27
efok

Level 17
  • 4062Posts
  • 220Oplossingen
  • 1630Likes

Je kan beter wachten op actie van een moderator hier. De telefonische helpdesk is, nou ja, “beperkt” in kunde en mogelijkheden. @Jiri 

EMV1
Topicstarter
Level 3
  • 11Posts
  • 0Oplossingen
  • 4Likes

Ik heb de klantenservice gevraagd om het alternatieve modem, met verwijzing naar dit topic en de conclusie.

Zojuist gebeld door de klantenservice: modem wordt opgestuurd.

Zodra ik het modem heb geïnstalleerd en OpenVPN werkt zoals verwacht, zal ik hier een de reactie van efok als oplossing markeren.

EMV1
Topicstarter
Level 3
  • 11Posts
  • 0Oplossingen
  • 4Likes

Update: Ubee modem ontvangen nadat ik bij de klantenservice naar de conclusie in dit topic had verwezen. Modem geïnstalleerd zonder problemen, en OpenVPN met DNS-resolution binnen het VPN netwerk werkt weer .

Alles opgelost dus. Dank aan @efok  voor het aandragen van de juiste oplossing, en @tobiastheebe @S4R en @Jiri  voor het meedenken!

 

(voor wie het weten wil: het toevoegen van specifieke entries aan de hosts file heb ik ook nog even geprobeerd met het Sagemcom modem. Dat werkte ook, maar dat is alleen een tijdelijke workaround, geen echte oplossing aangezien de IPs kunnen veranderen)

S4R

Level 16
  • 2058Posts
  • 72Oplossingen
  • 1297Likes

Dat Sagem modem veroorzaakt toch wel een hoop problemen.

lewa10

Level 2
  • 3Posts
  • 0Oplossingen
  • 2Likes

Ik heb hetzelfde probleem. Ik heb een Ubiquiti UniFi Express. Wireguard lukt zonder probleem maar OpenVPN niet meer sinds mijn nieuwe SmartWifiModem.

tobiastheebe

Level 20
T.E.A.M.
  • 32809Posts
  • 2339Oplossingen
  • 16597Likes

@lewa10 Is het modem in bridge mode geconfigureerd?

lewa10

Level 2
  • 3Posts
  • 0Oplossingen
  • 2Likes

Bedankt voor je bericht @tobiastheebe . Is inmiddels opgelost. De oplossing was om poort 1194 te forwarden vanaf de modem naar mijn UniFi Gateway.

tobiastheebe

Level 20
T.E.A.M.
  • 32809Posts
  • 2339Oplossingen
  • 16597Likes

Fijn om te lezen, maar bij een eigen router wordt aanbevolen om het modem in bridge mode te laten configureren. Dit is de meest stabiele en eenvoudige oplossing, waarbij geen port forwarding nodig is als de VPN-server op de router actief is.

E-mail notificaties
Aan Uit

Ontvang een update bij nieuwe reacties in dit topic.

Uitgelicht topic