1
Vraag
2
Reageer en help mee
Mark_1001

Stamgast
  • 6Posts
  • 0Oplossingen
  • 1Likes

Open VPN poort forwarding werkt niet

Voorheen had ik altijd een OpenVPN server draaien op mijn NAS (Synology).

Dit heeft altijd naar behoren gewerkt.

Onlangs wilde ik weer gebruik maken van deze VPN verbinding, maar ik krijg het met geen mogelijkheid meer aan de gang.

De poort forward staat nog goed (1194 UDP, naar het IP van mijn NAS).

Als ik via een poortscanner poort 1194 scan geeft deze aan dat de betreffende poort is gesloten.

De OpenVPN server op mijn NAS draait, deze staat ook ingesteld op poort 1194.

Firewall op de NAS uitschakelen maakt geen verschil.

 

Het toestel waarmee ik een VPN verbinding wil opzetten maakt verbinding via mijn IPv4 adres op poort 1194.

Het toestel geeft echter een timeout tijdens het verbinden, op de server logs zijn geen connection attempts te zien, het duidt er dus op dat poort 1194 inderdaad dicht staat, ondanks de forward in het modem.

 

Een veel gelezen oplossing is het uitschakelen van IPv6, volgens de Ziggo helpdesk is het echter niet mogelijk ?

 

Wie heeft de oplossing voor mij?

11 Reacties 11
tobiastheebe
Super Expert
Super Expert
  • 14235Posts
  • 878Oplossingen
  • 5797Likes

Port scanners werken alleen voor TCP.

 

Uitschakelen van IPv6 op de eRouter wordt gebruikelijk niet meer gedaan omdat Full Dual-Stack sinds eind juni in het gehele verzorgingsgebied beschikbaar is. Dit staat verder ook los van port forwarding, wat betrekking heeft op IPv4.

 

Heb je al gecontroleerd of het publieke/extern IP-adres mogelijk gewijzigd is? Lukt verbinden ook niet vanaf 4G/5G? Kun je binnen het LAN wel verbinding maken, op het interne IP-adres van de NAS?

Mark_1001
topicstarter
Stamgast
  • 6Posts
  • 0Oplossingen
  • 1Likes

Mijn externe IP adres is ongewijzigd, als ik verbonden ben met Wi-Fi kan ik gewoon via het lokale IP inloggen op de NAS.

Zodra ik via 4g een VPN verbinding wil opzetten lukt het niet om verbinding te maken met de VPN server.

tobiastheebe
Super Expert
Super Expert
  • 14235Posts
  • 878Oplossingen
  • 5797Likes

Is bij de firewall-instellingen van de modemrouter alleen de optie 'Firewall beveiliging' ingeschakeld? Zo nee, kun je de andere opties uitschakelen?

Mark_1001
topicstarter
Stamgast
  • 6Posts
  • 0Oplossingen
  • 1Likes

IP-flood detectie en ICMP flood detectie staan ingeschakeld. Het compleet uitschakelen van de firewall biedt echter ook geen soelaas.

tobiastheebe
Super Expert
Super Expert
  • 14235Posts
  • 878Oplossingen
  • 5797Likes

Het 'uitschakelen' van de firewall zorgt er in de praktijk voor dat alle inkomende verzoeken met een REJECT worden beantwoord, de firewall blijft dus actief. Kun je de detectie-opties en tevens UPnP uitschakelen?

Mark_1001
topicstarter
Stamgast
  • 6Posts
  • 0Oplossingen
  • 1Likes

UPnP staat al geruime tijd uitgeschakeld, detectie opties heb ik inmiddels uitgeschakeld.
Ook dit heeft geen effect

In het log file van OpenVPN wordt geconnect naar het juiste IP adres op poort 1194

tobiastheebe
Super Expert
Super Expert
  • 14235Posts
  • 878Oplossingen
  • 5797Likes

Als in de event log IPv4 WAN-verkeer zichtbaar is, dan houdt dit in dat port forwarding werkt.

Mark_1001
topicstarter
Stamgast
  • 6Posts
  • 0Oplossingen
  • 1Likes

Dit komt uit het log van de client, in de server logs is geen activiteit.
De client log geeft een connection timeout op 217.62.10.219:1194 via UDPv4

tobiastheebe
Super Expert
Super Expert
  • 14235Posts
  • 878Oplossingen
  • 5797Likes

Kun je de forwarding-regel verwijderen, de modemrouter opnieuw opstarten en de regel opnieuw toevoegen?

 

Als de NAS over een IPv6-adres beschikt en OpenVPN daarop luistert, dan kun je het ook via IPv6 proberen (met een filter-regel).

Mark_1001
topicstarter
Stamgast
  • 6Posts
  • 0Oplossingen
  • 1Likes

Ook dit werkt niet.

De NAS heeft geen IPv6 adres, enkel een (vast) IPv4 adres.
Ik houd het voor vandaag voor gezien, alvast ontzettend bedankt voor de hulp en het meedenken!

tobiastheebe
Super Expert
Super Expert
  • 14235Posts
  • 878Oplossingen
  • 5797Likes

Dan zou je de NAS tijdelijk op DHCP kunnen instellen en controleren of de forwarding-regel daarmee wel werkt, al moet het natuurlijk ook met een statisch IP-adres lukken.

E-mail notificaties
Aan Uit

Ontvang een update bij nieuwe reacties in dit topic.

Uitgelicht topic