snsgn
Meedenker
  • 14Reacties
  • 0Oplossingen
  • 1Likes

NAT loopback op Arris met IPv4

Beste community,


Al een jaar geleden vroeg ik Ziggo mijn router terug te zetten naar IPv4, vanwege het gebruik van een NAS en port forwarding mogelijkheden. Waar ik later nog tegenaan liep is het volgende: https://community.ziggo.nl/t5/Archief/NAT-loopback-problemen-Arris-Connectbox/m-p/189174#M91918  (zie laatste bericht, is van mij).


Ik ben hier weer ingedoken (ook voor andere doeleinden) ofwel, ik heb NAT loopback nodig. Is het zo dat omdat ik IPV4 heb dit hiermee samenhangt en ik dit nog steeds niet kan gebruiken? Software versie is 9.1.2009.201. Ik was in de veronderstelling dat dit wellicht inmiddels opgelost was na edits van @Mark Z  in dit topic: https://community.ziggo.nl/t5/Internet/NAT-loopback-problemen-Compal-Connectbox-NAS-server-slecht/td...


Men ruilde speciaal hun Compal voor een Arris (die ik dus al heb) om dit te laten werken, dus neem toch aan dat het op die van mij ook zou moeten lukken?


Hoor heel graag jullie reactie.

1 Geaccepteerde oplossing

Geaccepteerde oplossingen
efok
Expert
Expert
  • 3033Reacties
  • 160Oplossingen
  • 964Likes

@snsgn Je hebt al een pi-hole draaien? Dan is het simpel. Login in je pihole, -> Local DNS daar je *.synology.me toevoegen met het interne IP van je NAS.
(Overigens draait een DNS server op poort 53, niet op 25 (smtp))

Bekijk in context

17 Reacties 17
snsgn
topicstarter
Meedenker
  • 14Reacties
  • 0Oplossingen
  • 1Likes

NAT loopback is nogal een hot topic hier, maar niemand kan mij verder helpen?

Bert!
Super Expert
Super Expert
  • 41672Reacties
  • 2372Oplossingen
  • 8728Likes

Mogelijke oplossing:

Zet UPnP eens uit en maak handmatig de port forwards.

Laat het modem hierna even opnieuw opstarten.

Mariska Z
Community Moderator
Community Moderator
  • 3468Reacties
  • 312Oplossingen
  • 617Likes

Hi @snsgn 🙂 

Goed dat je hier aanklopt! Heb je al tijd gehad om de tip van Bert! te checken? 

snsgn
topicstarter
Meedenker
  • 14Reacties
  • 0Oplossingen
  • 1Likes

Ik heb zojuist even tijd gehad om het aan te passen. UPnP staat uit en heb de port forwarding handmatig gedaan. Er is helaas geen verschil.

 

Synology zegt 'OK' bij connection test result per poort (was voorheen ook), dus port forwarding is in ieder geval in orde.

 

Zodra ik van de wifi af ga synced mijn calender-event instant. Op wifi krijg ik niets gesynced, dus helaas 😑.

snsgn
topicstarter
Meedenker
  • 14Reacties
  • 0Oplossingen
  • 1Likes

Maar NAT loopback is dus niet een optie om aan of uit te vinken o.i.d.?

Bert!
Super Expert
Super Expert
  • 41672Reacties
  • 2372Oplossingen
  • 8728Likes

NAT loopback is niet aan of uit te vinken. @snsgn 

snsgn
topicstarter
Meedenker
  • 14Reacties
  • 0Oplossingen
  • 1Likes

Ok duidelijk. Maar de oplossing blijft uit. Er zijn veel mensen geholpen in genoemde topic. Waar zit het probleem?

Vincent Z
Community Moderator
Community Moderator
  • 1688Reacties
  • 134Oplossingen
  • 339Likes

Frustrerend dat het nog niet werkt zoals je voor ogen hebt @snsgn. Zie je het zitten om eventueel screenshots te delen van je instellingen? Scherm gevoelige informatie af. Hebben jullie ook wellicht nog een idee waar het in kan zitten @Bert! @Jonathan-458 @efok ?

efok
Expert
Expert
  • 3033Reacties
  • 160Oplossingen
  • 964Likes

Ik denk dat het gewoon in het modem zit, wat niet met NAT loopback uit de voeten kan. Ik weet niet of de Compal dat wel kan.

Anders moet je naar een workaround kijken. Dat kan bv door een eigen DNS server te gebruiken (pi-hole of op de NAS) en daar *.synology.me naar het interne IP adres van de NAS te laten verwijzen. Als je tenminste de DNS kan wijzigen op de Arris.

snsgn
topicstarter
Meedenker
  • 14Reacties
  • 0Oplossingen
  • 1Likes

@efok 

Het topic dat ik in mijn OP link gaat júist over dat men graag een Arris wilden vanwege dat de Compal geen NAT loopback kon. Ik heb al een Arris, dus hij zou het wél moeten kunnen lijkt mij? Maargoed, ik weet alle ins en outs niet van de verschillende routers en firmware, laat staan hoe alles op de achtergrond werkt. Ik hoopte iemand op dit forum tegen te komen die dit wel kan uitleggen.

 

Helaas is het op mijn NAS niet mogelijk om een DNS-server te draaien, omdat deze op poort 25 moet draaien en die heeft pihole al in gebruik, die ook draait op de NAS via Docker :), maar was een goede workaround geweest. Mogelijk valt hier nog iets in te knutselen?

snsgn
topicstarter
Meedenker
  • 14Reacties
  • 0Oplossingen
  • 1Likes

@Vincent Z 
Goed idee, ik zal deze week als ik tijd heb hier even aandacht aan besteden.

efok
Expert
Expert
  • 3033Reacties
  • 160Oplossingen
  • 964Likes

@snsgn Je hebt al een pi-hole draaien? Dan is het simpel. Login in je pihole, -> Local DNS daar je *.synology.me toevoegen met het interne IP van je NAS.
(Overigens draait een DNS server op poort 53, niet op 25 (smtp))

Bekijk in context

snsgn
topicstarter
Meedenker
  • 14Reacties
  • 0Oplossingen
  • 1Likes

@efokDraaien beiden op poort 53 bedoel ik inderdaad!

Maar goed idee! Netwerken is voor mij altijd wat ingewikkeld, dus had nog niet gedacht aan dat pihole de DNS kan regelen. Ik ga dit z.s.m. testen :).

snsgn
topicstarter
Meedenker
  • 14Reacties
  • 0Oplossingen
  • 1Likes

@efok

Nou, de workaround werkt, maar helaas met kanttekeningen.

 

Op ieder apparaat wordt de DNS handmatig aangepast naar het interne IP van de NAS, dus pihole, om adblocking/tracking/malware/etc tegen te gaan. De reden dat het niet op het gehele netwerk gebeurt is (je gelooft het niet), omdat mijn vriendin dit niet wil, anders werken haar ads in Candy Crush en andere games niet meer, dus zou ze geen rewards meer krijgen om naar reclame te kijken 🤣. Dat betekend dat mijn agenda niet gesynced wordt op haar device, maar op die van mij werkt het nu vlekkeloos door Local DNS in te stellen op pihole. Natuurlijk synced mijn agenda op haar device wel wanneer ze buiten ons netwerk is (dus op 4G zit bijv.), maargoed, dat deed het al. Ik zou natuurlijk Tail pihole.log kunnen gebruiken om te achterhalen welke ads ik voor haar specifieke device zou kunnen whitelisten door haar device in een andere group te plaatsen. Daarnaast is het wel zo dat nu via <mijnID>.synology.me:8080 mijn pihole te benaderen is van buiten mijn netwerk over HTTP, dus niet encrypted. Moet ik eigenlijk daar weer achteraan...

 

Al met al geeft de workaround dus weer andere mindere bijkomstigheden.

 

Ik vind het jammer dat NAT loopback niet gewoon werkt, dan zou dit alles niet nodig zijn, maar toch bedankt voor jouw workaround. Daar leer ik weer veel van en geeft stof tot nadenken.

efok
Expert
Expert
  • 3033Reacties
  • 160Oplossingen
  • 964Likes

Mooi dat het in principe werkt! Het probleem met je vrouw los ik natuurlijk niet op.....🤭😆

Whitelisten zal wel de enige oplossing zijn dan.

Wat ik niet helemaal begrijp is wat je zegt over dat je pihole nu van buiten te bereiken valt. Dat was toch al zo dan? Ik zie namelijk het verband met het wijzigen van je interne DNS niet.

Ik ben het met je eens dat NAT loopback zou moeten werken.

snsgn
topicstarter
Meedenker
  • 14Reacties
  • 0Oplossingen
  • 1Likes

Haha, tja. Als je eenmaal begint aan je eigen IT inrichten... Je kunt bezig blijven.

 

Ik was even in de war wat betreft interne DNS. Het kon inderdaad al.

 

Hoe dan ook houd ik me aanbevolen voor een oplossing betreffende NAT loopback.

Er komt ooit vast nog een eigen router waar ik het probleem mee kan oplossen, maar we wonen extreem klein hier, dus wil liever geen spullen erbij.

 

Bedankt voor je hulp zover!

SnarF007
Stamgast
  • 57Reacties
  • 1Oplossingen
  • 9Likes

De NAT loopback (met eigen domein) heeft voor mij ook nooit stabiel gewerkt, ook zonder uPnP.

Mijn oplossing is Ziggo modem in bridgemode (laten zetten) en een eigen router er achter. 

Uitgelicht topic