1
Vraag
2
Reacties
BiB

Level 2
  • 5Posts
  • 0Oplossingen
  • 2Likes

NAT loopback/hairpin Sagemcom F3896LG

Vandaag heb ik het SmartWifi modem Sagemcom F3896LG ontvangen, maar nog niet geïnstalleerd. Voordat ik dat ga doen wil ik zeker weten of dit modem niet het NAT loopback/hairpin probleem heeft, zoals het Compal CH7465LG-ZG​ modem een paar jaar geleden. Ik heb het internet afgezocht, maar ik kon geen duidelijk antwoord vinden. Ik hoop dat iemand kan bevestigen dat F3896LG niet dit probleem heeft.

 

Ik hoor het graag, alvast bedankt.

Oplossing

Geaccepteerde oplossingen
tobiastheebe

Level 20
T.E.A.M.
  • 29903Posts
  • 2072Oplossingen
  • 15001Likes

Hairpin/loopback NAT is voor de F3896LG-ZG sinds firmware-versie 4.5.13 beschikbaar, inmiddels is 4.6.24 de laatste versie voor modems die niet deel uitmaken van de test. Deze functie moet dus naar behoren werken. Bij de CH7465LG-ZG is ondersteuning voor hairpin/loopback NAT ook in een latere firmware toegevoegd.

Bekijk in context

14 Reacties 14
tobiastheebe

Level 20
T.E.A.M.
  • 29903Posts
  • 2072Oplossingen
  • 15001Likes

Hairpin/loopback NAT is voor de F3896LG-ZG sinds firmware-versie 4.5.13 beschikbaar, inmiddels is 4.6.24 de laatste versie voor modems die niet deel uitmaken van de test. Deze functie moet dus naar behoren werken. Bij de CH7465LG-ZG is ondersteuning voor hairpin/loopback NAT ook in een latere firmware toegevoegd.

BiB
Topicstarter
Level 2
  • 5Posts
  • 0Oplossingen
  • 2Likes

Heel hartelijk dank voor de snelle en behulpzame reactie! Ik ga het modem binnenkort installeren, dan kan ik het testen, maar ik ga ervan uit dat het inderdaad gewoon werkt.

BiB
Topicstarter
Level 2
  • 5Posts
  • 0Oplossingen
  • 2Likes

Ik heb het getest en het werkt, nogmaals dank.

tobiastheebe

Level 20
T.E.A.M.
  • 29903Posts
  • 2072Oplossingen
  • 15001Likes

Fijn om te lezen en dank voor de bevestiging.

pwz

Level 2
  • 4Posts
  • 0Oplossingen
  • 2Likes

Beste Tobias, Ik heb enkele weken de CH7465LG ontvangen en de hairpin / NAT loopback werkt niet. Telefonisch contact hielp niet, ze kennen de functie niet. Het is vreemd, want de vorige modem zag er hetzelfde uit en daarbij werkte het wel. Dit is de software versie: CH7465LG-NCIP-6.15.32p3-NOSH

Enig idee waar het aan ligt? Kan de optie misschien aangevinkt worden in het backend van de modem?

tobiastheebe

Level 20
T.E.A.M.
  • 29903Posts
  • 2072Oplossingen
  • 15001Likes

@pwz Hairpin/loopback NAT zou naar behoren moeten werken bij de CH7465, ik heb dit een aantal maanden geleden nog getest bij familie van mij op locatie, zij hebben een access point dat bereikbaar is via SSH. Vanaf mijn PC kon ik inloggen op het AP via het externe IP-adres en de middels port forwarding (DNAT) ingestelde externe poort. Hairpin/loopback NAT is geen functie die kan worden in- of uitgeschakeld. Heb je al getest met 4G/5G of bijvoorbeeld deze site?

pwz

Level 2
  • 4Posts
  • 0Oplossingen
  • 2Likes

Bijzonder. Bij mij werkte het ook enkele weken geleden nog, alleen sinds de modem vervangen is niet meer. Bij Fritzbox! is het overigens wel een optie die kan worden in- en uitgeschakeld, volgens de handleiding (ik heb al overwogen de modem te vervangen).
De poorten staan succesvol open. Mijn website werkt ook, alleen is het vanaf mijn eigen adres niet bereikbaar. Mijn website geeft ook een service-melding van de loopback niet succesvol is. Op mijn windows-computer heb ik het hosts-bestand aangepast, om dit te omzeilen. Alleen op Android is dat niet mogelijk helaas, tenminste niet zonder aan de slag te gaan met root-rechten. Dat betekent de apps die horen bij mijn server niet werken. 

Overigens lijkt het upnp-protocol meer rechten te hebben dan de browser-interface. Zo kun je via de browser poort 25 niet doorsturen, maar via upnp lukt het wel. Zou dit voor hairpin een optie kunnen zijn?

tobiastheebe

Level 20
T.E.A.M.
  • 29903Posts
  • 2072Oplossingen
  • 15001Likes

Op mijn EdgeRouter 4 kan de functie ook in- en uitgeschakeld worden. Volgens RFC 6886 zou hairpin/loopback NAT ondersteund moeten worden door een router waarop ook UPnP/NAT-PMP wordt ondersteund. Voor zover ik kan zien is het niet mogelijk om hairpin/loopback NAT in en uit te schakelen via UPnP/NAT-PMP en kunnen alleen (D)NAT-regels worden aangemaakt en verwijderd.

 

Ik zou het bij familie nog een keer kunnen testen over een paar weken.

tobiastheebe

Level 20
T.E.A.M.
  • 29903Posts
  • 2072Oplossingen
  • 15001Likes

@pwz Zoals beloofd: ik ben nu bij familie met CH7465 (firmware CH7465LG-NCIP-6.15.32p3-NOSH, hardware 5.01, S/N begint met DEAP) en hairpin/loopback NAT werkt (nog steeds) naar behoren:

 

20230525-04.PNG

20230525-05.PNG

 

Bij gebruik van handmatig aangemaakte port forwarding-regels dient UPnP te worden uitgeschakeld, dat is op de betreffende modemrouter ook het geval.

pwz

Level 2
  • 4Posts
  • 0Oplossingen
  • 2Likes

@tobiastheebe Bedankt voor het controleren. Je opmerking over het uitzetten van UPnP heeft me aan het denken gezet. Er bleken twee verschillende regels voor dezelfde poort 443 in de UPnP-lijst te staan op mijn server. Een voor https en één voor quickconnect. Beide heb ik verwijderd en ik heb de poort-forward regel opnieuw aangemaakt in het menu van de modem. Nu werkt de NAT-loopback weer zoals het hoort! 
Nu nog even uitzoeken of het ook gewoon werkt met één UPnP-regel en geeneen in het menu van de modem.

I.Wild

Level 1
  • 3Posts
  • 0Oplossingen
  • 0Likes

Beste Tobias,

 

Ik heb net mijn nieuwe modem geïnstalleerd (F3896LG-Zg met firmware LG-RDK_4.6.24-2206.7) Nu blijkt de Hairpin/loopback NAT niet te werken. Ik heb achter de Sagemcom een eigen netwerk hangen met DECO M-5

deze staat in DMZ-host. Hoe kan ik de Hairpin werkend krijgen? Eventueel de modem in bridge mode zetten?  mijn Deco netwerk heeft ip 192.168.178.xxx en wil deze niet veranderen omdat dit erg veel werk kost (de huidige modem staat ingesteld op 192.168.0.xxx

tobiastheebe

Level 20
T.E.A.M.
  • 29903Posts
  • 2072Oplossingen
  • 15001Likes

@I.Wild Hairpin/loopback NAT is in jouw geval niet afhankelijk van de modemrouter, maar van de eigen router. Verder is in jouw geval sprake van router achter router c.q. dubbele NAT met twee RFC 1918-subnets, waardoor hairpin/loopback NAT waarschijnlijk niet naar behoren werkt. Als hairpin/loopback NAT wordt ondersteund door Deco M5, dan zou dit inderdaad naar behoren moeten werken als je het modem in bridge mode laat configureren, bijvoorbeeld d.m.v. dit formulier. Er is dan geen sprake meer van 192.168.0.0/24, wel moet je alle apparatuur op/via de eigen router aansluiten, op het modem dient alleen de router aangesloten te zijn.

I.Wild

Level 1
  • 3Posts
  • 0Oplossingen
  • 0Likes

Hiervoor heb ik een technicolor modem gehad met de deco erachter in de DMZ en werkte allles naar behoren. Ik kan dus concluderen dat de Hairpin in de nieuwe modem niet werkt.  Ik heb nu mijn hele netwerk ingesteld achter de deco dus dat is geen probleem. In de bridge mode krijgt mijn deco dan een ander ip en geen 192.168.178.xxx dat gebruik ik voor mijn eigen netwerk.

 

 

tobiastheebe

Level 20
T.E.A.M.
  • 29903Posts
  • 2072Oplossingen
  • 15001Likes

Toch vermoed ik dat het aan de eigen router ligt, hairpin/loopback-verkeer blijft namelijk binnen het LAN van deze router. In het beginsel wordt het IP-adres van de WAN-interface aangeroepen en de router vertaalt dit naar het gateway-adres, in jouw geval waarschijnlijk 192.168.178.1, dit wordt dan de nieuwe afzender van het verkeer.

 

In bridge mode ontvangt de WAN-interface van de eigen router direct een publiek/extern IP-adres van de DHCP-server bij Ziggo, dus geen RFC 1918-adres zoals nu.

E-mail notificaties
Aan Uit

Ontvang een update bij nieuwe reacties in dit topic.

Uitgelicht topic