Netniet

Stamgast
  • 11Posts
  • 0Oplossingen
  • 3Likes

NAS soms onzichtbaar in netwerk

In huis heb ik een NAS Synology die ik gebruiken wil als mediumopslag en als verbinding met mijn computer en de TV, zodat ik de NAS-bestanden ook op mijn TV kan bekijken.

De modem/router bevindt zich in de andere kant van het huis; om verbinding met de computer aan de andere kant van het huis te maken en daar ook een wifi-punt te hebben, gebruik ik een Netgear Router R6400.

Tussen het modem, de NAS en de Netgear router en computer gebruik ik een 1GB switch.

Het ziet er als volgt uit:

Netniet_1-1641221704390.png

 

Het probleem:

Als de NAS rechtstreeks of via de Netgear Router op de computer aangesloten is, is er geen probleem. Maar als hij op het modem of op de switch aangesloten wordt, is de NAS  onzichtbaar in Windows verkenner en ook niet bereikbaar via de netverbinding.

Weet iemand hoe ik dit op kan lossen? Ik ben overigens niet erg thuis in technische details of afkortingen op dit gebied.

 

1 Oplossing

Geaccepteerde oplossingen
tobiastheebe
Super Expert
Super Expert
  • 8626Posts
  • 491Oplossingen
  • 3093Likes

Je kunt kiezen ook voor AP mode op de R6400. Dit heeft minder voeten in de aarde, je kunt dan alle apparatuur op dezelfde locatie laten staan. Bij AP mode wordt 178.0/24 het enige subnet.

 

Laat het gerust weten als je nog vragen hebt.

Bekijk in context

18 Reacties 18
tobiastheebe
Super Expert
Super Expert
  • 8626Posts
  • 491Oplossingen
  • 3093Likes

Bij gebruik van een eigen router wordt bridge mode geadviseerd. Je moet dan alle apparatuur op of via de R6400 aansluiten en de eigen router direct op de modemrouter aansluiten. Andere oplossing (eenvoudiger) is de R6400 als access point configureren.

 

Nu staan er twee routers achter elkaar en is er sprake van twee subnets. Inkomend verkeer van 178.0/24 naar 1.0/24 wordt door de firewall van de R6400 geblokkeerd, daardoor kun je de NAS niet bereiken als die laatste zich in 178.0/24 bevindt.

Netniet
topicstarter
Stamgast
  • 11Posts
  • 0Oplossingen
  • 3Likes

Bedankt voor je reactie.

Ga er mee aan de slag! Bedoel je bridge mode in het Ziggo modem of in de Netgear router?

Netniet
topicstarter
Stamgast
  • 11Posts
  • 0Oplossingen
  • 3Likes

En ik zie de door je genoemde nummers/adressen niet.....

tobiastheebe
Super Expert
Super Expert
  • 8626Posts
  • 491Oplossingen
  • 3093Likes

Met bridge mode bedoel ik de modemrouter. In dat geval moet je de switch op de R6400 aansluiten en op de switch vervolgens de TV en NAS aansluiten. Daarna staat alle apparatuur in subnet 1.0/24 en is er geen sprake meer van 178.0/24. Het modem kun je in bridge mode nog bereiken op 192.168.100.1.

 

De nummers die ik noemde zijn de twee subnets van de modemrouter (192.168.178.0/24) en de R6400 (192.168.1.0/24). Gemakshalve had ik 192.168 weggelaten. Het gedeelte '/24' betekent de grootte van het subnet, in dit geval 256 adressen voor beide subnets.

Netniet
topicstarter
Stamgast
  • 11Posts
  • 0Oplossingen
  • 3Likes

Bedankt; ik hoop er mee uit de voeten te kunnen!

tobiastheebe
Super Expert
Super Expert
  • 8626Posts
  • 491Oplossingen
  • 3093Likes

Je kunt kiezen ook voor AP mode op de R6400. Dit heeft minder voeten in de aarde, je kunt dan alle apparatuur op dezelfde locatie laten staan. Bij AP mode wordt 178.0/24 het enige subnet.

 

Laat het gerust weten als je nog vragen hebt.

Netniet
topicstarter
Stamgast
  • 11Posts
  • 0Oplossingen
  • 3Likes

Bedankt Tobias.

Even ter verduidelijking: alle verbindingen bij mij zijn bekabeld. Hetlaten fungeren van mijn Netgear Router als AP heeft toch alleen betrekking op draadloze WiFi vanaf deze router; de kabelverbinding met de NAS ondergaat daar toch geen invloed van? Tussen de Netgear en de computer enerzijds en het Ziggomodem en NAS anderzijds zit veel afstand en drie kamers. Ik heb daarom WiFi nodig bij het Ziggomodem en bij de Netgear router. Ik kan alle apparatuur ook daarom niet op de router aansluiten. En als ik de Netgear als AP ga gebruiken, dan heb ik toch geen verbinding van mijn computer met het internet meer? Of moet ik dan een aparte kabel van de computer naar de switch aanleggen?

Sorry voor de wellicht naieve onkunde..

tobiastheebe
Super Expert
Super Expert
  • 8626Posts
  • 491Oplossingen
  • 3093Likes

AP mode zorgt er simpel gezegd voor dat de R6400 geen router meer is maar alleen een switch met access point voor Wifi. Dit zorgt ervoor dat je één transparant LAN hebt i.p.v. twee LAN's/subnets zoals nu. Dit lost bereikbaarheidsproblemen tussen apparaten voor/achter de R6400 op. AP mode houdt niet dat je niet meer van bekabelde verbindingen gebruik kan maken, in tegendeel. Je kunt alle bekabelde apparatuur aangesloten laten zoals het nu is. Wel zullen sommige apparaten achter de R6400 mogelijk opnieuw opgestart moeten worden nadat AP mode ingeschakeld is.

Netniet
topicstarter
Stamgast
  • 11Posts
  • 0Oplossingen
  • 3Likes

Weer bedankt! En houd ik dan nog wel contact tussen mijn computer en internet via de bekabelde router?

tobiastheebe
Super Expert
Super Expert
  • 8626Posts
  • 491Oplossingen
  • 3093Likes

Aan de apparaten die vóór de R6400 staan (dus in subnet 178.0/24 van de modemrouter) verandert niets. De apparaten achter de R6400 komen in datzelfde subnet te staan zodra de R6400 in AP mode staat. Alle apparatuur staat dus in directe verbinding met de modemrouter, zo ook de computer.

Netniet
topicstarter
Stamgast
  • 11Posts
  • 0Oplossingen
  • 3Likes

Bedankt Tobias (zo heet mijn kleinzoon ook).

Ik ga het proberen.

tobiastheebe
Super Expert
Super Expert
  • 8626Posts
  • 491Oplossingen
  • 3093Likes

Leuk, een naamgenoot! Laat het gerust weten als je nog ergens tegenaan loopt.

Netniet
topicstarter
Stamgast
  • 11Posts
  • 0Oplossingen
  • 3Likes

Alles werkt! In het begin had ik via de Netgear router geen WiFi, maar dat bleek slechts een kwestie van tijd die hij nodig had. Was al maanden met dit probleem bezig, dus

Netniet
topicstarter
Stamgast
  • 11Posts
  • 0Oplossingen
  • 3Likes

Dus heel erg bedankt!

tobiastheebe
Super Expert
Super Expert
  • 8626Posts
  • 491Oplossingen
  • 3093Likes

Fijn om te lezen! Kun je de NAS nu probleemloos benaderen vanaf computer en TV?

Netniet
topicstarter
Stamgast
  • 11Posts
  • 0Oplossingen
  • 3Likes

Ja, vanaf allebei de apparaten! Alleen als ik de foto's op de NAS wil afspelen met de dia-voorstelling, krijg ik na enkele foto's de mededeling dat hij de bestanden niet kan lezen en moet ik terug naar de bestanden om ze te tonen. Maar dat zou wel eens aan de snelheid van mijn TV kunnen liggen, die is inmiddels ook alweer bijna 10 jaar. Nogmaals bedankt!

tobiastheebe
Super Expert
Super Expert
  • 8626Posts
  • 491Oplossingen
  • 3093Likes

Als test zou je van een reeks foto's een kopie kunnen maken in lage resolutie en die vervolgens afspelen op de TV en eventueel in de tussentijd een ping laten lopen naar het IP-adres van de TV.

Netniet
topicstarter
Stamgast
  • 11Posts
  • 0Oplossingen
  • 3Likes

Weer een goeie tip denk ik. En dus weer bedankt!

E-mail notificaties
Aan Uit

Ontvang een update bij nieuwe reacties in dit topic.

Uitgelicht topic