1
Vraag
2
Reacties
sjoerd001

Level 6
  • 112Posts
  • 5Oplossingen
  • 20Likes

Krijg geen IPv6 adressen meer op mijn interne apparaten

Het werkte (met moeite) maar krijg  geen ipv6 adressen meer intern na onderhoud van het netwerk op 11-11-2022 (no phun involved)

 

Ik gebruik Linux en zal regelmatig  aanpassingen moeten doen, maar nu krijg ik niks meer voor elkaar om intern ipv6 addressen te krijgen.

Voor onderhoud was het geen probleem. Nu wel.

 

Oplossing

Geaccepteerde oplossingen
efok

Level 17
  • 4060Posts
  • 219Oplossingen
  • 1628Likes

Ik zie zowel op br1 als op br0 een IPv6 adres in je listing van ip addr. Hoe kan dat dan? Bij mij is het zo dat de router een WAN ipv6 adres krijgt buiten de /56 prefix. Het hele blok ipv6 adressen wordt dan naar het WAN adres gerouteerd door Ziggo.

 

Als jij of een prefix, of een WAN adres krijgt, moet het in je configuratie zitten. Is dit centos of zoiets? Wat staat er in het dhclient-script? Verder moet er send ia-pd staan ipv ia-pa

Bekijk in context

25 Reacties 25
efok

Level 17
  • 4060Posts
  • 219Oplossingen
  • 1628Likes

Linux pikt IPv6 meestal wel op "out of the box". Kun je vertellen hoe je het hebt opgezet?

sjoerd001
Topicstarter
Level 6
  • 112Posts
  • 5Oplossingen
  • 20Likes


Wan Lan
Pysic Bridge Firewall Physic Bridge
eth0 -> br1 - firewall - eth1 ->br0

# cat /etc/sysctl.conf | sed '/^$/d' | sed '/^#/d'
net.ipv4.ip_forward = 1
net.ipv6.conf.br1.accept_ra = 2
net.ipv4.tcp_mtu_probing = 1
net.ipv4.tcp_base_mss = 1024
net.ipv4.conf.default.accept_redirects = 0
net.ipv4.conf.default.send_redirects = 0
net.ipv4.conf.default.rp_filter = 1
net.ipv4.conf.default.accept_source_route = 0
net.ipv4.tcp_slow_start_after_idle = 0
kernel.sysrq = 1
kernel.core_uses_pid = 1
fs.file-max = 2048737
vm.swappiness = 10
kernel.sem = 250 256000 32 1024
kernel.shmmax = 1073741824
kernel.shmall = 2831155
kernel.msgmax = 65535
kernel.msgmnb = 65535
net.core.somaxconn=2048
net.ipv4.tcp_max_syn_backlog = 2048
net.netfilter.nf_conntrack_acct=1
net.netfilter.nf_conntrack_expect_max=16384
net.netfilter.nf_conntrack_max=393216
net.core.rmem_default=262144
net.core.rmem_max=262144
net.core.wmem_default=262144
net.core.wmem_max=262144
net.ipv4.tcp_rmem=8096
net.ipv4.tcp_wmem=8096
net.ipv4.udp_rmem_min=8096
net.ipv4.udp_wmem_min=8096

# cat /etc/sysconfig/network | sed '/^$/d' | sed '/^#/d'
NETWORKING=yes
NETWORKING_IPV6=yes
IPV6_DEFAULTGW=fe80::217:10ff:fe91:6fa0%br1
HOSTNAME=asus
DOMAINNAME=example.com
NETWORKWAIT=yes
IPV6_AUTOCONF=yes
IPV6FORWARDING=yes
IPV6TO4INIT=no

# cat /etc/sysconfig/network-scripts/ifcfg-eth0 | sed '/^$/d' | sed '/^#/d'
NAME="WAN Link"
DEVICE=eth0
ETHTOOL_OPTS="speed 1000 duplex full autoneg on"
MACADDR=38:43:7D:78:3B:22
ONBOOT=yes
BOOTPROTO=none
BRIDGE=br1
TYPE=Ethernet
USERCTL=no
IPV6INIT=yes
NM_CONTROLLED=no
PEERDNS=no

# cat /etc/sysconfig/network-scripts/ifcfg-br1 | sed '/^$/d' | sed '/^#/d'
NAME="dhclient address from Ziggo modem"
ONBOOT=yes
DHCP_HOSTNAME=example.com
DEVICE=br1
TYPE=Bridge
BOOTPROTO=dhcp
DELAY=0.5
USERCTL=no
ARP=yes
NM_CONTROLLED=no
PEERDNS=no
IPV4_FAILURE_FATAL=no
DHCPV6C=yes # Use DHCP6 for config
IPV6INIT=yes
IPV6_AUTOCONF=yes # if 'no' dont use SLAAC
IPV6_DEFROUTE=yes
IPV6_PEERDNS=yes
IPV6_PEERROUTES=yes
IPV6_PRIVACY=no
IPV6_FAILURE_FATAL=no

 

 

 

 

Jacob
Community Moderator
Community Moderator
  • 4401Posts
  • 359Oplossingen
  • 1784Likes

@sjoerd001 goed dat je het hier even aangeeft, want ik vermoed dat @efok en/of @imars wel handige tips voor je hebben! 

efok

Level 17
  • 4060Posts
  • 219Oplossingen
  • 1628Likes

@sjoerd001Wat is dit voor apparaat? Ik zie iets van Asus? Wat zegt "ip addr" op je linux bak? En heb je de linuxbak direct aan het modem hangen? Als router? Of heb je een andere router? Hoe zit het precies? Modem in bridge?

sjoerd001
Topicstarter
Level 6
  • 112Posts
  • 5Oplossingen
  • 20Likes

@Jacob @efok Dank voor jullie reactie. Hoop dat iemand me ermee kan helpen.

 

@efok Onderstaand heb ik voor je. Hoop dat je er wat mee kunt of ergens stomme fouten kan vinden.

 

Board is een oude Asus P6T Deluxe met 2 ethernet poorten

Modem staat in bridge modus (geen extra router ertussen)

Ziggo Modem->br1(eth0)->fw->br0(eth1)->Lan

Als ik gewoon dhclient gebruik krijg ik wel een ip adress op br1 2a02:a204:x:x::/64
Als ik dhclient gebruik met onderstaand config file krijg ik
 alleen een prefix 2a02:a213:x:x::/56 address zonder ipv6 op br1

# cat /etc/dhcp/dhclient6.conf
script "/sbin/dhclient-script";
interface "br1" {
    send dhcp-client-identifier 0:1:0:1:2a:f0:e9:cf:x:x:x:x:3b:22;
    option dhcp6.fqdn "example.com";
    send dhcp6.rapid-commit;
    send dhcp6.ia-pa 1;
    send dhcp6.ia-na 1;
    also request dhcp6.vendor-opts, dhcp6.sntp-servers;
}

Ik kan radvd wel opstarten en intern ipv6 adressen uitgeven, maar kan er vervolgens niets mee.

Alleen op de doos zelf kan ik pingen en ipv6-test.com geeft 19 van 20 aan. (geen rev.ipv6.arpa)

# ip addr list
1: lo: <loopback,up,lower_up> mtu 16436 qdisc noqueue state UNKNOWN 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <broadcast,multicast,promisc,up,lower_up> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether x:x:x:x:3b:22 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::x:x:x:3b22/64 scope link 
       valid_lft forever preferred_lft forever
3: eth1: <broadcast,multicast,promisc,up,lower_up> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether x:x:x:x:36:3e brd ff:ff:ff:ff:ff:ff
    inet6 fe80::x:x:x:363e/64 scope link 
       valid_lft forever preferred_lft forever
4: wlan0: <broadcast,multicast> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether x:x:x:x:6c:1d brd ff:ff:ff:ff:ff:ff
51: br1: <broadcast,multicast,up,lower_up> mtu 1500 qdisc noqueue state UNKNOWN 
    link/ether x:x:x:x:3b:22 brd ff:ff:ff:ff:ff:ff
    inet 212.187.x.x/24 brd 255.255.255.255 scope global br1
>>>inet6 2a02:a204:x:x:x:x:x:ecf3/64 scope global  <<<<<<<<<<< ipv6 adress/64
       valid_lft forever preferred_lft forever
    inet6 fe80::x:x:x:3b22/64 scope link 
       valid_lft forever preferred_lft forever
52: br0: <broadcast,multicast,up,lower_up> mtu 1500 qdisc noqueue state UNKNOWN 
    link/ether x:x:x:x:36:3e brd ff:ff:ff:ff:ff:ff
    inet 10.10.x.x/8 brd 10.255.255.255 scope global br0
    inet6 2a02:a204:x:x::fe01/64 scope global 
      valid_lft forever preferred_lft forever
    inet6 fe80::x:x:x:363e/64 scope link 
      valid_lft forever preferred_lft forever</broadcast,multicast,up,lower_up></broadcast,multicast,up,lower_up></broadcast,multicast></broadcast,multicast,promisc,up,lower_up></broadcast,multicast,promisc,up,lower_up></loopback,up,lower_up>
efok

Level 17
  • 4060Posts
  • 219Oplossingen
  • 1628Likes

Ik zie zowel op br1 als op br0 een IPv6 adres in je listing van ip addr. Hoe kan dat dan? Bij mij is het zo dat de router een WAN ipv6 adres krijgt buiten de /56 prefix. Het hele blok ipv6 adressen wordt dan naar het WAN adres gerouteerd door Ziggo.

 

Als jij of een prefix, of een WAN adres krijgt, moet het in je configuratie zitten. Is dit centos of zoiets? Wat staat er in het dhclient-script? Verder moet er send ia-pd staan ipv ia-pa

Vincent
Community Moderator
Community Moderator
  • 4446Posts
  • 588Oplossingen
  • 2230Likes

Hi @sjoerd001! Hoe gaat het inmiddels? Als het nog speelt, zie je dan ergens een mogelijkheid om de vragen van @efok te beantwoorden? We zijn benieuwd. 

sjoerd001
Topicstarter
Level 6
  • 112Posts
  • 5Oplossingen
  • 20Likes

@Vincent @efok Bedankt voor jullie geduld.

 

Ok.Heb het wekend gekregen…Waarom het eerst niet werkte is me nog een raadsel.

(hele dhcp6c eruit gegooit)

 

Testen via ipv6-test.com geeft nu ook 20/20 aan op mijn interne devices.

 

Nog even afwachten of het na een reboot ook nog werkt.

 

/etc/sysctl.conf
net.ipv6.conf.all.forwarding = 1
net.ipv6.conf.all.autoconf = 1
net.ipv6.conf.default.forwarding = 1
net.ipv6.conf.default.autoconf = 1

 

/etc/radvd.conf
interface br0 {
AdvSendAdvert on;
MinRtrAdvInterval 3;
MaxRtrAdvInterval 10;
UnicastOnly off;
AdvManagedFlag off; # DHCPv6 server here
AdvOtherConfigFlag off; # DHCPv6 here even for extra options
AdvDefaultPreference high;
AdvLinkMTU 1500;
IgnoreIfMissing on;
AdvHomeAgentFlag off;
prefix 2a02:a213:a6bf:b080::/64
{
AdvOnLink on;
AdvAutonomous on;
AdvRouterAddr on;
};
MaxRtrAdvInterval 100;
RDNSS 2a02:a213:a6bf:b080::fe01 {
AdvRDNSSLifetime 150;
};
DNSSL example.com {
AdvDNSSLLifetime 150;
};
};

 

/etc/sysconfig/network-scripts
br0:
IPV6INIT=yes
IPV6ADDR_SECONDARIES=2a02:a213:a6bf:b080::fe01/64 <== zelf ingevuld
IPV6_AUTOCONF=yes
IPV6_FAILURE_FATAL=no

br1:
IPV6INIT=yes
IPV6ADDR_SECONDARIES=2a02:a213:a6bf:b080::a0a:1/64 <== zelf ingevuld
IPV6_AUTOCONF=yes # if 'no' dont use SLAAC
IPV6_PRIVACY=no
IPV6_FAILURE_FATAL=no

 

Externe ip test:
# dig -6 TXT +short o-o.myaddr.l.google.com @ns1.google.com | awk -F'"' '{ print $2}'
2a02:a213:a6bf:b080::a0a:1

 

Aantal pogingen (ca. 130x):)
# ip addr | grep br1:
129: br1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN

 

Route tabel:
# route -n -Ainet6
Kernel IPv6 routing table
Destination Next Hop Flags Metric Ref Use Iface
2a02:a213:a6bf:b080::/64 :: U 256 0 0 br0
2a02:a213:a6bf:b080::/64 :: U 256 0 0 br1
fe80::/64 :: U 256 0 0 br0
fe80::/64 :: U 256 0 0 br1
fe80::/64 :: U 256 0 0 eth1
fe80::/64 :: U 256 0 0 eth0
::/0 fe80::217:10ff:fe91:6fa0 UG 1 47079 0 br1
::1/128 :: U 0 14 1 lo
2a02:a213:a6bf:b080::/128 :: U 0 0 1 lo
2a02:a213:a6bf:b080::/128 :: U 0 0 1 lo
2a02:a213:a6bf:b080::fe01/128 :: U 0 1958 5 lo
2a02:a213:a6bf:b080::a0a:1/128 :: U 0 461 1 lo
fe80::/128 :: U 0 0 1 lo
fe80::/128 :: U 0 0 1 lo
fe80::/128 :: U 0 0 1 lo
fe80::/128 :: U 0 0 1 lo
fe80::223:54ff:fea5:363e/128 :: U 0 492 1 lo
fe80::223:54ff:fea5:363e/128 :: U 0 0 1 lo
fe80::3a43:7dff:fe78:3b22/128 :: U 0 40 1 lo
fe80::3a43:7dff:fe78:3b22/128 :: U 0 0 1 lo
ff02::1/128 ff02::1 UC 0 2 0 br0
ff02::1/128 ff02::1 UC 0 1 0 br1
ff02::fb/128 ff02::fb UC 0 418 0 br0
ff02::1:ff3d:6d91/128 ff02::1:ff3d:6d91 UC 0 13 0 br1
ff02::1:ff5a:b9bf/128 ff02::1:ff5a:b9bf UC 0 7 0 br1
ff02::1:ff8a:cfd3/128 ff02::1:ff8a:cfd3 UC 0 6 0 br1
ff02::1:ff93:ccad/128 ff02::1:ff93:ccad UC 0 10 0 br1
ff02::1:ffe2:9b1/128 ff02::1:ffe2:9b1 UC 0 11 0 br1
ff02::1:ffe2:cca9/128 ff02::1:ffe2:cca9 UC 0 11 0 br1
ff02::1:ffff:43/128 ff02::1:ffff:43 UC 0 1 0 br1
ff00::/8 :: U 256 0 0 br0
ff00::/8 :: U 256 0 0 br1
ff00::/8 :: U 256 0 0 eth1
ff00::/8 :: U 256 0 0 eth0

efok

Level 17
  • 4060Posts
  • 219Oplossingen
  • 1628Likes

Hmm, mooi dat het werk, maar heb je nu een manual override toegevoegd?

met IPV6ADDR_SECONDARIES=2a02:a213:a6bf:b080::fe01/64 <== zelf ingevuld

 

Dan gaat het weer stuk als Ziggo iets vernadert. Ik denk dat het anders moet kunnen, al weet ik ook niet precies hoe dan🙄

sjoerd001
Topicstarter
Level 6
  • 112Posts
  • 5Oplossingen
  • 20Likes

@efok  Dank voor je reactie

 

Ik kan er toch min of meer vanuitgaan dat die prefix 2a02:a213:a6bf:b080::/57 blijf behouden? Of veranderd dat ook elke eeh... 30 dagen

efok

Level 17
  • 4060Posts
  • 219Oplossingen
  • 1628Likes

@sjoerd001Bij is de prefix wel eens gewisseld, bij het opnieuw opstarten van miin router. Ik heb toen mijn DUID vastgezet. Maar helemaal 'vast' is het niet. Lukte het je helemaal niet om de handel dynamisch te configureren? Taaie kost, als je dit allemaa op de CLI moet configureren. Welk OS heb je erop staan?

sjoerd001
Topicstarter
Level 6
  • 112Posts
  • 5Oplossingen
  • 20Likes

@efok Dynamisch ga ik het nog proberen, maar zoals het nu gaat is het al dynamisch genoeg voor mij en met deze instellingen weet ik in ieder geval zeker dat het werkt.

Enne taaie kost valt wel mee. Zo leer je er ook nog wat van i.p.v. alles maar automatisch te laten doen.

 

Op het systeem zelf draait fedora.

 

Wat betreft die DUID. Zal er eens mee experimenteren.

sjoerd001
Topicstarter
Level 6
  • 112Posts
  • 5Oplossingen
  • 20Likes

@efok 

Andere vraag die je misschien weet. Hoe kom ik er achter wat mijn global ipv6 adres is. 

Op dit moment is dit:

2a02:a213:a6bf:b080:e8c9:9ffb:bf8d:1378

Hoe kom ik hier achter zonder een brouwser te gebruiken.

efok

Level 17
  • 4060Posts
  • 219Oplossingen
  • 1628Likes

@sjoerd001Ik gebruik daarvoor het commando "ip addr", of bedoel je dat niet?

Hier mijn output:

ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp0s31f6: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether d0:50:99:84:92:9c brd ff:ff:ff:ff:ff:ff
    inet 192.168.2.31/24 brd 192.168.2.255 scope global dynamic noprefixroute enp0s31f6
       valid_lft 55959sec preferred_lft 55959sec
    inet6 2001:1c01:30c7:bf01:7686:d054:e253:3be0/64 scope global dynamic noprefixroute 
       valid_lft 86398sec preferred_lft 14398sec
    inet6 fe80::28d:9359:942:bbfb/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
3: vpn0: <NO-CARRIER,POINTOPOINT,MULTICAST,NOARP,UP> mtu 1200 qdisc fq_codel state DOWN group default qlen 500
    link/none 
sjoerd001
Topicstarter
Level 6
  • 112Posts
  • 5Oplossingen
  • 20Likes

@efok Ja en nee misschien 😞

 

Jij hebt een global ipv6 van 2001:1c01:30c7:bf01:7686:d054:e253:3be0/64

 

Ik krijg dat in geen van de config op een of andere interface.

 

Ik zie alleen via ipv6 test-site mijn global ipv6 en is op dit moment nu:

2a02:a213:a6bf:b080:e8c9:9ffb:bf8d:1378

 

Snap het niet. Alleen als ik handmatig een ipv6 adres invul kan ik deze pingen vanaf het internet.

 

Ik zit zelf op fUPC en sinds kort gebruik kunnen maken met ipv6.

sjoerd001
Topicstarter
Level 6
  • 112Posts
  • 5Oplossingen
  • 20Likes

Had ook getest met dhcpv6c. Ging goed en gebruik het nog steeds met huidige config.

efok

Level 17
  • 4060Posts
  • 219Oplossingen
  • 1628Likes

Mijn output is trouwens van een desktop in mijn LAN. Op mijn router heb ik:

 

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 44:d9:e7:41:31:fb brd ff:ff:ff:ff:ff:ff
    inet 82.73.50.2/23 brd 255.255.255.255 scope global eth0
       valid_lft forever preferred_lft forever
    inet6 2001:1c01:3000:0:fde6:2fa:b4a2:xxxx/128 scope global 
       valid_lft forever preferred_lft forever
    inet6 fe80::46d9:e7ff:fe41:31fb/64 scope link 
       valid_lft forever preferred_lft forever
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 44:d9:e7:41:31:fc brd ff:ff:ff:ff:ff:ff
    inet 192.168.2.250/24 brd 192.168.2.255 scope global eth1
       valid_lft forever preferred_lft forever
    inet6 2001:1c01:30c7:bf01::1/64 scope global 
       valid_lft forever preferred_lft forever
    inet6 fe80::46d9:e7ff:fe41:31fc/64 scope link 
       valid_lft forever preferred_lft forever
4: eth2: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default qlen 1000
    link/ether 44:d9:e7:41:31:fd brd ff:ff:ff:ff:ff:ff
    inet 192.168.20.250/24 brd 192.168.20.255 scope global eth2
       valid_lft forever preferred_lft forever
    inet6 2001:1c01:30c7:bf04::1/64 scope global tentative 
       valid_lft forever preferred_lft forever

 

Ik ken fedora niet goed genoeg, en kan weinig vinden over prefix delegation en fedora, behalve wat verouderde info. Maar het moet toch mogelijk zijn om gewoon via SLAAC een WAN IP te krijgen en een /57 (fUPC) prefix op te vragen?

Misschien heb je hier wat aan?
https://sven-seeberg.de/wp/?p=951

 

sjoerd001
Topicstarter
Level 6
  • 112Posts
  • 5Oplossingen
  • 20Likes

@efok 

Huidige leases:

default-duid "\000\001\000\001*\xxx\xxx\3178C}x;\"";
lease6 {
interface "br1";
ia-na "2a02" {
starts 1671585362;
renew 293707;
rebind 469932;
iaaddr 2a02:a204:0:74d:xxxx:849 {
starts 1671585362;
preferred-life 587415;
max-life 1192215;
}
}
ia-pd "2a02" {
starts 1671585362;
renew 293707;
rebind 469932;
iaprefix 2a02:a213:a6be:fc00::/57 {
starts 1671585362;
preferred-life 587415;
max-life 1192215;
}
}
ia-pd "}x;"" {
starts 1671585362;
renew 300276;
rebind 480441;
iaprefix 2a02:a213:a6bf:b080::/57 {
starts 1671585362;
preferred-life 600552;
max-life 1205352;
}
}
option dhcp6.client-id 0:1:0:1:2a:xx:xx:xx:xx:xx:xx:xx:3b:22;
option dhcp6.server-id 0:1:0:1:28:xx:xx:xx:xx:xx:xx:xx:1d:90;
option dhcp6.reconf-accept ;
option dhcp6.name-servers 2001:730:3e42:1000::53,2001:730:3e42::53;
option dhcp6.unknown-11 3:1:0:29:cd:1a:4d:1:27:87:c7:1:b5:84:30:d4:47:7e:21:6b:4a:14:44:bb:85:8e:87:6d;
}

 

Snap er nog steeds niets van. 

Ik krijg 5 prefixes van fUPC.

3 zonder rdns:

2a02:a204:0:74d::

2a02:a204:0:274d::

2a02:a204:0:474d::

 

en 2 met rdns:

2a02:a213:a6bf:b080::57

2a02:a213:a6bf:fc00::57

 

Wat is er aan de hand?

 

Random

Level 16
  • 2166Posts
  • 101Oplossingen
  • 1125Likes

.

E-mail notificaties
Aan Uit

Ontvang een update bij nieuwe reacties in dit topic.

Uitgelicht topic