1
Vraag
2
Reacties
makhauser

Level 2
  • 7Posts
  • 0Oplossingen
  • 1Likes

Issues connecting to the internal NetScaler

Hello,

I've received a new router (the black one) from you, and my access to NetScaler (Citrix VDI/Xen) stopped working. Before that, there were no issues: it loaded the Workspace app normally. Since the installation, it tries to load, but fails regardless of the browser or connection type (Wi-Fi or cable connection). Unknown client error 1110 is the response. I tried using an alternative DNS from the option, but it didn't work. And probably shouldn't anyway.
Current IP: 94.211.x.x, worked fine with a white one before with a similar setup and w/ IP address 84.24.x.x;

 

It might also be a massive issue, as more and more colleagues are going to use it, and most of them are Ziggo clients. What could be the issue?
Thank you

P.S. The issue doesn't occur with external netscaler connection, but for that, either VPN needs to be stopped, or hosts has to be modified to resolve the URL not to localhost but to its initial address.

Oplossing

Geaccepteerde oplossingen
tobiastheebe

Level 20
T.E.A.M.
  • 32749Posts
  • 2325Oplossingen
  • 16574Likes

The black SmartWifi modem (F3896LG-ZG) is configured to use a non-standard MTU value by default and the standard value (1500) cannot be configured, decreasing it to 1499 does resolve issues like the one you were experiencing. There are no disadvantages to this configuration change.

Bekijk in context

12 Reacties 12
BAM

Level 13
  • 844Posts
  • 54Oplossingen
  • 219Likes

hey @makhauser,

 

Maybe this can be helpful 

 

 

Regards,

 

Bam

 

makhauser
Topicstarter
Level 2
  • 7Posts
  • 0Oplossingen
  • 1Likes

Hey @BAM, thanks. I don't have access to the config of this NetScaler, and it did work with a same setup on a previous model. Also, occurs in Chromium-based browser, not just Firefox. My colleague opened a similar thread recently, and is now in without using the roundabout

And as our employer is switching to the Citrix way of working, it will probably be a common issue unless the responsible team figures out what causes this issue in the independent scenarios. I will pass them that link, maybe they can take a more in-depth look, thanks

BAM

Level 13
  • 844Posts
  • 54Oplossingen
  • 219Likes

hey @makhauser,

 

Possibly  your modem needs to be set to  IPV6 Full Dualstack.

 

Concerning DNS, primary 8.8.8.8 secondary 1.1.1.1 can be an option.

 

 

Regards,

 

Bam

 

 

 

makhauser
Topicstarter
Level 2
  • 7Posts
  • 0Oplossingen
  • 1Likes

Hey @BAM, yes, I tried with 1.1.1.1, but it didn't work. What it takes to set the IPv6 Full Dualstack?  Do I need to raise a ticket?

tobiastheebe

Level 20
T.E.A.M.
  • 32749Posts
  • 2325Oplossingen
  • 16574Likes

Your router is already using Full Dual-Stack. In case of Dual-Stack Lite, the WAN IPv4 address would be in subnet 213.127.0.0/17.

 

Could you log in to the modem's web interface at 192.168.178.1 and adjust the firewall settings for IPv4 and (if available) IPv6, disabling all options except 'Firewall security'? See the Advanced settings, Security, Firewall page.

BAM

Level 13
  • 844Posts
  • 54Oplossingen
  • 219Likes

** Message dropped **

 

 

 

 

 

Regards,

 

Bam

 

makhauser
Topicstarter
Level 2
  • 7Posts
  • 0Oplossingen
  • 1Likes

Thanks, @tobiastheebe. Sorry, totally missed your message somehow. The only other option enabled was "flood detection", but it didn't help, unfortunately. Maybe it needs some time to apply, or I need to restart the router to be on the safe side

makhauser
Topicstarter
Level 2
  • 7Posts
  • 0Oplossingen
  • 1Likes

Ok, there is a new update. It didn't work, but seems that decreasing the MTU size actually helped. Not sure what else it breaks, and what comes from it, but is some progress already

tobiastheebe

Level 20
T.E.A.M.
  • 32749Posts
  • 2325Oplossingen
  • 16574Likes

The black SmartWifi modem (F3896LG-ZG) is configured to use a non-standard MTU value by default and the standard value (1500) cannot be configured, decreasing it to 1499 does resolve issues like the one you were experiencing. There are no disadvantages to this configuration change.

makhauser
Topicstarter
Level 2
  • 7Posts
  • 0Oplossingen
  • 1Likes

Thanks, @tobiastheebe, it's actually just the VPN MTU, and changing it solves the issue, will make it persistent then. Unfortunately, it is not a fully workable solution, as you need local admin rights to edit the setting for the interface, but at least is something (maybe some people also contact forum about this in the future). Also hope that our Citrix team can look deeper into that

tobiastheebe

Level 20
T.E.A.M.
  • 32749Posts
  • 2325Oplossingen
  • 16574Likes

No need to change the MTU size locally on the VPN interface. You can change the eRouter MTU size within the web interface.

makhauser
Topicstarter
Level 2
  • 7Posts
  • 0Oplossingen
  • 1Likes

Sorry to say, but in our particular case, that doesn't help. It might be good in general, and the settings router-wise are enjoyable, but in our company we tunnel only specific connections via TAP interface, and everything else goes via the regular ISP. But yes, if you change the MTU to say 1438, it goes almost instantly and Citrix Workspace app connects.

E-mail notificaties
Aan Uit

Ontvang een update bij nieuwe reacties in dit topic.

Uitgelicht topic