1
Vraag
2
Reacties
alpinist79

Level 2
  • 7Posts
  • 0Oplossingen
  • 2Likes

IPv6 in bridge mode met Edgerouter

Hoi, ik probeer ipv6 op mijn Edgerouter werkend te krijgen. Ik heb dhcpv6 ingesteld op mijn WAN interface en PD naar mijn interne netwerk met de Ziggo prefix /56. Maar ik krijg niet eens een ipv6 adres toegewezen. Lijkt wel alsof er toch geen ipv6 zit op mijn router ( Cisco EPC3925 ). Heeft iemand een werkende config om te delen?  Relevante config: 

 

interfaces {

    ethernet eth0 {

        address 192.xxx.xxx.1/24

        dhcpv6-pd {

            pd 0 {

                prefix-length 56

            }

            rapid-commit disable

        }

        duplex auto

        speed auto

    }

    ethernet eth1 {

        disable

        duplex auto

        speed auto

    }

    ethernet eth2 {

        address dhcp

        address dhcpv6

        duplex auto

        firewall {

            in {

                name WAN_IN

            }

            local {

                name WAN_LOCAL

            }

        }

        ipv6 {

            address {

            }

            dup-addr-detect-transmits 1

        }

        speed auto

    }

    loopback lo {

    }

}

Oplossing

Geaccepteerde oplossingen
tobiastheebe

Level 20
Super Expert
  • 15981Posts
  • 1015Oplossingen
  • 6993Likes

Onder eth0 kun je het blokje dhcpv6-pd verwijderen. Verder moeten er nog firewall chains gemaakt worden voor IPv6 en gekoppeld worden aan eth2.

 

Lees meer

set firewall ipv6-name WAN_LOCAL_IPV6 default-action drop
set firewall ipv6-name WAN_LOCAL_IPV6 description "WAN to router"
set firewall ipv6-name WAN_LOCAL_IPV6 rule 10 action accept
set firewall ipv6-name WAN_LOCAL_IPV6 rule 10 description "Allow established/related"
set firewall ipv6-name WAN_LOCAL_IPV6 rule 10 state established enable
set firewall ipv6-name WAN_LOCAL_IPV6 rule 10 state related enable
set firewall ipv6-name WAN_LOCAL_IPV6 rule 20 action drop
set firewall ipv6-name WAN_LOCAL_IPV6 rule 20 description "Drop invalid"
set firewall ipv6-name WAN_LOCAL_IPV6 rule 20 state invalid enable
set firewall ipv6-name WAN_LOCAL_IPV6 rule 30 action accept
set firewall ipv6-name WAN_LOCAL_IPV6 rule 30 description "Allow ICMP"
set firewall ipv6-name WAN_LOCAL_IPV6 rule 30 protocol ipv6-icmp
set firewall ipv6-name WAN_LOCAL_IPV6 rule 40 action accept
set firewall ipv6-name WAN_LOCAL_IPV6 rule 40 description "Allow DHCP"
set firewall ipv6-name WAN_LOCAL_IPV6 rule 40 destination port 546
set firewall ipv6-name WAN_LOCAL_IPV6 rule 40 protocol udp
set firewall ipv6-name WAN_LOCAL_IPV6 rule 40 source port 547

 

set firewall ipv6-name WAN_IN_IPV6 default-action drop
set firewall ipv6-name WAN_IN_IPV6 description "WAN inbound"
set firewall ipv6-name WAN_IN_IPV6 rule 10 action accept
set firewall ipv6-name WAN_IN_IPV6 rule 10 description "Allow established/related"
set firewall ipv6-name WAN_IN_IPV6 rule 10 state established enable
set firewall ipv6-name WAN_IN_IPV6 rule 10 state related enable
set firewall ipv6-name WAN_IN_IPV6 rule 20 action drop
set firewall ipv6-name WAN_IN_IPV6 rule 20 description "Drop invalid"
set firewall ipv6-name WAN_IN_IPV6 rule 20 state invalid enable
set firewall ipv6-name WAN_IN_IPV6 rule 30 action accept
set firewall ipv6-name WAN_IN_IPV6 rule 30 description "Allow ICMP"
set firewall ipv6-name WAN_IN_IPV6 rule 30 protocol ipv6-icmp

Bekijk in context

32 Reacties 32
Bert

Level 21
Super Expert
  • 63217Posts
  • 4369Oplossingen
  • 16683Likes

Je hebt voor IPv6 een nieuw modem nodig.

Ziggo kan je die gratis toesturen met de juiste hedendaagse aansluitmaterialen.

 

Kun je een foto hier plaatsen van de eerste plaats waar Ziggo je huis binnenkomt met eventuele splitters, versterkers en het modem op de foto?

Dan kunnen ook de juiste hedendaagse aansluitmaterialen meegestuurd worden.

tobiastheebe

Level 20
Super Expert
  • 15981Posts
  • 1015Oplossingen
  • 6993Likes

In de config moet ook nog e.e.a. aangepast worden.

 

Het blokje dhcpv6-pd moet onder de WAN-interface (eth2) aangemaakt worden, niet onder de LAN-interface:

 

set interfaces ethernet eth2 dhcpv6-pd pd 0 prefix-length 56
set interfaces ethernet eth2 dhcpv6-pd rapid-commit disable

 

Verder mist in dit blokje een definitie om een /64-prefix aan eth0 toe te wijzen:

 

set interfaces ethernet eth2 dhcpv6-pd pd 0 interface eth0 prefix-id ':1'
set interfaces ethernet eth2 dhcpv6-pd pd 0 interface eth0 host-address '::1'
set interfaces ethernet eth2 dhcpv6-pd pd 0 interface eth0 service slaac

efok

Level 17
Expert
  • 3783Posts
  • 206Oplossingen
  • 1440Likes

In aanvulling op @tobiastheebe : de Cisco EPC3925 ondersteunt geen IPv6 in Bridge. Alleen de witte connectboxen, en de Ubee1318ZG. Die laatste kan ik je aanraden, als je toch in bridge werkt.

Rapid commit enable

Werkt prima hier.

 

Mijn volledige config:

interfaces {
    ethernet eth0 {
        address dhcp
        description Internet
        dhcpv6-pd {
            pd 0 {
                interface eth1 {
                    host-address ::1
                    no-dns
                    prefix-id 1
                    service slaac
                }
                interface eth1.50 {
                    host-address ::1
                    prefix-id 2
                    service slaac
                }
                interface eth1.60 {
                    host-address ::1
                    prefix-id 3
                    service slaac
                }
                interface eth2 {
                    host-address ::1
                    prefix-id 4
                    service slaac
                }
                prefix-length /56
            }
            rapid-commit enable
        }
        duplex auto
        firewall {
            in {
                ipv6-name WAN6_IN
                name WAN_IN
            }
            local {
                ipv6-name WAN6_LOCAL
                name WAN_LOCAL
            }
        }
        speed auto
    }

 

En vergeet niet hardware offloading aan te zetten voor IPv6 op je Edgerouter, Anders haal je de snelheid niet.

alpinist79
Topicstarter
Level 2
  • 7Posts
  • 0Oplossingen
  • 2Likes

Thanks, ga eens even kijken hoe ik Ziggo Zakelijk om een nieuwe router kan vragen. 

tobiastheebe

Level 20
Super Expert
  • 15981Posts
  • 1015Oplossingen
  • 6993Likes

Goed om te weten dat Ziggo rapid-commit ondersteunt, dat was mij nog niet duidelijk.

efok

Level 17
Expert
  • 3783Posts
  • 206Oplossingen
  • 1440Likes

Misschien is het zakelijk anders voor de Cisco, maar zakelijk kun je denk ik sowieso om een Ubee vragen, dat is tegenwoordig hun zakelijk modem. 
let op, er is ook een zakelijk abonnement waarbij je een heel /48 blok krijgt en je een statisch IPv6 adres op je WAN moet ingeven. Dan is de configuratie iets anders. Welke variant abo heb je?

alpinist79
Topicstarter
Level 2
  • 7Posts
  • 0Oplossingen
  • 2Likes

Heb een Connectbox gekregen, dhcpv6 werkt prima maar als ik dit doe krijg ik de melding dat ik geen PD mag instellen op een interface waar ook dhcpv6 op zit ( eth2 is WAN )

tobiastheebe

Level 20
Super Expert
  • 15981Posts
  • 1015Oplossingen
  • 6993Likes

Op eth2, verwijder address dhcpv6 en voeg toe: ipv6 address autoconf.

alpinist79
Topicstarter
Level 2
  • 7Posts
  • 0Oplossingen
  • 2Likes

Helaas, geen Ziggo ipv6 adres. Kreeg ik wel met dhcpv6 overigens. Onder eth2 staat nu:

 

   ipv6 {

            address {

                autoconf

            }

tobiastheebe

Level 20
Super Expert
  • 15981Posts
  • 1015Oplossingen
  • 6993Likes

Met autoconf zou eth2 een /128-adres moeten ontvangen. In principe is dit niet eens nodig. Het gaat erom dat een /56-prefix wordt opgehaald met PD en een /64-prefix in het LAN beschikbaar wordt gesteld.

 

Start voor de zekerheid de router nog even opnieuw op. Zou je ook nog eens de nieuwe config van interfaces kunnen plaatsen?

alpinist79
Topicstarter
Level 2
  • 7Posts
  • 0Oplossingen
  • 2Likes

Sure:

 

interfaces {

    ethernet eth0 {

        address 192.168.123.1/24

        dhcpv6-pd {

            rapid-commit enable

        }

        duplex auto

        speed auto

    }

    ethernet eth1 {

        disable

        duplex auto

        speed auto

    }

    ethernet eth2 {

        address dhcp

        dhcpv6-pd {

            pd 0 {

                interface eth0 {

                    host-address ::1

                    prefix-id :1

                    service slaac

                }

                prefix-length 56

            }

            rapid-commit enable

        }

        duplex auto

        firewall {

            in {

                name WAN_IN

            }

            local {

                name WAN_LOCAL

            }

        }

        ipv6 {

            address {

                autoconf

            }

            dup-addr-detect-transmits 1

        }

        speed auto

    }

    loopback lo {

    }

}

tobiastheebe

Level 20
Super Expert
  • 15981Posts
  • 1015Oplossingen
  • 6993Likes

Onder eth0 kun je het blokje dhcpv6-pd verwijderen. Verder moeten er nog firewall chains gemaakt worden voor IPv6 en gekoppeld worden aan eth2.

 

Lees meer

set firewall ipv6-name WAN_LOCAL_IPV6 default-action drop
set firewall ipv6-name WAN_LOCAL_IPV6 description "WAN to router"
set firewall ipv6-name WAN_LOCAL_IPV6 rule 10 action accept
set firewall ipv6-name WAN_LOCAL_IPV6 rule 10 description "Allow established/related"
set firewall ipv6-name WAN_LOCAL_IPV6 rule 10 state established enable
set firewall ipv6-name WAN_LOCAL_IPV6 rule 10 state related enable
set firewall ipv6-name WAN_LOCAL_IPV6 rule 20 action drop
set firewall ipv6-name WAN_LOCAL_IPV6 rule 20 description "Drop invalid"
set firewall ipv6-name WAN_LOCAL_IPV6 rule 20 state invalid enable
set firewall ipv6-name WAN_LOCAL_IPV6 rule 30 action accept
set firewall ipv6-name WAN_LOCAL_IPV6 rule 30 description "Allow ICMP"
set firewall ipv6-name WAN_LOCAL_IPV6 rule 30 protocol ipv6-icmp
set firewall ipv6-name WAN_LOCAL_IPV6 rule 40 action accept
set firewall ipv6-name WAN_LOCAL_IPV6 rule 40 description "Allow DHCP"
set firewall ipv6-name WAN_LOCAL_IPV6 rule 40 destination port 546
set firewall ipv6-name WAN_LOCAL_IPV6 rule 40 protocol udp
set firewall ipv6-name WAN_LOCAL_IPV6 rule 40 source port 547

 

set firewall ipv6-name WAN_IN_IPV6 default-action drop
set firewall ipv6-name WAN_IN_IPV6 description "WAN inbound"
set firewall ipv6-name WAN_IN_IPV6 rule 10 action accept
set firewall ipv6-name WAN_IN_IPV6 rule 10 description "Allow established/related"
set firewall ipv6-name WAN_IN_IPV6 rule 10 state established enable
set firewall ipv6-name WAN_IN_IPV6 rule 10 state related enable
set firewall ipv6-name WAN_IN_IPV6 rule 20 action drop
set firewall ipv6-name WAN_IN_IPV6 rule 20 description "Drop invalid"
set firewall ipv6-name WAN_IN_IPV6 rule 20 state invalid enable
set firewall ipv6-name WAN_IN_IPV6 rule 30 action accept
set firewall ipv6-name WAN_IN_IPV6 rule 30 description "Allow ICMP"
set firewall ipv6-name WAN_IN_IPV6 rule 30 protocol ipv6-icmp

alpinist79
Topicstarter
Level 2
  • 7Posts
  • 0Oplossingen
  • 2Likes

Thanks, dat werkt. Krijg nu netjes wel IPv6 toegewezen en PD werkt ook naar m'n interne clients. Blijkbaar doet dhcpv6 nog iets speciaals waardoor fw niet aangepast hoeft te worden? 

 

 

tobiastheebe

Level 20
Super Expert
  • 15981Posts
  • 1015Oplossingen
  • 6993Likes

Fijn om te lezen! Ik begrijp alleen je vraag niet.

alpinist79
Topicstarter
Level 2
  • 7Posts
  • 0Oplossingen
  • 2Likes

Ziggo stelt in de - super summiere - documentatie die ik heb dat dhcpv6 aangezet moet worden op de router. Dat werkt maar dan krijg ik PD niet aan de gang. Toen ik autoconf aanzette zonder de FW regels in te stellen werkte dat niet. Vandaar dat ik me afvroeg of dhcpv6 support in de edgerouter al iets intelligents doet en FW doorlaat of zo.

tobiastheebe

Level 20
Super Expert
  • 15981Posts
  • 1015Oplossingen
  • 6993Likes

De documentatie van Ziggo is inderdaad erg summier.

 

DHCPv6 aan LAN-zijde is niet nodig als de router het verspreiden van DNS-servers via RA/RDNSS ondersteunt. De EdgeRouter gebruikt daarvoor radvd. De DNS-servers die de router aan WAN-zijde ontvangt, komen automatisch beschikbaar voor radvd. Aan WAN-zijde wordt DHCPv6 alleen gebruikt voor autoconf. Dit heeft alleen betrekking op het /128-adres van de router zelf en wordt alleen gebruikt voor verzoeken van de router zelf naar internet.

Erwin537

Level 2
  • 6Posts
  • 0Oplossingen
  • 3Likes

Ik heb dit topic gevonden op Google, ik heb een vergelijkbare situatie. Ik heb een Connectbox (in bridge mode) met daarachter een EdgeRouter X. Ik heb de configuratie zoals hierboven toegepast en zie in het dashboard op mijn WAN interface (toevallig ook eth2) een /128 adres. Echter als ik een check doe geeft hij aan dat ik geen IPv6 heb. Ik heb de configuratie ook vergeleken met die van Alpinist79 en met de laatste veranderingen doorgevoerd lijkt het overeen te komen.

 

Iemand enig idee wat ik mis?

tobiastheebe

Level 20
Super Expert
  • 15981Posts
  • 1015Oplossingen
  • 6993Likes

@Erwin537 Kun je de interfaces config en eventueel /etc/radvd.conf plaatsen? Wat geeft ipconfig /all (Windows) of ifconfig -a (macOS/Linux) aan?

Erwin537

Level 2
  • 6Posts
  • 0Oplossingen
  • 3Likes

Mijn interfaces config zit er zo uit:

interfaces {
    ethernet eth0 {
        duplex auto
        speed auto
    }
    ethernet eth1 {
        duplex auto
        speed auto
    }
    ethernet eth2 {
        address dhcp
        description Internet
        dhcpv6-pd {
            pd 0 {
                interface eth0 {
                    host-address ::1
                    prefix-id :1
                    service slaac
                }
                prefix-length 56
            }
            rapid-commit disable
        }
        duplex auto
        firewall {
            in {
                ipv6-name WAN_IN_IPV6
                name WAN_IN
            }
            local {
                ipv6-name WAN_LOCAL_IPV6
                name WAN_LOCAL
            }
        }
        ipv6 {
            address {
                autoconf
            }
            dup-addr-detect-transmits 1
        }
        speed auto
    }
    ethernet eth3 {
        duplex auto
        speed auto
    }
    ethernet eth4 {
        duplex auto
        poe {
            output off
        }
        speed auto
    }
    loopback lo {
    }

 

Ik had rapid commit op disable gezet om te proberen, maar had hem eerst op enable.

Hoe ik de /etc/radvd.conf krijg weet ik niet? Kan het ook zo één twee drie niet vinden. Niet met nano /etc/radvd.conf in ieder geval.

 

Wat ik net wel even getest heb: als ik curl naar https://v6.ipv6-test.com (wat die test gebruikt om ipv6 te testen) werkt dat wel vanuit de edgerouter, maar niet vanaf mijn laptop of pc. Het lijkt dus in mijn interne netwerk te zitten?

 

Bij ipconfig /all heb ik op de betreffende adapter een ipv6 adres en een temporary ipv6 adres. Ook staat er een DHCPv6 IAID en een DHCPv6 Client DUID.

 

Overigens wat ik dacht dat misschien nog relevant is: ik heb in de edgerouter DHCP 1.1.1.1 en 1.0.0.1 als DNS ingesteld. Maar op internet staat dat 1.1.1.1 IPv6 ondersteund, dus dat lijkt me dan geen probleem?

 

E-mail notificaties
Aan Uit

Ontvang een update bij nieuwe reacties in dit topic.

Polls
Ga je voor een film of een serie?

Uitgelicht topic