6YCGxVjmvMXNd
Gedreven Ontdekker
  • 9Reacties
  • 0Oplossingen
  • 3Likes

IPv6 forwarded Nextcloud server (Raspberry Pi) is extern niet benaderbaar alleen via wifi

Hi!
Ik heb een Connect box Eurodocsis 3.0 modem en een Raspberry Pi 3 draaien met daarop Nextcloud. Nextcloud is gekoppeld aan een domeinnaam zodat Nextcloud via mijn eigen domeinnaam benaderbaar is. Vervolgens heb ik op mijn Connect box 2 poorten, 80 en 443, geforward naar het lokale IP-adres van mijn Nextcloud. Nu gaat het volgende fout: als ik de domeinnaam benader via mijn wifi dan opent het login scherm van Nextcloud netjes en kan ik ermee aan de slag. Maar zodra ik van mijn wifi af ga en extern mijn domeinnaam benader dan krijg ik de error 'server not found'. Ik denk dat dit komt omdat ik of het forwarden niet goed opgezet heb of iets ander mis in mijn Connect box. Uberhaupt is dit allemaal erg nieuw voor mij. Hebben jullie enig idee wat ik verkeert doe? Hieronder een screenshot van de 80 port instellingen (zonder mijn IPv6 adres uitgeschreven te hebben. Die heb ik wel ingevuld in mijn Connect Box).
1 Geaccepteerde oplossing

Geaccepteerde oplossingen
Jbr67
Gedreven Raadgever
  • 523Reacties
  • 7Oplossingen
  • 122Likes
6YCGxVjmvMXNd wrote:

Nabrander 2: als je op basis van ipv6-adres verbindt , lukt het dan wel van buitenaf?
Als je nslookup of een ping doet naar je naam, krijg je dan de gewenste vertaling?
Als ik op mijn telefoon een vpn aanzet die een ipv6 tunnel aanzet dan wel. Dus ik denk dat daar het probleem ligt. Dat de externe locatie niet altijd ipv6 heeft. Dat is mooi balen want op mijn laptop lukt het mij niet om ipv6 tunnel aan te zetten mijn mijn vpn 😛 Heeft het zin om ziggo te vragen mijn router naar ipv4 te zetten? Zodat ik dit gedoe niet heb?


6YCGxVjmvMXNd

Oh .. ok. Dat maakt de zaak n stukje complexer/anders!
Ik begrijp dus dat je als je van "buiten" komt je niet altijd een ipv6 verbinding hebt?

Maar... dan zul je toch OOK van IPv4 gebruik MOETEN maken, en de juiste poorten moeten forwarden. Dat dus naast IPv6. Wat voor abbo heb je: ds full of ds lite?

Ik heb ook een IPv4 en IPv6 adres voor mijn server... mijn situatie lijkt op die van ds full. En ik heb in mijn DNS zowel een entry voor IPv4 (en de juiste forwardregels in mn router) en voor IPv6 (en de juiste filterregels in mn router).

Hope this helps....

Ciao, Jbr

Bekijk in context

24 Reacties 24
Marco1861
Expert
Expert
  • 979Reacties
  • 54Oplossingen
  • 278Likes
Zou moeten werken zo (1 t/m 65535 op 80/443). Domein ook toegevoegd als 'trusted_domains' in de config?
6YCGxVjmvMXNd
topicstarter
Gedreven Ontdekker
  • 9Reacties
  • 0Oplossingen
  • 3Likes
Marco1861 wrote:
Zou moeten werken zo (1 t/m 65535 op 80/443). Domein ook toegevoegd als 'trusted_domains' in de config?


Marco1861 ja ik heb het domein al toegevoegd aan de trusted domains array in de config. Kan het misschien liggen aan mijn domeinnaam registratie? Ik heb hem alleen geregistreerd met DNS-/redirectservice als product bij https://www.yourhosting.nl.
Jbr67
Gedreven Raadgever
  • 523Reacties
  • 7Oplossingen
  • 122Likes
6YCGxVjmvMXNd wrote:
Hi!
Ik heb een Connect box Eurodocsis 3.0 modem en een Raspberry Pi 3 draaien met daarop Nextcloud. Nextcloud is gekoppeld aan een domeinnaam zodat Nextcloud via mijn eigen domeinnaam benaderbaar is. Vervolgens heb ik op mijn Connect box 2 poorten, 80 en 443, geforward naar het lokale IP-adres van mijn Nextcloud. Nu gaat het volgende fout: als ik de domeinnaam benader via mijn wifi dan opent het login scherm van Nextcloud netjes en kan ik ermee aan de slag. Maar zodra ik van mijn wifi af ga en extern mijn domeinnaam benader dan krijg ik de error 'server not found'. Ik denk dat dit komt omdat ik of het forwarden niet goed opgezet heb of iets ander mis in mijn Connect box. Uberhaupt is dit allemaal erg nieuw voor mij. Hebben jullie enig idee wat ik verkeert doe? Hieronder een screenshot van de 80 port instellingen (zonder mijn IPv6 adres uitgeschreven te hebben. Die heb ik wel ingevuld in mijn Connect Box).


Dmme vraag wellicht maar heb je de laatste vier velden leeg, of heb je ze in het plaatje weggepoetst. Bij IPv6 is er (gelukkig) geen sprake meer van forwarding maar uitsluitend van filtering...
6YCGxVjmvMXNd
topicstarter
Gedreven Ontdekker
  • 9Reacties
  • 0Oplossingen
  • 3Likes
Jbr67 wrote:

6YCGxVjmvMXNd wrote:
Hi!
Ik heb een Connect box Eurodocsis 3.0 modem en een Raspberry Pi 3 draaien met daarop Nextcloud. Nextcloud is gekoppeld aan een domeinnaam zodat Nextcloud via mijn eigen domeinnaam benaderbaar is. Vervolgens heb ik op mijn Connect box 2 poorten, 80 en 443, geforward naar het lokale IP-adres van mijn Nextcloud. Nu gaat het volgende fout: als ik de domeinnaam benader via mijn wifi dan opent het login scherm van Nextcloud netjes en kan ik ermee aan de slag. Maar zodra ik van mijn wifi af ga en extern mijn domeinnaam benader dan krijg ik de error 'server not found'. Ik denk dat dit komt omdat ik of het forwarden niet goed opgezet heb of iets ander mis in mijn Connect box. Uberhaupt is dit allemaal erg nieuw voor mij. Hebben jullie enig idee wat ik verkeert doe? Hieronder een screenshot van de 80 port instellingen (zonder mijn IPv6 adres uitgeschreven te hebben. Die heb ik wel ingevuld in mijn Connect Box).
Dmme vraag wellicht maar heb je de laatste vier velden leeg, of heb je ze in het plaatje weggepoetst. Bij IPv6 is er (gelukkig) geen sprake meer van forwarding maar uitsluitend van filtering...


Ik heb de velden weggepoetst 😉
Marco1861
Expert
Expert
  • 979Reacties
  • 54Oplossingen
  • 278Likes
6YCGxVjmvMXNd wrote:

Marco1861 wrote:
Zou moeten werken zo (1 t/m 65535 op 80/443). Domein ook toegevoegd als 'trusted_domains' in de config?
Marco1861 ja ik heb het domein al toegevoegd aan de trusted domains array in de config. Kan het misschien liggen aan mijn domeinnaam registratie? Ik heb hem alleen geregistreerd met DNS-/redirectservice als product bij https://www.yourhosting.nl.


Hoe staan de records? AAAA-record en een CNAME?
6YCGxVjmvMXNd
topicstarter
Gedreven Ontdekker
  • 9Reacties
  • 0Oplossingen
  • 3Likes
Marco1861 wrote:
Zou moeten werken zo (1 t/m 65535 op 80/443). Domein ook toegevoegd als 'trusted_domains' in de config?
Marco1861 ja ik heb het domein al toegevoegd aan de trusted domains array in de config. Kan het misschien liggen aan mijn domeinnaam registratie? Ik heb hem alleen geregistreerd met DNS-/redirectservice als product bij https://www.yourhosting.nl.
Hoe staan de records? AAAA-record en een CNAME?


Marco1861
Expert
Expert
  • 979Reacties
  • 54Oplossingen
  • 278Likes
Ziet er goed uit. Echter zie ik op Github nog een open issue: https://github.com/nextcloud/suspicious_login/issues/44

'PR is at #107. There is still a lot to do, but I'll try to finish this in the next few weeks.'
Jbr67
Gedreven Raadgever
  • 523Reacties
  • 7Oplossingen
  • 122Likes
6YCGxVjmvMXNd
Nog paar nabranders.....

Aangezien je intern via wifi wel bij kan is je DNS- name resolution kennelijk ok.

Ik zie in je screenshots alleen maar een regel voor poort 80. Die van 443 ziet er net zo uit neem ik aan?

En, ik kan met je voorstellen dat dat servertje meerdere IPv6 adressen heeft... (bijv. als ie zelf ook uitgaande sessie optuigt). Mocht dat zo zijn, dan moet je private extension adressen niet gebruiken. Die zijn namelijk alleen bedoeld voor uitgaande sessie, en veranderen regelmatig....

Ciao,
Jbr
Gusto
Expert
Expert
  • 1490Reacties
  • 33Oplossingen
  • 145Likes
Yourhosting ondersteund nog geen IPv6.

https://www.yourhosting.nl/support/vps/vps-ipv6-ondersteuning/

mvg. Gusto
Jbr67
Gedreven Raadgever
  • 523Reacties
  • 7Oplossingen
  • 122Likes
Jbr67 wrote:
6YCGxVjmvMXNd
Nog paar nabranders.....

Aangezien je intern via wifi wel bij kan is je DNS- name resolution kennelijk ok.

Ik zie in je screenshots alleen maar een regel voor poort 80. Die van 443 ziet er net zo uit neem ik aan?

En, ik kan met je voorstellen dat dat servertje meerdere IPv6 adressen heeft... (bijv. als ie zelf ook uitgaande sessie optuigt). Mocht dat zo zijn, dan moet je private extension adressen niet gebruiken. Die zijn namelijk alleen bedoeld voor uitgaande sessie, en veranderen regelmatig....

Ciao,
Jbr

Nabrander 2: als je op basis van ipv6-adres verbindt , lukt het dan wel van buitenaf?
Als je nslookup of een ping doet naar je naam, krijg je dan de gewenste vertaling?
6YCGxVjmvMXNd
topicstarter
Gedreven Ontdekker
  • 9Reacties
  • 0Oplossingen
  • 3Likes
Jbr67 wrote:

Jbr67 wrote:
6YCGxVjmvMXNd

Nog paar nabranders.....

Aangezien je intern via wifi wel bij kan is je DNS- name resolution kennelijk ok.

Ik zie in je screenshots alleen maar een regel voor poort 80. Die van 443 ziet er net zo uit neem ik aan?

En, ik kan met je voorstellen dat dat servertje meerdere IPv6 adressen heeft... (bijv. als ie zelf ook uitgaande sessie optuigt). Mocht dat zo zijn, dan moet je private extension adressen niet gebruiken. Die zijn namelijk alleen bedoeld voor uitgaande sessie, en veranderen regelmatig....

Ciao,
Jbr
Nabrander 2: als je op basis van ipv6-adres verbindt , lukt het dan wel van buitenaf?
Als je nslookup of een ping doet naar je naam, krijg je dan de gewenste vertaling?


Als ik op mijn telefoon een vpn aanzet die een ipv6 tunnel aanzet dan wel. Dus ik denk dat daar het probleem ligt. Dat de externe locatie niet altijd ipv6 heeft. Dat is mooi balen want op mijn laptop lukt het mij niet om ipv6 tunnel aan te zetten mijn mijn vpn 😛 Heeft het zin om ziggo te vragen mijn router naar ipv4 te zetten? Zodat ik dit gedoe niet heb?
Jbr67
Gedreven Raadgever
  • 523Reacties
  • 7Oplossingen
  • 122Likes
6YCGxVjmvMXNd wrote:

Nabrander 2: als je op basis van ipv6-adres verbindt , lukt het dan wel van buitenaf?
Als je nslookup of een ping doet naar je naam, krijg je dan de gewenste vertaling?
Als ik op mijn telefoon een vpn aanzet die een ipv6 tunnel aanzet dan wel. Dus ik denk dat daar het probleem ligt. Dat de externe locatie niet altijd ipv6 heeft. Dat is mooi balen want op mijn laptop lukt het mij niet om ipv6 tunnel aan te zetten mijn mijn vpn 😛 Heeft het zin om ziggo te vragen mijn router naar ipv4 te zetten? Zodat ik dit gedoe niet heb?


6YCGxVjmvMXNd

Oh .. ok. Dat maakt de zaak n stukje complexer/anders!
Ik begrijp dus dat je als je van "buiten" komt je niet altijd een ipv6 verbinding hebt?

Maar... dan zul je toch OOK van IPv4 gebruik MOETEN maken, en de juiste poorten moeten forwarden. Dat dus naast IPv6. Wat voor abbo heb je: ds full of ds lite?

Ik heb ook een IPv4 en IPv6 adres voor mijn server... mijn situatie lijkt op die van ds full. En ik heb in mijn DNS zowel een entry voor IPv4 (en de juiste forwardregels in mn router) en voor IPv6 (en de juiste filterregels in mn router).

Hope this helps....

Ciao, Jbr

Bekijk in context

6YCGxVjmvMXNd
topicstarter
Gedreven Ontdekker
  • 9Reacties
  • 0Oplossingen
  • 3Likes
Jbr67 wrote:

6YCGxVjmvMXNd wrote:

Nabrander 2: als je op basis van ipv6-adres verbindt , lukt het dan wel van buitenaf?
Als je nslookup of een ping doet naar je naam, krijg je dan de gewenste vertaling?
Als ik op mijn telefoon een vpn aanzet die een ipv6 tunnel aanzet dan wel. Dus ik denk dat daar het probleem ligt. Dat de externe locatie niet altijd ipv6 heeft. Dat is mooi balen want op mijn laptop lukt het mij niet om ipv6 tunnel aan te zetten mijn mijn vpn 😛 Heeft het zin om ziggo te vragen mijn router naar ipv4 te zetten? Zodat ik dit gedoe niet heb?
6YCGxVjmvMXNd

Oh .. ok. Dat maakt de zaak n stukje complexer/anders!
Ik begrijp dus dat je als je van "buiten" komt je niet altijd een ipv6 verbinding hebt?

Maar... dan zul je toch OOK van IPv4 gebruik MOETEN maken, en de juiste poorten moeten forwarden. Dat dus naast IPv6. Wat voor abbo heb je: ds full of ds lite?

Ik heb ook een IPv4 en IPv6 adres voor mijn server... mijn situatie lijkt op die van ds full. En ik heb in mijn DNS zowel een entry voor IPv4 (en de juiste forwardregels in mn router) en voor IPv6 (en de juiste filterregels in mn router).

Hope this helps....

Ciao, Jbr


Klopt, als ik van "buiten" kom heb ik inderdaad niet altijd ipv6 verbinding.
Ik weet niet zo goed waar ik kan zien of ik ds full of ds lite heb. Ik heb een 'Internet compleet' abbonement bij Ziggo. Als ik in mijn router settings kijk zie ik niet zo snel een ipv4 setting staan.

Kun je jouw forwardregels en filterregels delen? En je DNS settings? Ik ga even opzoeken hoe ik een ipv4 adres kan toevoegen aan mij server.
Jbr67
Gedreven Raadgever
  • 523Reacties
  • 7Oplossingen
  • 122Likes
6YCGxVjmvMXNd wrote:
Klopt, als ik van "buiten" kom heb ik inderdaad niet altijd ipv6 verbinding. Ik weet niet zo goed waar ik kan zien of ik ds full of ds lite heb. Ik heb een 'Internet compleet' abbonement bij Ziggo. Als ik in mijn router settings kijk zie ik niet zo snel een ipv4 setting staan. Kun je jouw forwardregels en filterregels delen? En je DNS settings? Ik ga even opzoeken hoe ik een ipv4 adres kan toevoegen aan mij server.

hanh Kun jij even meekijken? Hoe ging het ook al weer met bekijken of iemand lite of full heeft?
efok
Expert
Expert
  • 3115Reacties
  • 170Oplossingen
  • 1009Likes
6YCGxVjmvMXNd (wat een naam....) Zie je iets als aftr.upc.nl in je modem? en wat staat daar exact?

Als de AFTR niet enabled is, zou je een regulier IPv4 adres moeten hebben. In je DNS moet je daarvoor een A record toevoegen. AAAA is alleen voor IPv6.

(Nog mooier is als je met een dynamisch DNS service gaat werken. Dan hoef je geen handmatige aanpassingen te doen als je IPs veranderen)
Gusto
Expert
Expert
  • 1490Reacties
  • 33Oplossingen
  • 145Likes
AFTR, word sinds 2010 niet meer ontwikkeld. 😉
6YCGxVjmvMXNd
topicstarter
Gedreven Ontdekker
  • 9Reacties
  • 0Oplossingen
  • 3Likes
efok wrote:
6YCGxVjmvMXNd (wat een naam....) Zie je iets als aftr.upc.nl in je modem? en wat staat daar exact?

Als de AFTR niet enabled is, zou je een regulier IPv4 adres moeten hebben. In je DNS moet je daarvoor een A record toevoegen. AAAA is alleen voor IPv6.

(Nog mooier is als je met een dynamisch DNS service gaat werken. Dan hoef je geen handmatige aanpassingen te doen als je IPs veranderen)


In mijn modem staat onder WAN IP settings het volgende:
IPv6 DS-Lite status: Enabled
DS-Lite-FQDN: aftr01.upc.nl

En verder een hoop info over IPv6 maar niks over IPv4.
Jbr67
Gedreven Raadgever
  • 523Reacties
  • 7Oplossingen
  • 122Likes
6YCGxVjmvMXNd wrote:

efok wrote:
6YCGxVjmvMXNd
In mijn modem staat onder WAN IP settings het volgende:
IPv6 DS-Lite status: Enabled
DS-Lite-FQDN: aftr01.upc.nl

En verder een hoop info over IPv6 maar niks over IPv4.


6YCGxVjmvMXNd Ok, je hebt dan dus geen (bijna) vast ipv4 adres met eventuele forwarding. Hebt. Je zult moeten vragen om terugzetten naar ipv4 only...
6YCGxVjmvMXNd
topicstarter
Gedreven Ontdekker
  • 9Reacties
  • 0Oplossingen
  • 3Likes
Jbr67 wrote:

6YCGxVjmvMXNd wrote:

efok wrote:
6YCGxVjmvMXNd
In mijn modem staat onder WAN IP settings het volgende:
IPv6 DS-Lite status: Enabled
DS-Lite-FQDN: aftr01.upc.nl

En verder een hoop info over IPv6 maar niks over IPv4.
6YCGxVjmvMXNd Ok, je hebt dan dus geen (bijna) vast ipv4 adres met eventuele forwarding. Hebt. Je zult moeten vragen om terugzetten naar ipv4 only...


Okay bedankt! Ga ik Ziggo morgen bellen. Waarom ipv4 only? Waarom niet allebei? Of kan dat niet bij Ziggo?

Uitgelicht topic