1
Vraag
2
Reacties
Bernard038

Level 2
  • 11Posts
  • 1Oplossingen
  • 2Likes

IPv6 DHCP uitschakelen in LAN

Hoi Allemaal,

 

Is het mogelijk om de IPv6 dhcp-server op de Connectbox helemaal uit te zetten? Mijn lokale hosts krijgen nu zowel een IPv4 adres van mijn eigen dhcp-server én een IPv6 adres vanuit de Connectbox. Hierdoor worden DNS-requests naar de IPv6 DNS server gestuurd en niét naar mijn eigen, lokale DNS server….

Oplossing

Geaccepteerde oplossingen
Bernard038
Topicstarter
Level 2
  • 11Posts
  • 1Oplossingen
  • 2Likes

Hoi tobias!

 

Probleem opgelost, ik heb 't volgende gedaan:

  • DHCP6 op "stateful" gezet
  • Bij DNS het IPv6 adres van mijn DNS server ingesteld als DNS (gekke is, bij IPv4 kan je geen lokaal adres gebruiken voor DNS, bij IPv6 kan dit wél, begrijp ook wel waar dit aan ligt, IPv6 heeft geen lokale range)

Bedankt!

Bekijk in context

7 Reacties 7
tobiastheebe

Level 20
T.E.A.M.
  • 32264Posts
  • 2277Oplossingen
  • 16280Likes

Nee, dat is niet mogelijk. Je kunt wel de DHCPv6-server instellen op 'stateful', bepaalde clients vallen dan terug op IPv4.

Marinus

Level 15
  • 1180Posts
  • 34Oplossingen
  • 364Likes

@Bernard038 

In de ConnectBox Giga (melkpak) is het wel mogelijk een eigen IPv6 DNS server in te stellen (IPv6 adres van je eigen DNS server).

 

Ik moet nog steeds goed testen of dit ook echt werkt. 

Pasi

Level 18
  • 10255Posts
  • 500Oplossingen
  • 5717Likes

Hallo,

Misschien IPv6 maar handmatig disable'n? Als het maar een paar apparaten zijn, dan is dat sneller dan een andere oplossing bedenken en die uitwerken.

Ik heb een RaspBerry PI met Pi-Hole, welke ook DHCP is ( de DHCP van Ziggo staat uit ). Maar soms ging IPv6 verkeer ( met reclame ) er toch omheen. Dus uiteindelijk op die paar eigen desktops/laptops/smartphones IPv6 maar uitgezet. 1 keer instellen, binnen een half uurtje gedaan en klaar is kees. Opgelost !

Bernard038
Topicstarter
Level 2
  • 11Posts
  • 1Oplossingen
  • 2Likes

Hoi Alledrie,

Dank voor her meedenken! Jammer genoeg is het uitzetten van IPv6 op smarthome devices geen optie. Er zal dus een eigen router komen zodat ik de connectbox in Bridge-mode kan (laten) zetten. Wel jammer... 

 

Nogmaals dank!

 

tobiastheebe

Level 20
T.E.A.M.
  • 32264Posts
  • 2277Oplossingen
  • 16280Likes

Had je mijn voorstel (DHCPv6-server instellen op 'stateful') al geprobeerd?

Bernard038
Topicstarter
Level 2
  • 11Posts
  • 1Oplossingen
  • 2Likes

Hoi tobias!

 

Probleem opgelost, ik heb 't volgende gedaan:

  • DHCP6 op "stateful" gezet
  • Bij DNS het IPv6 adres van mijn DNS server ingesteld als DNS (gekke is, bij IPv4 kan je geen lokaal adres gebruiken voor DNS, bij IPv6 kan dit wél, begrijp ook wel waar dit aan ligt, IPv6 heeft geen lokale range)

Bedankt!

tobiastheebe

Level 20
T.E.A.M.
  • 32264Posts
  • 2277Oplossingen
  • 16280Likes

In geval van het SmartWifi modem Giga, waar de DNSv6-servers inderdaad zelf ingesteld kunnen worden, zou stateful DHCPv6 (toewijzing GUA en DNSv6-servers beide via DHCPv6) niet nodig moeten zijn.

 

Klopt inderdaad wat je aangeeft, bij IPv6 is er wel een aparte prefix (/64) voor het LAN, maar deze wordt afgeleid van de delegated prefix (/56 of /57) die de router heeft ontvangen op de WAN-interface en bestaat dus uit globale adressen (GUA's).

 

Bij het nieuwe SmartWifi modem (zwart) is het wel mogelijk om voor zowel IPv4 als IPv6 de DNS-servers aan te passen.

E-mail notificaties
Aan Uit

Ontvang een update bij nieuwe reacties in dit topic.

Uitgelicht topic