qqq

Gedreven Raadgever
  • 68Posts
  • 2Oplossingen
  • 16Likes

Firmware-downgrade UBC1318ZG ongedaan maken ivm. native IPv6 in bridge mode

Goedemiddag,

 

Graag zou ik de firmware-downgrade op mijn UBC1318ZG ongedaan laten maken en een upgrade ontvangen naar 12.5.8008.S15.ZIGGO of nieuwer. Er stond enige tijd versie 12.5.3208 op het modem in verband met de problemen om IPv6-tunnels te gebruiken in nieuwere firmware-versies (zie https://community.ziggo.nl/t5/Internet/IPv6-tunnel-stuk-na-modem-firmware-upgrade/m-p/771387/highlig...).

 

Na de introductie van native IPv6 voor modems in bridge mode (zie https://community.ziggo.nl/t5/Internet/Eindelijk-IPv6-in-Bridge-modus/m-p/877859) wil ik graag overstappen. Maar ik krijg het met de oude firmware niet werkend (zie https://community.ziggo.nl/t5/Internet/Eindelijk-IPv6-in-Bridge-modus/m-p/877473#M98616). Ik zou dan ook graag uitsluiten dat de oude firmware het probleem is.

 

Welke Ziggo moderator kan een firmware-upgrade voor me aanvragen? Ik zal terugkoppelen of het mijn probleem verhelpt, mogelijk lopen ook anderen hier tegen aan.

 

Draai je ook firmware versie 12.5.3208 op je UBC1318ZG en werkt native IPv6? Dan hoor ik het ook graag; dat geeft namelijk ook uitsluitsel over de rol van de firmware.

1 Oplossing

Geaccepteerde oplossingen
Paul
Community Moderator
Community Moderator
  • 11460Posts
  • 952Oplossingen
  • 3070Likes

@qqq Fijn dat het gelukt is. Wat betreft je andere vraag heb ik mijn collega van InHome even laten kijken naar de firmware versie. Er is door hem op afstand een nieuwe versie gepushed naar jouw modem. Als je zo het modem even hertart, dan moet het modem deze automatisch geinstalleerd hebben. Laat maar weten of het gelukt is.

Bekijk in context

33 Reacties 33
Dave!
Super Expert
Super Expert
  • 17352Posts
  • 771Oplossingen
  • 4449Likes

@qqq  ik heb je topic voorgelegd aan de Ziggo Medewerkers en deze pakken dit op, als je volgende wilt doen

 

 je postcode en huisnummer in je Ziggo community profiel staan, deze zijn niet openbaar te zien, dan kunnen gelijk de juiste gegevens erbij gepakt worden.
Na klik op onderstaande link, op de volgende pagina naar beneden scrollen:
https://community.ziggo.nl/t5/user/myprofilepage/tab/personal-profile:personal-info

Paul
Community Moderator
Community Moderator
  • 11460Posts
  • 952Oplossingen
  • 3070Likes

Goedemorgen @qqq en een warm welkom op de Community,

Goed dat je met deze vraag aankopt op het forum! Full Dualstack hoort ook bij de gedowngrade firmware gewoon te werken op het Ubee1318ZG modem. Indien je in bridged modus op dit moment problemen ervaart, raad ik aan de firewall instellingen van je router te controleren en kijk ook of Prefix Delegation (PD) aanstaat in je router. 

qqq
topicstarter
Gedreven Raadgever
  • 68Posts
  • 2Oplossingen
  • 16Likes

Dank voor de reacties.

 

Ik begrijp uit de reactie van @Mariska dat er een andere gebruiker met een gedowngrade modem is waar dual-stack netjes werkt. Goed om dat expliciet bevestigd te hebben gekregen.

 

Blijft over waarom het bij mij niet werkt.

 

Even een expliciet quote uit de post die ik eerder linkte, waarin ik mijn stand van zaken beschreef:


@qqq  schreef:

Hier werkt het nog niet achter een Ubee1318ZG in bridge, na eea. gereboot te hebben. Mijn router draait een recente OpenWRT; in tcpdump zie ik mijn dhcp-client odhcp6c wel de DHCP6 solicit sturen, maar zie ik geen advertise terug van de server. Daarmee lijkt het op het eerste gezicht geen firewall-issue.


Staat er ergens gedocumenteerd waar een DCHPv6 sollicit aan moet voldoen om reactie te krijgen? Uit de aankondigingsmail haalde ik enkel dat voor prefix delegation het advies is om een /56 te requesten. Maar ik krijg dus uberhaupt geen antwoord, ook al zie ik mijn solicit richting het modem gaan.

qqq
topicstarter
Gedreven Raadgever
  • 68Posts
  • 2Oplossingen
  • 16Likes

@qqq  schreef:

Staat er ergens gedocumenteerd waar een DCHPv6 sollicit aan moet voldoen om reactie te krijgen? Uit de aankondigingsmail haalde ik enkel dat voor prefix delegation het advies is om een /56 te requesten. Maar ik krijg dus uberhaupt geen antwoord, ook al zie ik mijn solicit richting het modem gaan.

Of als alternatief, kan iemand me een .pcap sturen van een werkende DHCPv6 solicit-advertise-request-reply flow? Dan kan ik mijn solicit vergelijken met die van een werkende configuratie.

qqq
topicstarter
Gedreven Raadgever
  • 68Posts
  • 2Oplossingen
  • 16Likes

Het wordt nog interessanter. Ik heb zojuist remote de configuratie van een modem en router van een andere ziggo-lijn bekeken. Hetzelfde modem, zelfde versie van OpenWRT op de router, dezelfde DHCPv6 en firewall-configuratie. Bij het andere adres was er niets anders nodig dan een restart van het modem via de webinterface om het te laten werken.

 

Het enige verschil dat ik zie tussen deze twee addressen is de gebruikte firmware-versie op het modem: 12.5.3208 bij mij en 12.5.8008.S15.ZIGGO op het andere adres.

qqq
topicstarter
Gedreven Raadgever
  • 68Posts
  • 2Oplossingen
  • 16Likes

En weer een stapje verder met vergelijken. Op de werkende lijn zie ik router advertisements vanuit het Ziggo-netwerk op de upstream interface van de router:

13:53:54.789447 IP6 (class 0xe0, hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::2a52:61ff:YYYY:YYYY > ff02::1: [icmp6 sum ok] ICMP6, router advertisement, length 32
	hop limit 64, Flags [managed, other stateful], pref high, router lifetime 1800s, reachable time 3600000ms, retrans timer 0ms
	  source link-address option (1), length 8 (1): 28:52:61:XX:XX:XX
	    0x0000:  2852 6129 4019
	  mtu option (5), length 8 (1):  1500
	    0x0000:  0000 0000 05dc

 

Met exact dezelfde tcpdump-aanroep zie ik op de upstream interface van de router op mijn eigen lijn helemaal niets.

qqq
topicstarter
Gedreven Raadgever
  • 68Posts
  • 2Oplossingen
  • 16Likes

@Paulof @Mariska, kunnen jullie nagaan of de eerste hop in het Ziggo netwerk gezien vanaf mijn lijn goed staat geconfigureerd met betrekking tot router advertisements en dhcpv6 relay? Ik heb niet het idee dat ik zelf iets kan doen om dit issue verder uit te lopen, anders dan wellicht het modem voor de derde keer te herstarten.

Paul
Community Moderator
Community Moderator
  • 11460Posts
  • 952Oplossingen
  • 3070Likes

Wellicht dat expert @tobiastheebe nog een idee heeft voor wat betreft de configuratie. 

qqq
topicstarter
Gedreven Raadgever
  • 68Posts
  • 2Oplossingen
  • 16Likes

Huh? @Paul  Waarom reageer je niet vanuit Ziggo op de informatie die ik aanlever en/of de vragen die ik stel?

tobiastheebe
Super Expert
Super Expert
  • 8627Posts
  • 491Oplossingen
  • 3093Likes

Kun je eens de volgende regel opzoeken in de log van de UBC1318ZG om te zien of het modem een IPv6-profiel gebruikt?

 

Honoring MDD; IP provisioning mode = IPv4

qqq
topicstarter
Gedreven Raadgever
  • 68Posts
  • 2Oplossingen
  • 16Likes

@tobiastheebe  schreef:

Kun je eens de volgende regel opzoeken in de log van de UBC1318ZG om te zien of het modem een IPv6-profiel gebruikt?

 

Honoring MDD; IP provisioning mode = IPv4


Die logregel komt in het eventlog van beide modems voor.

tobiastheebe
Super Expert
Super Expert
  • 8627Posts
  • 491Oplossingen
  • 3093Likes

De regel vermeldt op beide modems ook 'IPv4'? Ik zou verwachten dat de regel 'IPv6' moet tonen bij een modem dat de boot file voor IPv6 in bridge mode heeft ontvangen, maar mogelijk heeft de regel alleen betrekking op het 10.0.0.0/8-subnet tussen CMTS en CM's.

 

Mijn UBC1318ZG heeft de nieuwe boot file voor bridge mode met IPv6 nog niet ontvangen en ga vooralsnog geen handmatige power cycle doen om dit te forceren.

qqq
topicstarter
Gedreven Raadgever
  • 68Posts
  • 2Oplossingen
  • 16Likes

@tobiastheebe  schreef:

De regel vermeldt op beide modems ook 'IPv4'?


Ja, zojuist dubbelgecheckt.

 


@tobiastheebe  schreef:

Ik zou verwachten dat de regel 'IPv6' moet tonen bij een modem dat de boot file voor IPv6 in bridge mode heeft ontvangen, maar mogelijk heeft de regel alleen betrekking op het 10.0.0.0/8-subnet tussen CMTS en CM's.


tobiastheebe
Super Expert
Super Expert
  • 8627Posts
  • 491Oplossingen
  • 3093Likes

Helder, daar kunnen we dus niets uit opmaken. Mogelijk heeft het toch met de firmware-versie te maken?

qqq
topicstarter
Gedreven Raadgever
  • 68Posts
  • 2Oplossingen
  • 16Likes

Het is in ieder geval een plek waar we de verschillen kunnen minimaliseren. Dus als dat te regelen is, lijkt me dat een productieve stap.

Paul
Community Moderator
Community Moderator
  • 11460Posts
  • 952Oplossingen
  • 3070Likes

@qqq Om een en ander uit te sluiten zou ik het modem even voor je uit bridgedmodus kunnen halen om te testen of het modem dan weer IPV6 Full Dualstack krijgt. Als dat dan werkt, weten we zeker dat het iets in de configuratie achter het modem moet zitten. Mocht je ook in routermodus geen IPV6 Full Dualstack krijgen, dan zou ik het nader moeten onderzoeken.

qqq
topicstarter
Gedreven Raadgever
  • 68Posts
  • 2Oplossingen
  • 16Likes

@Paulals je zegt "achter het modem", bedoel je dan in mijn netwerk thuis, of in het netwerk bij Ziggo?

Paul
Community Moderator
Community Moderator
  • 11460Posts
  • 952Oplossingen
  • 3070Likes

@qqq Sorry voor de verwarring. In dit geval bedoel ik met achter het modem het thuisnetwerk. 

qqq
topicstarter
Gedreven Raadgever
  • 68Posts
  • 2Oplossingen
  • 16Likes

In dat geval snap ik niet zo goed wat de door jou voorgestelde test ons gaat opleveren. Ik zou liever zien dat we eerst de firmware van het modem bijwerken tot de laatste versie, zoals ik oorspronkelijk vroeg en zoals @tobiastheebe net ook suggereerde. Is het mogelijk dat voor me aan te vragen?

E-mail notificaties
Aan Uit

Ontvang een update bij nieuwe reacties in dit topic.

Uitgelicht topic