Hans_R
Gedreven Meedenker
  • 20Reacties
  • 0Oplossingen
  • 2Likes

FTP faalt sinds 6 april 6u40

Ik heb een stuk software voor een meteo station (Cumulus) dat 24/7 draait en bestanden upload naar een server. Dat ging - al heel lang - tot 6 april 6u40 goed maar sindsdien krijg ik de melding tijdens het overdrachtsproces :

 

(Authentication failed because the remote party has closed the transport stream.)

 

Gesproken met de hosting service en die verwijst duidelijk naar Ziggo ivm de afhandeling van het FTP protocol  in combinatie met firewall. Het maken van de verbinding gaat prima maar het uploaden zelf gaat fout.

 

WinSCP geeft geen probleem.

Aan mijn kant is niets veranderd, de fail was spontaan na een herstart van de software na backup (dus een herinitialisatie) terwijl er er verder niets veranderd was (instellingen of zo).

 

Wie heeft een suggestie?

33 Reacties 33
Hans_R
topicstarter
Gedreven Meedenker
  • 20Reacties
  • 0Oplossingen
  • 2Likes

Er bleek een kabelbreuk bij Alphen a/d Rijn verantwoordelijk voor deze storing.

Alles voorbij en het functioneert weer prima.

 

Hans_R
topicstarter
Gedreven Meedenker
  • 20Reacties
  • 0Oplossingen
  • 2Likes

Dat functioneert dus helaas niet meer. Of de kabelbreuk er echt iets mee te maken heeft gehad is mij onduidelijk maar het probleem bestaat dus nog steeds (of weer).

 

De helpdesk weet echt van niets (weet niet eens wat FTP is) en de hosting provider wijst naar Ziggo. Om kort te gaan: ik val zo mooi tussen wal en schip.

 

De vraag blijft: wat is hier aan de hand en hoe onderzoek ik dat cq los ik het op?

 

Steefb
Expert
Expert
  • 9131Reacties
  • 1646Oplossingen
  • 2705Likes

Is je ip adres niet veranderd? Dat kan heel lang hetzelfde blijven, maar bij een grotere storing alle kans dat dat veranderd .

Hans_R
topicstarter
Gedreven Meedenker
  • 20Reacties
  • 0Oplossingen
  • 2Likes

Hi Steefb, nee, dat is niet veranderd.

Ik betwijfel ook of dat een oorzaak van het probleem zou zijn als het wel veranderd was.

 

Hans_R
topicstarter
Gedreven Meedenker
  • 20Reacties
  • 0Oplossingen
  • 2Likes

Leest iemand deze berichten trouwens wel? Ik geeft duidelijk aan dat het helemaal niet opgelost is en dan gaat er iemand mijn eerste melding dat het opgelost is als oplossing markeren. Wie doet dat? Is dat een moderator?

 

Nee, mijn probleem is helemaal niet opgelost. Helaas.

Ronihd
Super Expert
Super Expert
  • 7200Reacties
  • 265Oplossingen
  • 2133Likes


@Hans_R  schreef:

Leest iemand deze berichten trouwens wel? Ik geeft duidelijk aan dat het helemaal niet opgelost is en dan gaat er iemand mijn eerste melding dat het opgelost is als oplossing markeren. Wie doet dat? Is dat een moderator?

 

Nee, mijn probleem is helemaal niet opgelost. Helaas.


 

Uiteraard worden topics gelezen maar het is uiteraard niet zo dat het dan zo direct opgelost is en ook als een moderator het leest , ook hun kunnen niet alles oplossen.

 

Als ik op de foutmelding google krijg ik onder andere dit te zien : Ik kon inderdaad contact opnemen met de persoon die verantwoordelijk is voor de servers en een van de machines bereikte een limiet en verbrak de verbindingen ...

 

En dit ? https://gunnarpeipman.com/aspnet-mvc-authentication-failed-security-protocol/

 

Bovenstaande kan het probleem oplossen ? maar met zekerheid kan ik je vertellen dat het niet aan de kabelbeuk ligt , het was een glasvezel verbinding die kapot was en het lassen van die kabels kan niet fout gaan , zo wel dan werkt er niks.

 

 

Hans_R
topicstarter
Gedreven Meedenker
  • 20Reacties
  • 0Oplossingen
  • 2Likes


Uiteraard worden topics gelezen maar het is uiteraard niet zo dat het dan zo direct opgelost is en ook als een moderator het leest , ook hun kunnen niet alles oplossen.
[...]

Bovenstaande kan het probleem oplossen ? maar met zekerheid kan ik je vertellen dat het niet aan de kabelbeuk ligt , het was een glasvezel verbinding die kapot was en het lassen van die kabels kan niet fout gaan , zo wel dan werkt er niks.

OK, duidelijk.

 

Wat betreft je oplossingen die gaan over twee schijven:

 

  1. Servers die limieten bereiken
  2. Protocol selectie in mijn applicatie.

 

ad 1) Hoe kom ik bij iemand die die server chain kan nakijken of hoe kom ik te weten welke server het is?

 

ad 2) Mijn protocol selectie is:

SslProtocols = SslProtocols.Default | SslProtocols.Tls11 | SslProtocols.Tls12,

 

Het lijkt me dat daar iets mee is en dat ik eigenlijk None moet selecteren zodat het systeem de juiste selectie maakt. (zie docu hier). Dank voor de hint, ik ga er mee aan de gang en rapporteer terug.

Ronihd
Super Expert
Super Expert
  • 7200Reacties
  • 265Oplossingen
  • 2133Likes

oke , ik heb er niet zoveel verstand van dat ik daar echt de diepte mee in kan , maar een beetje googgelen kan helpen.

Als jij niets hebt veranderd moet het eigenlijk wel bij de tegenpartij zitten  ? Het is makkelijk om dit bij Ziggo neer te leggen maar als er bij Ziggo zo iets in een FTP protocol zou zijn veranderd ( ik zou niet weten wat ) dan zouden er toch veel meer klachten moeten zijn lijkt mij ? 

Hans_R
topicstarter
Gedreven Meedenker
  • 20Reacties
  • 0Oplossingen
  • 2Likes

OK. Het protocol dmv None op automatische selectie zetten helpt niet, ik krijg dezelfde foutmelding.

Als het nodig is kan ik de hele stacktrace hier dumpen, laat dan maar even weten.

De vraag is volgens mij: welke server op de route is op 6/4 om 6u40 in de ochtend ineens gaan protesteren en hoe  kom ik daar achter.

 

De hosting provider wijst naar Ziggo maar die beheert denk ik niet alle servers. Enige mogelijkheid hier grip op te krijgen?

Hans_R
topicstarter
Gedreven Meedenker
  • 20Reacties
  • 0Oplossingen
  • 2Likes

OK, jouw reactie was nog niet verschenen toen ik mijn vorige reactie poste.

 


@Ronihd  schreef:

oke , ik heb er niet zoveel verstand van dat ik daar echt de diepte mee in kan , maar een beetje googgelen kan helpen.

Als jij niets hebt veranderd moet het eigenlijk wel bij de tegenpartij zitten  ? Het is makkelijk om dit bij Ziggo neer te leggen maar als er bij Ziggo zo iets in een FTP protocol zou zijn veranderd ( ik zou niet weten wat ) dan zouden er toch veel meer klachten moeten zijn lijkt mij ? 


Ja, dat lijkt me ook. Ik zie het dan ook meer als een overschrijding van een limiet. Het protocol zelf zal niet veranderd zijn. Maar waar en welke limiet (ik stuur elke 30 seconden een klein bestand op en elke tien minuten een serie grotere bestanden).

 

Ronihd
Super Expert
Super Expert
  • 7200Reacties
  • 265Oplossingen
  • 2133Likes

Meer info en kennis heb ik er ook niet van.

 

Misschien dat  @Jonathan-458  er iets meer over kan zeggen als hij online is/komt  ? 

 

Hans_R
topicstarter
Gedreven Meedenker
  • 20Reacties
  • 0Oplossingen
  • 2Likes

@RonihdOK, bedankt zover. Wie weet krijg je nog een idee of haakt @Jonathan-458 aan.

Ronihd
Super Expert
Super Expert
  • 7200Reacties
  • 265Oplossingen
  • 2133Likes

Ik weet niet wanneer hij online komt of is 

Jonathan-458
Super Expert
Super Expert
  • 2304Reacties
  • 155Oplossingen
  • 735Likes

Beste @Hans_R,

 

Heb dit ooit eerder gehad op een Azure instance, toen was ik vergeten het client certificaat in te stellen en ook had ik de TLS versie op minimaal 1.0 staan ipv 1.1 of 1.2.

 

Dit loste destijds mijn probleem op, ik zie echter dat u al gebruik maakt van TLS1.2, klopt het certificaat bestand en/of is het mogelijk zelf een nieuwe te genereren of te ontvangen van uw host?

 

Over het algemeen heeft dit probleem overigens niet met Ziggo te maken, Het is meestal client of server sided issue. Het kan alleen misschien een probleem zijn als u IPv6 DS-Lite heeft.

 

MVG

Hans_R
topicstarter
Gedreven Meedenker
  • 20Reacties
  • 0Oplossingen
  • 2Likes

Dag Jonathan,

 

Bedankt voor je reactie.

 


Dit loste destijds mijn probleem op, ik zie echter dat u al gebruik maakt van TLS1.2, klopt het certificaat bestand en/of is het mogelijk zelf een nieuwe te genereren of te ontvangen van uw host?

Ik heb werkelijk geen idee waar ik dat certificaat moet zoeken. Het is een applicatie gebouwd in C# en alle SSL/FTPS werkt zo out of the box. Ik heb nooit een certificaat ingesteld en heb ook geen idee waar en hoe dat zou moeten. Ik ga er even vanuit dat het  runtime systeem daarvoor zorgt.

 


Over het algemeen heeft dit probleem overigens niet met Ziggo te maken, Het is meestal client of server sided issue. Het kan alleen misschien een probleem zijn als u IPv6 DS-Lite heeft.

1) als het een client sided issue zou zijn dan kan FTPS niet zomaar ineens er mee stoppen terwijl er aan het systeem niets veranderd is (ik was niet eens thuis) dus dat moeten we denk ik uitsluiten tenzij het heel goed beargumenteerd wordt.

 

2) server sided was ook mijn eerste gedachte maar na discussie met de hoster opzij gezet omdat zij claimen dat er aan hun kant niets veranderd was in de FTP configuratie.

 

Dat laat het transport dus over. En daar is wel iets voor te zeggen omdat zowel FTP als SFTP het gewoon doen maar FTPS niet. Dwz die maakt wel contact maar het gaat fout bij het transfer. Dus de commando poort (in dit geval 21) gaat goed maar de data poort - die random is ergens in de 50000 - daar gaat het mis. Het zou dus heel goed wel eens ergens een routing issue of een firewall issue van die datapoorten kunnen zijn.

 

De poorten 21 en 22 van FTP en SFTP worden wel doorgelaten maar die random datapoort voor de passieve verbinding daar lijkt het probleem te zitten.

 

Mvg. HansR

Jonathan-458
Super Expert
Super Expert
  • 2304Reacties
  • 155Oplossingen
  • 735Likes

Goede middag @Hans_R,

 

Als u in het verleden inderdaad geen apart certificaat handmatig in moest laden en hier niks in gewijzigd is dan kunnen wij dat overslaan.

 

Lukt het wel om via een ander netwerk een verbinding op te zetten naar deze server?
(bijvoorbeeld via VPN of mobiel netwerk / hotspot)

 

Heeft u alleen een connectbox of eigen router er achter hangen en zijn deze na het herstellen van de werkzaamheden opnieuw opgestart?

 

MVG

Hans_R
topicstarter
Gedreven Meedenker
  • 20Reacties
  • 0Oplossingen
  • 2Likes

Goedemiddag @Jonathan-458,

 

Dank voor de reactie.

 

Ja het lukt om een andere verbinding op te zetten. Sterker, het lukt zelfs via WinSCP vanaf dezelfde machine via TLS (automatische protocol keuze) maar die verbinding verbreekt automatisch weer vrij snel. Het  maken van de verbinding kan, via WinSCP is transfer ook wel mogelijk.

 

Ik heb alleen de connectbox zonder eigen router. En ja, die is al herhaaldelijk opnieuw opgestart.

 

Mvg,

HansR

Jonathan-458
Super Expert
Super Expert
  • 2304Reacties
  • 155Oplossingen
  • 735Likes

Goede middag @Hans_R,

 

Okey, dus via een ander netwerk i.c.m. WinSCP werkt het geheel naar behoren?

 

Het gaat dus alleen fout wanneer er via Ziggo's vaste verbinding een data transfer gestart moet worden.

 

Is het mogelijk om te testen met een eigen router?

 

MVG

Hans_R
topicstarter
Gedreven Meedenker
  • 20Reacties
  • 0Oplossingen
  • 2Likes

Dag @Jonathan-458 ,


Okey, dus via een ander netwerk i.c.m. WinSCP werkt het geheel naar behoren?

Het 'in combinatie' heb ik niet geprobeerd. De FTP site is in elk geval voor zover ik kan zien via andere netwerken bereikbaar.


Vanaf mijn eigen computer kan ik WinSCP gebruiken en dan krijg ik ook verbinding (ik krijg altijd verbinding alleen kan niet altijd een transfer plegen, de verbinding verbreekt.


Het gaat dus alleen fout wanneer er via Ziggo's vaste verbinding een data transfer gestart moet worden.

Ja, daar lijkt het wel op.


Is het mogelijk om te testen met een eigen router?

Ik heb geen eigen recente alternatieve router ter beschikking. Ik heb alleen nog een Linksys WRT54G van iets van 30 jaar oud. Ik weet niet eens of die het nog doet en ik heb daar indertijd Linux op geïnstalleerd en heb die onlangs weer geïnitialiseerd op Linksys software maar nooit geprobeerd. Lijkt me niet het ideale test-ding. En los daarvan - want ik ben wel even gaan kijken of ik die überhaupt aan kon sluiten - ik kan dat hele ding niet aansluiten omdat ik geen verloop van coax naar RJ11 heb. Helaas dus.


Met vriendelijke groet,

HansR

Uitgelicht topic