Don Leone
Ontdekker
  • 6Reacties
  • 1Oplossingen
  • 1Likes

EPC3928 – Foscam-C1 problematiek en oplossing

Ik heb problemen met het benaderen van Foscam type C1 IP Cams via internet.
Dit heeft waarschijnlijk te maken met Port Forwarding in de Cisco EPC3928 router.
Ik heb zowel de handleiding van Ziggo als van de fabrikant bekeken, de term “Port forwarding” is in beide totaal niet te vinden. Een gesprek met Ziggo draaide er op uit dat ze geen ondersteuning willen bieden. Vreemd omdat het m.i. hun product is dat het probleem veroorzaakt. Ik hoop dat deze community mij kan helpen. Er zijn verschillende threads over dit onderwerp, maar nèt niet datgene wat ik zoek of mijn probleem oplost.

Beschrijving thuissituatie:
Na het modem komt de Sisco EPC3928 router, daaraan is een Netgear WNDR3700 router gekoppeld. Aan die router hangen een Netgear NAS, Smart TV, de ene IP cam (bedraad) en een lijn naar de 1e etage waar een Apple Time machine staat (router & backup). Aan die laatste hangen de iMac, een Windows computer en twee printers (alles bedraad). Tenslotte is de andere IP cam via 2.4 Ghz WiFi verbonden met de Netgear router.

De apps:
De Foscam app waarmee ik de instellingen van de cams kan aanpassen, maar niet de IP-adressen en ook geen poorten. Sterker, ik kan die info niet eens boven tafel krijgen met die app, alleen dat de cams aangesloten zijn op het 2.4 Ghz WiFi netwerk. Wat ik voor het bedrade exemplaar wel vreemd vindt.
De OWLRFoscam app. Doet hetzelfde als bovenbeschreven “fabrieks”-app. Toont wel IP-adres en poortnummer. Bij het toevoegen van de cams past hij het poortnummer random aan. Maar wijzigen naar eigen gekozen adressering is onmogelijk.

Bevindingen in het veld:
Thuis werkt alles vlekkeloos (iMac en iPhone). Ben ik bij vrienden en ga op hun WiFi netwerk met de iPhone, dan kan ik de bedrade cam altijd bekijken, het WiFi exemplaar nooit. Op straat is het een kwestie van geluk hebben om het bedrade exemplaar te kunnen bekijken. Weet niet waarom dat random is. Krijg wel altijd en overal bewegingsmeldingen op m’n smartphone en zelfs op m’n horloge. Dat werkt dus wel.

Experimenteren met de Netgear router:
Daarop kan ik interne poorten openzetten. Die zijn van het type 10.0.0.xx:yyyyyy, duidelijk interne IP-adressen. Het lijkt alsof het openzetten of niet openzetten geen enkele invloed op het resultaat heeft.

Experimenteren met de Sisco router:
Ik probeer bij Applications & Gaming poorten open te zetten.
Ext houdt ik op 0 – 0.
IP adres 83.85.xxx.xxx (mijn externe, vaste IP adres)
IPv4
Startpoort = Eindpoort = yyyyyy
Protocol Both
Enable aangevinkt.
Deze instelling en vele andere die ik heb geprobeerd leveren een melding dat het een invalid IP adres is.
Verder staat de firewall op Low, IPv6 op on. Block port scan is aangevinkt, maar zonder vinkje helpt ook niet.
DMZ is disabled
UPnP is enabled
Al het andere is niet van toepassing of gaat me boven de pet.

Overige:
Ik trek de conclusie dat er blijkbaar WEL een poort openstaat, hoe kan ik anders bij vrienden wel de bedrade cam bekijken.
Alle variaties van poortscanning levert op dat alle veelgebruikte poorten dicht staan (ook 80, hoe kan ik dan internetten?). Ook de poorten van de cams staan dicht.
Heb wat gelezen over vaste IP adressen aan de cams toewijzen. Daarbij worden voorbeelden genoemd van IP nummers, maar die hebben de structuur van externe IP adressen. Hoe dat kan op je interne netwerk vat ik ook niet.

Graag jullie support, want ik ben out of options op dit moment.
1 Geaccepteerde oplossing

Geaccepteerde oplossingen
Don Leone
topicstarter
Ontdekker
  • 6Reacties
  • 1Oplossingen
  • 1Likes
EPC3928 – Foscam-C1 De Oplossing

Helaas heeft deze community niet aan mijn verwachtingen voldaan. Geen enkele reactie op mijn vraagstelling.
Dus zelf overal op internet rondgestruind en uiteindelijk zelf de oplossing gevonden.
Kost veel tijd, voordeel is dat ik er een hoop van geleerd heb.
Voor degenen met soortgelijke problemen hierbij de oplossing en wat tips.

Eerst in de verkeerde richting gezocht door te denken dat port forwarding de oplossing zou zijn.
Niet dus. Als je de cams bedraad wel in de buitenwereld kan zien, maar niet als ze op WiFi aangesloten zijn, dan is de oorzaak niet een dichtstaande poort.

Geef je cam een statisch IP-adres en de zaak loopt als een trein.
Daarvoor heb ik eerst in mijn eigen router aangegeven dat het uitdelen van dynamische adressen bij 10 mag beginnen.
Je hebt 10.0.0.2 t/m 10.0.0.255 ter beschikking (nr. 1 is standaard de router zelf). Voor mijn Netgear vind ik dat onder LAN instellingen, Router gebruiken als DHCP server (dynamisch toewijzen van IP adressen in bovengenoemde serie), het vakje “starten bij” 10.0.0.x ingevuld (ik heb dus voor x=10 gekozen). Nummers 2 t/m 9 zijn dan als vaste IP adressen toe te wijzen.

Hoe zit het bij jouw router? Ga naar de site portforward.com, dan “How to setup your router”. Moet wel heel vreemd zijn als die van jou er niet bij staat.

Eerst je IP cam installeren volgens gebruiksaanwijzing. Als je die (later) via WiFi wil gebruiken toch eerst bedraad installeren. Mijn ervaring is dat dit het makkelijkst gaat en altijd lukt.

Achterhalen van benodigde info.
Uit de App store haal je Foscam (van de leverancier) en OWLRFoscam (derden). De laaste heeft het voordeel dat het IP adres en poortnummer op te vragen is. Een andere mogelijkheid is een app als Net Analyzer.
Verder heb je de “myfoscam” site van de leverancier. Daarmee kan je op je computer de cambeelden bekijken. Ik krijg er op die site echter geen adresinfo uit. Heb je eenmaal het IP adres en poortnummer, dan in je browser die gegevens invoeren. Voor mij was dat o.a. 10.0.0.18:55000 (let op de dubbele punt voor het poortnummer).
Nu krijg je een overvloed aan info over je IP cam te zien.
By the way: heb je te maken met slechts 1 router (de modem/router van Ziggo), dan zit je waarschijnlijk in de 192.168.178.x range.

In het gedetailleerde overzicht van Foscam zoek je het tabje Network, IP configuration. Zet de vink bij DHCP uit (dus geen dynamisch adres). Pas het IP-adress aan naar een keuze in de range die je vrij hebt gehouden. Voor mij in bovenstaand voorbeeld dus tussen 10.0.0.2 en 10.0.0.9. Save.
Dan naar Wireless Settings. Voer je netwerknaam in (SSID), weet je het niet exact, dan even de scan button gebruiken. Denk eraan dat Foscam met 5.0 Ghz waarschijnlijk niet werkt, neem dus een 2.4 Ghz verbinding (kan je opzoeken in je router). Encryption is normaal gesproken WPA2 (dat is een reeds gemaakte keuze in de router).

En toen werkte de boel: de cams bekijken via twee routers en door twee firewalls heen.

Mocht jouw probleem wel zitten in port forwarding, dan is het handig om portforward.com te raadplegen met specifieke info per router. Vooral als het gaat om een dubbele router configuratie.

Als je alle je apparatuur uitzet, dan is de opstartvolgorde van groot belang. De eerste router die aangaat wordt de baas. De volgende zijn geen “echte” routers meer, maar zijn alleen nog maar verdeelstations, toewijzen doen ze niets.
Voor mij is het eerst de Netgear router aanzetten (de plek je waar ik de instellingen regel), dan de Apple airport time capsule en als laatste de Cisco modem/router. Telkens wachten totdat alle benodigde lampjes branden.

Wil je meer weten over al die netwerk kreten, dan is Tweaking4All “Grondbeginselen Thuisnetwerk” een goed te begrijpen en informatieve site.

Bekijk in context

1 Reactie 1
Don Leone
topicstarter
Ontdekker
  • 6Reacties
  • 1Oplossingen
  • 1Likes
EPC3928 – Foscam-C1 De Oplossing

Helaas heeft deze community niet aan mijn verwachtingen voldaan. Geen enkele reactie op mijn vraagstelling.
Dus zelf overal op internet rondgestruind en uiteindelijk zelf de oplossing gevonden.
Kost veel tijd, voordeel is dat ik er een hoop van geleerd heb.
Voor degenen met soortgelijke problemen hierbij de oplossing en wat tips.

Eerst in de verkeerde richting gezocht door te denken dat port forwarding de oplossing zou zijn.
Niet dus. Als je de cams bedraad wel in de buitenwereld kan zien, maar niet als ze op WiFi aangesloten zijn, dan is de oorzaak niet een dichtstaande poort.

Geef je cam een statisch IP-adres en de zaak loopt als een trein.
Daarvoor heb ik eerst in mijn eigen router aangegeven dat het uitdelen van dynamische adressen bij 10 mag beginnen.
Je hebt 10.0.0.2 t/m 10.0.0.255 ter beschikking (nr. 1 is standaard de router zelf). Voor mijn Netgear vind ik dat onder LAN instellingen, Router gebruiken als DHCP server (dynamisch toewijzen van IP adressen in bovengenoemde serie), het vakje “starten bij” 10.0.0.x ingevuld (ik heb dus voor x=10 gekozen). Nummers 2 t/m 9 zijn dan als vaste IP adressen toe te wijzen.

Hoe zit het bij jouw router? Ga naar de site portforward.com, dan “How to setup your router”. Moet wel heel vreemd zijn als die van jou er niet bij staat.

Eerst je IP cam installeren volgens gebruiksaanwijzing. Als je die (later) via WiFi wil gebruiken toch eerst bedraad installeren. Mijn ervaring is dat dit het makkelijkst gaat en altijd lukt.

Achterhalen van benodigde info.
Uit de App store haal je Foscam (van de leverancier) en OWLRFoscam (derden). De laaste heeft het voordeel dat het IP adres en poortnummer op te vragen is. Een andere mogelijkheid is een app als Net Analyzer.
Verder heb je de “myfoscam” site van de leverancier. Daarmee kan je op je computer de cambeelden bekijken. Ik krijg er op die site echter geen adresinfo uit. Heb je eenmaal het IP adres en poortnummer, dan in je browser die gegevens invoeren. Voor mij was dat o.a. 10.0.0.18:55000 (let op de dubbele punt voor het poortnummer).
Nu krijg je een overvloed aan info over je IP cam te zien.
By the way: heb je te maken met slechts 1 router (de modem/router van Ziggo), dan zit je waarschijnlijk in de 192.168.178.x range.

In het gedetailleerde overzicht van Foscam zoek je het tabje Network, IP configuration. Zet de vink bij DHCP uit (dus geen dynamisch adres). Pas het IP-adress aan naar een keuze in de range die je vrij hebt gehouden. Voor mij in bovenstaand voorbeeld dus tussen 10.0.0.2 en 10.0.0.9. Save.
Dan naar Wireless Settings. Voer je netwerknaam in (SSID), weet je het niet exact, dan even de scan button gebruiken. Denk eraan dat Foscam met 5.0 Ghz waarschijnlijk niet werkt, neem dus een 2.4 Ghz verbinding (kan je opzoeken in je router). Encryption is normaal gesproken WPA2 (dat is een reeds gemaakte keuze in de router).

En toen werkte de boel: de cams bekijken via twee routers en door twee firewalls heen.

Mocht jouw probleem wel zitten in port forwarding, dan is het handig om portforward.com te raadplegen met specifieke info per router. Vooral als het gaat om een dubbele router configuratie.

Als je alle je apparatuur uitzet, dan is de opstartvolgorde van groot belang. De eerste router die aangaat wordt de baas. De volgende zijn geen “echte” routers meer, maar zijn alleen nog maar verdeelstations, toewijzen doen ze niets.
Voor mij is het eerst de Netgear router aanzetten (de plek je waar ik de instellingen regel), dan de Apple airport time capsule en als laatste de Cisco modem/router. Telkens wachten totdat alle benodigde lampjes branden.

Wil je meer weten over al die netwerk kreten, dan is Tweaking4All “Grondbeginselen Thuisnetwerk” een goed te begrijpen en informatieve site.

Bekijk in context

Uitgelicht topic