1
Vraag
2
Reacties
R-Ubels

Level 2
  • 6Posts
  • 2Oplossingen
  • 4Likes

Authentication fout bij verzending mail Synology

Hallo,

Ik ben een Synology DSM 7.1 Mailplus aan het instellen voor mailverkeer en kies de Ziggo SMTP instellingen voor uitgaande mail. Ik heb de onderstaande settings gebruikt:

Uitgaande serverinstellingen

  • server: smtp.ziggo.nl
  • serverpoort: 587
  • type versleuteling: STARTTLS (geen andere optie mogelijk in Synology)
  • verificatie vereist: ja
  • gebruikersnaam: volledig e-mailadres
  • wachtwoord: je e-mailwachtwoord

Ik heb een half jaar geleden vernomen dat Ziggo alleen nog maar STARTTLS accepteert voor uitgaande mail. Mijn vorige server ondersteunde dit niet meer, maar Synology wel. Dit is bij hen de enige optie en wordt ook vermeld als een versleutelingsoptie op de site van Ziggo. (https://www.ziggo.nl klantenservice/e-mail/serverinstellingen)

 

Als ik een mail verstuur komt deze echter in de wachtrij met 'deferred' melding. De mail wordt door Ziggo niet geaccepteerd.

 

De foutmelding daarbij is:

SASL authentication failed; server smtp.ziggo.nl[212.54.42.9] said: 535 5.7.0 SMTP301 Authentication failed for user xxxxxx@xxxxxxx.nl ;id=DnzJp5onEHKcS;sid=DnzJp5onEHKcS;mta=smtp2.tb;d=20230106;t=154640[CET];ipsrc=xx.xx.xx.xx;
 
Voor inkomende mail gebruik ik een MX record voor twee domeinen (werk en privé) welke ingesteld zijn bij mijn hosting provider.
 
Voor de verificatie heb ik het volgende ingesteld bij mijn hosting provider:
 
  • SPF
  • DKIM
  • DMARC
  • DANE

Ik weet niet of deze instellingen welke ingesteld zijn voor mijn domein misschien conflicteren bij de verzending naar Ziggo. Maar als ik ze uit zet blijft de foutmelding aanwezig.

 

Wie kan mij helpen om deze fout te verhelpen?

Oplossingen

Geaccepteerde oplossingen
R-Ubels
Topicstarter
Level 2
  • 6Posts
  • 2Oplossingen
  • 4Likes

Op magische wijze lijkt het nu opgelost. Ik denk dat omdat ik de DNS verwijzing naar externe servers vrij laat had ingesteld dat de verificatie van diverse beveiligingsprotocollen zoals SPF, DKIM, DMARC en DANE nog niet doorgewerkt was in het WWW. Volgens mij was dat de oorzaak.

Bekijk in context

R-Ubels
Topicstarter
Level 2
  • 6Posts
  • 2Oplossingen
  • 4Likes

Ook dit weer sneller opgelost dan ik dacht.

Ik had nog een verzend relay uitzonderingsregel staan dat alle mail van domein 2 altijd verzonden moet worden via smtp.ziggo.nl (misschien met een fout ww?)

Die heb ik weg gehaald waarna de mailverzending werkt.

 

Synology verificatie.jpg

Bekijk in context

19 Reacties 19
Bert

Level 21
T.E.A.M.
  • 76396Posts
  • 5203Oplossingen
  • 22532Likes

Mail die je verzend met een ander domein als afzender, dan die domein namen die onder Ziggo vallen, via de smtp server van Ziggo, worden geblokt.

Die andere domein mails zullen verzonden moeten worden via de smtp server van dat domein of de smtp server van die provider.

puppie

Level 17
  • 2705Posts
  • 67Oplossingen
  • 1108Likes

Een speciaal synology forum, ook geheel Nederlands.

kijk daar eens of stel daar deze vraag.

> klik <

S4R

Level 16
  • 2057Posts
  • 71Oplossingen
  • 1296Likes

@Bert  schreef:

Mail die je verzend met een ander domein als afzender, dan die domein namen die onder Ziggo vallen, via de smtp server van Ziggo, worden geblokt.

Die andere domein mails zullen verzonden moeten worden via de smtp server van dat domein of de smtp server van die provider.


@Bert dat klopt niet wat je zegt, want dat werkt wel. Ik heb dat net getest.

Mijn zakelijke info@computer..........nl mail laten versturen met smtp.ziggo.nl komt gewoon aan.

 

Gebruik dan wel SMTP poort 465 en SSL/TLS

 

Bert

Level 21
T.E.A.M.
  • 76396Posts
  • 5203Oplossingen
  • 22532Likes

@S4R schreef:"Gebruik dan wel SMTP poort 465 en SSL/TLS"

 

Het klopt wel wat ik zeg via poort 587 en daar heeft TS het over.

 

De omweg die je noemt wordt niet vermeld op de standaard instellingen pagina van Ziggo IMAP-, POP-, SMTP-instellingen | Klantenservice | Ziggo

@R-Ubels heeft het over poort 587 en daar reageer ik op.

 

Gezien het aantal toenemende meldingen in de loop van de tijd op dit forum, dat het ineens niet meer lukt om mails te verzenden met een ander domein als afzender, lijkt het er sterk op dat deze manier van spam tegengaan, langzaam maar zeker, steeds verder uitgerold wordt.

Dit wordt in die topics topics ook bevestigd door de moderators.

Verzendende Poort 25 op steeds meer locaties dicht, poort 587 steeds verder dicht voor andere afzender domeinen, dan ga ik een poort 465 niet adviseren, want ik vermoed dat die ook niet lang meer beschikbaar zal zijn.

S4R

Level 16
  • 2057Posts
  • 71Oplossingen
  • 1296Likes

@Bert  587 en STARTTLS ook geen probleem hier. Dat klopt dus niet.

Om SMTP misbruik te voorkomen moet je je juist aanmelden.

Relaying zonder aanmelden werkt nergens meer. Net zoals inderdaad het gebruik van port 25.

efok

Level 17
  • 4060Posts
  • 219Oplossingen
  • 1628Likes

Het kan wel met een ander domein, zowel via 587 als 465,  maar je moet wel rekening houden met zaken als SPF. DKIM gaat helemaal niet werken. De kans dat deze route in een spamfilter bij de ontvanger blijft hangen is daarom duidelijk groter.Dat terzijde.

 

@R-Ubels je meldt toch wel aan met je ziggo account?

Bert

Level 21
T.E.A.M.
  • 76396Posts
  • 5203Oplossingen
  • 22532Likes

@S4R  schreef:

@Bert  587 en STARTTLS ook geen probleem hier. Dat klopt dus niet.

Om SMTP misbruik te voorkomen moet je je juist aanmelden.

Relaying zonder aanmelden werkt nergens meer. Net zoals inderdaad het gebruik van port 25.


Aanmelden is sowieso een must.

Geen probleem bij jou, mooi, dat komt dan nog wel.

Ik kijk simpelweg wat er op dit forum allemaal naar voren komt wat ineens niet meer werkt met mail verzending.

Vandaar mijn tekst: "Gezien het aantal toenemende meldingen in de loop van de tijd op dit forum, dat het ineens niet meer lukt om mails te verzenden met een ander domein als afzender, lijkt het er sterk op dat deze manier van spam tegengaan, langzaam maar zeker, steeds verder uitgerold wordt."

S4R

Level 16
  • 2057Posts
  • 71Oplossingen
  • 1296Likes

Ik vind het een rare redenatie. Het versturen gaat via smtp.ziggo.nl. Dan zouden er dus smtp servers zijn die het wel en niet doen. Het lijkt mij dat als je iets uit zet voor smtp.ziggo.nl het overal uit gaat en niet bij de ene wel en bij de andere niet.

Enigma147

Level 7
  • 178Posts
  • 14Oplossingen
  • 155Likes

je zit helemaal verkeerd. Waarom wil je de ziggo mailserver gebruiken om te versturen, als je webhosting hebt?  

 

Gewoon de mailserver gebruiken die bij je webhosting zit voor de SMTP relay van je synology.  

Of probeer je iets heel anders voor elkaar te krijgen? 

Bert

Level 21
T.E.A.M.
  • 76396Posts
  • 5203Oplossingen
  • 22532Likes

@S4R  schreef:

Ik vind het een rare redenatie. Het versturen gaat via smtp.ziggo.nl. Dan zouden er dus smtp servers zijn die het wel en niet doen. Het lijkt mij dat als je iets uit zet voor smtp.ziggo.nl het overal uit gaat en niet bij de ene wel en bij de andere niet.


@S4R Het is ook een raar verhaal, als je telkens in kleine bosjes dat soort topics tegenkomt.

Leg het maar eens uit, als Ziggo zelf vooraf geen informatie hierover deelt.

 

Het lijkt wel of er getest wordt met aantal accounts en dan weer een aantal erbij enz., gezien de meldingen die telkens in kleine bosjes tegelijk komen en dan weer een poos niets en dat is zo al een aantal maanden bezig.

De communicatie ontbreekt volledig, het wordt over de schutting gegooid en zoek het als klant maar lekker zelf uit, de helpdesk heeft geen idee en verwijst dan naar het forum.

Wat een blamage.

Enigma147

Level 7
  • 178Posts
  • 14Oplossingen
  • 155Likes

@Bert Ja, dat viel mij ook al op.  vragen met dit onderwerp komen in golven. Het is ook schandalig dat Ziggo het niet aan de betreffende gebruikers van te voren communiceert en ze wijst op de juiste instellingen.

 

Dat mensen met problemen met het instellen vind ik nog eens niet zo gek, al zouden ze bijvoorbeeld een paar youtube filmpjes kunnen maken voor populaire email clients, als Outlook, Thunderbird, EM-cliënt, android en iphone. om maar een paar te noemen. Als ze dat deden zou het hier al een hoop schelen. 

Richard G.

Level 16
  • 1793Posts
  • 85Oplossingen
  • 949Likes

Inderdaad een blamage, net zoals het volledig afsluiten plots van poort 25 zonder enige vorm van communicatie. Daar gaat dit ook weer naar toe. Ik begin langzaam klaar te zijn met dat geneuzel van Ziggo op die manier.

Zolang je fatsoenlijk authenticeert met je Ziggo mail adres en wachtwoord op de SMTP, moet je eigenlijk ook voor een andere domeinnaam kunnen versturen.
Dit werd ook gedaan omdat niet alle hosters voor door hun geleverde diensten een smtp server leverden, de meesten doen dat nu wel.
SPF en DKIM instellingen maken daarvoor 0 uit, want dat wordt pas bij de ontvanger gecontroleerd en kan dan wel door de ontvangende mailserver geweigerd worden.

Echter dat genereert niet deze aparte SASL authenticatiefout die @R-Ubels hier laat zien.

Dus ja als dit weer een nieuwe anti-spam is van Ziggo.... pffff..... Vermoeiend. Laat ze eens duidelijkheid geven. Glasvezel ligt hier al en met deze flut communicatie wordt ie steeds interessanter hoor.

R-Ubels
Topicstarter
Level 2
  • 6Posts
  • 2Oplossingen
  • 4Likes

Op magische wijze lijkt het nu opgelost. Ik denk dat omdat ik de DNS verwijzing naar externe servers vrij laat had ingesteld dat de verificatie van diverse beveiligingsprotocollen zoals SPF, DKIM, DMARC en DANE nog niet doorgewerkt was in het WWW. Volgens mij was dat de oorzaak.

R-Ubels
Topicstarter
Level 2
  • 6Posts
  • 2Oplossingen
  • 4Likes

Dank allen voor het meedenken. Het lijkt dus gewoon allemaal te lukken met Ziggo. Zorg alleen dat als je de verificaties instelt bij je domein host dat je DNS op je DNS server goed ingesteld staat naar buiten toe en dat de verificaties de tijd krijgen om door het WWW heen te werken zodat je herkend wordt. Wellicht helpt dit een volgende die hier ook last van heeft.

Bert

Level 21
T.E.A.M.
  • 76396Posts
  • 5203Oplossingen
  • 22532Likes

Ik had eerder niet gezocht op de foutmelding, toch maar eens eerder doen de volgende keer, het kan ook een fout van de Ziggo mailserver geweest kunnen zijn: https://www.google.nl/search?q=SASL+authentication+failed 

 

“SASL login authentication failed generic failure” error mainly happens due to wrong configuration of authentication mechanism in mail server.

R-Ubels
Topicstarter
Level 2
  • 6Posts
  • 2Oplossingen
  • 4Likes

Helaas is de foutmelding weer ontstaan uit het niets.

De onderstaande foutmelding wordt echter alleen gemeld voor 1 van de twee domeinen ingesteld op mijn synology server.

 

ASL authentication failed; server smtp.ziggo.nl[212.54.42.9] said: 535 5.7.0 SMTP301 Authentication failed for user xxxxxxx@xxxxxxxxl.nl ;id=Fx8FpePzxQ9nm;sid=Fx8FpePzxQ9nm;mta=smtp3.tb;d=20230112;t=135645[CET];ipsrc=89.98.186.239;

 

Beide domeinen hebben het gedaan. Domein 1 is een ouder domein welke ik eerder ook al gebruikte Domein 2 is een nieuw domein. Beide domeinen verzenden via de zelfde SMTP server van Ziggo met de eerde genoemde instellingen overgenomen vanuit de Ziggo site. Het is op zich dus al vreemd dat mail van het ene domein wel verzonden wordt en van het andere domein niet.

 

Ik heb vervolgens alle verificatie instellingen van Domein 2 op mijn Argeweb domein host het zelfde gemaakt als de settings van Domein 1. En ca. 2 uur gewacht. De foutmelding blijft komen.

 

Maar het kan nog gekker!

 

Ik dacht: "Laat ik eens mijn Solcon SMTP server hier aan koppelen in plaats van Ziggo. Omdat ik altijd zo veel problemen ervaarde met Ziggo en uitgaande mail heb het kleinste account van Solcon, waar ik alleen mee kan versturen, aangehouden. Zo gezegd, zo gedaan, en ik heb weer twee mailtjes verstuurd. Domein 1 komt aan, domein 2 komt niet aan. Ik ga vervolgens naar de foutmelding kijken en wat stelt mijn verbazing! De foutmelding is precies het zelfde, inclusief de 'smtp.ziggo.nl' en de Ziggo gebruikersnaam! Dit ondanks dat ik het via mail.solcon.nl verstuur als SMTP server! Ik heb daarna mijn mailserver op nieuw opgestart om zeker te zijn dat niets blijft hangen in de settings. Dat mocht echter niet baten.

 

  1. De server gebruikt 1 SMTP uitgaand adres. Of ik die nu instel op Ziggo of op Solcon,de mailserver geeft een Ziggo foutmelding bij domein 2 en niet bij domein 1.
  2. Beide domeinen hebben het wel gedaan op de nieuwe Synology server. (misschien domein 2 maar kort, ik weet niet precies hoe lang domein 2 er uit ligt)
  3. De instellingen op Argeweb zijn het zelfde voor beide domeinen(zie foto hieronder)
  4. De verificatie van mijn Synology mailserver mailplus sluiten aan op die van Argeweb
  5. Domein 1 (oud domein) komt wel aan en domein 2 (nieuw domein) komt niet aan en staat als deferred in de mailserver met de genoemde SALS foutmelding.

Ik zou bijna zeggen dat er een filter op het internetverkeer zit die herkent dat er mail verkeer van domein 2 verzonden wordt en dat filtert. Maar dat lijkt mij ook sterk.

 

Vervolgens heb ik Ziggo gebeld. Helaas wordt je daar niet geholpen en vragen ze alleen of de webmail het doet. Als die het doet dan zeggen ze dat het aan je eigen software ligt....  😒

 

Argeweb en Synology settings

Argeweb instellingen.jpgSynology verificatie.jpg

 

Heeft iemand een idee waar dit aan kan liggen?

 

 

Enigma147

Level 7
  • 178Posts
  • 14Oplossingen
  • 155Likes

Waarom gebruik je niet de mailserver van argeweb?   Ik neem aan dat beide domeinen daar gehost worden?

R-Ubels
Topicstarter
Level 2
  • 6Posts
  • 2Oplossingen
  • 4Likes

Ook dit weer sneller opgelost dan ik dacht.

Ik had nog een verzend relay uitzonderingsregel staan dat alle mail van domein 2 altijd verzonden moet worden via smtp.ziggo.nl (misschien met een fout ww?)

Die heb ik weg gehaald waarna de mailverzending werkt.

 

Synology verificatie.jpg

R-Ubels
Topicstarter
Level 2
  • 6Posts
  • 2Oplossingen
  • 4Likes

Goed idee om ook eens te onderzoeken. Ik ging er altijd van uit dat ik alleen een domain hosting abbo had. Maar wellicht dat ik via MX records ook uitgaande mail rechtstreeks kan verzenden via Argeweb.

 

https://www.argeweb.nl/e-mail/kb/wat-zijn-de-mailservers-van-argeweb-115.html

 

Dit geprobeerd, werkt perfect! Bedankt voor de tip Enigma147!

 

E-mail notificaties
Aan Uit

Ontvang een update bij nieuwe reacties in dit topic.

Uitgelicht topic