1
Vraag
2
Reacties
CoosV

Level 3
  • 17Posts
  • 1Oplossingen
  • 5Likes

Asustor-nas niet extern bereikbaar

Ik heb een Asustor NAS, model AS-204TE en sinds enige tijd kan ik de Nas niet meer bereiken van buiten mijn netwerk. Ik heb alle instellingen nagelopen, poorten en zo, en die zijn goed. Binnen de NAS krijg ik ook allemaal groene vinkjes maar wat ik ook probeer, van buiten aanmelden lukt niet. ik zie wel verglijkbare problemen met synology nassen, maar daar kan ik niet zoveel mee. Heb de helpdesk van Ziggo gebeld maar daar kreeg ik een volkomen onwetende dame aan de lijn die nog nooit van een NAS gehoord had, laat staan dat ze weet wat ipv4 en ipv 6 is, laat staan het verschil. Ikzelf denk dat het inderdaad aan een firewall setting van de router ligt, maar hoe dit op te lossen? 

Een advies zou meer dan welkom zijn, want ik ben al dagen bezig met het zoeken naar een oplossing

Oplossing

Geaccepteerde oplossingen
CoosV
Topicstarter
Level 3
  • 17Posts
  • 1Oplossingen
  • 5Likes

Uiteindelijk is de oplossing zo simpel dat het bijna genant is. Het komt erop neer dat ik de ezconnect verbinding uit heb moeten zetten en de NAS opnieuw op moest starten en de ezconnect weer aan heb moeten zetten. Het loopt nu weer allemaal als een zonnetje.

Dank aan alle reageerders voor hun positieve meedenken en aandragen van oplossingen. Ben in elk geval dolblij dat het probleem is opgelost want werd er wel een beetje wanhopig van.

Bekijk in context

35 Reacties 35
jansmarcel

Level 16
  • 1591Posts
  • 77Oplossingen
  • 757Likes

Is de Ziggo modem ook de router in je netwerk? Zo ja is er portforwarding toegepast? Is je publieke IP-adres misschien aangepast en is het daardoor niet meer bereikbaar?

CoosV
Topicstarter
Level 3
  • 17Posts
  • 1Oplossingen
  • 5Likes

Het modem is idd ook de router binen mijn netwerk, of mijn ipadres is aangepast weet ik niet, in elk geval niet door mij. Hoe kan ik dit controleren? En verder wordt er geen contact gemaakt door het invullen van een ipadres, elke asusnas heeft een eigen unieke naam waarmee je via 'ezconnect', een webapplicatie, contact kunt maken met je nas van elke willekeurige plek ter wereld met een internetverbinding of mobiele telefoon.

jansmarcel

Level 16
  • 1591Posts
  • 77Oplossingen
  • 757Likes

Ik ken de asus nassen niet, blijkbaar werkt het vergelijkbaar met een synology.
Je IP adres kun je bijvoorbeeld via deze website achterhalen: https://www.whatismyip.com/
Het resultaat hoef je hier niet te posten. Wel even aangeven of het nog de oude of een andere is.
Een "handleiding hoe je de instellingen voor portforwarding kunt na lopen of instellen zou je hier moeten kunnen vinden: https://community.ziggo.nl/t5/Tips-van-Ziggo/Port-forwarding-op-het-SmartWifi-modem-voorheen-Connect...

Heb je vragen post ze hier. Dan kunnen we mee denken.

Marinus

Level 16
  • 1286Posts
  • 38Oplossingen
  • 406Likes

@CoosV 

 

Al deze stappen https://www.asustor.com/nl/admv2?type=5&subject=21&sub=124 heb je doorlopen?

 

Als ik het goed begrijp maakt de Asustor NAS een verbinding met een website op het internet.

 

Om van buiten het LAN (je eigen netwerk achter de router) verbinding te maken met je Asustor NAS ga je eerst naar deze website. Deze maakt dan verbinding met je NAS via de verbinding die eerder al is opgezet.

 

Geen poortforwarding nodig.

Geen problemen met firewalls. Deze kunnen (IPv4 en IPv6) op aan  blijven staan.

 

 

anoniemforum

Level 19
T.E.A.M.
  • 10130Posts
  • 594Oplossingen
  • 2856Likes

AS-204TE is een nas uit 2013 bijna

11 jaar oud en krijgt dus waarschijnlijk geen (beveiliging)updates meer

het is dan niet aanbevolen om de nas toegankelijk te maken via internet

 

Marinus

Level 16
  • 1286Posts
  • 38Oplossingen
  • 406Likes

@anoniemforum 

 

Ik ben het in principe met je eens, echter als het via  asustor ez-connect gaat is dat niet zo'n probleem. (Maar wellicht zit daar het probleem. Wordt de NAS niet langer ondersteund.)

 

Zolang de NAS niet achter poortforwarding zit is er eigenlijk geen probleem.

CoosV
Topicstarter
Level 3
  • 17Posts
  • 1Oplossingen
  • 5Likes

De beveiliging wordt nog steeds geupdated. Daar zit het probleem niet, graag oplossingen aandragen, geen aannames.

CoosV
Topicstarter
Level 3
  • 17Posts
  • 1Oplossingen
  • 5Likes

 



Het resultaat hoef je hier niet te posten. Wel even aangeven of het nog de oude of een andere is.

Mijn ipadres weet ik wel, maar hoe weet ik nou of het overeenkomt met mijn oude, maar volgens mij heb je een ip adres bij ezconnect niet nodig, je meldt je aan met de naam van je nas.

Ik heb het idee dat de firewall van het modem de boel blokkeert, want binnen mijn huisnetwerk kan ik de nas prima benaderen, zowel met mijn telefoon, ipad, laptop als pc.

Overigens heb ik alle poorten opengezet met gebruik van uPnP. En als ik de lijst bekijk, dat zijn er nogal wat, Zou ik deze dan allemaal handmatig opnieuw moten gaan opvoeren?

CoosV
Topicstarter
Level 3
  • 17Posts
  • 1Oplossingen
  • 5Likes

Gateway, is dat het ipadres van het modem, dus 192.168.178.1 of is dat het ipadres dat naar buiten gaat.

jansmarcel

Level 16
  • 1591Posts
  • 77Oplossingen
  • 757Likes

Het adres wat je hier noemt is het adres waar de instellingen van de modem op te bereiken zijn. Het is een intern adres. Vaak beginnen (interne) netwerken met 10.xxx.xxx.xxx of 192.168.xxx.xxx

Marinus

Level 16
  • 1286Posts
  • 38Oplossingen
  • 406Likes

@CoosV 

 

  1. voor ezconnect hoeven er géén poorten open gezet te worden
  2. voor ezconnect is upnp niet nodig, zet dus maar weer uit.
  3. een (inkomende) firewall blokkeert ezconnect niet

Als je op de site van ezconnect je probeert aan te melden met de naam van je NAS, wat gebeurt er dan?

CoosV
Topicstarter
Level 3
  • 17Posts
  • 1Oplossingen
  • 5Likes

Dan krijg ik de melding dat de connection has failed

afbeelding_2024-05-30_210138819.png 

 

CoosV
Topicstarter
Level 3
  • 17Posts
  • 1Oplossingen
  • 5Likes

ik heb dus uPnP uitgezet maar dat had geen positief gevolg

 

Marinus

Level 16
  • 1286Posts
  • 38Oplossingen
  • 406Likes

@CoosV 

 

Heb je op je NAS deze stappen doorlopen?

https://www.asustor.com/nl/admv2?type=5&subject=21&sub=124 

 

Je screenshot geeft aan wat er niet goed gaat:

- je cloudID op ezconnect is niet bekend

 - daarom kan je niet inloggen.

 

Heeft verder niets met je eigen/ziggo netwerk te maken.

CoosV
Topicstarter
Level 3
  • 17Posts
  • 1Oplossingen
  • 5Likes

Als ik intern, dus binnen mijn netwerk aanlog gaat het prima, ik heb ook contact met de helpdesk van ASUSTOR en van hen kreeg ik het antwoord:

 

I can see your NAS is able to communicate with the relay server.

Dus mijn id is wel bekend. Ik heb het ook al veranderd, maar dat had geen positef effect.

De stappen van ASUSTOR heb ik al doorlopen met nil, nada resultaat. Met webdav+ heb ik hetzelfde, intern loopt het als een trein maar van buiten kan ik er niet in.

Marinus

Level 16
  • 1286Posts
  • 38Oplossingen
  • 406Likes

Maar inloggen bij ezconnect lukt niet.

 

Het probleem lijkt mij daar te liggen.

Om van buitenaf toegang te krijgen tot je NAS moet je kunnen inloggen via ezconnect.

 

Waarom lukt dat niet?

Iets voor ASUSTOR om te beantwoorden.

 

Alles vanuit je netwerk gaat verder goed, er is communicatie met de relay server, maar er komt geen verbinding tot stand, waarom niet?

Is de software in de NAS wel de juiste versie? Minimaal 3.2?

CoosV
Topicstarter
Level 3
  • 17Posts
  • 1Oplossingen
  • 5Likes

ADM versie is 3.5.9.RWM1, dus ruim up to date.

Ik begin het idee te krijgen dat zowat alle ip's op een zwarte lijst staan, mijn nas wordt constant aangevallen en na drie pogingen komt dat ip adres op een zwarte lijst. Eer staan er inmiddels ruim 38000 op en ik heb het idee dat hier een begin van een oplossing ligt.

Marinus

Level 16
  • 1286Posts
  • 38Oplossingen
  • 406Likes

ADM versie is 3.5.9.RWM1, dus ruim up to date.

Dat is mooi!

 


Ik begin het idee te krijgen dat zowat alle ip's op een zwarte lijst staan, mijn nas wordt constant aangevallen en na drie pogingen komt dat ip adres op een zwarte lijst. Eer staan er inmiddels ruim 38000 op en ik heb het idee dat hier een begin van een oplossing ligt.


Dat zie je in je NAS?

Zo ja, 

  1. zet in ieder geval de firewall op de router AAN (voor IPv4 en IPv6) overige blokjes mogen uit blijven.
  2. haal alle poortforwarding regels naar je NAS weg (en voor de zekerheid ook de andere indien aanwezig)
  3. zet upnp uit
  4. herstart je router (niet nodig, maar.....) en herstart je NAS.
  5. kun je een andere ezconnect naam maken in de NAS?
  6. kijk daarna wat er gebeurt
Karel.

Level 16
  • 2118Posts
  • 269Oplossingen
  • 1465Likes

 

Heb je de blacklist in je NAS al eens geprobeerd te wissen. Misschien sta jezelf op een of ander manier ook in die blacklist. Die blacklist houd kennelijk ook webdav tegen. https://www.asustor.com/online/online_help?id=9

 

Die 38000 adressen zijn IP adressen van buitenaf die op jouw NAS proberen in te breken. Als je die blacklist dus kan wissen zal die daarna opnieuw opgebouwd worden door verdachte pogingen.

 

En/of zet je eigen WAN ip adres op de whitelist.

 

Heb je het ook al eens geprobeerd om in te loggen via deze link: http://cloudid.ezconnect.to/

Als dat ook niet werkt kan het mogelijk iets zijn met het modem bijvoorbeeld HAIRPIN-NAT wat momenteel in de Compal connectboxen/smartwifi modems niet meer lijkt te werken.

 

 

 

 

 

E-mail notificaties
Aan Uit

Ontvang een update bij nieuwe reacties in dit topic.

Uitgelicht topic