Markengel
Ontdekker
  • 4Posts
  • 1Oplossingen
  • 5Likes

Alternatieve DNS met je Connectbox en tegelijk advertenties blokkeren via Raspberry PI

Haĺlo,

Momenteel ben ik bezig een raspberry pi in te zetten naar een alternatieve DNS met add blocker (Pi-Hole). Nu loop ik tegen het feit aan dat mijn Connect box dat niet ondersteund betreft instellen alternatieve DNS.

Nu kwam ik een oud topic tegen (6 maanden geleden) op dit forum wat precies aansloot bij mijn probleem:

https://community.ziggo.nl/thuisnetwerk-software-101/toch-alternatieve-dns-met-je-connect-box-en-tegelijk-advertenties-blokkeren-via-raspberry-pi-26715

Nu loop ik vast Bij stap 3 en/of 4 het uitzetten van mijn dhcp en aanzetten van de dhcp in de pi-hole.

Als ik in de Connect box de dhcp uitzet, klapt mijn internet er uit. Wi-Fi en bekabeld werken beide niet meer.
Ook kan ik de router niet meer benaderen via een ethernet kabel. Uiteindelijk de router/modem een harde reset gegeven en de router/modem weer terug gekregen in zijn fabrieksinstellingen.

Edit*
Mijn Raspberry pi heb ik verbonden met Wi-Fi op het thuisnetwerk en heeft een vast IP adres ingesteld gekregen via een config-file van Raspbian (OS van de Pi).

Iemand hier ervaring mee en kan me verder helpen?

Groet,

Mark
1 Geaccepteerde oplossing

Geaccepteerde oplossingen
Markengel
topicstarter
Ontdekker
  • 4Posts
  • 1Oplossingen
  • 5Likes
Heb de Raspberry voorzien van een nieuwe raspbian stretch. Deze keer heb ik niet voor Wi-Fi gekozen, maar voor ethernet. Door deze file (/etc/wpa_supplicant/wpa_supplicant.conf) te bewerken had ik mijn wifi werkend gemaakt bij de vorige keer.

Setup van Pi-hole doorlopen. gekozen voor ipv4 en ipv6, statische ip adres voor Raspberry Pi en de DNS van openDNS.
Eigenlijk het zelfde ingesteld als de eerste keer behalve dat ik nu via eth0 verbinding heb.

In het modem van Ziggo heb ik de dhcp uitgezet en in het web interface-scherm van de pi hole heb ik de dhcp functie aangezet van de Pi.

Deze keer keer geen problemen 🙂
Alles werkt zoals het beschreven staat.
Geen advertensies te zien binnen mijn netwerk!

Dank voor de hulp.

Bekijk in context

14 Reacties 14
King006
Gedreven Raadgever
  • 490Posts
  • 9Oplossingen
  • 110Likes
Volgens mij moet de PI via LAN aangesloten zijn. Maar wellicht dat hgoor ondersteuning kan geven? 🙂
hgoor
Liefhebber
  • 27Posts
  • 0Oplossingen
  • 8Likes
King006 wrote:
Volgens mij moet de PI via LAN aangesloten zijn. Maar wellicht dat hgoor ondersteuning kan geven? 🙂


Correct: de Pi moet via Ethernet aangesloten zijn - althans mij is het nooit gelukt om wifi te gebruiken.

Via WiFi zal het niet betrouwbaar werken (wifi op de Pi is gewoon minder goed) en zal bovendien trager zijn qua afhandelen van de DNS aanvragen (elke aanvraag moet eerst naar je PiHole en dan van daaruit verder).
hgoor
Liefhebber
  • 27Posts
  • 0Oplossingen
  • 8Likes
Markengel wrote:
Edit*
Mijn Raspberry pi heb ik verbonden met Wi-Fi op het thuisnetwerk en heeft een vast IP adres ingesteld gekregen via een config-file van Raspbian (OS van de Pi).

Iemand hier ervaring mee en kan me verder helpen?

Groet,

Mark


Ik raad je aan om de ethernet aansluiting te gebruiken! Wederom vast IP enzo instellen, en de rest van de handleiding gebruiken, dan zou het goed moeten gaan.
Markengel
topicstarter
Ontdekker
  • 4Posts
  • 1Oplossingen
  • 5Likes
Super, dank voor de reacties. Ga vanavond als ik thuis ben aan de slag er mee.
efok
Expert
Expert
  • 3158Posts
  • 170Oplossingen
  • 1033Likes
Markengel Je bent niet de 1e die hier tegen aan loopt. Je hebt vermoedelijk DS-lite op je modem. In dit topic stelt de Topicstarter dat het uitschakelen van DHCP op je modem alleen voor IPv4 opgaat, en je modem vrolijk IPv6-adressen blijft uitdelen (niet heel raar, omdat IPv6 adressen, publieke adressen zijn, die je van Ziggo moet krijgen.) Daarbij geeft hij ook standaard DNS servers mee over IPv6.

Waar het exact misgaat in deze setup is me niet helemaal helder en kan ik niet voor je reproduceren omdat ik geen connectbox en geen DS-lite heb. Wellicht kan je in dat topic nog iets meer gewaar worden.

Hier is het ook al gesignaleerd.
DennyW
Expert
Expert
  • 2769Posts
  • 232Oplossingen
  • 690Likes
Als een apparaat een IP-adres heeft (al of niet statisch of toegewezen gekregen via DHCP) dan niet in het zelfde subnet zit dat weer een ander apparaat heeft, dan "zien" die twee elkaar niet.
Om de vicieuze cirkel te doorbreken welke apparaten elkaar wel of niet kunnen zien omdat deze, ten tijde van het confituren van de DHCP-pool en de IP-adressen, zelf IP-adressen hebben die niet "passen" in het subnet van de apparaten die je wilt aanpassen, even het volgende.:
Het wordt een "spelletje stuivertje wisselen".
Je kan dit door breken door een PC / laptop (tijdelijk) een statisch IP-adres te geven dat wel past in het sub net van het "onbereikbare" device.
Het IP-adres van de Pi-Hole is zelfs ook via de command line (b.v. met Putty) opnieuw in te stellen met het commando: pihole -r
efok
Expert
Expert
  • 3158Posts
  • 170Oplossingen
  • 1033Likes
Ik neem dat TS zijn pi-hole wel een IPv4 heeft gegeven in de range waarin ook de gateway van het modem valt. Dus dat komt dan wel goed. Er gaat ergens nog iets mis, omdat er IPv6 settings van het modem worden verkregen inclusief de Ziggo DNS servers. Als eerste wordt vermoedelijk geprobeerd het DNS verkeer over IPv6 af te handelen. Daarmee wordt de pi-hole dan gepasseerd. Ik zie alleen niet helder, waarom dit het hele netwerk onderuit zou moeten trekken. Of het modem moet intern iets doen met de uitgedeelde DHCP-leases in het kader van de routering van IPv4 verkeer, wat plat gaat zodra je DHCPv4 uit zet. Bij DS-Lite wordt het IPv4 verkeer immers getunneld door IPv6, behalve de interne IPv4 adressen. Misschien dat dit niet meer lekker werkt, als het modem niet weet wat er aan IPv4 in het netwerk hangt, zodra een andere DHCP het overneemt. Maar nu ben ik vrolijk aan het speculeren. De werking van de connectbox blijft toch een blackbox, voor ons als consument..
DennyW
Expert
Expert
  • 2769Posts
  • 232Oplossingen
  • 690Likes
efok wrote:
Ik neem dat TS zijn pi-hole wel een IPv4 heeft gegeven in de range waarin ook de gateway van het modem valt. Dus dat komt dan wel goed.


Een RaspberryPi zal (met het OS Raspbian) weliswaar met de standaard instellingen DHCP gebruiken, edoch als vervolgens PI-Hole wordt geïnstalleerd zal bij de configuratie voorgesteld worden om er een statisch adres van te (laten) maken. Een statische DHCP toewijzing of een "echte" statisch IP-adres (IPbv4 en IPv6) is bij Pi-Hole niet ongebruikelijk.
efok
Expert
Expert
  • 3158Posts
  • 170Oplossingen
  • 1033Likes
DennyW wrote:

efok wrote:
Ik neem dat TS zijn pi-hole wel een IPv4 heeft gegeven in de range waarin ook de gateway van het modem valt. Dus dat komt dan wel goed.
Een RaspberryPi zal (met het OS Raspbian) weliswaar met de standaard instellingen DHCP gebruiken, edoch als vervolgens PI-Hole wordt geïnstalleerd zal bij de configuratie voorgesteld worden om er een statisch adres van te (laten) maken. Een statische DHCP toewijzing of een "echte" statisch IP-adres (IPbv4 en IPv6) is bij Pi-Hole niet ongebruikelijk.


Dat klopt. Daarom ga ik er vanuit dat het wel in de goede range zal zitten. Maar daar moet TS het antwoord maar op geven.
hgoor
Liefhebber
  • 27Posts
  • 0Oplossingen
  • 8Likes
efok wrote:
Markengel Je bent niet de 1e die hier tegen aan loopt. Je hebt vermoedelijk DS-lite op je modem. In dit topic stelt de Topicstarter dat het uitschakelen van DHCP op je modem alleen voor IPv4 opgaat, en je modem vrolijk IPv6-adressen blijft uitdelen (niet heel raar, omdat IPv6 adressen, publieke adressen zijn, die je van Ziggo moet krijgen.) Daarbij geeft hij ook standaard DNS servers mee over IPv6.

Waar het exact misgaat in deze setup is me niet helemaal helder en kan ik niet voor je reproduceren omdat ik geen connectbox en geen DS-lite heb. Wellicht kan je in dat topic nog iets meer gewaar worden.

Hier is het ook al gesignaleerd.


Als ik kijk in mijn settings van de Connect Box, is er nergens, maar dan ook nergens een verwijzing naar IPv6. Dat wijkt dus af van de andere screenshots:



Ik heb volgens de settings ook geen extern IPv6:



Maar los daarvan: zoals je kunt zien, krijgt mijn Pi-Hole wel degelijk IPV6 verzoeken, en handeld die ook netjes af via de eigen DNS die ik heb opgegeven en zeker niet via de Connect Box.



M.a.w.: volgens mij heeft het niks te maken met IPv6.

Gewoon bekabeld gebruiken, de Pi als DHCP instellen en voila..
Markengel
topicstarter
Ontdekker
  • 4Posts
  • 1Oplossingen
  • 5Likes
Heb de Raspberry voorzien van een nieuwe raspbian stretch. Deze keer heb ik niet voor Wi-Fi gekozen, maar voor ethernet. Door deze file (/etc/wpa_supplicant/wpa_supplicant.conf) te bewerken had ik mijn wifi werkend gemaakt bij de vorige keer.

Setup van Pi-hole doorlopen. gekozen voor ipv4 en ipv6, statische ip adres voor Raspberry Pi en de DNS van openDNS.
Eigenlijk het zelfde ingesteld als de eerste keer behalve dat ik nu via eth0 verbinding heb.

In het modem van Ziggo heb ik de dhcp uitgezet en in het web interface-scherm van de pi hole heb ik de dhcp functie aangezet van de Pi.

Deze keer keer geen problemen 🙂
Alles werkt zoals het beschreven staat.
Geen advertensies te zien binnen mijn netwerk!

Dank voor de hulp.

Bekijk in context

efok
Expert
Expert
  • 3158Posts
  • 170Oplossingen
  • 1033Likes
Mooi. En ik maar moeilijk doen?. hgoor zolang je alleen een IPv4-profiel hebt zal het wel goed gaan. De andere topics hadden wel IPv6.
Markengel
topicstarter
Ontdekker
  • 4Posts
  • 1Oplossingen
  • 5Likes
efok wrote:
Mooi. En ik maar moeilijk doen?. hgoor zolang je alleen een IPv4-profiel hebt zal het wel goed gaan. De andere topics hadden wel IPv6.


Je liep al iets vooruit op de zaken. Het had me misschien verder kunnen helpen als het niks met de kabel was geworden.
Anne H
Community Developer
Community Developer
  • 3698Posts
  • 207Oplossingen
  • 1279Likes
Mooi topic mensen! Welkom op onze Community Markengel. Fijn dat de Pi-hole via ethernet (en met DHCP uit op de modem, en aan in de Pi-hole) goed aan de praat te krijgen is. Dat kan alleen bij modems van ons die op IPv4 zijn ingesteld.

Pi-hole kent ook andere opties zoals versleutelde DNS. Daar is wat voor te zeggen. In no-time heb je thuis een zeer complex netwerk draaien. Mocht dat tot gekke verschijnselen leiden dan raden wij aan om de modem in bridge mode te laten zetten en je eigen router te gebruiken, daarvoor hebben wij die optie erin gebouwd.

Uitgelicht topic