1
Vraag
2
Reacties
Bill_King

Level 1
  • 2Posts
  • 1Oplossingen
  • 0Likes

"Mijn Ziggo" App on my iPhone 13 no longer works since coupling with my new Vodafone account

Sorry for the English...

 

The iPhone App "Mijn Ziggo" was working perfectly on my iPhone 13 Max Pro iOS v 16.1.1

I recently began a new Vodafone account, then coupled the "Mijn Ziggo" account with the new "My Vodafone" account. The 2 accounts now have the same email and same password (as recommended).

The "Mijn Ziggo" App on my iPhone shows "GEEN VERBINDING" - "Er is iets fout gegaan".

I have tried uninstalling the App, rebooting, then installing it from new.

My first email address with "Mijn Ziggo" was changed to the new account email address I setup for "My Vodafone".

I can login to my Ziggo account on my iPhone using Safari or Google Chrome. I can login to my Ziggo account using any browser on my PC. I have "Mijn Ziggo" on my Android Samsung Tablet and that App DOES work correctly. It's just the iPhone "Mijn Ziggo" App which is the problem.

I am almost sure that there is a bug in the "Mijn Ziggo" App where it is looking for my old email address and/or the Face ID data which are now different.

Please offer a solution to this issue, including, but not limited to, fixing the ""Mijn Ziggo" iPhone App.

Thank you in advance.

Oplossing

Geaccepteerde oplossingen
Bill_King
Topicstarter
Level 1
  • 2Posts
  • 1Oplossingen
  • 0Likes

Nope, as I wrote above The "Mijn Ziggo" App on my iPhone shows "GEEN VERBINDING" - "Er is iets fout gegaan".

The App does NOT allow entering new login data, it does NOT start at all.

 

I found out a solution to my problem.

On my PC I logged into my Ziggo account with my new email address. Then changed the email address to the previous valid email address (therefore the Ziggo & Vodafone accounts were no longer linked).

I then tried to start the "Mijn Ziggo" App on my iPhone. IT WORKED!!

I then logged out of my Ziggo account on my PC (so that there would be no conflicts).

I then changed my login email address using the "Mijn Ziggo" App on my iPhone to the new email address which is the same as my Vodafone email address. Then the "Mijn Ziggo" App worked. (Also the Ziggo & Vodafone accounts were re-linked again.)

 

Suggestions to the iPhone "Mijn Ziggo" App programmers :

(1) Don't use Apple persistent data storage on iOS devices.

Why? Because when the App is deleted (uninstalled) the data is "persistent", meaning that it stays there even after the App has been deleted. Bad idea!

(2) If it's impossible to login to the "Mijn Ziggo" App (after a few tries maybe or if an error like written above is encountered), then at least allow the user to enter new login data (email & password) to at least allow the App to start.

Why? The current situation is that when a logic fails due to "unknown reasons", then the App locks the user out. Very poor programming in my opinion. Perhaps this is why the App has such a poor rating.

 

When the App is changed and fixed using the above suggestions, then I will change my Apple App Store rating from the current "1 star" to something higher.

 

Thank you in advance (to the programmers).

Bekijk in context

2 Reacties 2
Wim C.

Level 17
Super Expert
  • 3486Posts
  • 151Oplossingen
  • 2447Likes

Hi @Bill_King 

You don't have to apologize for your English language. Dutch is a difficult language to learn; even for Dutch people.
As I understand it, your My Ziggo app asks for your previous login details. Have you already tried logging out of this app and then logging back in?

Bill_King
Topicstarter
Level 1
  • 2Posts
  • 1Oplossingen
  • 0Likes

Nope, as I wrote above The "Mijn Ziggo" App on my iPhone shows "GEEN VERBINDING" - "Er is iets fout gegaan".

The App does NOT allow entering new login data, it does NOT start at all.

 

I found out a solution to my problem.

On my PC I logged into my Ziggo account with my new email address. Then changed the email address to the previous valid email address (therefore the Ziggo & Vodafone accounts were no longer linked).

I then tried to start the "Mijn Ziggo" App on my iPhone. IT WORKED!!

I then logged out of my Ziggo account on my PC (so that there would be no conflicts).

I then changed my login email address using the "Mijn Ziggo" App on my iPhone to the new email address which is the same as my Vodafone email address. Then the "Mijn Ziggo" App worked. (Also the Ziggo & Vodafone accounts were re-linked again.)

 

Suggestions to the iPhone "Mijn Ziggo" App programmers :

(1) Don't use Apple persistent data storage on iOS devices.

Why? Because when the App is deleted (uninstalled) the data is "persistent", meaning that it stays there even after the App has been deleted. Bad idea!

(2) If it's impossible to login to the "Mijn Ziggo" App (after a few tries maybe or if an error like written above is encountered), then at least allow the user to enter new login data (email & password) to at least allow the App to start.

Why? The current situation is that when a logic fails due to "unknown reasons", then the App locks the user out. Very poor programming in my opinion. Perhaps this is why the App has such a poor rating.

 

When the App is changed and fixed using the above suggestions, then I will change my Apple App Store rating from the current "1 star" to something higher.

 

Thank you in advance (to the programmers).

E-mail notificaties
Aan Uit

Ontvang een update bij nieuwe reacties in dit topic.

Polls
Ga je voor een film of een serie?

Uitgelicht topic

Prijswijziging per 1 juli 2022

Binnenkort informeren we iedereen persoonlijk over de prijswijziging van 1 juli 2022. Tussen 9 en 31 mei ontvang je van ons een e-mail of brief wanneer er iets wijzigt in je abonnementskosten. Voor 1 ...

Geplaatst in Archief