Vraag

Ubee Modem schakelt uit met Linux Mint 19.2

  • 26 maart 2019
  • 15 Reacties
  • 299x Bekeken

Ik heb een Dual Boot systeem met Windows 7 en linux Mint (Bionic Beaver).
Als ik alleen via Windows opstart heb ik altijd internet (bekabeld), geen problemen.
Zodra ik linux Opstart schakelt mijn modem de verbinding uit, als ik dan reboot naar Windows heb ik daar ook geen internet en ziet Windows de modem niet eens meer, zegt dan dat de kabel er niet inzit of beschadigt is.

Enige optie is dan de router uitzetten en na 30 seconden weer aanzetten, en dan opstarten in Windows, en dan moet ik de kabel er zelfs nog uithalen en weer indoen en probleemoplosser draien anders blijt ie zeggen geen kabel aangesloten.
Na de probleemoplosser gedraid te hebben heb ik pas weer internet.

Dus er gaat iets enorm fout in de Ubee Modem, of bij Ziggo op de server, een soort block of iets dergelijks.

Als ik in de modem kijk (dat kan nog wel) dan staat er in de modem gewoon dat alles goed werkt en de PC gewoon aangesloten is en de modem heeft een IP adres.

maar de PC kan dan geen gateway meer vinden terwijl de Ubee modem gewoon aangeeft dat ie 192.168.178.1 als gateway voor het interne netwerk heeft.

Ik heb van alles geprobeerd, als ik Linux een vast IP adres geef en DHCP uitschakel, dan werkt het alleen als ik de modem reset, en dan Linux opstart met een vast IP adres, dan heb ik internet, zodra ik dan Windows opstart geeft de modem geen IP adressen meer totdat ie weer opnieuw gereset wordt.

Wat is hier aan de hand ?
Ik weet wel wat van Netwerken, maar dit gaat me boven mijn pet.

15 Reacties

Reputatie 7
Badge +26
Is het niet de netwerkkaart in je computer die het even niet meer snapt?

In windows ken ik deze stappen. Linux , geen idee.

1. Nieuw IP adres opvragen van de router/modem
Volg deze stappen:
1. Klik op Start
2. Typ in CMD
3. Rechtermuisklik op Opdrachtprompt en kies Als Administrator uitvoeren
4. In het zwarte venster typt u het volgende commando:
Typ ipconfig /renew en druk op Enter.


2. Nieuw IP adres opvragen van de router/modem
Volg deze stappen:
1. Klik op Start
2. Typ in CMD
3. Rechtermuisklik op Opdrachtprompt en kies Als Administrator uitvoeren
4. In het zwarte venster typt u de volgende commando’s:
a. Typ netsh winsock reset en druk op Enter.
b. Typ netsh int ip reset en druk op Enter.
c. Typ ipconfig /release en druk op Enter.
d. Typ ipconfig /renew en druk op Enter.
e. Typ ipconfig /flushdns en druk op Enter.
Nee dat is het niet, die stappen heb ik al geprobeerd, dat doet helemaal niets, de modem reageert gewoon nergens meer op zodra Linux geprobeer heeft contact te maken met de modem.

Ik vermoed eerder dat de DHCP connectie van Linux problemen veroorzaakt in de modem, wat precies weet ik niet, maar de modem crashed gewoon als Linux contact maakt.
Reputatie 7
Badge +17
En wat geeft windows als IP configuratie aan op het moment dat je geen gateway hebt?
En kun je op die momenten bv nog wel via IP adres in je modem komen of pingen?
Badge +11
Heel merkwaardig. Ik draai al jaren Linux mint, maar dat Linux een modem onderuit trapt ben ik nog niet tegengekomen....
valt er nog iets los te peuteren uit de logs..?

je zegt dat je modem “uitschakelt” maar dat je nog wel in het modem kunt kijken. Dat snap ik niet helemaal.
Dat betekent dat er dus wel gewoon communicatie mogelijk is tussen Mint en Modem, en het modem dus niet is uitgeschakeld.

kun je in zo’n situatie eens een mtr doen naar bijvoorbeeld 1.1.1.1

Aanvulling: je zegt dat de PC “de gateway niet kan vinden”, wat zie je in de networkmanager in Linux mint als gateway?
Reputatie 4
Hi @Marcurio, wat vreemd dat je problemen ondervindt met de verbinding, wanneer je opstart met Linux. Ben je er inmiddels alsnog uitgekomen? Misschien kun je anders nog terugkomen op de vragen van Nick999 en efok, zodat we je verder kunnen proberen te helpen.
Reputatie 5
Badge +4
Check evwn of je mint editie wel de correcte lan drivers gebruikt. Heel incidenteel kunnen ze net een verkeerde driver pakken. En dan gaat het niet goed.
Ik heb Arch-Linux geïnstalleerd met Xfce als DE. En ook deze (zelf geconfigureerde Linux Distro) word niet eens gezien door "Het DinG" Sterker, de router raakt gewoon de weg kwijt. Moet ik mijn jaren lange kennis m.b.t. Linux nu overboord gooien? Een simpel voorbeeld: Ethernet Online Brengen:

code:
check IP: ip a (niets)

ping-test: ping -c 5 www.google.com (niets)
systemctl status NetworkManager
systemctl start NetworkManager


Dit alles bij het configureren van een Dektop Omgeving

Tijdens de installatie zoekt Arch-Linux ook naar pakketten,
hier had ik echter geen problemen mee,

Dat was gisteren, vandaag dus eerst controle op aanwezigheid
van Internet.... Jammer, niet één piep klein pingetje.

En als dit nu de eerste keer is dat ik arch installeer.... NEE
@Ziggo Help, ik weet het even niet meer.
Reputatie 7
Badge +13
Als je meerdere besturingssystemen hebt, dan MOET je de instelling "Snel opstarten" (goed verstopt: Instellingen/ Systeem /Energiebeheer en Slaapstand / Extra energie-instellingen / Het gedrag van de aan-uit-knoppen bepalen / Instellingen wijzigen die momenteel niet beschikbaar zijn / ==> vinkje weghalen bij "Snel opstarten inschakelen (aanbevolen)) uitschakelen.

Doe je dit niet dan blijft de HDD in gebruik bij het Windowssysteem en raakt het gekoppelde bestand hyberfil.sys (en ander bestanden die nog in gebruik zijn en blijven) beschadigd als het andere besturingssysteem tot leven wordt gewekt.

De z.g. snel opstart optie is namelijk een soort veredelde slaapstand. Uitzetten / afsluiten en aanzetten /opstarten PC, geeft dan geen schone reboot.
Dank voor je input @DennyW, echter ik gebruik (heb) geen dual-boot, sterker nog, ik heb helemaal geen Windows. Naast mijn Linux hobby ben ik een Apple User .

Dus deze:
Doe je dit niet dan blijft de HDD in gebruik bij het Windowssysteem en raakt het gekoppelde bestand hyberfil.sys

gaat niet op.

Toch bedankt voor het meedenken. Ik denk eerder dat het een overkill is van IPv6. Ik denk er aan om een router (heb er nog eentje liggen) achter te zetten en dan het "DING" in bridge modes te zetten.
Nee dat is het niet, die stappen heb ik al geprobeerd, dat doet helemaal niets, de modem reageert gewoon nergens meer op zodra Linux geprobeer heeft contact te maken met de modem.

Ik vermoed eerder dat de DHCP connectie van Linux problemen veroorzaakt in de modem, wat precies weet ik niet, maar de modem crashed gewoon als Linux contact maakt.

Daar kan je prima gelijk in hebben @Marcurio, zoals ik al zei, volgen mij is de enige oplossing een router, in bridge, achter het "Ding" zetten.
@Nick999, windows gebruikt een intern ip adres 169.254..blabla..gateway weet ik ff niet, heb Linux al een tijdje niet meer gestart door dit probleem, geen zin om elke keer mijn modem te resetten, en ik wekr voornamelijk aan 3D projecten in Autodesk Maya, dus ik heb Linux niet echt nodig.

@efok, ik heb nergens gezegd dat Linux de modem uitschakelt, ik zei hij schakelt de verbinding uit, dat is iets anders. Modem draait gewwon, ik kan gewoon in de settings komen, hij doet alleen geen enkele verbinding meer leggen, zelfs niet met mijn televisie, de hele DHCP werkt niet meer, niets krijgt een ip adres toegewezen totdat ik ee reset uitvoer.
En zelfs dan moet ik in windows goochelen om de verbinding weer op gang te krijgen.
Ben een beginner met Linux, dus ik zou niet weten waar de logs staan, in Windows kan ik ze wel vinden bij de system event manager, daar krijg ik een DHCP fout.
Ik weet niet wat een MTR is, ik weet wel wat pingen is maar dat doet niets natuurlijk, de verbinding is totaal weg naar elk ip adres.
Zoals ik al zei heb ik Linux al een tijd niet gestart, dus dat weet ik niet meer wat hij als gatweay aangaf, maar ik weet nog wel dat zowel Windows als Linux de reguliere gateway niet meer kon aanspreken omdat de modem nergens meer op reageert.
Aangezien jij zelf blijkbaar wel kaas gegeten hebt van Linux zal je best wel weten wat Linux dan doet in zo'n situatie vermoed ik, Windows pakt dan een 169.254.xx ip adres, ik vermoed dat Linux ook zon intern adres heeft voor als er geen communicatie mogelijk is naar de modem, want dat is het geval.
Waar de logs staan is op zich wel interessant, dat wil ik wel weten, dan wil ik nog wel eens een poging wagen om het op te lossen, alhoewel ik er toen wel dagen mee bezig ben geweest met de hulp van mijn broer en die weet praktisch alles van Linux, die kwam er ook niet uit met de informatie die ik hem allemaal moest geven.
In Windows kan ik aardig uit de voeten met configureren en troubleshooten, repareer al jaren PC's met Windows en los softwareproblemen op, maar zoals ik al zei netwerken is niet mijn sterkste kant, dat snap ik maar een klein beetje.

@Darkje, ik zal eens kijken of er andere dirvers beschikbaar zijn, ik dacht dat ie de realtek drivers gewoon geinstalleerd had, maar ik zal even checken.

@Dennyw, ik heb snel opstarten altijd standaard uitstaan.

@Darwin, zou kunnen, ik heb momenteel een switch erachter hangen omdat mijn modem niet meer als 1 verbinding toestaat, terwijl het volgens Ziggo 2 apparaten zouden moeten zijn die erop kunnen, ik snap eerlijk gezegd niet waarom ze een modem uitgeven met 4 poorten erop en dat je er dan maar 2 apparaten aan kan hangen.
Ik kan er wel 4 aanhangen maar dan doen 3 het er gewoon niet, terwijl de modem ze wel ziet en ook een ip adres geeft, maar ja, met een switch werkt dat dus wel.
Ik heb nog wel een router liggen dus ik kan dat wel proberen.
@Nick999, windows gebruikt een intern ip adres 169.254..blabla..gateway weet ik ff niet, heb Linux al een tijdje niet meer gestart door dit probleem, geen zin om elke keer mijn modem te resetten, en ik wekr voornamelijk aan 3D projecten in Autodesk Maya, dus ik heb Linux niet echt nodig.

Edit:
@Marcurio dus ik zou niet weten waar de logs staan


Je logs kan je vinden wanneer je binnen de terminal als Root inlogt en dan:

code:
systemctl status (enter)





Dan krijg je een aardig overzicht en tegelijkertijd zie je of je systeem actief is.

En hier nog een heel goed hulpje: The Linux Command Line een gratis PDF van een kleine 200 pagina's, even downloaden 🙂 En hier nog meer. Wanneer je echt Linux wilt leren, dan zijn er vele "gratis" boeken en PDFs te googlen. Ook 3D progamma's zoals het gratis FreeCAD https://www.freecadweb.org en misschien ken je reddit wel, waar ze een heel 3D modelling in Linux forum hebben.

Ik ga nu mijn r7000 er tussen zetten en maar hopen dat het lukt.

ps: een switch is heel wat anders dan een router, daar heb een ingang en meestal 4 uitgangen. Wanneer je daar je switch nog tussen zet dan kan je aardig vooruit.
@Darwin, thanks, mijn broer is ook een Linux wiz dus ik kan hem alles vragen, maar ik ben te afhankelijk voor mijn werk van Windows, dus elke keer installeer ik het, maar ik kan er niet mee wat ik ermee moet doen, ik maak 3D modellen voor videogames en de 3D software is allemaal wel aan de praat te krijgen op Linux als je gevorderd bent zoals Maya, maar veel ook niet zoals ZBrush en 3DCoat enzo.

Dus elke keer heb ik een dual boot system opgezet maar start ik na een tijdje Linux bijna niet meer op, en om zo goed te worden in Linux dat je alles zelf kan installeren zonder dat je uren aan het zoekn ben naar oplossingen op het internet, dan ben je wel even bezig, ik heb er gewoon de tijd niet echt voor..

Ik ben wel redelijk ver gekomen destijds met installeren van games met POL en Wine, en heb ook wel een DAW aan de praat gekregen, maar iedere keer ben ik een paar dagen bezig om zoiets aan de praat te krijgen op Linux, het lukt wel, maar is te tijdrovend.

En 3d staat echt nog in de kinderschoenen in Linux, ik heb me er destijds wel in verdiept, alleen Maya is interessant, maar dat is een hel om aan de praat te krijgen.

Ik ken het verschil tussen een switch en een router.
Badge +11
@Nick999, windows gebruikt een intern ip adres 169.254..blabla..gateway weet ik ff niet, heb Linux al een tijdje niet meer gestart door dit probleem, geen zin om elke keer mijn modem te resetten, en ik wekr voornamelijk aan 3D projecten in Autodesk Maya, dus ik heb Linux niet echt nodig.
Een 169.254 adres geeft aan dat Windows geen IP via DHCP kan krijgen.

@efok, ik heb nergens gezegd dat Linux de modem uitschakelt, ik zei hij schakelt de verbinding uit, dat is iets anders. Modem draait gewwon, ik kan gewoon in de settings komen, hij doet alleen geen enkele verbinding meer leggen, zelfs niet met mijn televisie, de hele DHCP werkt niet meer, niets krijgt een ip adres toegewezen totdat ik ee reset uitvoer.

Ik citeer je titel:

"Ubee Modem schakelt uit met Linux Mint 19.2"

Maar goed ik begrijp dat je modem up blijft, maar dat je dhcp niet leker loopt. Je zegt ook dat Windows een "intern ip adres 169.254..blabla" gebruikt. Dat komt alleen voor als je DHCP niet werkt. Je zegt dat de verbinding wordt uitgeschakeld, en toch kun je in je modem komen? Het wordt me niet echt duidelijker helaas.

Dit stukje vind ik ook opvallend:
@Darwin, zou kunnen, ik heb momenteel een switch erachter hangen omdat mijn modem niet meer als 1 verbinding toestaat, terwijl het volgens Ziggo 2 apparaten zouden moeten zijn die erop kunnen, ik snap eerlijk gezegd niet waarom ze een modem uitgeven met 4 poorten erop en dat je er dan maar 2 apparaten aan kan hangen.
Ik kan er wel 4 aanhangen maar dan doen 3 het er gewoon niet, terwijl de modem ze wel ziet en ook een ip adres geeft, maar ja, met een switch werkt dat dus wel.
Ik heb nog wel een router liggen dus ik kan dat wel proberen.


Als je modem maar 1 IP uitdeelt, lijkt het er sterk op dat hij in bridge staat. Is dat het geval?
Dat zei ik dus in mijn 2e bericht dat ik dacht dat het aan DHCP lag.
Ik snap niet veel van netwerken, maar ik kan wel goed logisch nadenken, dus na alles wat ik geprobeerd had dacht ik dat het aan DHCP moest liggen, ik zei in Linux maar ik bedoelde natuurlijk DHCP server in het modem.

Oh de titel, tja een een generieke titel om kort en bondig iets duidelijk te maken, beetje flauw dat je daar dan zo letterlijk op reageert terwijl ik in mijn hele verdere bericht dat niet zo specifiek meldt. Zo te merken ben je namelijk slimmer dan dat.
Dat het modem up blijft had je ook uit de content van mijn initiele bericht op kunnen maken.

Ik vermoed dat ik draadloos erin ben gekomen nu je het zo zegt, moet bijna wel want wat ik gezegd heb in mijn initiele bericht klopt wel, en mijn bedraded internet is dood als dit gebeurt, ik heb een wifi dongle liggen dus ik vermoed dat ik het wifi netwerk gebruikt heb, dus DHCP op wifi zou het dan nog wel doen.
Nu moet ik wel zeggen dat dit al 2 maanden geleden is dat ik het gedaan heb, dus het zit niet vers in mijn geheugen, ik zal het vanmiddag weer eens even testen als ik wat tijd heb, zodat ik meer precieze info kan geven.
Al heb ik er niet zoveel vertrouwen in dat iemand me echt kan helpen hiermee omdat het overduidelijk aan het modem ligt die in de war raakt, ik denk dat het IC verantwoordelijk voor de RJ45 poorten vastloopt van wat Linux doet met opstarten, en niet zo'n beetje ook, muurvast zit het dan..
Zoals eerder gezegd, als ik Linux een vast IP adres geef dan werkt mijn internet gewoon.
Alleen dan moet ik nog naar overstappen naar Windows wel weer even de probleemoplosser uitvoeren omdat Windows dan denkt dat er geen kabel aangesloten is, dus ook dan doet Linux iets vreemds intern in de modem, alleen niet zo erg dat de RJ45 poorten compleet vastlopen in DHCP.

Ik kan eigenlijk alleen determineren wat er gebeurt, waarom iets gebeurt en wat er precies gebeurt intern daar heb ik geen kaas van gegeten.

Nee modem staat niet in Bridge, 100% zeker..

Reageer