Beantwoord

PHP Hosting - verouderde versie?


Kom een aantal keren tegen dat mijn browser een site niet kan openen omdat hij hem niet kan vinden. Volgens mij heeft dat te maken met het feit dat ik momenteel PHP 5.4 heb. Hoe kan dit worden verhoogd naar tenminste 5.6?
icon

Best beantwoord door RodneyFortuna 21 mei 2019, 12:17

Sorry, het webadres is weggevallen. Moet zijn "beach minerals.org".

Ik krijg precies dezelfde melding, de eigenaar van de website moet dus even zijn PHP versie opkrikken in de dashboard van zijn/haar hostings provider. Heel veel mensen hebben een website, maar vergeten nog wel is het onderhoud. Deze Word Press website heeft WP versie 5.1.1 terwijl versie 5.2 er al is en dus zullen andere plugins en thema ook wel niet zijn bijgewerkt, met het gevolg dat de website crasht en niet meer werkt.

Hier is dus niets aan te doen, dan dat de eigenaar van de website deze naloopt en weer werkend maakt. Dit probleem staat dus totaal buiten Ziggo.
Bekijk origineel

23 Reacties

Reputatie 7
Badge +16
PHP is iets wat alleen op de webserver draait en niets te maken heeft met de werking van een browser.
OK, maar hoe kan ik dan de PHP updaten naar 5.6 of hoger?
Als het gaat over een bezoek aan een externe Web Site, dan heb je zelf PHP niet nodig & valt er niets te updaten.

Kun je je vraag wat scherper stellen? Heb je een eigen Web Server?
Zo ja........
Met lagere PHP versies kan die nog prima werken.
Waarom wil je een Upgrade? Wat gaat er mis?
Reputatie 7
Badge +16
Hier staan alle versies van PHP :
https://www.php.net/downloads.php

Installeren/upgraden volgens de handleiding van je webserver (of host), want dat verschilt per server.
Badge +11
OK, maar hoe kan ik dan de PHP updaten naar 5.6 of hoger?

Normaliter biedt je hosting partij van je website die optie wel in je beheeromgeving. PHP 5.4 is echt verouderd, ik zou gelijk naar versie 7+ gaan, als je toch bezig bent.

Alleen als ik je openingpost lees heb je het over meerdere sites, hoe zit het precies?
Reputatie 3
Badge +5
Zoals eerder al gezegd, de PHP kan je instellen als je zelf een website hebt draaien (dit gaat meestal via een hosting, daar zelf een website op een server laten draaien nogal ingewikkeld is) De PHP versie is nu 7.3.

Als jij als bezoeker van een website problemen hebt met de PHP versie zou ik even kijken of je geen update moet uploaden van je webbrowser of wellicht een andere webbrowser gebruiken. Ook kan het zijn dat de website gewoonweg niet goed is onderhouden en een foutmelding geeft.
Heb Ziggo gebeld over dit probleem, maar zij kunnen mij niet helpen en verwijzen naar de Community. Eevn voor alle duidelijkheid:
Ik probeer op de volgende website te komen: , maar krijg het volgende foutbericht: "Your server is running 5.4.45 but WordPress 5.2 requires at least 5.6.20"
Ik krijg dit bericht op zowel Safari als Firefox.
Kan iemand mij helpen?
Sorry, het webadres is weggevallen. Moet zijn "beach minerals.org".
Reputatie 3
Badge +5
Sorry, het webadres is weggevallen. Moet zijn "beach minerals.org".

Ik krijg precies dezelfde melding, de eigenaar van de website moet dus even zijn PHP versie opkrikken in de dashboard van zijn/haar hostings provider. Heel veel mensen hebben een website, maar vergeten nog wel is het onderhoud. Deze Word Press website heeft WP versie 5.1.1 terwijl versie 5.2 er al is en dus zullen andere plugins en thema ook wel niet zijn bijgewerkt, met het gevolg dat de website crasht en niet meer werkt.

Hier is dus niets aan te doen, dan dat de eigenaar van de website deze naloopt en weer werkend maakt. Dit probleem staat dus totaal buiten Ziggo.
Dit antwoord verbaast mij. Als ik de foutmelding goed lees, zie ik dat "mijn" server een PHP versie van 5.4.45 gebruikt, terwijl WordPress voor de website in kwestie 5.6.20 vraagt.

Volgens mij zou "mijn" server dan ook voor het verouderde 5.4 een update moeten aanbieden. Bijvoorbeeld naar 5.6 of hoger (7.3?).
Reputatie 3
Badge +5
Als ik het dus goed begrijp ben jij eigenaar van deze website?

Your server is running PHP version 5.4.45 but WordPress 5.2 requires at least 5.6.20.
Bovenstaande melding betekend dus dat de website op de server een andere versie moet krijgen. (dit is dus gericht aan de eigenaar van de website)

Je website loopt via godaddy toch ? dan moet je inloggen in je klanten panel en daar je php hoger zetten en als het goed is krijg je daar ook van je hostingspartij een mail van. Zou eerst naar 5.6 gaan en alles updaten, want je weet immers niet of sommige plugins moeilijk gaan doen als je 7.3 gaat draaien.... (heb zelf geen problemen gehad met de 7.3 en heb heel wat websites in onderhoud)

Als het goed is kan je dan weer inloggen op je website en moet je al je plugins thema en Wordpress even updaten. Zou wel eerst een back-up maken. Mijn ervaring is dat websites met achterstallig onderhoud nog wel is plat gaan namelijk en foutmeldingen kunnen geven.

Tevens zou ik je website HTTPS maken, aangezien Google dat wel prettig vind en beter is voor de ranking.
Nee, ik ben geen eigenaar van deze website.
Ik gebruik al jaren Ziggo en heb nog nooit dit probleem gehad.
De melding betekent volgens mij, dat de server die ik gebruik (dat is toch Ziggo?) een PHP versie van tenminste 5.6 moet hebben om op de website van te komen.
Ik weet niet hoe ik de PHP hoger kan of mag zetten. Dat zou de server (Ziggo) voor mij moeten doen.
Reputatie 3
Badge +5
Nee de melding is niet voor jou, maar voor de eigenaar van de website, aangezien jij niets met een server te maken hebt als bezoeker zijnde.
Dat is vreemd. Alweer is het website adres van beach minerals weggevallen in mijn laatste antwoord.
Reputatie 3
Badge +5
Dat is vreemd. Alweer is het website adres van beach minerals weggevallen in mijn laatste antwoord.

Ja mijn vorige antwoord was ook ineens weg, denk verwijderd en de link kan wel kloppen, denk dat een link vermelden is uitgezet, zodat er niet te veel reclame troep op het forum komen.
@RodneyFortuna Ik heb de verdwenen reaktie gelezen & gaf hem een Like. Het klopte helemaal, wat je schreef.
Het Forum doet soms raar. Daar ben je het slachtoffer van geworden.
Herhaald corrigeren van een bericht is gevaarlijk.
Er is een redelijke kans dat het bericht weer terugkomt. Gedoe allemaal.

@Brookside
PHP zit aan de Server-kant.
Als daar een foutmelding over komt ligt dit aan onzorgvuldigeheid van de eigenaar van de Site.
Als je dat zelf niet bent, dan valt er niks te verbeteren, anders dan door contact te leggen met de eigenaar en haar te wijzen op de fout.
Jammer, maar helaas. Ben blij dat er nu duidelijkheid is. Bedankt.

Toch vraag ik mij af waarom Ziggo nog steeds een verouderde versie Van PHP gebruikt.
Dit heeft niks met Ziggo te maken. Het probleem zit op de Web Server die je wilt gebruiken. Dat is hier eerder al benadrukt.
Als bv Google iets verkeerds doet met www.google.com dan moet je bij Google zijn.
Niet bij Ziggo.
EN WELKE PHP VERSIE GEBRUIKT ZIGGO DAN OP HUN SITE?
Geen idee. Het is ook maar de vraag of Ziggo php gebruikt voor z'n Site.
Wat is je probleem met de Ziggo Site? Dat zag ik nog niet, of las daarover heen.

Liever niet zo hoofdletters gebruiken. Dat is tegen de Netiquette.
HET WAS MAAR EEN VRAAG, IK HEB GEEN PROBLEEM MET HUN SITE.

BEDANKT VOOR DE MOEITE.
Ok. Caps Lock uitzetten.
Badge +11
Jammer, maar helaas. Ben blij dat er nu duidelijkheid is. Bedankt.

Toch vraag ik mij af waarom Ziggo nog steeds een verouderde versie Van PHP gebruikt.


Is het je echt duidelijk? De 2e zin geeft aan dat je het nog niet heb begrepen. Ziggo is je provider, maar de websites en de bijbehorende servers die je bezoekt zijn niet van Ziggo.
“Your server” is gericht aan de eigenaar van de website, niet aan de bezoeker. Netter was geweest als er had gestaan “This server”, maar dat ligt dan weer aan wordpress.

Reageer