Beantwoord

Packet loss (deel 2) Bij aorta net



Toon eerste bericht

42 Reacties

Ik heb ook even een dl aangezet. Bij mij is het ook "traag"



Dan kan ik als enige nog bedenken, en wat het NOC / datacenter niet zal vertellen, dat ze geen peering agreement hebben met congen.. of hoe ze verder ook heten. Dat verklaart niet de packetloss, want dat is gewoon een snmp blokkade.
Ik geloof dat je in het register van de AMS-IX kunt kijken hoe die peering loopt. Vraag me alleen niet hoe.
Zwavelstok schreef:

Ik heb ook even een dl aangezet. Bij mij is het ook "traag"



Dan kan ik als enige nog bedenken, en wat het NOC / datacenter niet zal vertellen, dat ze geen peering agreement hebben met congen.. of hoe ze verder ook heten. Dat verklaart niet de packetloss, want dat is gewoon een snmp blokkade.
Ik geloof dat je in het register van de AMS-IX kunt kijken hoe die peering loopt. Vraag me alleen niet hoe.


Ik had in maart ook bandbreedte problemen heb gelukkig nog een log van een traceroute van toen, maar ik zie dat ze in maart ook al via cogent liepen. Het probleem was toen verholpen en ik kon met volle snelheid weer alles doen (ook via cogent dus).

Ik ben in ieder geval blij dat we kunnen uitsluiten dat het specifiek aan mijn verbinding ligt. We zijn een stap verder. 🙂

Ik heb ook weer contact gehad met mijn datacenter en zij blijven aangeven dat het probleem bij Ziggo zit. Zij leveren enkel tot "185.27.239.249" en dat de rest opgepakt wordt door de ISP's.

Hopelijk komt er nog een moderator langs en kan hij iemand intern aantikken.

Je zou bijna zeggen om alle servers in een busje te gooien en te verhuizen naar Amsterdam om van het probleem af te zijn, maar 20 servers verhuis je niet zomaar even. 😉
Ik ben er een tijdje uit, en ben ff niet scherp door direct dingen te zien.

aorta.net, ik weet zeker (denk ik) dat deze wordt gebruikt voor default routing. Dus geen peering, en minimale bandbreedte, ze voldoen alleen aan de peer-verplichting.
Aorta.net is overigens gewoon lid van de Ziggo familie.

Dus je hebt gewoon pech.

enne, je verbinding.. daar hebben we het nog wel een keer over 😜
Zwavelstok schreef:

Ik ben er een tijdje uit, en ben ff niet scherp door direct dingen te zien.

aorta.net, ik weet zeker (denk ik) dat deze wordt gebruikt voor default routing. Dus geen peering, en minimale bandbreedte, ze voldoen alleen aan de peer-verplichting.
Aorta.net is overigens gewoon lid van de Ziggo familie.

Dus je hebt gewoon pech.


Ik hoop erop dat Ziggo mij in ieder geval nog support kan bieden. Aangezien het tot een week geleden gewoon goed ging.

enne, je verbinding.. daar hebben we het nog wel een keer over 😜


Haha, komt goed. Bedankt voor je inzet in ieder geval! 🙂
WesleyNL schreef:


Ik hoop erop dat Ziggo mij in ieder geval nog support kan bieden. Aangezien het tot een week geleden gewoon goed ging.



Dit kan dagelijks veranderen. Ben maar blij dat deze route niet via Oostenrijk loopt.
Reputatie 7
Badge +31
#LekkerBezig @Zwavelstok ☺

Ik hoop dat een Ziggo moderator dit vlot op kan pakken om hier uitsluitsel over te geven of de achterliggende afdelingen mee te laten kijken.
Zij komen eens in de paar werkdagen langs in ieder topic.
Het probleem lijkt inmiddels "vanzelf" verholpen te zijn. Ik ben ondertussen wel op zoek gegaan naar een nieuwe carrier aangezien dit probleem helaas al meerdere keren voorgekomen is.

In ieder geval, bedankt allemaal voor jullie hulp!

Het is al bijna twee weken dat ik merk dat internationaal verkeer via aorta/cogento met enorme lag bij mijn systeem aankomt. Ik ben geen expert, maar als het 5+ jaar onder de 250ms ligt als bijvoorbeeld iemand op een minecraft server komt spelen, en opeens een week is het minstens 500ms tot 5000ms. En steeds met tracert naar hun IP komt aorta/cogent in het lijstje voor, maar als iemand toevallig via andere routing op de server komt is de ping netjes onder de 100ms.

Ik heb thuis alles gedaan om te checken dat het niet het os/hardware modem en/of router is. en mijn netwerk is ondertussen beter op de lan dan jaren hiervoor, verbinding heen en weer naar ziggo en NL sites is uitmuntend, veel EU verbindingen naar mij toen zitten onder de 100ms, makkelijk, meestal zelfs minder. (behalve als het over parijs verloopt trouwens). En tot 250ms naar en terug van US, behalve als het dus over aorta/cogent verloopt, boom: timeouts en noem het maar op.

Nu is het maar een mc servertjes, boeie, kan het op een vps gooien ergens. Maar het is een hobby tussen handjevol vrienden en niet de moeite waard.

Verder, streamen naar youtube gaat prima voor 30s, daarna zakt het voor 35 minutesn naar 160kb/s en dan weer minuutje ok. Terwijl het vorige maand gewoon 100% prima was. Switch ik naar twitch: 100% full speed - no problems.

netstat het ip van youtube wat gebruikt wordt, en ja hoor, aorta/cogent routing of peering or whatever. die van twitch? nope, andere routing.

Na het vinden van deze thread ben ik het met @op eens, shit aint right.


screenshot is van server van ramnode naar mijn ziggo ip.

gaan we van mijn ziggo naar een persoon met 5000+ ms lag .. geen aorta, geen probleem.



beetje googlen in laatste 14 dagen en je ziet allemaal game-threads van mensen met aorta.net melding op upc zweden, andere landen, WoW servers spelers in EU, en noem het maar op die allemaal in hun tracert aorta.net/cogent hebben.
Als ik vraag aan mensen in USA om naar mijn ip een mrt -c 40 iphere te doen, zien ze er meestal zo uit.

Reactie Ziggo:



Reactie Aorta/Cogent: This is an ISP problem, you're not our customer and we cannot assist you.

Dit gaat dus nog wel even duren :9
Ondertussen meerdere malen via twitter DM gesprekken gehad over dit probleem. Het is niet opgelost voor mij. Ik heb geen oplossing en krijg er ook niet eentje.

Die aorta host is mij verteld, is niet 'packet loss', maar 'blokkeert icmp traffic als er te veel is', en werd verwezen om maar weer hier te posten want als hun een ping doen is het 4/4 received en dus alles in orde blijkbaar ..

Alles wat ik test (en kan) lijkt ook inderdaad prima in orde, maar streamen naar youtube kan bijvoorbeeld niet meer, terwijl naar twitch geen problemen geeft. Youtube tracert zegt dat het over aorta gaat, twitch niet.. Mensen kunnen niet gamen meer op mijn MC server bijvoorbeeld, omdat US->NL traffic via cogentco/aorta verloopt in 9/10 gevallen en er dus 90% packet loss op mtr naar voren komt, lag en 2500 tot soms 9000ms en ze melden allemaal hetzelfde als ze tracert of mtr naar de host doen.

Ik ben bang dat ziggo dit oude bekende upc probleem niet kan oplossen van wat ik uit de twitter dms begrijp.
Badge +8
Als ik je plaatjes goed begrijp loopt een mtr vanuit de USA naar jouw eigen IP dood op asd-tr0021-cr101-bundle-ether61-1.aorta.net. Dat is wel gek. Aorta.net is de LibertyGlobal backbone dacht ik en asd is Amsterdam. Dat die aorta-router ICMP dropt kan prima kloppen, maar zou ze wel moeten doorlaten naar routers verderop in de route naar jouw Ziggo IP thuis. Tenminste een mtr vanuit het buitenland naar mijn thuis IP, laat nog twee hops zien na asd-rc0001-cr101-bundle-ether60-1.aorta.net, maar dat is net een andere aorta-hop.

Ook streamen naar youtube moet toch gewoon kunnen? wat laat een mtr naar a.rtnp.youtube.com zien?

En die Mincraft-server staat bij jou thuis? en is vanuit NL wel te bereiken?
Nog een toevoeging op de terechte observaties van efok.
De hop na aorta gaat mis & dat hoeft niet per se een echt probleem te zijn.

Pingplotter komt in dit soort situaties verder, heb ik gemerkt, want die doet, als nodig, ook traceroute tries met bv UDP packets ipv met ICMP echo.
Dan komt er ineens een hostname of ip in beeld met een Packet Loss van 100% voor ICMP tries.

Het zou goed zijn dit ook eens vanuit USA of hier te proberen.
Dat laatste lukt als de Target hostname of het Ip wordt prijsgegeven.
Dan kan via een PM om dit niet meteen op straat te gooien.

Gr Han
efok schreef:

Als ik je plaatjes goed begrijp loopt een mtr vanuit de USA naar jouw eigen IP dood op asd-tr0021-cr101-bundle-ether61-1.aorta.net. Dat is wel gek. Aorta.net is de LibertyGlobal backbone dacht ik en asd is Amsterdam. Dat die aorta-router ICMP dropt kan prima kloppen, maar zou ze wel moeten doorlaten naar routers verderop in de route naar jouw Ziggo IP thuis. Tenminste een mtr vanuit het buitenland naar mijn thuis IP, laat nog twee hops zien na asd-rc0001-cr101-bundle-ether60-1.aorta.net, maar dat is net een andere aorta-hop.

Ook streamen naar youtube moet toch gewoon kunnen? wat laat een mtr naar a.rtnp.youtube.com zien?

En die Mincraft-server staat bij jou thuis? en is vanuit NL wel te bereiken?



Er zijn ondertussen aardig wat sites online, forums zoals deze, maar ook van andere ISP in EU, tweakers.net, etc. waar mensen klagen over gamen, streamen, etc. Als er dan tevens gevraagd wordt welke tracert/mtr/ping er is, is aorta.net steeds in het rijtje. Dit heeft niets volgens mij met wat er bij mij thuis staat te maken. Mijn ouders hebben tevens ziggo en zitten in een dorpje verderop, bijna dezelfde resultaten.

Ja, er zijn mensen uit de USA die "deze minuut" gewoon kunnen verbinden en een stabiele 200ms ping reactie hebben binnen een dienst, een spel.. ze loggen uit en loggen weer in, en hun ping is weer rond de 1000 of opeens 7500ms. En hun geluk was op.

Ja, er zijn mensen binnen EU die kunnen verbinden en geen problemen hebben, of genoegen hebben met 150ms ping (wat voorheen altijd 50ms ping was). Maar ook dat vind ik een duidelijk verschil.

Als ik mijn telefoon op 4g zet en bijvoorbeeld inlog via tmobile, dan is de ping niet meer 25ms maar 275 tot 400ms.

CloudFlare account gemaakt, om het IP ergens achter te gooien, SRV ns record aangemaakt zodat de mensen die binnenkomen via aorta en lag hebben misschien andere route krijgen, maar maakt niet uit. Ook het cloudflare IP waarmee ze verbinden heeft die lag. CloudFlare support gevraagd wat er is, ze zeggen: uit ons onderzoek blijkt dat het icmp verkeer bij aorta.net van liberty global tegengehouden wordt en reroute krijgt.

OpenVPN/OpenConnect van TorGuard geprobeerd, een 10gbit streaming IP van $99/maand en men verbind via frankrijk of germany of usa met een 10.x ip op de servers, geen success, ze hebben gewoon aorta.net in hun mtr zitten en dus lag.

Als je googled zie je vanaf 2013, 2015, 2017, en dit jaar allemaal discussies van hetzelfde probleem. Meestal zonder echte oplossing, meestal zegt men van: hey het is opeens opgelost. En meestal zegt chello, upc, ziggo helpdesk: heb je al nieuwe kabel geprobeerd.

De tests vanuit ziggo naar mij en mij naar ziggo is 5ms lag met 201mbit down en 21,4 mbit up, en waar het goed gaat is het niet via die aorta, en met volle pot heen en weer, zoals ik zei: 90% v/d cloud diensten werken prima, twitch werkt wel bijvoorbeeld.. Had Youtube enzo maar andere cdn om te kiezen. Maar er zijn er maar 2, primary & secondary. Dropbox bijvoorbeeld werkt prima voor fotos, maar een video begint met volle snelheid en dropt na enkele megabytes naar bijna niks en duurt eeuwen voor de film klaar is, en foto rolt hier dan ook zo doorheen natuurlijk.

Ik heb het mac adres in de router aangepast en modem staat op bridge, alle kabels vervangen "just in case" en meeste combinaties van mijn firewall wel geprobeerd ondertussen. Thuis kan ik weinig meer doen.

De reactie van ziggo op twitter was dan ook dat wat er op het aorta netwerk gebeurd is buiten hun tech weet ik het, en ze vinden het jammer dat ze geen oplossing zien voor me en wensen me veel suc6 met het oplossen. Ik heb ze screenshot gegeven van sites die aorta aanwijzen als het probleem, en herinnerd dat aorta hun verantwoording is. Ze zeiden hiervoor dat het niet hun probleem was want anders stond de helpdesk wel roodgloeiend, maar ondertussen zie je de resultaten over aorta groeien in google results van mensen met problemen die niets met ziggo te maken hebben zoals wow gamers, LoL gamers, tweakers met hun VPS services, VPN forums waar ze vragen waarom het fout gaat bij aorta, etc.

Maar goed, het zal wel aan mij liggen, ik ben de oorzaak van dat alles, want ik heb controle over aorta.


mtr naar youtube's ingest server
Host Loss% Snt Last Avg Best Wrst StDev
1. 192.168.1.1 0.0% 33 0.3 0.3 0.3 0.5 0.1
2. 10.160.65.129 0.0% 33 8.4 12.1 7.4 81.2 13.8
3. 212.142.51.9 0.0% 33 9.7 10.6 8.6 21.4 2.5
4. asd-tr0021-cr101-bundle-ether112-1.aorta.net 0.0% 32 9.4 12.3 8.9 67.3 10.1
5. nl-ams02a-rc2-lag-61-1.aorta.net 96.8% 32 9.5 9.5 9.5 9.5 0.0
6. nl-ams14a-ri1-ae5-0.aorta.net 0.0% 32 15.6 16.5 8.8 61.1 11.3
7. 74.125.146.228 0.0% 32 9.4 14.5 8.9 121.6 19.7
8. 108.170.241.129 0.0% 32 11.3 10.9 8.7 20.1 2.1
9. 216.239.42.71 0.0% 32 9.9 12.9 8.8 86.1 13.4
10. ams15s22-in-f14.1e100.net 0.0% 32 9.6 10.1 8.5 13.9 1.2
Badge +8
mrfloris schreef:



CloudFlare support gevraagd wat er is, ze zeggen: uit ons onderzoek blijkt dat het icmp verkeer bij aorta.net van liberty global tegengehouden wordt en reroute krijgt.

OpenVPN/OpenConnect van TorGuard geprobeerd, een 10gbit streaming IP van $99/maand en men verbind via frankrijk of germany of usa met een 10.x ip op de servers, geen success, ze hebben gewoon aorta.net in hun mtr zitten en dus lag.

Als je googled zie je vanaf 2013, 2015, 2017, en dit jaar allemaal discussies van hetzelfde probleem.

De tests vanuit ziggo naar mij en mij naar ziggo is 5ms lag met 201mbit down en 21,4 mbit up, en waar het goed gaat is het niet via die aorta, en met volle pot heen en weer, zoals ik zei: 90% v/d cloud diensten werken prima, twitch werkt wel bijvoorbeeld.. Had Youtube enzo maar andere cdn om te kiezen. Maar er zijn er maar 2, primary & secondary. Dropbox bijvoorbeeld werkt prima voor fotos, maar een video begint met volle snelheid en dropt na enkele megabytes naar bijna niks en duurt eeuwen voor de film klaar is, en foto rolt hier dan ook zo doorheen natuurlijk.

Thuis kan ik weinig meer doen.

De reactie van ziggo op twitter was dan ook dat wat er op het aorta netwerk gebeurd is buiten hun tech weet ik het, en ze vinden het jammer dat ze geen oplossing zien voor me en wensen me veel suc6 met het oplossen. Ik heb ze screenshot gegeven van sites die aorta aanwijzen als het probleem, en herinnerd dat aorta hun verantwoording is. Ze zeiden hiervoor dat het niet hun probleem was want anders stond de helpdesk wel roodgloeiend, maar ondertussen zie je de resultaten over aorta groeien in google results van mensen met problemen die niets met ziggo te maken hebben zoals wow gamers, LoL gamers, tweakers met hun VPS services, VPN forums waar ze vragen waarom het fout gaat bij aorta, etc.


mtr naar youtube's ingest server
Host Loss% Snt Last Avg Best Wrst StDev
1. 192.168.1.1 0.0% 33 0.3 0.3 0.3 0.5 0.1
2. 10.160.65.129 0.0% 33 8.4 12.1 7.4 81.2 13.8
3. 212.142.51.9 0.0% 33 9.7 10.6 8.6 21.4 2.5
4. asd-tr0021-cr101-bundle-ether112-1.aorta.net 0.0% 32 9.4 12.3 8.9 67.3 10.1
5. nl-ams02a-rc2-lag-61-1.aorta.net 96.8% 32 9.5 9.5 9.5 9.5 0.0
6. nl-ams14a-ri1-ae5-0.aorta.net 0.0% 32 15.6 16.5 8.8 61.1 11.3
7. 74.125.146.228 0.0% 32 9.4 14.5 8.9 121.6 19.7
8. 108.170.241.129 0.0% 32 11.3 10.9 8.7 20.1 2.1
9. 216.239.42.71 0.0% 32 9.9 12.9 8.8 86.1 13.4
10. ams15s22-in-f14.1e100.net 0.0% 32 9.6 10.1 8.5 13.9 1.2



Je schrijft een heleboel, en ik heb er een paar stukken uitgelicht hierboven.

Cloudfare bevestigt aan je dat er een probleem is. Dat lijkt me op zich wel stevig staan.
Je mtr naar youtube laat echter geen packet loss zien op de youtube server en normale pingtijden toch? Dus daar zie ik nu geen probleem.

Heb je links naar de Google resultaten en de screenshots waarnaar je verwijst?
Hier ook last van exact hetzelfde probleem...

Gamen is dan ook echt waardeloos geworden.

Heb je toevallig al progressie met aorta of ziggo ?
@Takens
Wat bedoel je met 'exact hetzelfde probleem'?

Packet Loss bij een tussengelegen hop, zoals een host in aorta.net,
is geen probleem bij een traceroute.
Dat is zo ingesteld op die host. Die reageert niet op alle ping try packets van de traceroute die een TTL=1 hebben. Soms zie je onderweg zelfs 100% loss.

Packet loss bij de Target Host kan wel wijzen op een probleem.

Verklaar je dus nader. Laat maar een trace zien.
Gr Han

https://en.wikipedia.org/wiki/Traceroute

Reageer