Beantwoord

Packet loss (deel 2) Bij aorta net

  • 13 september 2018
  • 42 Reacties
  • 3170x Bekeken

Dit is een opvolgtopic voor https://community.ziggo.nl/internetverbinding-102/90-packet-loss-bij-aorta-net-30965. Een Ziggo supportmedewerker raadde mij aan om een nieuw topic te openen, omdat ik op "opgelost" heb gedrukt.

Ik zal het topic even zo veel mogelijk samenvatten:

Ik ben van mijn datacenter doorverwezen naar Cogent en van Cogent naar jullie toe.

Ik heb al een tijd last van het probleem dat ik bij sommige routes en enorme packet loss heb, waardoor het downloaden van bestanden gewoon niet te doen is met een lage snelheid (denk aan 400 kb/sec max) en regelmatig dropt mijn verbinding.

Ik heb met behulp van MTR (tool) een report opgemaakt van mijn thuis IP naar mijn datacenter rack toe:

Van thuis IP naar server (nu 50x):



Van server naar thuis IP:



Van RoutIt naar server (geen issues, want daar zit geen Cogent route in):



Het probleem lijkt zich af te spelen op 149.11.134.250.

Ik heb contact gehad met mijn datacenter en zij geven aan dat ik dit probleem bij Cogent ligt en dat ik het met hun of met Ziggo moet oplossen. Nu heb ik contact gehad met Cogent en mijn datacenter en kreeg als reactie:

Cogent:
Dear Wesley.
please contact your internet service provider in regards to this. We cannot support you as a non-Cogent customer.


Datacenter:
Looks like Ziggo has problems with internal network and peerings with other providers (Cogent in this case). Network engineers confirmed that there are no problems with our network actually.

Dus hierbij mijn vraag om hulp van een Ziggo medewerker. :)

Misschien handig om te weten:
  • Ik zit niet op WiFi
  • Modem meerdere malen gereset
  • Router meerdere malen gereset
  • Dit probleem speelt zich af op alle Ziggo verbindingen naar mijn datacenter toe, maar niet bij andere providers (KPN e.d.).
icon

Best beantwoord door WesleyNL 22 september 2018, 00:10

Het probleem lijkt inmiddels "vanzelf" verholpen te zijn. Ik ben ondertussen wel op zoek gegaan naar een nieuwe carrier aangezien dit probleem helaas al meerdere keren voorgekomen is.

In ieder geval, bedankt allemaal voor jullie hulp!
Bekijk origineel

42 Reacties

Ik zie dat je al gemiddeld 20ms latency hebt naar je eigen router. En 70ms als slechtste.
Terwijl met je KPN verbinding dat probleem niet hebt.
Ik zie dat je al gemiddeld 20ms latency hebt naar je eigen router. En 70ms als slechtste.
Terwijl met je KPN verbinding dat probleem niet hebt.

Omdat ik KPN op mijn kantooradres heb en Ziggo thuis. Maar dat verklaart het probleem overigens niet, want het zit 'm echt in de peering.
Dat verklaart mijn inziens niet waarom je latency zo hoog is naar je eigen router. Doordat de fluctuatie behoorlijk hoog is doet mij nou net vermoeden dat je probleem daar ligt, en niet op het Ziggo netwerk.

Die "packetloss" is geen probleem tussen die 2 routers, want dan zouden de hops daarna ook dezelfde of hogere packetloss laten zien.
Als ik een MTR opstart, zie ik dezelfde packet-loss:

Bij een normale tracert zie je die niet eens.

Tracing route to 149.11.134.250 over a maximum of 30 hops

1 9 ms 5 ms 5 ms 10.160.65.1
2 7 ms 8 ms 7 ms 212.142.55.157
3 10 ms 9 ms 11 ms asd-tr0021-cr101-bundle-ether111-1.aorta.net [84.116.244.121]
4 * * * Request timed out.
5 11 ms 9 ms 9 ms nl-ams14a-ri1-ae5-0.aorta.net [84.116.135.34]
6 10 ms 11 ms 11 ms be3065.ccr41.ams03.atlas.cogentco.com [130.117.14.1]
7 11 ms 11 ms 12 ms be2755.rcr21.ams08.atlas.cogentco.com [130.117.48.58]
8 10 ms 11 ms 12 ms 149.11.134.250

Trace complete.

Maar het heeft geen effect op de uiteindelijke verbinding.
Dat verklaart mijn inziens niet waarom je latency zo hoog is naar je eigen router. Doordat de fluctuatie behoorlijk hoog is doet mij nou net vermoeden dat je probleem daar ligt, en niet op het Ziggo netwerk.

Die "packetloss" is geen probleem tussen die 2 routers, want dan zouden de hops daarna ook dezelfde of hogere packetloss laten zien.

De latency is in dit geval hoog omdat ik het probleem na ging bootsen met een vpn verbinding naar huis toe. Geloof mij, het probleem doet zich voort op alle Ziggo adressen van mijn collega's, familie en vrienden. Je gaat mij niet wijs maken dat het probleem bij hun allemaal ligt. 😉 en mijn kennissen met een andere provider hebben dit probleem totaal niet, dus datacenter issues kunnen we uitsluiten.

Mijn datacenter en meerdere gebruikers op dit forum hebben het probleem overigens bevestigd. Waarom geef jij dan aan dat het specifiek aan mijn latency ligt?

Ik wil met alle plezier een MTR voor je draaien vanavond vanuit huis, zodat je een 1 ms latency kunt zien naar mijn router en alsnog packet loss bij Cogent.


Ik wil met alle plezier een MTR voor je draaien vanavond vanuit huis, zodat je een 1 ms latency kunt zien naar mijn router en alsnog packet loss bij Cogent.


Ja graag


Ik wil met alle plezier een MTR voor je draaien vanavond vanuit huis, zodat je een 1 ms latency kunt zien naar mijn router en alsnog packet loss bij Cogent.
Ja graag

Hier heb je alvast 2 MTR reports.

1) Utrecht op Ziggo Zakelijk



2) Apeldoorn op Ziggo



Downloadsnelheid vanaf Utrecht op Ziggo Zakelijk naar Datacenter:



Downloadsnelheid vanaf Utrecht op Ziggo Zakelijk naar een willekeurig adres:



Downloadsnelheid vanaf Utrecht op Routit naar Datacenter:


Ben je er nog steeds van overtuigd dat het een latency probleem is van mijn router? Bovenstaande tests (op Apeldoorn na) is uitgevoerd vanaf dezelfde kabel op dezelfde router. Ik en mijn datacenter geloven namelijk sterk dat dit een peering issue is tussen Cogent en Ziggo.
Badge +11
Hmm, ik zie vanaf hier een klein verschil.

MTR -c 40 vanaf een KPN-lijn:

Start: Thu Sep 13 17:06:11 2018
HOST: ****** Loss% Snt Last Avg Best Wrst StDev
1.|-- 192.168.2.254 0.0% 40 0.3 0.3 0.2 0.9 0.0
2.|-- 195.190.228.91 0.0% 40 5.3 7.4 4.8 39.5 5.9
3.|-- nl-asd2-pice-ir01.kpn.net 90.0% 40 7.4 7.4 7.2 7.7 0.0
4.|-- asd2-rou-1022.NL.euroring 0.0% 40 10.4 10.3 9.2 21.1 2.0
5.|-- asd2-rou-1043.NL.euroring 0.0% 40 9.4 10.1 9.3 16.2 1.0
6.|-- asd-s17-rou-1041.NL.euror 0.0% 40 10.0 10.2 9.7 12.1 0.3
7.|-- ae-6.r25.amstnl02.nl.bb.g 0.0% 40 11.2 10.6 10.1 12.2 0.3
8.|-- ae-19.r24.amstnl02.nl.bb. 0.0% 40 8.3 10.0 8.1 43.9 6.1
9.|-- ae-0.a00.amstnl02.nl.bb.g 0.0% 40 8.8 9.7 8.0 18.0 2.2
10.|-- 81.20.64.30 0.0% 40 8.7 10.0 8.0 37.4 5.5
11.|-- rtr1.dedicolo.com 0.0% 40 11.3 11.2 10.5 12.1 0.0
12.|-- 185.68.182.1 0.0% 40 9.8 10.2 9.5 11.2 0.2


0% loss op 185.68.182.1

Vanaf Ziggo-aansluiting:
mtr -c 40 --report 185.68.182.1
Start: 2018-09-13T17:04:35+0200
HOST: *******-desktop Loss% Snt Last Avg Best Wrst StDev
1.|-- router 0.0% 40 0.4 0.4 0.3 0.4 0.0
2.|-- 10.255.166.1 0.0% 40 10.3 9.0 3.5 13.2 2.1
3.|-- asn-rc0002-cr101-ae122-0. 0.0% 40 10.2 11.4 6.2 44.5 5.6
4.|-- asd-rc0001-cr101-bundle-e 0.0% 40 16.7 14.9 10.6 21.2 2.2
5.|-- ??? 100.0 40 0.0 0.0 0.0 0.0 0.0
6.|-- nl-ams14a-ri1-ae8-0.aorta 0.0% 40 15.1 16.0 12.6 33.3 3.3
7.|-- be3065.ccr41.ams03.atlas. 0.0% 40 14.5 14.5 11.2 20.3 1.9
8.|-- be2755.rcr21.ams08.atlas. 0.0% 40 15.0 15.7 11.9 23.4 1.9
9.|-- 149.11.134.250 0.0% 40 13.8 17.2 8.7 66.6 10.1
10.|-- rtr1.dedicolo.com 2.5% 40 12.2 15.2 9.9 20.9 2.5
11.|-- 185.68.182.1 2.5% 40 15.4 16.2 11.5 20.6 1.8

2.5% loss, hoewel een 2e run 0.0% loss liet zien. Ik vraag me daarom een beetje af hoe reeël dit is voor jouw probleem. Wat wel zo is, is inderdaad dat de peering van KPN via een andere route loopt dan Ziggo, hoewel de loss pas optreedt aan het einde van de keten. Zou toch cogent of je datacenter nog maar eens lastig vallen.
Hmm, ik zie vanaf hier een klein verschil.

MTR -c 40 vanaf een KPN-lijn:

Start: Thu Sep 13 17:06:11 2018
HOST: ****** Loss% Snt Last Avg Best Wrst StDev
1.|-- 192.168.2.254 0.0% 40 0.3 0.3 0.2 0.9 0.0
2.|-- 195.190.228.91 0.0% 40 5.3 7.4 4.8 39.5 5.9
3.|-- nl-asd2-pice-ir01.kpn.net 90.0% 40 7.4 7.4 7.2 7.7 0.0
4.|-- asd2-rou-1022.NL.euroring 0.0% 40 10.4 10.3 9.2 21.1 2.0
5.|-- asd2-rou-1043.NL.euroring 0.0% 40 9.4 10.1 9.3 16.2 1.0
6.|-- asd-s17-rou-1041.NL.euror 0.0% 40 10.0 10.2 9.7 12.1 0.3
7.|-- ae-6.r25.amstnl02.nl.bb.g 0.0% 40 11.2 10.6 10.1 12.2 0.3
8.|-- ae-19.r24.amstnl02.nl.bb. 0.0% 40 8.3 10.0 8.1 43.9 6.1
9.|-- ae-0.a00.amstnl02.nl.bb.g 0.0% 40 8.8 9.7 8.0 18.0 2.2
10.|-- 81.20.64.30 0.0% 40 8.7 10.0 8.0 37.4 5.5
11.|-- rtr1.dedicolo.com 0.0% 40 11.3 11.2 10.5 12.1 0.0
12.|-- 185.68.182.1 0.0% 40 9.8 10.2 9.5 11.2 0.2


0% loss op 185.68.182.1

Vanaf Ziggo-aansluiting:
mtr -c 40 --report 185.68.182.1
Start: 2018-09-13T17:04:35+0200
HOST: *******-desktop Loss% Snt Last Avg Best Wrst StDev
1.|-- router 0.0% 40 0.4 0.4 0.3 0.4 0.0
2.|-- 10.255.166.1 0.0% 40 10.3 9.0 3.5 13.2 2.1
3.|-- asn-rc0002-cr101-ae122-0. 0.0% 40 10.2 11.4 6.2 44.5 5.6
4.|-- asd-rc0001-cr101-bundle-e 0.0% 40 16.7 14.9 10.6 21.2 2.2
5.|-- ??? 100.0 40 0.0 0.0 0.0 0.0 0.0
6.|-- nl-ams14a-ri1-ae8-0.aorta 0.0% 40 15.1 16.0 12.6 33.3 3.3
7.|-- be3065.ccr41.ams03.atlas. 0.0% 40 14.5 14.5 11.2 20.3 1.9
8.|-- be2755.rcr21.ams08.atlas. 0.0% 40 15.0 15.7 11.9 23.4 1.9
9.|-- 149.11.134.250 0.0% 40 13.8 17.2 8.7 66.6 10.1
10.|-- rtr1.dedicolo.com 2.5% 40 12.2 15.2 9.9 20.9 2.5
11.|-- 185.68.182.1 2.5% 40 15.4 16.2 11.5 20.6 1.8

2.5% loss, hoewel een 2e run 0.0% loss liet zien. Ik vraag me daarom een beetje af hoe reeël dit is voor jouw probleem. Wat wel zo is, is inderdaad dat de peering van KPN via een andere route loopt dan Ziggo, hoewel de loss pas optreedt aan het einde van de keten. Zou toch cogent of je datacenter nog maar eens lastig vallen.

Het is natuurlijk lastig om een vinger te wijzen, maar ik heb meerdere keren gemaild en geklaagd bij mijn datacenter en ze zijn er flink van overtuigd dat het probleem echt niet bij hun ligt en dat ik dit moet oplossen met Cogent of Ziggo. Nu wil Cogent mij niet te woord staan en verwijzen zij mij door naar Ziggo, Ziggo's helpdesk verwees mij door naar de community (beetje raar..) omdat hier af en toe een specialist komt kijken.

Ziggo kan en mag contact opnemen met Cogent omdat zij ermee samenwerken, mijn datacenter staat, voor zover ik weet, daar los van. Een kleine analyse runnen vanaf Ziggo lijkt mij toch geen kwaad kunnen?

Het is namelijk zeer frustrerend dat er geen normale verbinding tot stand gebracht kan worden tussen mijn huis en mijn rack en ik sta hier compleet machteloos tussen en wordt al dagen lang van het kastje naar de muur gewezen.
Badge +11
Ziggo's helpdesk verwees mij door naar de community (beetje raar..) omdat hier af en toe een specialist komt kijken.

Dat is zeker raar, want al hoe slim wij ook zijn 😊, wij kunnen hooguit meekijken, maar het ook niet voor je oplossen. Ziggo zou toch een telefoontje naar Cogent kunnen wagen. Maar dit gaat de basis-helpdesk boven de pet, en dan verwijzen ze je maar naar een forum. Ze kunnen je beter doorzetten naar een 2e of 3e lijn lijkt me.

Ziggo kan en mag contact opnemen met Cogent omdat zij ermee samenwerken, mijn datacenter staat, voor zover ik weet, daar los van. Een kleine analyse runnen vanaf Ziggo lijkt mij toch geen kwaad kunnen?

Het is namelijk zeer frustrerend dat er geen normale verbinding tot stand gebracht kan worden tussen mijn huis en mijn rack en ik sta hier compleet machteloos tussen en wordt al dagen lang van het kastje naar de muur gewezen.

Precies

Ter info:

wget http://speedtest.xs4all.net/files/2GB.bin
--2018-09-13 18:12:21-- http://speedtest.xs4all.net/files/2GB.bin
Herleiden van speedtest.xs4all.net (speedtest.xs4all.net)... 194.109.6.103
Verbinding maken met speedtest.xs4all.net (speedtest.xs4all.net)|194.109.6.103|:80... verbonden.
HTTP-verzoek is verzonden; wachten op antwoord... 200 OK
Lengte: 2000000000 (1,9G) [application/octet-stream]
Wordt opgeslagen als: ‘2GB.bin

2GB.bin.2 10%[=======> ] 192,33M 17,3MB/s eta 2m 1s

wget http://185.68.182.14/2GB.bin
--2018-09-13 18:09:57-- http://185.68.182.14/2GB.bin
Verbinding maken met 185.68.182.14:80... verbonden.
HTTP-verzoek is verzonden; wachten op antwoord... 200 OK
Lengte: 2000000000 (1,9G) [application/octet-stream]
Wordt opgeslagen als: ‘2GB.bin.1’

2GB.bin.1 1%[ ] 22,65M 1,00MB/s eta 36m 6s

Dit is vanuit het noorden van het land. Ook hier geen hoge download snelheid vanaf jouw datacenter naar mij. Er is ergens een bottleneck. (Uiteraard weet ik niet wat jouw server in het datacenter normaal zou moeten kunnen leveren.)
Ben ook wel benieuwd of naar de mening en test van 1 van de Ziggo moderators hier.
Ik blijf erbij, die verbinding van jouw is niet goed. Als je kijkt naar de kolom "worst", dat zijn me nogal hoge getallen. De fluctuatie is veel te hoog.

Als je de nummers van KPN neemt, die zien er allemaal goed uit. Die van Ziggo is niet best.
Ik denk dat je eigen verbinding eens onder de loep moet nemen.

Ziggo's helpdesk verwees mij door naar de community (beetje raar..) omdat hier af en toe een specialist komt kijken.
Dat is zeker raar, want al hoe slim wij ook zijn 😊, wij kunnen hooguit meekijken, maar het ook niet voor je oplossen. Ziggo zou toch een telefoontje naar Cogent kunnen wagen. Maar dit gaat de basis-helpdesk boven de pet, en dan verwijzen ze je maar naar een forum. Ze kunnen je beter doorzetten naar een 2e of 3e lijn lijkt me.


Ziggo kan en mag contact opnemen met Cogent omdat zij ermee samenwerken, mijn datacenter staat, voor zover ik weet, daar los van. Een kleine analyse runnen vanaf Ziggo lijkt mij toch geen kwaad kunnen?

Het is namelijk zeer frustrerend dat er geen normale verbinding tot stand gebracht kan worden tussen mijn huis en mijn rack en ik sta hier compleet machteloos tussen en wordt al dagen lang van het kastje naar de muur gewezen.
Precies

Ter info:

wget http://speedtest.xs4all.net/files/2GB.bin
--2018-09-13 18:12:21-- http://speedtest.xs4all.net/files/2GB.bin
Herleiden van speedtest.xs4all.net (speedtest.xs4all.net)... 194.109.6.103
Verbinding maken met speedtest.xs4all.net (speedtest.xs4all.net)|194.109.6.103|:80... verbonden.
HTTP-verzoek is verzonden; wachten op antwoord... 200 OK
Lengte: 2000000000 (1,9G) [application/octet-stream]
Wordt opgeslagen als: ‘2GB.bin

2GB.bin.2 10%[=======> ] 192,33M 17,3MB/s eta 2m 1s

wget http://185.68.182.14/2GB.bin
--2018-09-13 18:09:57-- http://185.68.182.14/2GB.bin
Verbinding maken met 185.68.182.14:80... verbonden.
HTTP-verzoek is verzonden; wachten op antwoord... 200 OK
Lengte: 2000000000 (1,9G) [application/octet-stream]
Wordt opgeslagen als: ‘2GB.bin.1’

2GB.bin.1 1%[ ] 22,65M 1,00MB/s eta 36m 6s

Dit is vanuit het noorden van het land. Ook hier geen hoge download snelheid vanaf jouw datacenter naar mij. Er is ergens een bottleneck. (Uiteraard weet ik niet wat jouw server in het datacenter normaal zou moeten kunnen leveren.)
Ben ook wel benieuwd of naar de mening en test van 1 van de Ziggo moderators hier.

Bedankt voor 't meetesten en denken :)

Download hetzelfde bestand maar voor de grap eens via jouw KPN verbinding en je zult je volledige snelheid eruit halen in ieder geval.
Ik blijf erbij, die verbinding van jouw is niet goed. Als je kijkt naar de kolom "worst", dat zijn me nogal hoge getallen. De fluctuatie is veel te hoog.

Als je de nummers van KPN neemt, die zien er allemaal goed uit. Die van Ziggo is niet best.
Ik denk dat je eigen verbinding eens onder de loep moet nemen.

Ok, maar hoe verklaar je dat andere ziggo gebruikers op dit forum hetzelfde probleem ervaren? Allemaal foutieve verbindingen met hun routers volgens jou?
Reputatie 4
Badge +4
aorta.net nodes (ooit van UPC geloof ik) hebben wel vaker performance problemen gehad. Hoge packet loss en meer dan 600 ms response.


Ik wil met alle plezier een MTR voor je draaien vanavond vanuit huis, zodat je een 1 ms latency kunt zien naar mijn router en alsnog packet loss bij Cogent.
Ja graag

Hierbij een MTR van mijn eigen thuisnetwerk.



Wat is nu je mening? Mijn wrst is 1.7 ms. Ben je nog steeds van mening dat het aan mijn eigen latency naar mijn router ligt?
Ok, maar hoe verklaar je dat andere ziggo gebruikers op dit forum hetzelfde probleem ervaren? Allemaal foutieve verbindingen met hun routers volgens jou?

Met name welke andere gebruikers?

Goed, ik blijf erbij wat ik zo bij je zie. Als ik het mis heb, hoor ik dat tegen die tijd graag van je 😉

Kijk dan eens naar die 2de hop .. dat is gewoon niet goed.

Ok, maar hoe verklaar je dat andere ziggo gebruikers op dit forum hetzelfde probleem ervaren? Allemaal foutieve verbindingen met hun routers volgens jou?Met name welke andere gebruikers?

Goed, ik blijf erbij wat ik zo bij je zie. Als ik het mis heb, hoor ik dat tegen die tijd graag van je 😉

Check gelijk even mijn laatste screenshot. 🙂
Ja, reactie had ik erbij geschreven

Ok, maar hoe verklaar je dat andere ziggo gebruikers op dit forum hetzelfde probleem ervaren? Allemaal foutieve verbindingen met hun routers volgens jou?Met name welke andere gebruikers?

Goed, ik blijf erbij wat ik zo bij je zie. Als ik het mis heb, hoor ik dat tegen die tijd graag van je 😉


Kijk dan eens naar die 2de hop .. dat is gewoon niet goed.

Oke, laten we stellen dat het specifiek aan mijn probleem ligt.

Als ik nu op dit moment verbindt met welk VPN dan ook (HideMyAss, Vypr, Nord of welke dan ook), gaat het helemaal perfect en heb ik geen packet loss.

Vrienden/familie/kennissen met Ziggo ervaren hetzelfde als ze bijvoorbeeld een bestand downloaden vanaf 1 van mijn servers.

Vrienden/familie/kennissen met KPN ervaren dit niet.

Bekijk mijn screenshots eens met mijn downloads vanuit hetzelfde netwerk. Hoe kan je verklaren dat in hetzelfde netwerk geen packetloss meer is zodra ik met een ander provider verbindt, vanuit meerdere locaties vanuit het land met Ziggo verbindingen?

Kijk naar de post van gebruiker efok, hij heeft ook het probleem zodra hij een bestand download vanaf mijn server.
Hier nog even een video van wat ik bedoel:

https://streamable.com/wy3ad

Ik waardeer overigens jouw hulp en het meedenken hoor, maar het kan niet aan mijn verbinding liggen. Deze video bewijst het eigenlijk al.
Ik was even eten.

Kan je mij een traceroute laten zien met de vpn?
Ik was even eten.

Kan je mij een traceroute laten zien met de vpn?

traceroute to 185.68.182.14 (185.68.182.14), 64 hops max, 52 byte packets
1 unn-195-181-172-161.datapacket.com (195.181.172.161) 14.733 ms 12.937 ms 13.768 ms
2 unn-195-181-172-174.datapacket.com (195.181.172.174) 13.370 ms 10.681 ms 16.538 ms
3 ae0-406.ams10.core-backbone.com (81.95.2.189) 13.859 ms 15.743 ms 12.457 ms
4 3winfra-eq-am7.ams-ix.net (80.249.213.204) 10.859 ms 16.131 ms 14.515 ms
5 rtr1.dedicolo.com (185.27.239.249) 13.546 ms 16.683 ms 14.695 ms
6 185.68.183.251 (185.68.183.251) 15.623 ms 16.803 ms 19.399 ms
7 185.68.182.14 (185.68.182.14) 13.313 ms 16.724 ms 18.278 ms
kan het ook met MTR?
kan het ook met MTR?

Reageer