Beantwoord

Maximale downloadsnelheid van 100 Mbps met Mikrotik CRS109-8G-1S-2HnD

  • 5 november 2019
  • 54 Reacties
  • 1094x Bekeken

Mijn Ziggo Modem staat in Bridge mode. Ik heb er een Mikrotik CRS109-8G-1S-2HnD router/switch aan hangen. Wanneer ik mijn laptop aan een LAN poort van de Mikrotik switch hang haal ik met een speedtest een maximale download snelheid van +/- 100 Mbps download en 40 Mbps upload. Als ik de kabel waarmee de Mikrotik verbonden is direct verbind met mijn laptop haal ik met dezelfde speedtest een download snelheid van 500 Mbps download en 40 Mbps upload. Dat laatste komt overeen met de snelheid van mijn Ziggo abonnement

Het lijkt er op dat de Mikrotik dus de bottleneck is qua download snelheid. Heb al een paar dingen gecheckt:

Op de Mikrotik kan ik zien dat de poort van de Mikrotik die verbonden is met het Ziggo modem staat ingesteld op 1 Gbps. Lijkt me goed.

Bestanden kopieren tussen computers die zijn aangesloten op de LAN poorten van de Mikrotik gaat met meer dan 115 Mb per seconde dus dat zit aan de limiet van de 1 Gbps poorten.

Al het internet verkeer moet natuurlijk op de Mikrotik via de firewall (NAT). Zou dat de bottleneck kunnen zijn of moet de Mikrotik CRS109-8G-1S-2HnD dat met gemak aankunnen. Zou graag willen weten of ik toch nog op zoek moet naar een obscure instelling in de Mikrotik om de bottleneck weg te nemen of dat dit apparaat gewoon aan zijn max. zit en ik hem beter kan vervangen door een ander appararaat zonder 100 Mbps limiet voor verkeer op de WAN poort.
 

icon

Best beantwoord door Peter uit Amsterdam 15 december 2019, 16:09

@Gusto@efok 

Het heeft even geduurt maar inmiddels heb ik de CRS125-24G-1S-2HnD van een nieuwe configuratie voorzien. Het duurde even wat langer omdat ik dat met een scriptje wilde doen. De oude configuratie was een beetje een zooitje geworden en een recentelijk hardware probleem met de Mikrotik had mij aan het denken gezet dat een scriptje, waarmee je de router helemaal geautomatiseerd zou kunnen inrichten, toch wel handig zou zijn. Ik weet niet of je een back-up eenvoudig kunt terug zetten op een ander type Mikrotik dat zou dan ook een optie zijn geweest maar met een scriptje ben je waarschijnlijk flexibeler.

Daarnaast heb ik de afgelopen tijd mijn Ziggo abonnement ge-downgrade. Immers ik heb eigenlijk maanden lang niet echt gemerkt dat mijn Mikrotik de snelheid beperkte tot maar 100 Mbit dus ik dacht dan ik het wel een tijdje gaan proberen met 250 Mbit download i.p.v. 500 Mbit download.

Is er natuurlijk wel een nieuwe nul-meting nodig waarbij ik mijn laptop direct verbind met het Ziggo modem (dus zonder Mikrotik er tussen). Dit is daarvan het resultaat:

 

 

Dat is dus keurig de snelheid van mijn nieuwe “Complete” abonnement.

Nadat ik de CRS125-24G-1S-2HnD volledig opnieuw had ingericht vanaf een factory reset (met mijn scriptje) heb ik weer een speedtest gedaan met dit resultaat:
 

 

 

Weg 100 Mbit limiet. Hoera! Probleem opgelost. Het kleine snelheids verlies dat nog zichtbaar is kan ik verklaren vanuit mijn Mikrotik configuratie. Naast mijn basis WIFI heb ik ook nog een gasten WIFI geconfigureerd. Via een Firewall rule blokkeer ik al het verkeer van het gasten netwerk naar ons huis netwerk. Omdat te kunnen blokkeren moest ik voor alle Mikrotik bridges instellen dat verkeer over een bridge via de firewall moet lopen. (Kan dat handiger?) Dat is een setting/vinkje onder:

    /interface bridge settings
    set use-ip-firewall=yes

Als ik die even instel op "no” dan krijg ik weer de volle snelheid:
 


 

Nog een tip voor als je zelf de snelheid van je verbindingen op een Mikrotik wil testen. Zorg dat je tijdens het testen alle WinBox verbindingen sluit naar je router. Het is leuk dat je in de GUI van WinBox alle IP packetjes kun zien langs komen maar al die tellertjes die real-time worden bijgewerkt hebben volgens mij wel een beperkend effect op je metingen. Ik kreeg de beste resultaten als alle WinBox sessies gesloten waren.

Ik ben in de afgelopen tijd weer wat wijzer geworden en nog meer onder de indruk geraakt van wat je allemaal kunt doen met Mikrotik routers.

Groeten, en bedankt voor al jullie tips en hulp.

Bekijk origineel

54 Reacties

@Ronihd ,

een Mikrotik kan veel meer dan een Asus (zelfs met alternative firmware). :wink:

 

Groet, Gusto

Reputatie 6
Badge +7

Ach, wie weet hebben anderen er nog iets aan :smiley:

@Gusto@efok 

Het heeft even geduurt maar inmiddels heb ik de CRS125-24G-1S-2HnD van een nieuwe configuratie voorzien. Het duurde even wat langer omdat ik dat met een scriptje wilde doen. De oude configuratie was een beetje een zooitje geworden en een recentelijk hardware probleem met de Mikrotik had mij aan het denken gezet dat een scriptje, waarmee je de router helemaal geautomatiseerd zou kunnen inrichten, toch wel handig zou zijn. Ik weet niet of je een back-up eenvoudig kunt terug zetten op een ander type Mikrotik dat zou dan ook een optie zijn geweest maar met een scriptje ben je waarschijnlijk flexibeler.

Daarnaast heb ik de afgelopen tijd mijn Ziggo abonnement ge-downgrade. Immers ik heb eigenlijk maanden lang niet echt gemerkt dat mijn Mikrotik de snelheid beperkte tot maar 100 Mbit dus ik dacht dan ik het wel een tijdje gaan proberen met 250 Mbit download i.p.v. 500 Mbit download.

Is er natuurlijk wel een nieuwe nul-meting nodig waarbij ik mijn laptop direct verbind met het Ziggo modem (dus zonder Mikrotik er tussen). Dit is daarvan het resultaat:

 

 

Dat is dus keurig de snelheid van mijn nieuwe “Complete” abonnement.

Nadat ik de CRS125-24G-1S-2HnD volledig opnieuw had ingericht vanaf een factory reset (met mijn scriptje) heb ik weer een speedtest gedaan met dit resultaat:
 

 

 

Weg 100 Mbit limiet. Hoera! Probleem opgelost. Het kleine snelheids verlies dat nog zichtbaar is kan ik verklaren vanuit mijn Mikrotik configuratie. Naast mijn basis WIFI heb ik ook nog een gasten WIFI geconfigureerd. Via een Firewall rule blokkeer ik al het verkeer van het gasten netwerk naar ons huis netwerk. Omdat te kunnen blokkeren moest ik voor alle Mikrotik bridges instellen dat verkeer over een bridge via de firewall moet lopen. (Kan dat handiger?) Dat is een setting/vinkje onder:

    /interface bridge settings
    set use-ip-firewall=yes

Als ik die even instel op "no” dan krijg ik weer de volle snelheid:
 


 

Nog een tip voor als je zelf de snelheid van je verbindingen op een Mikrotik wil testen. Zorg dat je tijdens het testen alle WinBox verbindingen sluit naar je router. Het is leuk dat je in de GUI van WinBox alle IP packetjes kun zien langs komen maar al die tellertjes die real-time worden bijgewerkt hebben volgens mij wel een beperkend effect op je metingen. Ik kreeg de beste resultaten als alle WinBox sessies gesloten waren.

Ik ben in de afgelopen tijd weer wat wijzer geworden en nog meer onder de indruk geraakt van wat je allemaal kunt doen met Mikrotik routers.

Groeten, en bedankt voor al jullie tips en hulp.

@Peter uit Amsterdam,

kun je de wan-poort (ether1-gateway)  nu wel op 1000M full zetten?

 

Groet, Gusto

Alle poorten staan op 100 Mbps, opvallen genoeg. Het probleem zal toch wel in de de microfilm zitten. (Dat is geen pleidooi voor een Asus overigens :))

Psssst @Top10 NL eSport Speler ,

dit heeft niets met Windows te maken. :wink:

@acoster, Ja gedaan. Ik heb een kabel die of in Mikrotik stop of in mijn laptop (zelfde kabel) dus. Direct aangesloten op de laptop geeft die een download snelheid van 500 Mbps. Als ik hem in de Mikrotik stop gebruik ik natuurlijk een andere kabel verbonden met de LAN kant van mijn Mikrotik. Via die kabels (en poorten) haal ik op de LAN kant van het netwerk bijna 1000 Mbps als ik een groot bestand kopieer tussen twee computer aangesloten op de LAN poorten. 

@Gusto, ik kan de WAN poort niet op 1 Gbps zetten. Als ik dat doe komen het Ziggo modem en de Mikrotik er samen niet uit en is er geen verbinding.
 


Stel ik de poort vervolgens in op 100 Mbps dan heb ik weer verbinding.
 

 

Die setting van 100 Gbps heb ik vervolgens maar weer verwijderd zodat er qua instelling van de snelheid van de poorten geen verschil is tussen WAN en LAN kant van de Mikrotik.

 

@efok: alle LAN poorten staan inmiddels ingesteld op 1000 Mbps. Tenminste als ik een export doe van de config zie ik nergens meer een speed van 100 Mbps behalve bij die verdomde WAN poort die verbonden is met de router van Ziggo:
 


Dat lijkt dus meer de uitkomst van “overleg” tussen het Ziggo Modem en de Mikrotik.

 

@Peter uit Amsterdam 

zet die MTU eens terug naar 1500 en L2 MTU 1598.

 

Groet, Gusto

Probeer eens de instelling “Auto Nagotion”


Dit dus. Viel mij ook op dat je die uit hebt staan. Zet je dit aan, dan zouden de netwerken zelf de Snelheid moeten regelen, normaliter.

Reputatie 6
Badge +7

Voor de duidelijkheid:

De norm voor gigabit ethernet schrijft voor dat de poort altijd op auto-negotiate moet staan. Auto-negotiate is niet hetzelfde als auto-sense. Met auto-sense wordt de snelheid bepaald, dus 10, 100, of 1000 Mb/s . Met auto-negotiate worden vervolgens de overige parameters ingesteld, zoals full / half duplex etc.

Flow-control is ook belangrijk. Volgens mij zag ik dat dit was uitgeschakeld. Dat is natuurlijk niet de bedoeling, flow-control moet altijd ingeschakeld zijn!

Reputatie 7
Badge +14

@Peter uit Amsterdam 

Kan je ergens lezen wat de snelheid van de wanport is ? ergens in de config menu's van de router ?

En als 2e ik weet dat je geschreven hebt dat je wel de volle snelheid haalt als je de laptop rechtstreeks op het modem aansluit met dezelfde kabel , maar ik zou toch als ik jou was het ook nog even proberen met een andere netwerk kabel !

 

Ben je echt aan een nieuwe toe koop een asus ;-) 

@caesar ,

Peter heeft al wekenlang niet meer gereageerd.

@Peter uit Amsterdam ,

kun je de wan-poort (ether1-gateway)  nu wel op 1000M full zetten?

 

Groet, Gusto

@Peter uit Amsterdam ,

wat je ook kan proberen is fasttrack aanzetten: https://wiki.mikrotik.com/wiki/Manual:IP/Fasttrack#Description

 

Groet, Gusto

Hallo@Gusto,

Dank je! Ik was op zoek naar de bevestiging dat dit zou moeten kunnen. Ik ben daarom wat verder in de configuratie van de Mikrotik gedoken. Om antwoord te geven op je vraag. Ik heb niet heel veel firewall rules gemaakt. Althans niet veel meer dan je zou verwachten in een default config. Ik heb ook gebruik gemaakt van de ingebouwde optie van Mikrotik RouterOS voor een speedtest. Zie hieronder:
 

Wat opvalt is dat de CPU van de Mikrotik maar voor 50 % belast wordt. Zonder enige kennis van zaken denk ik dan: de Mikrotik moet het inderdaad aankunnen. Met nog wat meer zoek werk vond ik dit:
 


Op de interface die verbonden is met het Ziggo modem heb ik maar 100 Mbps. Het lijkt er op dat als het Ziggo modem en mijn Mikrotik onderling gaan bepalen op welke snelheid ze gaan communiceren ze op 100 Mbps uitkomen. Ik heb getracht aan de Mikrotik kant 1 Gbps te forceren maar dat gaat steeds fout. Dat vervalt de verbinding.

Wel vreemd dat blijkbaar via mijn laptop de snelheid van het Ziggo modem geen beperking heeft van 100 Mbps. Iemand enig idee hoe die 100 Mbps limiet te verwijderen is?
 

 

 

Reputatie 7

De DOCSIS MTU is 1518 bytes.

@Peter uit Amsterdam ,

mooi dat het opgelost is.

Maar dat verhaal over die bridges snap ik niet helemaal.

Een backup maken kan via:

files → backup / upload

 

Groet, Gusto

Reputatie 7
Badge +14

@Ronihd,

een Mikrotik kan veel meer dan een Asus (zelfs met alternative firmware). :wink:

 

Groet, Gusto

 

Spreek ik zeker niet tegen maar voor mij voldoet het heel goed , heel stabiel !

Mijn router draaide tot op gisteren ruim 100 dagen zonder reboot , gister viel de stroom ff uit hier en dan heb je een niet gewilde reboot ;-)

@Ronihd,

voor een demo kijk hier:http://demo2.mt.lv/

login: demo

geen password

 

Groet, Gusto

@Gusto ik ben lerende maar als ik het goed begrepen heb werkt het als volgt.
Ik heb op mijn Mikrotik de volgende twee Bridges geconfigureerd:
 

 

Gasten mogen gebruik maken van onze internet verbinding maar ik wil voorkomen dat ze op ons "eigen netwerk gaan rond neuzen. Om die reden wil ik al het verkeer van het Gasten netwerk naar het FAMILY netwerk kunnen blokkeren. De oplossing die ik daarvoor heb gevonden is een firewall rule (filter). Om die rule te kunnen gebruiken moet ik het verkeer "over de bridges” via de firewall laten verlopen. Dat is een setting die je alleen kunt instellen voor alle bridges. Ik heb gemerkt dat dat gepaard gaat met een langzamere internet download speed. Niet gek natuurlijk omdat nu al het bridge verkeer via de firewall moet. Omdat het snelheidsverlies gering is, kan ik er wel mee leven.

 

 

@Peter uit Amsterdam,

ik heb maar een bridge:

 en een firewall-rule:

 

En geen gast komt op mijn netwerk. :wink:

@Ronihd,

een Mikrotik kan veel meer dan een Asus (zelfs met alternative firmware). :wink:

 

Groet, Gusto

 

Spreek ik zeker niet tegen maar voor mij voldoet het heel goed , heel stabiel !

Mijn router draaide tot op gisteren ruim 100 dagen zonder reboot , gister viel de stroom ff uit hier en dan heb je een niet gewilde reboot ;-)


Tja, z’n lange uptime red een een Mikrotik niet, 10x per jaar een update/upgrade. :wink:

@Peter uit Amsterdam heb je dit inmiddels getackeld? Er is nog iemand die een soortgelijk probleem heeft. 
https://community.ziggo.nl/thuisnetwerk-software-101/ziggo-cut-the-speed-down-to-100mb-if-you-are-using-bridge-mode-and-not-solving-it-50078#post522287

Misschien komen jullie er samen uit?

@efok ,

 

ja exact, maar dan gaat het dus mis ?

ja exact, maar dan gaat het dus mis ?


Je kan handmatig dat “vinkje” zetten, vandaar mijn vraag. :wink:

@Gusto en alle anderen, ik heb een Mikrotik configuratie scriptje gemaakt en daarmee een Mikrotik hAP lite geconfigureerd. Tevens daarbij ook fasttrack aangezet. Daarmee behaalde ik de volgende resultaten:
 

 

Nog niet echt een verbetering.

Ik had ook nog een RB750GL tot mijn beschikking. Echt een oudje maar zie hier de resultaten:
 



Beide hebben routers hebben een identieke inrichting maar blijkbaar trekt de hardware van de hAP lite het niet helemaal. Uit het resultaat van de RB750GL blijkt dat er geen issue is tussen Ziggo modem en Mikrotik. Mijn volgende stap is om de CRS109-8G-1S-2HnD een identieke "schone” inrichting te geven met fasttrack want ik vermoed dat het of de fasttrack is die de snelheid verbetering geeft of dat er een bepaalde instelling in mijn huidige configuratie van de CRS109-8G-1S-2HnD een probleem geeft om de maximale download snelheid te halen.

 

Reageer