Beantwoord

Maximale downloadsnelheid van 100 Mbps met Mikrotik CRS109-8G-1S-2HnD

  • 5 november 2019
  • 54 Reacties
  • 1196x Bekeken

Mijn Ziggo Modem staat in Bridge mode. Ik heb er een Mikrotik CRS109-8G-1S-2HnD router/switch aan hangen. Wanneer ik mijn laptop aan een LAN poort van de Mikrotik switch hang haal ik met een speedtest een maximale download snelheid van +/- 100 Mbps download en 40 Mbps upload. Als ik de kabel waarmee de Mikrotik verbonden is direct verbind met mijn laptop haal ik met dezelfde speedtest een download snelheid van 500 Mbps download en 40 Mbps upload. Dat laatste komt overeen met de snelheid van mijn Ziggo abonnement

Het lijkt er op dat de Mikrotik dus de bottleneck is qua download snelheid. Heb al een paar dingen gecheckt:

Op de Mikrotik kan ik zien dat de poort van de Mikrotik die verbonden is met het Ziggo modem staat ingesteld op 1 Gbps. Lijkt me goed.

Bestanden kopieren tussen computers die zijn aangesloten op de LAN poorten van de Mikrotik gaat met meer dan 115 Mb per seconde dus dat zit aan de limiet van de 1 Gbps poorten.

Al het internet verkeer moet natuurlijk op de Mikrotik via de firewall (NAT). Zou dat de bottleneck kunnen zijn of moet de Mikrotik CRS109-8G-1S-2HnD dat met gemak aankunnen. Zou graag willen weten of ik toch nog op zoek moet naar een obscure instelling in de Mikrotik om de bottleneck weg te nemen of dat dit apparaat gewoon aan zijn max. zit en ik hem beter kan vervangen door een ander appararaat zonder 100 Mbps limiet voor verkeer op de WAN poort.
 

icon

Best beantwoord door Peter uit Amsterdam 15 december 2019, 16:09

@Gusto@efok 

Het heeft even geduurt maar inmiddels heb ik de CRS125-24G-1S-2HnD van een nieuwe configuratie voorzien. Het duurde even wat langer omdat ik dat met een scriptje wilde doen. De oude configuratie was een beetje een zooitje geworden en een recentelijk hardware probleem met de Mikrotik had mij aan het denken gezet dat een scriptje, waarmee je de router helemaal geautomatiseerd zou kunnen inrichten, toch wel handig zou zijn. Ik weet niet of je een back-up eenvoudig kunt terug zetten op een ander type Mikrotik dat zou dan ook een optie zijn geweest maar met een scriptje ben je waarschijnlijk flexibeler.

Daarnaast heb ik de afgelopen tijd mijn Ziggo abonnement ge-downgrade. Immers ik heb eigenlijk maanden lang niet echt gemerkt dat mijn Mikrotik de snelheid beperkte tot maar 100 Mbit dus ik dacht dan ik het wel een tijdje gaan proberen met 250 Mbit download i.p.v. 500 Mbit download.

Is er natuurlijk wel een nieuwe nul-meting nodig waarbij ik mijn laptop direct verbind met het Ziggo modem (dus zonder Mikrotik er tussen). Dit is daarvan het resultaat:

 

 

Dat is dus keurig de snelheid van mijn nieuwe “Complete” abonnement.

Nadat ik de CRS125-24G-1S-2HnD volledig opnieuw had ingericht vanaf een factory reset (met mijn scriptje) heb ik weer een speedtest gedaan met dit resultaat:
 

 

 

Weg 100 Mbit limiet. Hoera! Probleem opgelost. Het kleine snelheids verlies dat nog zichtbaar is kan ik verklaren vanuit mijn Mikrotik configuratie. Naast mijn basis WIFI heb ik ook nog een gasten WIFI geconfigureerd. Via een Firewall rule blokkeer ik al het verkeer van het gasten netwerk naar ons huis netwerk. Omdat te kunnen blokkeren moest ik voor alle Mikrotik bridges instellen dat verkeer over een bridge via de firewall moet lopen. (Kan dat handiger?) Dat is een setting/vinkje onder:

    /interface bridge settings
    set use-ip-firewall=yes

Als ik die even instel op "no” dan krijg ik weer de volle snelheid:
 


 

Nog een tip voor als je zelf de snelheid van je verbindingen op een Mikrotik wil testen. Zorg dat je tijdens het testen alle WinBox verbindingen sluit naar je router. Het is leuk dat je in de GUI van WinBox alle IP packetjes kun zien langs komen maar al die tellertjes die real-time worden bijgewerkt hebben volgens mij wel een beperkend effect op je metingen. Ik kreeg de beste resultaten als alle WinBox sessies gesloten waren.

Ik ben in de afgelopen tijd weer wat wijzer geworden en nog meer onder de indruk geraakt van wat je allemaal kunt doen met Mikrotik routers.

Groeten, en bedankt voor al jullie tips en hulp.

Bekijk origineel

54 Reacties

@Peter uit Amsterdam,

ik heb maar een bridge:

 en een firewall-rule:

 

En geen gast komt op mijn netwerk. :wink:

@Gusto ik ben lerende maar als ik het goed begrepen heb werkt het als volgt.
Ik heb op mijn Mikrotik de volgende twee Bridges geconfigureerd:
 

 

Gasten mogen gebruik maken van onze internet verbinding maar ik wil voorkomen dat ze op ons "eigen netwerk gaan rond neuzen. Om die reden wil ik al het verkeer van het Gasten netwerk naar het FAMILY netwerk kunnen blokkeren. De oplossing die ik daarvoor heb gevonden is een firewall rule (filter). Om die rule te kunnen gebruiken moet ik het verkeer "over de bridges” via de firewall laten verlopen. Dat is een setting die je alleen kunt instellen voor alle bridges. Ik heb gemerkt dat dat gepaard gaat met een langzamere internet download speed. Niet gek natuurlijk omdat nu al het bridge verkeer via de firewall moet. Omdat het snelheidsverlies gering is, kan ik er wel mee leven.

 

 

@Peter uit Amsterdam ,

mooi dat het opgelost is.

Maar dat verhaal over die bridges snap ik niet helemaal.

Een backup maken kan via:

files → backup / upload

 

Groet, Gusto

@Gusto@efok 

Het heeft even geduurt maar inmiddels heb ik de CRS125-24G-1S-2HnD van een nieuwe configuratie voorzien. Het duurde even wat langer omdat ik dat met een scriptje wilde doen. De oude configuratie was een beetje een zooitje geworden en een recentelijk hardware probleem met de Mikrotik had mij aan het denken gezet dat een scriptje, waarmee je de router helemaal geautomatiseerd zou kunnen inrichten, toch wel handig zou zijn. Ik weet niet of je een back-up eenvoudig kunt terug zetten op een ander type Mikrotik dat zou dan ook een optie zijn geweest maar met een scriptje ben je waarschijnlijk flexibeler.

Daarnaast heb ik de afgelopen tijd mijn Ziggo abonnement ge-downgrade. Immers ik heb eigenlijk maanden lang niet echt gemerkt dat mijn Mikrotik de snelheid beperkte tot maar 100 Mbit dus ik dacht dan ik het wel een tijdje gaan proberen met 250 Mbit download i.p.v. 500 Mbit download.

Is er natuurlijk wel een nieuwe nul-meting nodig waarbij ik mijn laptop direct verbind met het Ziggo modem (dus zonder Mikrotik er tussen). Dit is daarvan het resultaat:

 

 

Dat is dus keurig de snelheid van mijn nieuwe “Complete” abonnement.

Nadat ik de CRS125-24G-1S-2HnD volledig opnieuw had ingericht vanaf een factory reset (met mijn scriptje) heb ik weer een speedtest gedaan met dit resultaat:
 

 

 

Weg 100 Mbit limiet. Hoera! Probleem opgelost. Het kleine snelheids verlies dat nog zichtbaar is kan ik verklaren vanuit mijn Mikrotik configuratie. Naast mijn basis WIFI heb ik ook nog een gasten WIFI geconfigureerd. Via een Firewall rule blokkeer ik al het verkeer van het gasten netwerk naar ons huis netwerk. Omdat te kunnen blokkeren moest ik voor alle Mikrotik bridges instellen dat verkeer over een bridge via de firewall moet lopen. (Kan dat handiger?) Dat is een setting/vinkje onder:

    /interface bridge settings
    set use-ip-firewall=yes

Als ik die even instel op "no” dan krijg ik weer de volle snelheid:
 


 

Nog een tip voor als je zelf de snelheid van je verbindingen op een Mikrotik wil testen. Zorg dat je tijdens het testen alle WinBox verbindingen sluit naar je router. Het is leuk dat je in de GUI van WinBox alle IP packetjes kun zien langs komen maar al die tellertjes die real-time worden bijgewerkt hebben volgens mij wel een beperkend effect op je metingen. Ik kreeg de beste resultaten als alle WinBox sessies gesloten waren.

Ik ben in de afgelopen tijd weer wat wijzer geworden en nog meer onder de indruk geraakt van wat je allemaal kunt doen met Mikrotik routers.

Groeten, en bedankt voor al jullie tips en hulp.

Reputatie 6
Badge +7

Ach, wie weet hebben anderen er nog iets aan :smiley:

@caesar ,

Peter heeft al wekenlang niet meer gereageerd.

Reputatie 6
Badge +7

Voor de duidelijkheid:

De norm voor gigabit ethernet schrijft voor dat de poort altijd op auto-negotiate moet staan. Auto-negotiate is niet hetzelfde als auto-sense. Met auto-sense wordt de snelheid bepaald, dus 10, 100, of 1000 Mb/s . Met auto-negotiate worden vervolgens de overige parameters ingesteld, zoals full / half duplex etc.

Flow-control is ook belangrijk. Volgens mij zag ik dat dit was uitgeschakeld. Dat is natuurlijk niet de bedoeling, flow-control moet altijd ingeschakeld zijn!

Pssstt… @efok  ik ben geen expert. :wink:

@efok,

Ian heeft een ander probleem, zijn router ziet maar 100Mb op de poort.

Ik vermoed verouderde software + firmware.

 

Groet, Gusto

@Gusto Dat was hier in 1e instantie ook het geval, als ik terug lees. Hier is met daarna settings gespeeld. But you’re the expert 😉.  Zou mooi zijn als je Ian op weg kan helpen.

@efok ,

dan heb ik wel info nodig. :wink:

@efok,

Ian heeft een ander probleem, zijn router ziet maar 100Mb op de poort.

Ik vermoed verouderde software + firmware.

 

Groet, Gusto

@Gusto Dat was hier in 1e instantie ook het geval, als ik terug lees. Hier is met daarna settings gespeeld. But you’re the expert 😉.  Zou mooi zijn als je Ian op weg kan helpen.

Hier is een mis-configuratie van RouterOS het geval. :slight_smile:

🤐

Psssst @Top10 NL eSport Speler ,

dit heeft niets met Windows te maken. :wink:

Hey

 

Open ‘Command Prompt’ en copy paste dit “netsh interface tcp set global autotuning=normal”. En voer nogmaals een speedtest uit, probeer dit keer fast.com i.p.v. speedtest.net.

 

 

@efok ,

Ian heeft een ander probleem, zijn router ziet maar 100Mb op de poort.

Ik vermoed verouderde software + firmware.

 

Groet, Gusto

@Peter uit Amsterdam heb je dit inmiddels getackeld? Er is nog iemand die een soortgelijk probleem heeft. 
https://community.ziggo.nl/thuisnetwerk-software-101/ziggo-cut-the-speed-down-to-100mb-if-you-are-using-bridge-mode-and-not-solving-it-50078#post522287

Misschien komen jullie er samen uit?

Hi @Gusto , het opnieuw inrichten van mijn router ga ik deze week doen als ik een dag vrij heb. Moet er even voor zorgen dat de rest van het gezin er geen last van heeft.

Kom er eind deze week op terug. 

@Peter uit Amsterdam ,

is het ondertussen opgelost?

 

Groet, Gusto

@Peter uit Amsterdam ,

zorg dat die fasttrack-regels als eerste staan in de firewall-regels.

 

 

Groet, Gusto

@Gusto en alle anderen, ik heb een Mikrotik configuratie scriptje gemaakt en daarmee een Mikrotik hAP lite geconfigureerd. Tevens daarbij ook fasttrack aangezet. Daarmee behaalde ik de volgende resultaten:
 

 

Nog niet echt een verbetering.

Ik had ook nog een RB750GL tot mijn beschikking. Echt een oudje maar zie hier de resultaten:
 



Beide hebben routers hebben een identieke inrichting maar blijkbaar trekt de hardware van de hAP lite het niet helemaal. Uit het resultaat van de RB750GL blijkt dat er geen issue is tussen Ziggo modem en Mikrotik. Mijn volgende stap is om de CRS109-8G-1S-2HnD een identieke "schone” inrichting te geven met fasttrack want ik vermoed dat het of de fasttrack is die de snelheid verbetering geeft of dat er een bepaalde instelling in mijn huidige configuratie van de CRS109-8G-1S-2HnD een probleem geeft om de maximale download snelheid te halen.

 

Reputatie 7

De DOCSIS MTU is 1518 bytes.

@Peter uit Amsterdam ,

wat je ook kan proberen is fasttrack aanzetten: https://wiki.mikrotik.com/wiki/Manual:IP/Fasttrack#Description

 

Groet, Gusto

Ik dacht even online wat te gaan lezen over dit apparaat, maar kwam er al snel achter dat dit een uitgebreid apparaat is waar je wel wat kennis voor moet hebben en tijd om goed in te stellen:

https://tweakers.net/productreview/112939/mikrotik-crs109-8g-1s-2hnd-in.html 

Router OS
Wat direct duidelijk wordt als je dit apparaat gebruikt; Is dat het niet een standaard Router/Acces Point/switch is. Het apparaat werkt out-of-the box met een paar standaard instellingen. Maar al gauw merk je dat het instellen van dit apparaat niet zo makkelijk is als een standaard linksys routertje.

De functionaliteiten die het bied gaan al gauw richting de kant van de Professionele routers. Zo vindt je instellingen als MPLS, OSPF, BGP, PPPoE enz. Je hebt dan ook enige kennis nodig van netwerken en waar de vele functies nou voor dienen. Het heeft mij dan ook een aantal maanden gekost om het hele systeem te begrijpen. Eigenlijk viel het kwartje pas nadat ik verschillende Cisco Courses had gevolgd.

Het is een taai probleem. Ik heb nog wat andere Mikrotik hardware. Ik ga proberen mijn configuratie daarop over te zetten om te kijken of dat een verschil geeft. Hoop dat de hardware daarvan snel genoeg is. Als ik daarvan resultaten heb meld ik me weer. Iedereen enorm bedankt voor het meedenken. Daarmee ben ik echt al een stuk verder gekomen.

Hmm, tja Als de link nu wel 1 Gbps is, is dat een sta vooruit. Verder pas ik even. MTU had je al op 1500 gehad hè? Dat is wel de gebruikelijke waarde.

Reageer