Beantwoord

Maximale downloadsnelheid van 100 Mbps met Mikrotik CRS109-8G-1S-2HnD

  • 5 november 2019
  • 54 Reacties
  • 1146x Bekeken

Mijn Ziggo Modem staat in Bridge mode. Ik heb er een Mikrotik CRS109-8G-1S-2HnD router/switch aan hangen. Wanneer ik mijn laptop aan een LAN poort van de Mikrotik switch hang haal ik met een speedtest een maximale download snelheid van +/- 100 Mbps download en 40 Mbps upload. Als ik de kabel waarmee de Mikrotik verbonden is direct verbind met mijn laptop haal ik met dezelfde speedtest een download snelheid van 500 Mbps download en 40 Mbps upload. Dat laatste komt overeen met de snelheid van mijn Ziggo abonnement

Het lijkt er op dat de Mikrotik dus de bottleneck is qua download snelheid. Heb al een paar dingen gecheckt:

Op de Mikrotik kan ik zien dat de poort van de Mikrotik die verbonden is met het Ziggo modem staat ingesteld op 1 Gbps. Lijkt me goed.

Bestanden kopieren tussen computers die zijn aangesloten op de LAN poorten van de Mikrotik gaat met meer dan 115 Mb per seconde dus dat zit aan de limiet van de 1 Gbps poorten.

Al het internet verkeer moet natuurlijk op de Mikrotik via de firewall (NAT). Zou dat de bottleneck kunnen zijn of moet de Mikrotik CRS109-8G-1S-2HnD dat met gemak aankunnen. Zou graag willen weten of ik toch nog op zoek moet naar een obscure instelling in de Mikrotik om de bottleneck weg te nemen of dat dit apparaat gewoon aan zijn max. zit en ik hem beter kan vervangen door een ander appararaat zonder 100 Mbps limiet voor verkeer op de WAN poort.
 

icon

Best beantwoord door Peter uit Amsterdam 15 december 2019, 16:09

@Gusto@efok 

Het heeft even geduurt maar inmiddels heb ik de CRS125-24G-1S-2HnD van een nieuwe configuratie voorzien. Het duurde even wat langer omdat ik dat met een scriptje wilde doen. De oude configuratie was een beetje een zooitje geworden en een recentelijk hardware probleem met de Mikrotik had mij aan het denken gezet dat een scriptje, waarmee je de router helemaal geautomatiseerd zou kunnen inrichten, toch wel handig zou zijn. Ik weet niet of je een back-up eenvoudig kunt terug zetten op een ander type Mikrotik dat zou dan ook een optie zijn geweest maar met een scriptje ben je waarschijnlijk flexibeler.

Daarnaast heb ik de afgelopen tijd mijn Ziggo abonnement ge-downgrade. Immers ik heb eigenlijk maanden lang niet echt gemerkt dat mijn Mikrotik de snelheid beperkte tot maar 100 Mbit dus ik dacht dan ik het wel een tijdje gaan proberen met 250 Mbit download i.p.v. 500 Mbit download.

Is er natuurlijk wel een nieuwe nul-meting nodig waarbij ik mijn laptop direct verbind met het Ziggo modem (dus zonder Mikrotik er tussen). Dit is daarvan het resultaat:

 

 

Dat is dus keurig de snelheid van mijn nieuwe “Complete” abonnement.

Nadat ik de CRS125-24G-1S-2HnD volledig opnieuw had ingericht vanaf een factory reset (met mijn scriptje) heb ik weer een speedtest gedaan met dit resultaat:
 

 

 

Weg 100 Mbit limiet. Hoera! Probleem opgelost. Het kleine snelheids verlies dat nog zichtbaar is kan ik verklaren vanuit mijn Mikrotik configuratie. Naast mijn basis WIFI heb ik ook nog een gasten WIFI geconfigureerd. Via een Firewall rule blokkeer ik al het verkeer van het gasten netwerk naar ons huis netwerk. Omdat te kunnen blokkeren moest ik voor alle Mikrotik bridges instellen dat verkeer over een bridge via de firewall moet lopen. (Kan dat handiger?) Dat is een setting/vinkje onder:

    /interface bridge settings
    set use-ip-firewall=yes

Als ik die even instel op "no” dan krijg ik weer de volle snelheid:
 


 

Nog een tip voor als je zelf de snelheid van je verbindingen op een Mikrotik wil testen. Zorg dat je tijdens het testen alle WinBox verbindingen sluit naar je router. Het is leuk dat je in de GUI van WinBox alle IP packetjes kun zien langs komen maar al die tellertjes die real-time worden bijgewerkt hebben volgens mij wel een beperkend effect op je metingen. Ik kreeg de beste resultaten als alle WinBox sessies gesloten waren.

Ik ben in de afgelopen tijd weer wat wijzer geworden en nog meer onder de indruk geraakt van wat je allemaal kunt doen met Mikrotik routers.

Groeten, en bedankt voor al jullie tips en hulp.

Bekijk origineel

54 Reacties

Hallo @Peter uit Amsterdam ,

je Microtik moet dat makkelijk aan kunnen.

Heb je veel firewall-regels aangemaakt?

 

Groet, Gusto

Hallo@Gusto,

Dank je! Ik was op zoek naar de bevestiging dat dit zou moeten kunnen. Ik ben daarom wat verder in de configuratie van de Mikrotik gedoken. Om antwoord te geven op je vraag. Ik heb niet heel veel firewall rules gemaakt. Althans niet veel meer dan je zou verwachten in een default config. Ik heb ook gebruik gemaakt van de ingebouwde optie van Mikrotik RouterOS voor een speedtest. Zie hieronder:
 

Wat opvalt is dat de CPU van de Mikrotik maar voor 50 % belast wordt. Zonder enige kennis van zaken denk ik dan: de Mikrotik moet het inderdaad aankunnen. Met nog wat meer zoek werk vond ik dit:
 


Op de interface die verbonden is met het Ziggo modem heb ik maar 100 Mbps. Het lijkt er op dat als het Ziggo modem en mijn Mikrotik onderling gaan bepalen op welke snelheid ze gaan communiceren ze op 100 Mbps uitkomen. Ik heb getracht aan de Mikrotik kant 1 Gbps te forceren maar dat gaat steeds fout. Dat vervalt de verbinding.

Wel vreemd dat blijkbaar via mijn laptop de snelheid van het Ziggo modem geen beperking heeft van 100 Mbps. Iemand enig idee hoe die 100 Mbps limiet te verwijderen is?
 

 

 

@Peter uit Amsterdam ,

ik zie dat RouterOS up to date is, is de firmware dat ook?

 

 

Groet, Gusto

Hallo @Gusto , ik heb een hele oude versie van de firmware 3.33. Ik ga een upgrade doen als ik mijn internet connectie even kan missen.

Helaas, een upgrade van de firmware maakt geen verschil.

 

@Peter uit Amsterdam ,

ik vind de cpu-belasting wel erg hoog, staan er veel connecties open?

 

Groet, Gusto

 

@Gusto, ongeveer 85 connecties open. De hooge CPU belasting is alleen ten tijde van de speedtest in de screenshot. Daarna zakt het weer terug naar 5 a 10 %.

Reputatie 7
Badge +14

@Peter uit Amsterdam 

Kan je ergens lezen wat de snelheid van de wanport is ? ergens in de config menu's van de router ?

En als 2e ik weet dat je geschreven hebt dat je wel de volle snelheid haalt als je de laptop rechtstreeks op het modem aansluit met dezelfde kabel , maar ik zou toch als ik jou was het ook nog even proberen met een andere netwerk kabel !

 

Ben je echt aan een nieuwe toe koop een asus ;-) 

@Peter uit Amsterdam ,

kun je de wan-poort (ether1-gateway)  nu wel op 1000M full zetten?

 

Groet, Gusto

@Ronihd ,

een Mikrotik kan veel meer dan een Asus (zelfs met alternative firmware). :wink:

 

Groet, Gusto

Reputatie 7
Badge +14

@Ronihd,

een Mikrotik kan veel meer dan een Asus (zelfs met alternative firmware). :wink:

 

Groet, Gusto

 

Spreek ik zeker niet tegen maar voor mij voldoet het heel goed , heel stabiel !

Mijn router draaide tot op gisteren ruim 100 dagen zonder reboot , gister viel de stroom ff uit hier en dan heb je een niet gewilde reboot ;-)

@Ronihd,

voor een demo kijk hier:http://demo2.mt.lv/

login: demo

geen password

 

Groet, Gusto

@Ronihd,

een Mikrotik kan veel meer dan een Asus (zelfs met alternative firmware). :wink:

 

Groet, Gusto

 

Spreek ik zeker niet tegen maar voor mij voldoet het heel goed , heel stabiel !

Mijn router draaide tot op gisteren ruim 100 dagen zonder reboot , gister viel de stroom ff uit hier en dan heb je een niet gewilde reboot ;-)


Tja, z’n lange uptime red een een Mikrotik niet, 10x per jaar een update/upgrade. :wink:

@Peter uit Amsterdam,

kun je de wan-poort (ether1-gateway)  nu wel op 1000M full zetten?

 

Groet, Gusto

Alle poorten staan op 100 Mbps, opvallen genoeg. Het probleem zal toch wel in de de microfilm zitten. (Dat is geen pleidooi voor een Asus overigens :))

@efok ,

 

ja exact, maar dan gaat het dus mis ?

ja exact, maar dan gaat het dus mis ?


Je kan handmatig dat “vinkje” zetten, vandaar mijn vraag. :wink:

Reputatie 6
Badge +9

@Peter uit Amsterdam 

Heb je wel eens alle ethernetkabels los gehaald en enkel je laptop verbonden aan de Microtik en dan een test gedaan?

Ik ging even door je lijst met aangesloten apparatuur heen, ik zie er ook een Hue op staan en deze kan maximaal 100Mbps aan. Misschien dat de Mikrotik de laagst mogelijke snelheid pakt en die op alle poorten gebruikt?

 

@acoster, Ja gedaan. Ik heb een kabel die of in Mikrotik stop of in mijn laptop (zelfde kabel) dus. Direct aangesloten op de laptop geeft die een download snelheid van 500 Mbps. Als ik hem in de Mikrotik stop gebruik ik natuurlijk een andere kabel verbonden met de LAN kant van mijn Mikrotik. Via die kabels (en poorten) haal ik op de LAN kant van het netwerk bijna 1000 Mbps als ik een groot bestand kopieer tussen twee computer aangesloten op de LAN poorten. 

@Gusto, ik kan de WAN poort niet op 1 Gbps zetten. Als ik dat doe komen het Ziggo modem en de Mikrotik er samen niet uit en is er geen verbinding.
 


Stel ik de poort vervolgens in op 100 Mbps dan heb ik weer verbinding.
 

 

Die setting van 100 Gbps heb ik vervolgens maar weer verwijderd zodat er qua instelling van de snelheid van de poorten geen verschil is tussen WAN en LAN kant van de Mikrotik.

 

@efok: alle LAN poorten staan inmiddels ingesteld op 1000 Mbps. Tenminste als ik een export doe van de config zie ik nergens meer een speed van 100 Mbps behalve bij die verdomde WAN poort die verbonden is met de router van Ziggo:
 


Dat lijkt dus meer de uitkomst van “overleg” tussen het Ziggo Modem en de Mikrotik.

 

Reputatie 7
Badge +14

@Ronihd,

voor een demo kijk hier:http://demo2.mt.lv/

login: demo

geen password

 

Groet, Gusto

Gaat mij ff te diep , maar ziet er wel goed uit 

Reputatie 7
Badge +14

Probeer eens de instelling “Auto Negotation”

Reputatie 7
Badge +14

Het probleem is de wan poort ! , als je de kabel van het modem uit je router haalt kan je hem dan wel op 1 GB zetten ipv 100 MB?

 

Doe jezelf lol ;-) @Peter uit Amsterdam  probeer gewoon een andere kabel tussen je router en het modem ( als je dat dan nog niet hebt gedaan ? ) 

@acoster, Ja gedaan. Ik heb een kabel die of in Mikrotik stop of in mijn laptop (zelfde kabel) dus. Direct aangesloten op de laptop geeft die een download snelheid van 500 Mbps. Als ik hem in de Mikrotik stop gebruik ik natuurlijk een andere kabel verbonden met de LAN kant van mijn Mikrotik. Via die kabels (en poorten) haal ik op de LAN kant van het netwerk bijna 1000 Mbps als ik een groot bestand kopieer tussen twee computer aangesloten op de LAN poorten. 

@Gusto, ik kan de WAN poort niet op 1 Gbps zetten. Als ik dat doe komen het Ziggo modem en de Mikrotik er samen niet uit en is er geen verbinding.
 


Stel ik de poort vervolgens in op 100 Mbps dan heb ik weer verbinding.
 

 

Die setting van 100 Gbps heb ik vervolgens maar weer verwijderd zodat er qua instelling van de snelheid van de poorten geen verschil is tussen WAN en LAN kant van de Mikrotik.

 

@efok: alle LAN poorten staan inmiddels ingesteld op 1000 Mbps. Tenminste als ik een export doe van de config zie ik nergens meer een speed van 100 Mbps behalve bij die verdomde WAN poort die verbonden is met de router van Ziggo:
 


Dat lijkt dus meer de uitkomst van “overleg” tussen het Ziggo Modem en de Mikrotik.

 

@Peter uit Amsterdam 

zet die MTU eens terug naar 1500 en L2 MTU 1598.

 

Groet, Gusto

Probeer eens de instelling “Auto Nagotion”


Dit dus. Viel mij ook op dat je die uit hebt staan. Zet je dit aan, dan zouden de netwerken zelf de Snelheid moeten regelen, normaliter.

Probeer eens de instelling “Auto Nagotion”


Dit dus. Viel mij ook op dat je die uit hebt staan. Zet je dit aan, dan zouden de netwerken zelf de Snelheid moeten regelen, normaliter.

@Peter uit Amsterdam,

heeft lopen “kloten” met de instellingen. :wink:

 

Groet, Gusto

Reageer