Beantwoord

Connectbox vatbaar voor buffer overflow attack, firmware update mogenlijk?


Hallo allemaal,
Ik was net aan het scannen met Avast anti virus en bij het scannen van netwerk problemen geeft avast de melding dat mijn Compal connectbox vatbaar is voor de CVE-2017-14491 exploit... Aanvallers zouden via een lek in dnsmasq toegang kunnen krijgen tot mijn netwerk. Is er een mogenlijkheid om de firmware handmatig te updaten?
Dit is mijn connectbox info:
Standard specification compliant : DOCSIS 3.0
Hardware version : 4.01
Software version : CH7465LG-NCIP-4.50.18.23-4m1-GA-NOSH
Cable MAC address :
Cable modem serial number :
System up time : 89day(s)20h:26m:30s
Network access : Allowed
icon

Best beantwoord door Be rt 21 februari 2018, 00:25

Deze is niet handmatig te updaten.
Updates komen automatisch van Ziggo.

Bekijk origineel

Dit topic is gesloten. Staat je antwoord hier niet bij, start dan een nieuw topic.

4 Reacties

Reputatie 7
Badge +31
Deze is niet handmatig te updaten.
Updates komen automatisch van Ziggo.
Reputatie 7
Badge +15
Het is een al langer bestaand probleem en geldt voor heel veel routers. Alleen heeft Avast het onlangs pas aan de scan toegevoegd.
Dit zegt Avast :


Last week we added this detection into Wifi inspector. This detection is based on DNS version obtained via remote finteprint also called banner detection.
Banner detections are not critical (in this particular case is detection verbosity set to warning), it says your device is likely vulnerable. We are not sending real exploit probes to detect vulnerable DNS servers, because its too dangerous and it may cause the application crash.

You should test your router manually with the following command in cmd:
nslookup -type=txt -class=chaos version.bind ROUTER_IP

For example:
c:\>nslookup -type=txt -class=chaos version.bind 192.168.0.1
Server: router
Address: 192.168.0.1

version.bind text =

"dnsmasq-2.45"

All versions prior to 2.78 are vulnerable.

To solve the vulnerability on your device, apply the firmware or system update that contains DnsMasq software version 2.78 or higher provided by your device's manufacturer.
If an update addressing the vulnerability is not yet available for your device, you can secure your router or Wi-Fi hotspot with a strong password to minimize risks imposed by the vulnerability. More details can be found also here: https://help.avast.com/en/av_free/17/hns/cve-2017-14491.html

Reputatie 5
Badge +4
Er zitten wel meer beveiligingsproblemen in de ConnectBox, zoals de DoS die optreedt met 200Kbit/s aan pakketjes. 😉

Dnsmasq staat niet open naar het internet en kan dus niet zomaar van buitenaf aangevallen worden.
Reputatie 2
Badge
ArieKanarie schreef:

Er zitten wel meer beveiligingsproblemen in de ConnectBox, zoals de DoS die optreedt met 200Kbit/s aan pakketjes. 😉

Dnsmasq staat niet open naar het internet en kan dus niet zomaar van buitenaf aangevallen worden.



Wat bedoel je daar precies mee.? Ik heb dat als ik veel verbindigen tegelijkertijd heb (torrents bijv) de CB eruit klapt. Bedoel je dat?

EDIT
Nee dat bedoel je waarschijnlijk niet 😉