Beantwoord

Open vpn aan de praat krijgen

  • 1 december 2018
  • 43 reacties
  • 3584 keer bekeken

Hallo allemaal,

Ik heb een satelietontvanger in mijn netwerk zitten.
Nu moet ik op die ontvanger een openvpn verbinding activeren.
Het lukt me maar niet om het draaiend te krijgen.
Is er iemand die mij stap voor stap erdoor heen kan loodsen.
Ik begrijp dat er geen optie is in de technicolor van Ziggo om vpn te activeren.
Vandaar de openvpn in de satelietontvanger.
icon

Best beantwoord door efok 4 december 2018, 14:58

@satfrico

Precies wat ik dacht. Je setup gebruikt nog de DNS server van Ziggo (84.116.46.21). Deze is niet bereikbaar van buiten het Ziggo netwerk (dus ook niet via je VPN). Het lukt je daarom niet om www.google.com om te zetten in een IP-adres.
GooseVPN probeert daarom de OpenDNS servers naar je te pushen, dat zie je in je log:
code:
Mon Dec 3 13:14:56 2018 PUSH: Received control message: 'PUSH_REPLY,redirect-gateway def1,dhcp-option DNS 208.67.222.222,dhcp-option DNS 208.67.220.220


Deze worden echter niet opgepikt door je receiver. Het wordt nu zaak de receiver zover te krijgen dat hij niet meer de Ziggo DNS server voor OpenVPN blijft gebruiken.

Misschien kun je in de interface van de receiver gewoon ergens handmatig de 2 bovenstaande DNS servers opgeven? Dan werkt het altijd (met en zonder VPN).

Kan dat niet, dan voeren we de moeilijkheidsgraad nog wat op, en is er een script nodig, om je receiver te vertellen dat wanneer openvpn verbonden wordt hij over moet naar een andere DNS server.

Misschien staat dit script al op je receiver onder /etc/openvpn/update-resolv.conf
Anders bijgaand het script:
code:
#!/bin/bash
#
# Parses DHCP options from openvpn to update resolv.conf
# To use set as 'up' and 'down' script in your openvpn *.conf:
# up /etc/openvpn/update-resolv-conf
# down /etc/openvpn/update-resolv-conf
#
# Used snippets of resolvconf script by Thomas Hood and Chris Hanson.
# Licensed under the GNU GPL. See /usr/share/common-licenses/GPL.
#
# Example envs set from openvpn:
#
# foreign_option_1='dhcp-option DNS 193.43.27.132'
# foreign_option_2='dhcp-option DNS 193.43.27.133'
# foreign_option_3='dhcp-option DOMAIN be.bnc.ch'
#

[ -x /sbin/resolvconf ] || exit 0
[ "$script_type" ] || exit 0
[ "$dev" ] || exit 0

split_into_parts()
{
part1="$1"
part2="$2"
part3="$3"
}

case "$script_type" in
up)
NMSRVRS=""
SRCHS=""
for optionvarname in ${!foreign_option_*} ; do
option="${!optionvarname}"
echo "$option"
split_into_parts $option
if [ "$part1" = "dhcp-option" ] ; then
if [ "$part2" = "DNS" ] ; then
NMSRVRS="${NMSRVRS:+$NMSRVRS }$part3"
elif [ "$part2" = "DOMAIN" ] ; then
SRCHS="${SRCHS:+$SRCHS }$part3"
fi
fi
done
R=""
[ "$SRCHS" ] && R="search $SRCHS
"
for NS in $NMSRVRS ; do
R="${R}nameserver $NS
"
done
echo -n "$R" | /sbin/resolvconf -a "${dev}.openvpn"
;;
down)
/sbin/resolvconf -d "${dev}.openvpn"
;;
esac



Sla dit script op als het bestand update-resolv-conf onder /etc/openvpn/
maak het script uitvoerbaar met:
code:
chmod +x /etc/openvpn/update-resolv-conf


Voeg vervolgens onderaan je client.conf het volgende toe:
code:
script-security 2
up /etc/openvpn/update-resolv-conf
down /etc/openvpn/update-resolv-conf
Bekijk origineel

Dit topic is gesloten. Staat je antwoord hier niet bij, stel dan je vraag in een nieuw topic.

43 Reacties

Reputatie 7
Badge +17
Is er in de gebruikershandleiding van de fabrikant van "een satellietontvanger" niet te vinden hoe e.e.a. te realiseren?
@KBX458 ik heb dat allemaal doorlopen via een handleiding.
Openvpn is geinstalleerd op de ontvanger, echter ik krijg geen verbinding.
En helaas heb ik geen kennis van de client.cfg met een eventuele fout die erin staat.
Want als ik de .log bekijk staat er een hoop in, maar voor mij abacadabra
Reputatie 7
Badge +17
Ook mij ontbreekt de kennis voor dit probleem. Er rest dus niet anders dan wachten tot iemand op dit forum met wél die kennis het oppikt. Mogelijk kun je alvast merk en type van de ontvanger plaatsen en een screenshot van de loggegevens.
Reputatie 7
Badge +27
Zonder merk en type van de ontvanger is daar vrij weinig over te zeggen.

Heef de fabrikant van de ontvanger geen forum ?
In fora van satellietontvangers is misschien meer informatie te vinden dan bij (kabel) Ziggo.
@Steefb Het betreft een Vu-Duo2 ontvanger.
Ik had gehoopt dat er iemand op dit forum was die mogelijk verstand van had.
Ik ben al weken aan het googlen via de welbekende satelietsites.
Echter geen resultaat. Dit was mijn laatste hoop zeg maar 😉
Tsja, als het via de Linux config files moet, dan weet ik het ook niet.

Wel heb je dit voor de Synology NAS VPN Server voor o.m. OpenVPN.
https://www.synology.com/en-global/knowledgebase/DSM/help/VPNCenter/vpn_setup

Heb je waarschijnlijk niks aan. Dacht toch: je weet maar nooit.

Gr Han
Reputatie 7
Badge +17
Ik kwam nog dit tegen. Misschien kan het van nut zijn.
https://support.cyberghostvpn.com/hc/en-us/articles/213271089-Sat-Receiver-How-to-configure-OpenVPN-for-VU-Solo2
@satfrico dus de satelliet ontvanger moet je openvpn server worden? En die wil je vanaf buiten kunnen bereiken?
Kun je uitleggen waar je op vastloopt?
@efok het is de bedoeling dat de ontvanger inlogd in amerika.
Zodoende kan ik weer IPTV kijken.
Ik heb een config bestand gemaakt aan de hand van wat ik heb opgevraagd bij mijn vpn provider. Als ik de openvpn start dan zegt de ontvanger dat hij draait. Echter als ik kijk wat het ip adres is dan is dat nog steeds hetzelfde ip adres als voordat openvpn liep.
Dus daar gaat het eigenlijk fout.

dit is de conf

client
dev tun
proto tcp-client
remote us-6.xxx.xxx 443
remote-cert-tls server
persist-key
persist-tun
ca xxxx.crt
tls-auth login.txt
cipher AES-256-CBC
comp-lzo
verb 5
mute 20
route-method exe
route-delay 2
route 0.0.0.0 0.0.0.0
float
auth-user-pass login.txt
auth-retry interact
ifconfig-nowarn
log /etc/openvpn/openvpn.log

en dit is dan het logbestand

Sun Dec 2 09:40:30 2018 us=611328 Current Parameter Settings:
Sun Dec 2 09:40:30 2018 us=613565 config = '/etc/openvpn/client.conf'
Sun Dec 2 09:40:30 2018 us=615633 mode = 0
Sun Dec 2 09:40:30 2018 us=618863 persist_config = DISABLED
Sun Dec 2 09:40:30 2018 us=620381 persist_mode = 1
Sun Dec 2 09:40:30 2018 us=621930 show_ciphers = DISABLED
Sun Dec 2 09:40:30 2018 us=623574 show_digests = DISABLED
Sun Dec 2 09:40:30 2018 us=625121 show_engines = DISABLED
Sun Dec 2 09:40:30 2018 us=626608 genkey = DISABLED
Sun Dec 2 09:40:30 2018 us=628242 key_pass_file = '[undef]'
Sun Dec 2 09:40:30 2018 us=629774 show_tls_ciphers = DISABLED
Sun Dec 2 09:40:30 2018 us=631280 Connection profiles [default]:
Sun Dec 2 09:40:30 2018 us=632802 proto = tcp-client
Sun Dec 2 09:40:30 2018 us=634497 local = '[undef]'
Sun Dec 2 09:40:30 2018 us=636976 local_port = 0
Sun Dec 2 09:40:30 2018 us=638810 remote = 'us-6.XXXX.com'
Sun Dec 2 09:40:30 2018 us=640220 remote_port = 443
Sun Dec 2 09:40:30 2018 us=641747 remote_float = ENABLED
Sun Dec 2 09:40:30 2018 us=643541 bind_defined = DISABLED
Sun Dec 2 09:40:30 2018 us=645509 bind_local = DISABLED
Sun Dec 2 09:40:30 2018 us=647021 NOTE: --mute triggered...
Sun Dec 2 09:40:30 2018 us=648556 205 variation(s) on previous 20 message(s) suppressed by --mute
Sun Dec 2 09:40:30 2018 us=650164 OpenVPN 2.3.6 mipsel-oe-linux-gnu [SSL (OpenSSL)] [lzo] [epoll] [mh] [IPv6] built on Mar 2 2018
Sun Dec 2 09:40:30 2018 us=651743 library versions: OpenSSL 1.0.2a 19 Mar 2015, LZO 2.09
Sun Dec 2 09:40:30 2018 us=653614 WARNING: file 'login.txt' is group or others accessible
Sun Dec 2 09:40:30 2018 us=659667 WARNING: file 'login.txt' is group or others accessible
Sun Dec 2 09:40:30 2018 us=663623 Control Channel Authentication: using 'login.txt' as a free-form passphrase file
Sun Dec 2 09:40:30 2018 us=665763 Outgoing Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
Sun Dec 2 09:40:30 2018 us=667562 Incoming Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
Sun Dec 2 09:40:30 2018 us=669776 LZO compression initialized
Sun Dec 2 09:40:30 2018 us=672088 Control Channel MTU parms [ L:1560 D:168 EF:68 EB:0 ET:0 EL:0 ]
Sun Dec 2 09:40:30 2018 us=674007 Socket Buffers: R=[87380->131072] S=[16384->131072]
Sun Dec 2 09:40:30 2018 us=699327 Data Channel MTU parms [ L:1560 D:1450 EF:60 EB:135 ET:0 EL:0 AF:3/1 ]
Sun Dec 2 09:40:30 2018 us=700968 Local Options String: 'V4,dev-type tun,link-mtu 1560,tun-mtu 1500,proto TCPv4_CLIENT,comp-lzo,cipher AES-256-CBC,auth SHA1,keysize 256,tls-auth,key-method 2,tls-client'
Sun Dec 2 09:40:30 2018 us=703048 Expected Remote Options String: 'V4,dev-type tun,link-mtu 1560,tun-mtu 1500,proto TCPv4_SERVER,comp-lzo,cipher AES-256-CBC,auth SHA1,keysize 256,tls-auth,key-method 2,tls-server'
Sun Dec 2 09:40:30 2018 us=704935 Local Options hash (VER=V4): 'd6e4d6ac'
Sun Dec 2 09:40:30 2018 us=706843 Expected Remote Options hash (VER=V4): '308ee575'
Sun Dec 2 09:40:30 2018 us=718473 Attempting to establish TCP connection with [AF_INET]XXX.XXX.30.9:443 [nonblock]
Sun Dec 2 09:40:31 2018 us=725547 TCP connection established with [AF_INET]XXX.XXX.30.9:443
Sun Dec 2 09:40:31 2018 us=727128 TCPv4_CLIENT link local: [undef]
Sun Dec 2 09:40:31 2018 us=728579 TCPv4_CLIENT link remote: [AF_INET]XXX.XXX.30.9:443
WSun Dec 2 09:40:31 2018 us=842831 Connection reset, restarting [0]
Sun Dec 2 09:40:31 2018 us=845023 TCP/UDP: Closing socket
Sun Dec 2 09:40:31 2018 us=846892 SIGUSR1[soft,connection-reset] received, process restarting
Sun Dec 2 09:40:31 2018 us=851819 Restart pause, 5 second(s)
Aha, duidelijk. Je wilt dus de ontvanger als cliënt op een vpn zetten. Zo in je log te zien kom je al een heel eind. Het lukt je om een verbinding op de zetten met de provider, alleen wordt de connectie vervolgens gereset. De vraag is waardoor dat komt.
Met welke VPN provider wil je verbinding maken? Misschien zit er net een dingetje in je configuratie toch niet lekker.
Ja ik zag dat ik bij de provider binnen ben in Amerika.
Ik heb dat ook nagevraagd bij Goosevpn en die bevestigen dat het ipadres van de server in Amerika is.
Alleen komt die reset er maar steeds aan waardoor ik niet een ander ip adres krijg.
Ik heb goosevpn
@satfrico Goosevpn geeft op hun site geen informatie over hun configuratie als je geen account hebt. Ik neem aan dat je van hen een .ovpn file of zo hebt gekregen? Wellicht ook een tls-auth key?

Mijn vraag: Hoe doe je de authenticatie bij inloggen bij Goose VPN? Ik zie in je client config de regels:
code:
tls-auth login.txt
auth-user-pass login.txt


Normaliter verwijst tls-auth naar een static key. Die heeft een format als:
code:

#
# 2048 bit OpenVPN static key
#
-----BEGIN OpenVPN Static key V1-----
9aaf4ed69be7de2175f919ce46c8619benn0geenhe1eb0e1cijfersen1etters
-----END OpenVPN Static key V1-----



auth-user-pass zou moeten verwijzen naar je inloggegevens, dus user en password, in een simpel tekstbestand als:
code:
yourusername
yourpassword


Aangezien beide parameters bij jou naar de file login.txt verwijzen, vraag ik mij af of dit wel klopt. Maar ik ben aan het speculeren, want ik ken de configuratie voor Goose niet.
@efok Het klopt inderdaad dat ik een ovpn file heb ontvangen. Of beter gezegd ik kan die zelf downloaden van hun site, voor elke server een andere ovpn. Ik heb de ovpn genomen welke wel draait als ik via mijn pc iptv wil kijken. Zodoende weet ik dat die ovpn goed moet zijn.

Ik moet met mijn emailadres en een wachtwoord inloggen op de site van goose.
Deze twee heb ik dan ook onder elkaar in een losse .txt geplaatst.
Dan weet ik niet zo goed wat ik met die tls moet doen die je aangeeft.
Ik zie op de site van goose wel een token staan wat een beetje lijkt op wat jij neerzet, alleen dat is een regel van 40 cijfers en letters.
Echter ik heb ook een crt bestand gekregen van hun welke ik ook heb verwerkt in de conf en die bestaat uit allemaal cijfers en letters en dan een regel of 10.
En die ziet er dan zo uit.

-----BEGIN CERTIFICATE-----
eenheleboellettersencijfers
-----END CERTIFICATE-----
Ik weet ook niet exact hoe Goose het heeft ingericht. Zonder de files van jou te kunnen zien moet ik een beetje gokken, maar in je cliënt.conf staat een verwijzing naar een CRT bestand:

code:
ca xxxx.crt


Dat moet inderdaad het genoemde crt bestand zijn. Dat klopt wel.

Daarnaast zou het heel goed kunnen dat het token op de site van goose waar je over spreekt, gebruikt dient te worden voor de TLS authenticatie.
Zie het als een extra beveiliging. Bovenop username en password, heb je ook nog een tls autorisatie key nodig om te kunnen inloggen. Ik weet niet zeker of de sleutel van 40 tekens waar jij naar verwijst dit is, maar het zou kunnen. Dan moet tls-auth hiernaar verwijzen. Dit kan gewoon in een txt bestand. Meestal wordt het bestand ta.key genoemd. Dan krijg je dus.
code:
tls-auth ta.key


(Je kan eventueel ook de .ovpn file op je PC eens in een tekst-editor openen en zien of er iets over een tls-auth sleutel in staat)
@efok heb je zelf ook een satelietontvanger draaien?

ik heb de .ovpn even geopend en dan zie je onderstaande staan in het bestand.

client
proto tcp-client
dev tun
auth-user-pass
cipher AES-256-CBC
nobind
verb 3
comp-lzo
tun-mtu 1470
mssfix 1460
keepalive 5 60

onderstaande foto is van de vu duo2

@satfrico Nee, Ik heb geen ontvanger. Ik heb wel openvpn geïnstalleerd en geconfigureerd op mijn eigen server, waar ik op kan inloggen vanaf andere devices. Daarvoor heb ik ook .ovpn files gemaakt, en maak ik toevallig ook gebruik van tls-auth.

Maar je antwoord maakt het niet direct makkelijker voor me 😅😅

In je .ovpn zie ik namelijk wat andere opties dan in je cliënt.config. Waaronder ook definities voor tun-mtu en mssfix. Maar weer niets over tls-auth. Waarom heb je tls-auth dan in je cliënt.config opgenomen? Ik mis toch de specifieke instructies van goose, waardoor ik je niet helemaal goed op weg kan helpen vrees ik.

Je screenshot laat zien dat je openvpn cliënt op de ontvanger wel loopt, maar niks doet, want er wordt immers geen verbinding opgebouwd. Maar ja dat wist je al.

Toch verwacht ik dat het wel gewoon moet kunnen werken, als je de cliënt de juiste instructies geeft, via je cliënt.conf bestand.

Edit: ik heb nog even rondgesnuffeld en een .ovpn-file weten te bemachtigen van Goose 😙😙 en bovendien een soort manual aangetroffen. Niet specifiek voor jou maar het leert ons wel wat. De .ovpn bevat de basis instellingen en ook een ca certificaat. Die laatste heb jij al apart op je ontvanger gezet als xxxx.crt. Op basis daarvan kom ik tot de volgende setup voor je client.conf:

code:
remote us-6.goosevpn.com 443
client
proto tcp-client
dev tun
auth-user-pass login.txt
cipher AES-256-CBC
nobind
verb 3
comp-lzo
tun-mtu 1470
mssfix 1460
keepalive 5 60
ca xxxx.crt
log /etc/openvpn/openvpn.log


In login.txt moet dan je usernaam en het token wat je bij Goose kunt aanmaken plaatsen (dat token geldt als password, tenminste dat staat in die manual). Ik beloof niets, maar probeer het eens..
@efok Jij bent de beste, hahaha
Ik dacht gisterenavond we gaan er wel uit komen.
Want voor dat ik jou edit had gezien kwam ik al een stuk verder.
Ik was er inmiddels achtergekomen dat het password in login.txt de token moest zijn en niet het wachtwoord wat ik gebruik om in te loggen bij goose.
Echter we komen nog net niet helemaal tot een werkend iets.

zie de foto's voor wat er nog net niet wil lukken.

@satfrico Nee, maar je lijkt nu wel een OpenVPN IP adres te hebben, dus dat lijkt een stap verder. Alleen heb je er nog geen werkende verbindig over.

Hmm, Het zou kunnen dat je sat ontvanger nog niet weet dat hij de opgezette VPN-verbinding nu ook moet gebruiken voor de verbinding met het internet. In je eerste client setup stond iets over route, misschien moeten we daar nog iets mee.

Maar eerst nog een paar vraagjes:
Welke setup heb je nu exact gebruikt? Die van mij? Wil je daarin verb 3 in verb 5 veranderen? Dan krijgen we meer te zien in de logs. Vervolgens VPN aanzetten:

Als je dan inlogt via SSH of telnet op die ontvanger:
-wat vind je nu in dat openvpn.log bestand?
-en als je typt
code:
ifconfig


en
code:
route


en
code:
traceroute 1.1.1.1
@efok inderdaad we komen steeds een stukje verder in het geheel.
ik moet helaas over kwartiertje naar me werk, dus ik kan niet meer reageren.
Ik gebruik jou cfg bestand.

dit is wat het log zegt:


code:
Mon Dec  3 13:14:51 2018 OpenVPN 2.3.6 mipsel-oe-linux-gnu [SSL (OpenSSL)] [lzo] [epoll] [mh] [IPv6] built on Mar  2 2018
Mon Dec 3 13:14:51 2018 library versions: OpenSSL 1.0.2a 19 Mar 2015, LZO 2.09
Mon Dec 3 13:14:51 2018 WARNING: file 'login.txt' is group or others accessible
Mon Dec 3 13:14:51 2018 WARNING: normally if you use --mssfix and/or --fragment, you should also set --tun-mtu 1500 (currently it is 1470)
Mon Dec 3 13:14:51 2018 Socket Buffers: R=[87380->131072] S=[16384->131072]
Mon Dec 3 13:14:51 2018 Attempting to establish TCP connection with [AF_INET]204.155.30.9:443 [nonblock]
Mon Dec 3 13:14:52 2018 TCP connection established with [AF_INET]204.155.30.9:443
Mon Dec 3 13:14:52 2018 TCPv4_CLIENT link local: [undef]
Mon Dec 3 13:14:52 2018 TCPv4_CLIENT link remote: [AF_INET]204.155.30.9:443
Mon Dec 3 13:14:52 2018 TLS: Initial packet from [AF_INET]204.155.30.9:443, sid=518adb91 6121a8db
Mon Dec 3 13:14:52 2018 WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent this
Mon Dec 3 13:14:52 2018 VERIFY OK: depth=1, C=NL, ST=South Holland, L=Rotterdam, O=GOOSE, OU=MyOrganizationalUnit, CN=GOOSE CA, name=EasyRSA, emailAddress=info@goosevpn.com
Mon Dec 3 13:14:52 2018 Validating certificate key usage
Mon Dec 3 13:14:52 2018 ++ Certificate has key usage 00a0, expects 00a0
Mon Dec 3 13:14:52 2018 VERIFY KU OK
Mon Dec 3 13:14:52 2018 Validating certificate extended key usage
Mon Dec 3 13:14:52 2018 ++ Certificate has EKU (str) TLS Web Server Authentication, expects TLS Web Server Authentication
Mon Dec 3 13:14:52 2018 VERIFY EKU OK
Mon Dec 3 13:14:52 2018 VERIFY OK: depth=0, C=NL, ST=South Holland, L=Rotterdam, O=GOOSE, OU=MyOrganizationalUnit, CN=vpn.goosevpn.com, name=EasyRSA, emailAddress=info@goosevpn.com
Mon Dec 3 13:14:54 2018 WARNING: 'link-mtu' is used inconsistently, local='link-mtu 1530', remote='link-mtu 9060'
Mon Dec 3 13:14:54 2018 WARNING: 'tun-mtu' is used inconsistently, local='tun-mtu 1470', remote='tun-mtu 9000'
Mon Dec 3 13:14:54 2018 Data Channel Encrypt: Cipher 'AES-256-CBC' initialized with 256 bit key
Mon Dec 3 13:14:54 2018 Data Channel Encrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
Mon Dec 3 13:14:54 2018 Data Channel Decrypt: Cipher 'AES-256-CBC' initialized with 256 bit key
Mon Dec 3 13:14:54 2018 Data Channel Decrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
Mon Dec 3 13:14:54 2018 Control Channel: TLSv1, cipher TLSv1/SSLv3 DHE-RSA-AES256-SHA, 2048 bit RSA
Mon Dec 3 13:14:54 2018 [vpn.goosevpn.com] Peer Connection Initiated with [AF_INET]204.155.30.9:443
Mon Dec 3 13:14:56 2018 SENT CONTROL [vpn.goosevpn.com]: 'PUSH_REQUEST' (status=1)
Mon Dec 3 13:14:56 2018 PUSH: Received control message: 'PUSH_REPLY,redirect-gateway def1,dhcp-option DNS 208.67.222.222,dhcp-option DNS 208.67.220.220,route 10.31.4.1,topology net30,ping 5,ping-restart 60,socket-flags TCP_NODELAY,ifconfig 10.31.4.18 10.31.4.17'
Mon Dec 3 13:14:56 2018 OPTIONS IMPORT: timers and/or timeouts modified
Mon Dec 3 13:14:56 2018 OPTIONS IMPORT: --socket-flags option modified
Mon Dec 3 13:14:56 2018 Socket flags: TCP_NODELAY=1 succeeded
Mon Dec 3 13:14:56 2018 OPTIONS IMPORT: --ifconfig/up options modified
Mon Dec 3 13:14:56 2018 OPTIONS IMPORT: route options modified
Mon Dec 3 13:14:56 2018 OPTIONS IMPORT: --ip-win32 and/or --dhcp-option options modified
Mon Dec 3 13:14:56 2018 ROUTE_GATEWAY 192.168.178.1/255.255.255.0 IFACE=wlan0 HWADDR=f4:28:53:00:0d:43
Mon Dec 3 13:14:56 2018 TUN/TAP device tun0 opened
Mon Dec 3 13:14:56 2018 TUN/TAP TX queue length set to 100
Mon Dec 3 13:14:56 2018 do_ifconfig, tt->ipv6=0, tt->did_ifconfig_ipv6_setup=0
Mon Dec 3 13:14:56 2018 /sbin/ip link set dev tun0 up mtu 1470
Mon Dec 3 13:14:56 2018 /sbin/ip addr add dev tun0 local 10.31.4.18 peer 10.31.4.17
Mon Dec 3 13:14:56 2018 /sbin/ip route add 204.155.30.9/32 via 192.168.178.1
Mon Dec 3 13:14:56 2018 /sbin/ip route add 0.0.0.0/1 via 10.31.4.17
Mon Dec 3 13:14:56 2018 /sbin/ip route add 128.0.0.0/1 via 10.31.4.17
Mon Dec 3 13:14:56 2018 /sbin/ip route add 10.31.4.1/32 via 10.31.4.17
Mon Dec 3 13:14:56 2018 Initialization Sequence Completed


Gefeliciteerd , je traceroute laat al een werkende IP verbinding zien over je VPN! 1.1.1.1 bereik je duidelijk vanuit de USA.

In je log zie ik het volgende:
Je Sat-ontvanger krijgt ook de route gepushed van Goose VPN en gebruikt deze in je traceroute dus dat lijkt te kloppen. Daarnaast zie je dat er DNS servers (die van OpenDNS) worden gepushed voor de VPN verbinding. De vraag is of die wel lekker werken:

Kun je eens met de VPN aan intypen:

code:
ping www.google.com

en
code:
nslookup www.google.com


Daarnaast zie ik nog wel wat meldingen over de mtu-size. Dat vind ik een beetje raar omdat die settings direct van Goose zelf afkomstig zijn. Maar laat dat nu maar even voor wat het is.
@efok , het lijkt wel of hij jumbo-frames verstuurd.
Of de Ziggo modem/router blokkeert Path MTU Discovery. (ICMP)
@efok , het lijkt wel of hij jumbo-frames verstuurd.
Of de Ziggo modem/router blokkeert Path MTU Discovery. (ICMP)


@Gusto ja die 9000 hè? Dat hele MTU/mss gebeuren zit ik niet zo heel goed in.

Heb jij nog suggesties over dat stukje in deze setup?
@efok , jumbo-frames over het internet lijkt me onwaarschijnlijk.
Ik zal me nog eens buigen over de config.
code:
comp-lzo
tun-mtu 1470
mssfix 1460
keepalive 5 60

Ik zou de tun-mtu op 1500 zetten

Groet, Gusto
VPN tunnel mtu moet lager dan 1500 wegens inpakken originele packet.
Anders fragmentatie. 1470 lijkt me zo slecht nog niet.
Maar het beste?
https://forums.openvpn.net/viewtopic.php?t=25039
Gr Han
@hanh , Goose-VPN meld pakket-groote van 9000, dus er gaat iets mis.

Groet, Gusto